Jump to content
Halvhjearne

Custom Spawn Dialog with Gear & HALO Selection, moving Map, Credits, Custom spawns and more ...

Recommended Posts

 

 

here:

	case "esseker":{
		[
			[[9500,5600]],	//esseker
			[[11900,7950]],	//Novi Grad
			[[11082,10280],2],	//Camp Spencer
			[[2655,1269]],		//Grozna Mountain
			[[2000,4180]],	//Krupa
			[[6470,5445],1],	//Neptun Resort
			[[6660,3850]],		//Plava Vrana
			[[9950,10725]]	//Gromada Caves
		]
	};

when i put this in i cant open the spawn menu, without it in it works perfect but then i only have the default spawn points, any ideas where im going wrong? or would changing the default spawn points be more efficient ? 

Edited by scrote
nvm i got it working

Share this post


Link to post
Share on other sites

Good News halv lol .. after epoch update 0.3.3.1 the pictures work .. bad news. the teleporters dont ..BUT .. may have been me adding the traders, I tried using the aussi map example and modify the spawn points giving a name .. .. no errors for this mod in rpt .. Im going to revert back and try again ... 

Share this post


Link to post
Share on other sites

Hi,

i installed the sript like in description but i ever get kicked by battleye. What i am doing wrong?

Here is the init:

[] execVM "addons\halv_spawn\init.sqf";

//Status Bar
    if(hasInterface) then{[] execVM "addons\Status_Bar\init_statusBar.sqf"};

 

here is the description:

#include "addons\halv_spawn\Halv_defines.hpp"
#include "addons\halv_spawn\spawndialog.hpp"

author = "Epoch Mod Team";
class Header
{
 gameType = Sandbox;
 minPlayers = 1;
 maxPlayers = 100;
};
respawn = "BASE";
respawnDelay = 600;
respawnDialog = 0;

onLoadMission= "Epoch";
OnLoadIntro = "Welcome to Epoch Mod";
loadScreen = "\x\addons\a3_epoch_assets\pictures\loadScreen_ca.paa";
OnLoadIntroTime = False;
OnLoadMissionTime = False;
onLoadName = "Epoch Mod";
disabledAI = true;
scriptedPlayer = 1;
disableChannels[]={0,2,6};
enableItemsDropping = 0;
briefing = 0;
debriefing = 0;
enableDebugConsole = 0;
joinUnassigned = 0;
respawnOnStart = 0;
forceRotorLibSimulation = 1;

corpseManagerMode = 1;
corpseLimit = 10;
corpseRemovalMinTime = 1200;
corpseRemovalMaxTime = 3600;

wreckManagerMode = 1;
wreckLimit = 2;
wreckRemovalMinTime = 60;
wreckRemovalMaxTime = 360;

class cfgFunctions
{
    class A3E
    {
        tag = "EPOCH";
        class Client
        {
            file = "\x\addons\a3_epoch_code\init";
            class init
            {
                preInit = 1;
            };
            class postinit
            {
                postInit = 1;
            };
        };
    };
    class VEMF
  {
      tag = "VEMF";
      class VEMFclient
      {
          file = "VEMFclient";
        class vemfClientMessage {};
        class vemfClientInit { postInit = 1; };
      };
  };
};

class CfgRemoteExec
{
  class Functions
  {
    mode = 1;
    jip = 0;
    class EPOCH_server_save_vehicles {
      allowedTargets=2;
      jip = 0;
    };
  };
  class Commands {mode=0;};
};
class CfgEpochSapper
{
    detonateDistMax = 8; //Random distance between 3m and this number at which sapper detonates. Min value = 4
    groanTrig = 16; //Percentage chance of a groan. Min value = 4
    sRange = 300; //Distance from target over which sapper will dispose. Range within which sapper code will be aware of targets. Distance up to which sapper will attempt to find a spot to hide in. Min Value = 150.
    smellDist = 24; //Distance up to which sapper can smell. Used to decide if sapper can see target when deciding to charge and influences target selection. Is influenced by wind direction. Min Value = 8.
};

class CfgEpochUAV
{
    UAVMinDist = 48; //Minimum distance to choose next position when roaming. Min Value = 8.
    UAVMaxDist = 180; //Maximum distance to choose next position when roaming. Min Value = 42 / Max Value = 400.
    UAVHeight = 100; //Set height when roaming, slight randomness is applied to this value. UAV will choose own height when locked onto target. Min Value = 42 / Max Value = 280. UAV can still spot targets from height !
};

class CfgEpochAirDrop
{
    AirDropFreq = 1200; //AirDropChance, to decide if Air drop occurs, will only be checked once per AirDropFreq time period, for each player. Min value = 120.
    AirDropChance = 6; //Percentage chance of air drop, for current player. Checked every AirDropFreq and upon antagonists spawn trigger. -1 To disable.
};

class CfgEpochCloak
{
    cRange = 300; //Distance, from target, at which Cloak will dispose. Cloak is also aware of players within this range. (Min: 60 / Max: 600)
    cAggression = 75; //Percentage chance of attack, currently a psychological attack (Cultist spooky voice). (Min: 1 / Max: 100)
    attackFrequency = 120; //One attack only per this period. (Min: 120)
    attackDistance = 38; // Distance, from target, up to which Cloak will attack. Lower for less vocals. (Min: 16)
    targetChangeFrequency = 42; //Cloak will only attempt to change target once per this period. Make Higher to stick to first target player. (Min: 42)
    teleportChance = 66; //Chance for cloak to teleport. (Min: 1)
    hoverFrequency = 1280; //Cloak has new hover attack. When player is above cloak, and at a distance, cloak will float to player and teleport attack. Only perform one of these moves per this period. (Min: 240)
};

class RscTitles
    {
    
    #include "addons\Status_Bar\statusBar.hpp"
    #include "VEMFclient\hpp_mainVemfClient.hpp"
    
    };

 

i got scrpits.log like this:

24.09.2015 01:33:43: Miagiboy (77.21.51.175:2304) 6565e41c93555b614bdad93b49dbb4cc - #0 "briefing\enddefault_ca.paa'/>",0,0,15,0,0,8406] spawn bis_fnc_dynamicText;
};
};
}else{
player setPos _position;
titleText[forma"
24.09.2015 01:41:52: Miagiboy (77.21.51.175:2304) 6565e41c93555b614bdad93b49dbb4cc - #15 "eCollisionWith player;
player moveInDriver _chute;
_chute setVelocity [0,0,0];
waitUntil{vehicle player isEqualTo _chute};
if (a"
24.09.2015 01:56:40: Miagiboy (77.21.51.175:2304) 6565e41c93035b614bdad93b49dbb4cc - #15 "eCollisionWith player;
player moveInDriver _chute;
_chute setVelocity [0,0,0];
waitUntil{vehicle player isEqualTo _chute};
if (a"
24.09.2015 02:08:43: Miagiboy (77.21.51.175:2304) 6565e41c93555b614bdad93b49dbb4cc - #16 "eCollisionWith player;
player moveInDriver _chute;
_chute setVelocity [0,0,0];
waitUntil{vehicle player isEqualTo _chute};
if (a"
24.09.2015 02:19:42: Miagiboy (77.21.51.175:2304) 6565e41c93555b614bdad93b49dbb4cc - #25 "m = (_geararr select 9) call BIS_fnc_selectRandom;
player addbackpack _item;
(_addedgear select 9) pushBack ['random',_item];
}e"

 

 

Tried to fix the BE Filter but ever got a new restriction. Last one i couldn t fix.

 

Can anybody help me? What i am doing wrong?

 

Many thanks for help

Share this post


Link to post
Share on other sites

 

Hi,

i installed the sript like in description but i ever get kicked by battleye. What i am doing wrong?

Try these 

Scripts.txt

Line 1:

!"spawn BIS_fnc_dynamicText;" !"] spawn BIS_fnc_dynamicText;" !"zoneY + safezoneH - 0.8,0.7],_onScreenTime,0.5] spawn BIS_fnc_dynamicText;

Line 17: (setvelocity line)

!"player setvelocity [" !"bis_fnc_halo_vel * 0.96;\n player setvelocity [" !="eCollisionWith player; player moveInDriver _chute; _chute setVelocity [0,0,0]; waitUntil{vehicle player isEqualTo _chute}; if (a"

around Line 50: look for displayaddeventhandler

!"displayaddeventhandler ["keydown","_this call bis_fnc_halo_keydown;"];"

around Line 37: look for createdialog

!"createdialog \"Halv_spawn_dialog\";"

 


In the createvehicle.txt

 

5 "" !="I_UAV_01_F" !="(I|B|O)_UAV_AI" !"_EPOCH" !="B_65x39_Minigun_Caseless_Red_splash" !="B_762x51_Minigun_Tracer_Yellow_splash" !="B_(Swing|Stick)" !"^SmokeShell" !"^G_40mm_" !"^F_40mm_" !"Sub_F_" !"^F_Signal_" !="mini_Grenade" !="GrenadeHand" !="LaserTarget(C|W|E)" !"^Chemlight_" !="(ClaymoreDirectionalMine|DemoCharge|SatchelCharge)_Remote_Ammo" !="SLAMDirectionalMine_Wire_Ammo"  !="(CMflare_Chaff|Sapper_Charge|SapperB_Charge|ATMine_Range)_Ammo" !="APERS(TripMine_Wire|BoundingMine_Range|Mine_Range)_Ammo" !="Epoch_(Sapper|SapperB|Cloak)_F" !="GreatWhite_F" !="groundWeaponHolder" !="WeaponHolderSimulated" !="Epoch_(Male|Female)_F" !"Supply[0-9]" !"Steerable_Parachute_F" !="Epoch_Female_CamoRed_F" !="Land_Cages_F" !="(O|I|B)_UAV_01_backpack_F" !="I_(helipilot|helicrew)_F" !"B_Parachute_02_F" !="M_AT" !="SmokeLauncherAmmo" !="B_AssaultPack_cbr" !="B_AssaultPack_dgtl" !="B_AssaultPack_khk" !="B_AssaultPack_mcamo" !="B_AssaultPack_ocamo" !="B_AssaultPack_rgr" !="B_AssaultPack_sgg" !="B_Carryall_cbr" !="B_Carryall_khk" !="B_Carryall_mcamo" !="B_Carryall_ocamo" !="B_Carryall_oli" !="B_Carryall_oucamo" !="B_FieldPack_blk" !="B_FieldPack_cbr" !="B_FieldPack_khk" !="B_FieldPack_ocamo" !="B_FieldPack_oli" !="B_FieldPack_oucamo" !="B_Kitbag_cbr" !="B_Kitbag_mcamo" !="B_Kitbag_rgr" !="B_Kitbag_sgg" !="B_Parachute" !="B_TacticalPack_blk" !="B_TacticalPack_mcamo" !="B_TacticalPack_ocamo" !="B_TacticalPack_oli" !="B_TacticalPack_rgr" !="Land_ClutterCutter_medium_F"
5 "_EPOCH" !="(SapperHead|Jack)_SIM_EPOCH" !="Wood(Floor|LargeWall|Stairs|Ramp|Foundation)_EPOCH" !="(Tipi|StorageShelf|CinderWallHalf|Foundation|Wood(Floor|LargeWall|Stairs|Ramp|Foundation))_Ghost_EPOCH" !="(Tipi|StorageShelf|LockBox|FirePlace|FirePlaceOn|PlotPole|I_Soldier|Jack|Freezer|Tarp|CinderWallHalf)_EPOCH" !="(Bed|locker|Filing|Chair|ChairRed|wardrobe|cooker|Couch|Table|Pelican|Fridge|Shelf|ToolRack|Shoebox|Bunk|Rabbit)_EPOCH"  !="(Sheep|Goat|Snake|Hen|Cock|Fin|Alsatian)_random_EPOCH" !="(LockBox|CinderWall|CinderWallGarage|CinderWallHalf|PlotPole|Tipi|StorageShelf|Fireplace)_SIM_EPOCH" !="Wood(Floor|LargeWall|LargeWallCor|LargeWallDoor|LargeWallDoorL|LargeWallDoorway|Stairs|Stairs2|Ramp)_SIM_EPOCH" !="(WoodFoundation|Foundation)_EPOCH" !="smallbackpack_red_epoch" !="smallbackpack_green_epoch" !="smallbackpack_teal_epoch" !="smallbackpack_pink_epoch"
5 SeaGull

Share this post


Link to post
Share on other sites

ok tried installing this on a clean server with infistar installed but the teleport pads will not work. Added the infistar updates and such but no luck. I installed it 4 times and still no luck.

Okay got it to work finally but now instead of the glitch of spawning back in the air it kicks me to the lobby then when coming back in im at one of the old spawn areas.

Edited by Steven1230

Share this post


Link to post
Share on other sites

 

Try these 

 

Hidden Content

Thanks for the answer Steven. But it didn t work i got new battleye kick

#24 "m = (_geararr select 9) call BIS_fnc_selectRandom;
player addbackpack _item;
(_addedgear select 9) pushBack ['random',_item];
}e"

Dont know what the problem is i tried it on a new installed server with no other scripts running on it :-(

Share this post


Link to post
Share on other sites

Tested it again without battleye activation and it is working well.What kind of battleye exceptions i have to fill in?Can you post complete scripts and createvehicle which is working with these script? Thanks for help

Share this post


Link to post
Share on other sites

Just installed the script did the Antihack thing and players are still getting kicked when they choose the halo spawn.

 

20:37:36 "<infiSTAR.de FNC_AH2_KICKLOGSPAWN> ["vgeptvhdoqgcrpq1t15",["Dominic","76561198087295149","SLOG_SKICK",[65,99,116,105,111,110,115,58,32,56,57,47,56,55,32,112,111,115,115,105,98,108,101,32,115,99,114,111,108,108,32,109,101,110,117,32,104,97,99,107]]]"
20:37:36 "<infiSTAR.de>SL| 0h 48min | Dominic(76561198087295149) | Actions: 89/87 possible scroll menu hack (v0218)"
20:37:36 "<infiSTAR.de>KickLog| Dominic(76561198087295149)   (v0218)"

 

Edit

Forcing ground spawn fixed it.

 

Edited by Three Plus

Share this post


Link to post
Share on other sites

Tested it again without battleye activation and it is working well.What kind of battleye exceptions i have to fill in?Can you post complete scripts and createvehicle which is working with these script? Thanks for help

Having the same issue, battlEye just kicks me out for 

 2:57:10   };
 2:57:10   };
 2:57:10   }else{
 2:57:10   player setPos _position;
 2:57:10   titleText[forma"
 2:57:10 Player Exodius kicked off by BattlEye: Script Restriction #0

That.. Any solution would be great!

Share this post


Link to post
Share on other sites

Having the same issue, battlEye just kicks me out for 

 2:57:10   };
 2:57:10   };
 2:57:10   }else{
 2:57:10   player setPos _position;
 2:57:10   titleText[forma"
 2:57:10 Player Exodius kicked off by BattlEye: Script Restriction #0

That.. Any solution would be great!

I have something else now, just read all the posts in here, but still get kicked for:

 

15:30:53   player moveInDriver _chute;
15:30:53   _chute setVelocity [0,0,0];
15:30:53   waitUntil{vehicle player isEqualTo _chute};
15:30:53   if (a"
15:30:53 Player Exodius kicked off by BattlEye: Script Restriction #15

Share this post


Link to post
Share on other sites

Is it possible set static spawn points for like Central, Eastern and Western adding the cords for them just spawns you in the general area or am I doing something wrong?

 

Edit.

I really need to look into things more before I post.....

Edited by Three Plus

Share this post


Link to post
Share on other sites
 

Thanks for the answer Steven. But it didn t work i got new battleye kick

Dont know what the problem is i tried it on a new installed server with no other scripts running on it :-(

add this to line 26

!="m = (_geararr select 9) call BIS_fnc_selectRandom; player addbackpack _item; (_addedgear select 9) pushBack ['random',_item]; }e"

Edited by Steven1230

Share this post


Link to post
Share on other sites

The cure would be to disable or dumb down the anti-teleport check in the default antihack. My understanding is that infiStar does not demonstrate this behavior. Halve has a post on page 21 of this thread that points you in the right direction. His proposed fix did not work for me but there are probably other approaches including a few carefully placed comments.

Share this post


Link to post
Share on other sites

I noticed the other day when spawning into the server and para spawning that if I was given a parachute (instead of a backpack) and used it. I wouldn't spawn back into the air. So the spawning back up into the air has to do with the script adding a backpack and then having you parachute without actually having one on.

Share this post


Link to post
Share on other sites

Does anyone have this working with 0.3.4.0?

I updated from 0.3.3.1 to 0.3.4.0 and mine no longer works...keep getting "Spawn menu aborted", but I can evaluate the expression the script is using in my debug console and it's returning well under 35.

Share this post


Link to post
Share on other sites

Does anyone have this working with 0.3.4.0?

I updated from 0.3.3.1 to 0.3.4.0 and mine no longer works...keep getting "Spawn menu aborted", but I can evaluate the expression the script is using in my debug console and it's returning well under 35.

Works fine for me. You could try doing a fresh install or if you're using Infistar make sure you have the proper allowedDialogs set.

Edited by Three Plus

Share this post


Link to post
Share on other sites

Works fine for me. You could try doing a fresh install or if you're using Infistar make sure you have the proper allowedDialogs set.

Yep, I am using Infistar. I don't think the issue is with an alloweddialogs though, as the script itself is aborting and logging it; theoretically because it thinks the player isn't near the spawn.

Appreciate the info, that at least confirms it's something I've messed up then.

Share this post


Link to post
Share on other sites

I noticed the other day when spawning into the server and para spawning that if I was given a parachute (instead of a backpack) and used it. I wouldn't spawn back into the air. So the spawning back up into the air has to do with the script adding a backpack and then having you parachute without actually having one on.

that is incorrect, if you can use a parachute, then you can use halo jump, the problem is anti tp reverting your position when the player is in the air.

it can be fixed and i provided info on a possible fix for the default antihack, however i think everyone ignores it, most likely cause they dont understand.

Does anyone have this working with 0.3.4.0?

I updated from 0.3.3.1 to 0.3.4.0 and mine no longer works...keep getting "Spawn menu aborted", but I can evaluate the expression the script is using in my debug console and it's returning well under 35.

idk what you are trying to say here as it makes no sense.

if you get "Spawn menu aborted" that means you where not near the cloneroom when you spawned in.

Share this post


Link to post
Share on other sites

Hi Halv,

I just wanted to say that I did try your suggestion of changing the line in the standard AH and was overjoyed at first because it seemed to fix the issue but on further observation of the players they were popping back up again I understand that it is the anti TP but you are correct in stating that I do not understand the script.

I would also like to say I appreciate your time and creation of this addon because it is awesome even in it's current impaired state due to the AH.

Share this post


Link to post
Share on other sites
idk what you are trying to say here as it makes no sense.

if you get "Spawn menu aborted" that means you where not near the cloneroom when you spawned in.

 

I'm standing in the middle of the clone room. In fact, if I pull up the debug console and put in 'player distance getMarkerPos "respawn_west";' I get a number that is far smaller than 35. Usually it's very close to 0.

Yes, what's happening makes no sense to me either. It worked fine with 0.3.3.1, which is why I asked if anyone had it working with 0.3.4.0. Since it is, that narrows my troubleshooting focus to something I messed up somewhere and not some change with 0.3.4.0.

For some reason, when the script runs, it seems to be getting a distance larger than 35. I tried adding code in to log the actual number it's using in the comparison:

 

if(player distance _rspawnw > 35)exitWith{Halv_moveMap = nil;Halv_fill_spawn = nil;Halv_near_cityname = nil;Halv_spawn_player = nil;Halv_spawns = nil;HALV_senddeftele = nil;HALV_HALO = nil;HALV_SELECTSPAWN = nil;HALV_fill_gear = nil;HALV_fnc_returnnameandpic = nil;HALV_fill_gear = nil;Halv_ontreedoubleclick = nil;Halv_ontreeselected = nil;HALV_GEAR_TOADD = nil;HALV_player_removelisteditem = nil;HALV_addiweaponwithammo = nil;HALV_fnc_halo = nil;HALV_playeraddcolours = nil;diag_log "Spawn Menu Aborted...";diag_log format["[halv_spawn] Distance: %1",(player distance _rspawnw)];};


 

Edit: Got that added code working. It gets even weirder:

7:16:37 "Spawn Menu Aborted..."
7:16:37 "[halv_spawn] Distance: 23005.6"

The only thing I can figure at this point is that something is off in the timing during the spawning sequence.

Edit2:

Yep, it's some kind of timing issue. If I change the section of spawndialog.sqf to:

 

// Makes the script start when player is ingame
waitUntil{!isNil "Epoch_my_GroupUID"};
waitUntil{!isNil "HALV_senddeftele"};
sleep 15;

//exit if player is not near a spawn
if(player distance _rspawnw > 35)exitWith{Halv_moveMap = nil;Halv_fill_spawn = nil;Halv_near_cityname = nil;Halv_spawn_player = nil;Halv_spawns = nil;HALV_senddeftele = nil;HALV_HALO = nil;HALV_SELECTSPAWN = nil;HALV_fill_gear = nil;HALV_fnc_returnnameandpic = nil;HALV_fill_gear = nil;Halv_ontreedoubleclick = nil;Halv_ontreeselected = nil;HALV_GEAR_TOADD = nil;HALV_player_removelisteditem = nil;HALV_addiweaponwithammo = nil;HALV_fnc_halo = nil;HALV_playeraddcolours = nil;diag_log "[halv_spawn] Spawn Menu Aborted...";diag_log format["[halv_spawn] Distance: %1",(player distance _rspawnw)];};

it works properly.

Edited by dtmullican

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By THAC0_Gewch
      https://github.com/OlofTheBald/DayZ-Humanity-Loadout-Granter/tree/Epoch_1.0.5.1
       
      Updated for 1.0.6.x
    • By THAC0_Gewch
      Many years ago, I made a Humanity Loadout script for 1.0.5.x. The script is basic, it checks your players' humanity and grants a pre-set loadout when they spawn depending on their humanity level.
      I've now updated and optimized this script for 1.0.6.x:
      https://github.com/OlofTheBald/DayZ-Humanity-Loadout-Granter
       
       
    • By Restiphani
      Our server is running however when someone gets killed it looks like it's using the standard revive with the defibrillator and you can only revive once per spawn. How do you change that to unlimited revives or to use the multigun with the heal player attachment?
    • By JakeQue
      Is there anyway to add a disable footsteps for admins?
       
      Also I would love to be able to spawn a mission in from the admin menu, I tried some code but it just breaks Infistar, it would seem it is executing it automatically.
       
       
      Thank you!
    • By JakeQue
      Hi, me again.
       
      For some reason when i spawn in and collect coins or loadout the next time i disconnect and come back it puts me back into spawn and money is all disappeared. 

      There's no hive errors.
      The only error in the Server RPT is :
      And I have 2 errors in my client RPT. Looks like they relate to zsc but I have reinstalled it from scratch and still the same.
      and 
       
      Sorry to be such a noob with this one!!
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...