Jump to content

Question

Hi, me again.

 

For some reason when i spawn in and collect coins or loadout the next time i disconnect and come back it puts me back into spawn and money is all disappeared. 


There's no hive errors.

The only error in the Server RPT is :

Spoiler

_globalCoins = _character getVar>
23:21:01   Error position: <];


_globalCoins = _character getVar>
23:21:01   Error Missing ]
23:21:01 File z\addons\dayz_server\compile\server_playerSync.sqf, line 38
23:21:01 Error in expression <[];
_medical =        [];
_distanceFoot =    [0,0];

And I have 2 errors in my client RPT. Looks like they relate to zsc but I have reinstalled it from scratch and still the same.

Spoiler

Error in expression <,0];
_globalCoins = player getVariable [Z_globalVariable,0];
};


_model call pl>
  Error position: <Z_globalVariable,0];
};


_model call pl>
  Error Undefined variable in expression: z_globalvariable
File mpmissions\__CUR_MP.Chernarus\dayz_code\compile\player_humanityMorph.sqf, line 36
Error in expression <e,_bankCoins,true];
player setVariable [Z_globalVariable,_globalCoins,true];
};
>
  Error position: <Z_globalVariable,_globalCoins,true];
};
>
  Error Undefined variable in expression: z_globalvariable
File mpmissions\__CUR_MP.Chernarus\dayz_code\compile\player_humanityMorph.sqf, line 102
"keyboard_keys reset"
"WARNING illegal RE rhideObjectcode with args:[any,O 1-1-E:1 REMOTE,true]"

and 

Spoiler

Error in expression <oneyVariable,0] call BIS_fnc_numberText,CurrencyName]];
ctrlSetText [23002,forma>
  Error position: <CurrencyName]];
ctrlSetText [23002,forma>
  Error Undefined variable in expression: currencyname
File mpmissions\__CUR_MP.Chernarus\dayz_code\external\zsc\zscInit.sqf, line 122
Error in expression <at['Gave %1 %2 %3!',_this select 0,_num,CurrencyName];
_sl = format['%1 %2 %4 to>
  Error position: <CurrencyName];
_sl = format['%1 %2 %4 to>
  Error Undefined variable in expression: currencyname
Error in expression <oneyVariable,0] call BIS_fnc_numberText,CurrencyName]];
ctrlSetText [23002,forma>
  Error position: <CurrencyName]];
ctrlSetText [23002,forma>
  Error Undefined variable in expression: currencyname
File mpmissions\__CUR_MP.Chernarus\dayz_code\external\zsc\zscInit.sqf, line 122
Error in expression <T_OK",[_amount] call BIS_fnc_numberText,CurrencyName] call dayz_rollingMessages;>
  Error position: <CurrencyName] call dayz_rollingMessages;>
  Error Undefined variable in expression: currencyname
File mpmissions\__CUR_MP.Chernarus\dayz_code\external\zsc\zscInit.sqf, line 156

 

Sorry to be such a noob with this one!!

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Ok, now i've got hive errors appearing out of nowhere. 

Spoiler

2018-05-08 21:48:00 HiveExt: [Error] Error executing |CHILD:201:44:[200,[6301.77,7815.79,0.00143433]]:[["Binocular_Vector","NVGoggles_DZE","UZI_SD_EP1","ItemMap","ItemCompass","ItemHatchet","ItemKnife","ItemMatchbox","ItemEtool","ItemGPS","CDF_dogtags","ItemRadio","ItemCrowbar","DMR_DZ"],<null>,<null>]:["DZ_Backpack_EP1",[[],[]],[[],[]]]:[false,false,false,false,false,false,false,12000,[],[0,0],0,"O",true,[0.488571,0.205556,0],false]:false:false:0:0:0:0:[["UZI_SD_EP1","amovpsitmstpsnonwpstdnon_ground",37],[]]:0:0::0:490430:|
2018-05-09 20:53:02 HiveExt: [Error] Error executing |CHILD:205:11:<null>:4.14505e+006:|

 

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, JakeQue said:

Hi, me again.

 

For some reason when i spawn in and collect coins or loadout the next time i disconnect and come back it puts me back into spawn and money is all disappeared. 


There's no hive errors.

The only error in the Server RPT is :

  Hide contents

_globalCoins = _character getVar>
23:21:01   Error position: <];


_globalCoins = _character getVar>
23:21:01   Error Missing ]
23:21:01 File z\addons\dayz_server\compile\server_playerSync.sqf, line 38
23:21:01 Error in expression <[];
_medical =        [];
_distanceFoot =    [0,0];

And I have 2 errors in my client RPT. Looks like they relate to zsc but I have reinstalled it from scratch and still the same.

  Hide contents

Error in expression <,0];
_globalCoins = player getVariable [Z_globalVariable,0];
};


_model call pl>
  Error position: <Z_globalVariable,0];
};


_model call pl>
  Error Undefined variable in expression: z_globalvariable
File mpmissions\__CUR_MP.Chernarus\dayz_code\compile\player_humanityMorph.sqf, line 36
Error in expression <e,_bankCoins,true];
player setVariable [Z_globalVariable,_globalCoins,true];
};
>
  Error position: <Z_globalVariable,_globalCoins,true];
};
>
  Error Undefined variable in expression: z_globalvariable
File mpmissions\__CUR_MP.Chernarus\dayz_code\compile\player_humanityMorph.sqf, line 102
"keyboard_keys reset"
"WARNING illegal RE rhideObjectcode with args:[any,O 1-1-E:1 REMOTE,true]"

and 

  Hide contents

Error in expression <oneyVariable,0] call BIS_fnc_numberText,CurrencyName]];
ctrlSetText [23002,forma>
  Error position: <CurrencyName]];
ctrlSetText [23002,forma>
  Error Undefined variable in expression: currencyname
File mpmissions\__CUR_MP.Chernarus\dayz_code\external\zsc\zscInit.sqf, line 122
Error in expression <at['Gave %1 %2 %3!',_this select 0,_num,CurrencyName];
_sl = format['%1 %2 %4 to>
  Error position: <CurrencyName];
_sl = format['%1 %2 %4 to>
  Error Undefined variable in expression: currencyname
Error in expression <oneyVariable,0] call BIS_fnc_numberText,CurrencyName]];
ctrlSetText [23002,forma>
  Error position: <CurrencyName]];
ctrlSetText [23002,forma>
  Error Undefined variable in expression: currencyname
File mpmissions\__CUR_MP.Chernarus\dayz_code\external\zsc\zscInit.sqf, line 122
Error in expression <T_OK",[_amount] call BIS_fnc_numberText,CurrencyName] call dayz_rollingMessages;>
  Error position: <CurrencyName] call dayz_rollingMessages;>
  Error Undefined variable in expression: currencyname
File mpmissions\__CUR_MP.Chernarus\dayz_code\external\zsc\zscInit.sqf, line 156

 

Sorry to be such a noob with this one!!

If you are getting these errors then you are not running the correct configVariables.sqf: https://github.com/EpochModTeam/DayZ-Epoch/blob/master/SQF/dayz_code/configVariables.sqf#L74-L77

https://github.com/EpochModTeam/DayZ-Epoch/blob/master/Server Files/MPMissions/DayZ_Epoch_11.Chernarus/init.sqf#L47

 

PLEASE DO NOT OVERWRITE THIS FILE, IF YOU DO, KEEP THE ORIGINAL LINE IN YOUR INIT.SQF AND PUT YOUR OVERWRITTEN configVariables.sqf AFTER THE ORIGINAL.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Larkin993
      [GOM] Hardcore Sauerland
      Discord:https://discord.gg/Sx7FWQK
      IP: 185.251.226.35:2900
      Mods: Overwatch - Epoch
      Server name: [GOM] Hardcore Sauerland|AI/MISSIONS|TOW/LIFT|COINS|DEPLOYBIKE|
      Server Rules:
      No building 1000m from traders No glitching No Duping No voice in side chat Respect other players and admins Dont blow up locked vehicles Server features:
      Deploy Bike Scan GPS R/C Tools Blood Bag Self Roaming AI Missions Custom Trader Prices Coins - No Banks 6 Hours Restart 24 - 6 - 12 GMT Active Admins Groups [F5] Base Raiding 3hr Day and Night PVP Buy Cinder Walls Refuel / Repair Tools Break Tame Dogs Kill Messages Zombie Hordes Heli Crashes  
    • By McLovin
      NOTICE: Duplicate of another question posted in the wrong section.
       
      So I've been playing this server that has a number of mods installed. I've been playing it for quite a while with the only errors I've been getting are regarding a 45 round RPK mag being missing, but other than that I've had no errors or any issues loading. Upon trying to place a plot pole, nothing happens; absolutely nothing, like no preview shows up, no prompt saying "starting construction" or anything like that, just blankness. When I try to do it again it says "building already in progress" and I can't do anything, not even lock my vehicle. Is there anything that can be done, or that can explain this phenomenon? To further the understanding of how this came to be, I bought a plot pole from the trader in Trader City Stary and tried placing it near Stary, but not too near it (near a thicket of bushes in the distance). Upon right clicking and hitting the build option, that's when I face my issue.
    • By rocalpha
      Bonjour, j’écris aujourd’hui parce que j’aimerais savoir si vous ne pourrez pas m'aider. Je loue un serveur via gportal et j’aimerais pouvoir être mon serveur en PvE, mais aussi créer des éléments de base pour la connexion et des choses simples comme . J'ai un autre problème lorsque j'achète une voiture chère à pied cela me met une flèche rouge puis rien non aucun véhicule il apparait qu'après un redémarrage du serveur
    • By Warburgg
      I installed the dynamic climate script and it happens that it rains on the server but only lasts 10 seconds and stops. Is it because I use the script that speeds server time? I currently use Control Time which allows the server to have 2 hours of day and 1 hour night.
      The other climates such as overcast and fog last the forecast time 5-20 minutes but the rain does not.
      In my logs show: 16:52:30 "39:2 Debug: Rain set to 0.92421 for 10.6582 minutes". It rains until it rains but soon stops.
  • Advertisement
  • Advertisement
  • Supporters
  • Advertisement
  • Discord

×