Jump to content
  • 0
Sign in to follow this  
burky45

Skins preventing riding in vehicles

Question

On our server we had unlocked the skins so that we can use all arma 2 skins but once unlocked they work properly but me and another player had the unlocked skin set to our players but could not get in a vehicle together but as soon as one player removes the skin I.E dieing we can ride again as long as the player with the unlocked skin gets in last

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Had a thought about this issue and could it be related to "score" http://community.bistudio.com/wiki/score

 

That's an interesting theory - have to put that into a debug monitor and see if it plays out the way your thinking. Not sure how "humanity" is working in relation to score , but the humanity definitely does make an impact on this issue

Share this post


Link to post
Share on other sites
  • 0

Humanity is an arbitrary number that is only used by dayz. I believe that in A2 If you have a -2500 score it will mark you as an enemy ie teamkiller. Wearing the skin of another faction maybe another cause

 

So I guess the question to be answered is who or what is causing score to move +/-      - assuming it is tied to  score.  I would agree that part of it makes sense when you kill "friendly" AI soldier(s) you will have the vehicle bug, your tag will become red..

Share this post


Link to post
Share on other sites
  • 0

 

Check unit rating. Rating is increased for killing enemies, decreased for killing friendlies (see Rating Values). Can be changed via addRating by the mission designer.

The rating of the player is displayed as the "score" at the end of the mission. Via Description.ext one can define how many points it takes to get a perfect score, as well as the number of stars.

 

So in theory - it should be possible to throw a script into the scroll wheel to "fix vehicle bug"  and have it "addrating" to that player.

Share this post


Link to post
Share on other sites
  • 0

the od thing is as soon as we remove the unlocked skin from the player vehicle interaction is perfectly fine but once we add it back it dosent work again, i mean the player wearing the skin can get in and out of vehciels perfectly fine but as soon as someone else trys to get in the same vehcile they cant

Share this post


Link to post
Share on other sites
  • 0

We have this issue with the bandit camo skin and the terrorist uniform... possibly others.

 

vbawol, how can I find the players rating?  I'll try to track that tonight and get you some data but I don't know where to find that info.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By 2DayZ2Retirement
      -PROBLEM SOLVED-
       
      G'day, Survivors.
      I am having an issue on my server where vehicles which spawn randomly around the map repair themselves upon server restart.
      I use this config in my init.sqf which successfully spawns the vehicles in damaged and with low fuel...
      DynamicVehicleDamageLow = 75;
      DynamicVehicleDamageHigh = 100;
      DynamicVehicleFuelLow = 0;
      DynamicVehicleFuelHigh = 25;
      ...However upon each server restart the vehicles repair themselves (the fuel remains low however) and for the life of me I can't figure out why this is happening. 
      DayZ Version -DayZ Epoch 1.0.6.2
      Scripts Used -DZAI | -DZMS | -Right Click Actions (Suicide, Smoke Drugs, GPS Scan)
      AntiHack - InfiSTAR
      Server Host - GTXGaming
      My HiveEXT.log and arma2oaserver.RPT logs are not showing anything out of the ordinary.
      I'm not sure if it matter, but all Planes/Helicopters and Boats have been removed from the server via the dynamic_vehicle.sqf.
      In addition, all of the traders and trader cities being removed by removing the call for the CfgServerTrader.hpp in the description.ext.
      If there is any other info I can show to assist in fixing this problem please let me know, any help would be greatly appreciated.
      Cheers.
    • By Brian Soanes
      To unlock vehicles left in your traders over a server restart, open your epoch_server.pbo

      In epoch_server\compile\epoch_vehicle\EPOCH_load_vehicles.sqf
      Find
      if (_allowDamage) then { Just above that, add this
      A3E_SafeZonePosArray = [ [[18451.9,14278.1,0]], //Altis East trader [[13333.5,14494.3,0]], //Altis Central trader [[6192.46,16834,0]] //Altis West trader ]; { if (_vehicle distance (_x select 0) < 200) then { _vehicle lock false; diag_log format["Vehicle %1 left in trader unlocked @ %2", _class, mapGridPosition _vehicle]; }; } forEach A3E_SafeZonePosArray; Pack pbo and you're good to go
    • By Kovicson
      Hey guys, I was looking through my RPT for the server and seen this
      I have no idea what it is... but infistar seems to not like it.
      Any ideas?
      Thank you
      18:39:58 "<infiSTAR.de> CONNECTLOG: CONNECT - Bob Stookee(PLAYER ID)" 18:39:58 "<infiSTAR.de> KickLog: SERVER kicked Bob Stookee(PLAYER ID) - TempBanned" 18:40:03 "INFO - Player: PID#16(Bob Stookee)(UID:PLAYER ID/CID:141) Status: LOGGING IN" 18:40:04 "INFO - Player: PID#16(Bob Stookee)(UID:PLAYER ID/CID:141) Status: LOGIN PUBLISHING, Location factory [132079]" 18:40:10 "<infiSTAR.de> BAN: Bob Stookee (PLAYER ID) | BadFile: blah.sqf - #line 1 "blah.sqf" player addWeapon "M16A2"; player addMagazine "20Rnd_556x45_Stanag"; " 18:40:10 "<infiSTAR.de> BAN: Bob Stookee (PLAYER ID) | BadFile: blah.sqf - #line 1 "blah.sqf" player addWeapon "M16A2"; player addMagazine "20Rnd_556x45_Stanag"; " 18:40:10 "<infiSTAR.de> KickLog: SERVER kicked Bob Stookee(PLAYER ID) - Bob Stookee (PLAYER ID) | BadFile: blah.sqf - #line 1 "blah.sqf" player addWeapon "M16A2"; player addMagazine "20Rnd_556x45_Stanag"; " 18:40:10 "["PVAHR_0_p8c4d7f43821237871843",["Bob Stookee","PLAYER ID","BAN",[66,97,100,70,105,108,101,58,32,98,108,97,104,46,115,113,102,32,45,32,35,108,105,110,101,32,49,32,34,98,108,97,104,46,115,113,102,34,10,112,108,97,121,101,114,32,97,100,100,87,101,97,112,111,110,32,34,77,49,54,65,50,34,59,32,10,112,108,97,121,101,114,32,97,100,100,77,97,103,97,122,105,110,101,32,34,50,48,82,110,100,95,53,53,54,120,52,53,95,83,116,97,110,97,103,34,59,32]]]" 18:40:10 "Player UID#PLAYER ID CID#141 PID#16(Bob Stookee) as Survivor2_DZ died at Wilderness [813895]" 18:40:10 "DeathMessage: Bob Stookee died from blood loss." 18:40:16 "<infiSTAR.de> KickLog: SERVER kicked Bob Stookee(PLAYER ID) - TempBanned" 18:40:20 "<infiSTAR.de> CONNECTLOG: DISCONNECT - Bob Stookee(PLAYER ID)" 18:40:20 "INFO: OnPlayerDisconnect exiting. Player is near respawn_west. This is normal after death. [PLAYER ID","Bob Stookee"]" 18:40:20 Client: Remote object 16:4 not found 18:40:21 Client: Object 6:425 (type Type_149) not found. 18:40:21 Client: Object 10:552 (type Type_149) not found. 18:40:21 Client: Object 17:11 (type Type_149) not found. 18:42:22 Server: Object 6:444 not found (message 70) 18:42:22 Server: Object 6:443 not found (message 89) 18:42:24 Server: Object 10:672 not found (message 70) 18:42:24 Server: Object 6:445 not found (message 94) 18:42:28 Server: Object 6:408 not found (message 221) 18:42:30 "<infiSTAR.de> CONNECTLOG: CONNECT - Bob Stookee(PLAYER ID)" 18:42:30 "<infiSTAR.de> KickLog: SERVER kicked Bob Stookee(PLAYER ID) - TempBanned"  
    • By calinova22
      How would I go about adding custom vehicles to my server? I want to have an F35B with no weapons. I know how to remove the weapons, just cant find the file for the jet itself to edit.
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...