Jump to content
2DayZ2Retirement

Vehicles Repairing Themselves On Server Restart (DETAILS UPDATED)

Recommended Posts

-PROBLEM SOLVED-

 

G'day, Survivors.

I am having an issue on my server where vehicles which spawn randomly around the map repair themselves upon server restart.

I use this config in my init.sqf which successfully spawns the vehicles in damaged and with low fuel...

DynamicVehicleDamageLow = 75;
DynamicVehicleDamageHigh = 100;
DynamicVehicleFuelLow = 0;
DynamicVehicleFuelHigh = 25;

...However upon each server restart the vehicles repair themselves (the fuel remains low however) and for the life of me I can't figure out why this is happening. 

DayZ Version -DayZ Epoch 1.0.6.2

Scripts Used -DZAI | -DZMS | -Right Click Actions (Suicide, Smoke Drugs, GPS Scan)

AntiHack - InfiSTAR

Server Host - GTXGaming

My HiveEXT.log and arma2oaserver.RPT logs are not showing anything out of the ordinary.

I'm not sure if it matter, but all Planes/Helicopters and Boats have been removed from the server via the dynamic_vehicle.sqf.

In addition, all of the traders and trader cities being removed by removing the call for the CfgServerTrader.hpp in the description.ext.

If there is any other info I can show to assist in fixing this problem please let me know, any help would be greatly appreciated.

Cheers.

Share this post


Link to post
Share on other sites

Ignore this thread. I solved the problem... Kind of. I have reinstalled my server and am slowly re-adding my custom files, the error was somehow connected to a custom CfgLoot list I am using though I am not exactly sure how this affected the vehicles and repaired them each reset.

Edited by 2DayZ2Retirement
Problem solved.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By killerkiwi
      hello all i made this crafting menu a while back all this dose make crafting quicker and kinda easier and i left some buttons free to customise ect
      creddit to juandayz and theduke helping with some code and giving tips on arma 2 gui edditor
      you will need click action script to make this work
      this really easy to install got to you description.ext and add the two lines to the bottom
      #include "Stormz\menu\STORMZ_CRAFT_MENU_DEFINES.hpp"
      #include "Stormz\menu\STORMZ_CRAFT_MENU.hpp"
      Step two got to MPMissions\your instance folder\overwrites\click_actions\
      and open config.sqf add this line to DZE_CLICK_ACTIONS = [];
      ["ItemToolbox","Stormz Craft Menu","execVM 'Stormz\menu\open_menu.sqf';","true"]
      like this DZE_CLICK_ACTIONS = [["ItemToolbox","Stormz Craft Menu","execVM 'Stormz\menu\open_menu.sqf';","true"]];
       

      last thing to do is move the STORMZ folder to your instance folder and you are done have fun
      >>>>DOWNLOAD<<<<
      an image to see what it looks like

       
      big thanks to MigSDev5 for making this better this have more items and build houses builds heils ect here his is added code 
       his epoch profile Mig
      https://github.com/MigSDev5/StormzCrafting/commits?author=MigSDev5
       
    • By rocalpha
      Bonjour, j’écris aujourd’hui parce que j’aimerais savoir si vous ne pourrez pas m'aider. Je loue un serveur via gportal et j’aimerais pouvoir être mon serveur en PvE, mais aussi créer des éléments de base pour la connexion et des choses simples comme . J'ai un autre problème lorsque j'achète une voiture chère à pied cela me met une flèche rouge puis rien non aucun véhicule il apparait qu'après un redémarrage du serveur
    • By Warburgg
      I installed the dynamic climate script and it happens that it rains on the server but only lasts 10 seconds and stops. Is it because I use the script that speeds server time? I currently use Control Time which allows the server to have 2 hours of day and 1 hour night.
      The other climates such as overcast and fog last the forecast time 5-20 minutes but the rain does not.
      In my logs show: 16:52:30 "39:2 Debug: Rain set to 0.92421 for 10.6582 minutes". It rains until it rains but soon stops.
    • By Brian Soanes
      To unlock vehicles left in your traders over a server restart, open your epoch_server.pbo

      In epoch_server\compile\epoch_vehicle\EPOCH_load_vehicles.sqf
      Find
      if (_allowDamage) then { Just above that, add this
      A3E_SafeZonePosArray = [ [[18451.9,14278.1,0]], //Altis East trader [[13333.5,14494.3,0]], //Altis Central trader [[6192.46,16834,0]] //Altis West trader ]; { if (_vehicle distance (_x select 0) < 200) then { _vehicle lock false; diag_log format["Vehicle %1 left in trader unlocked @ %2", _class, mapGridPosition _vehicle]; }; } forEach A3E_SafeZonePosArray; Pack pbo and you're good to go
    • By Tanita-Corp
      Hello guys)
      Tell me please how to make 
      spawned veh. unused 4 day deleted
      with key veh. unused 14 day deleted
       
      I broke my head
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...