Jump to content
grave867

[Release] UEP BattlEye Extended Controller Installer

Recommended Posts

Hi, i seemed to install the tool ok and everytime i run the start file the BEC splash window shows up. However i'm getting no restarts and the ingame messages are not woking. Any suggestions what it could be or where to start looking?

Share this post


Link to post
Share on other sites

I personally have no idea why the restarts or messages wouldn't work. When BEC starts does it say scheduled 42 tasks if so it should be working. If not then BEC can't find your scheduler and you will have to delete all those files and use the installer again. If it still doesn't show up after that then idk :huh:

Share this post


Link to post
Share on other sites

Make sure you have a bans.txt

 

Also for my problem i just changed it so it shutdown the server and runs the bat at the same time. This is ok becuase there is already a 7 sec delay built into the restart.bat

This solution may be caused by the fact that your computer takes longer to restart the server and bec is executed with not enough to time to locate the server since the server takes so long to start. 

Share this post


Link to post
Share on other sites

I personally have no idea why the restarts or messages wouldn't work. When BEC starts does it say scheduled 42 tasks if so it should be working. If not then BEC can't find your scheduler and you will have to delete all those files and use the installer again. If it still doesn't show up after that then idk :huh:

 

When I click on the start.bat in my main server folder, a black window comes up and with something about waiting so many seconds press any key. So I let that count down and then another couple of lines of text flash up in the black window but then the window closes itself before I get a chance to see what the lines say. Not sure if that is the 42 tasks thing you're on about?

 

After the window disappears I get a BEC splash window (red/silver) which stays on for a few moments, along with the boxes and ticks showing me that arma2oa is starting. After a short while the these disappear and I'm left with the usual server host box.

 

Make sure you have a bans.txt

 

Also for my problem i just changed it so it shutdown the server and runs the bat at the same time. This is ok becuase there is already a 7 sec delay built into the restart.bat

 

I didn't have this in my files so I added it in the same folder with whitelist, admins, scheduler etc, but it's made no difference. I still get no restarts, no messages or anything.

 

Any other thoughts before I have to try reinstalling it?

Share this post


Link to post
Share on other sites

This solution may be caused by the fact that your computer takes longer to restart the server and bec is executed with not enough to time to locate the server since the server takes so long to start. 

No becasue when i run the restart bat it works. It looks like to me that the delay between the server stopping and bec running the bat file is too long that bec shutsdown becasue it has lost connection to the armaserver.

Share this post


Link to post
Share on other sites

The simplest check to know if BEC is even running at all would be to see the messages come up in game. At least then I would know it's processing something. I am sure it's something extremely basic like my file paths are wrong but for the life of me, I've checked again and again. 

Share this post


Link to post
Share on other sites

The simplest check to know if BEC is even running at all would be to see the messages come up in game. At least then I would know it's processing something. I am sure it's something extremely basic like my file paths are wrong but for the life of me, I've checked again and again. 

The file paths shouldn't be wrong unless you changed file names from the default server install.

Share this post


Link to post
Share on other sites

No becasue when i run the restart bat it works. It looks like to me that the delay between the server stopping and bec running the bat file is too long that bec shutsdown becasue it has lost connection to the armaserver.

If anything the wait time would be too short since bec doesn't care when it starts just as long as the server is fully running when it starts.

 

However I recently updated the tool for people who don't have a database password, since before if you didn't have one the tool wouldn't work.

 

The best thing I can recommend is to do a fresh install of your server and then use the UEP BEC Installer again. This is not the first time I have had people not get it to work then they do a fresh install and then everything is fine. Generally if the tool doesn't work right out of the box it is something that you have done to your server that is causing it not to work.

Share this post


Link to post
Share on other sites

hey im having a problem i do every step and on the last one after the second message inpput box the next step comes up and its blank and ive tried putting the batch location and what not and after i proceed nothing seems to happen

I honestly don't know why that would happen, download it again and try again?....if the problem persists there may be something wrong with your windows interpreter.  :mellow:

Share this post


Link to post
Share on other sites

After the last step mine crashed, I had no idea what to enter so i left it blank.

It goes from step 7 of 7 and then opens up a blank box (See attached image), no idea what goes there, after pressing ok it crashes.

Problem signature:
  Problem Event Name:    CLR20r3
  Problem Signature 01:    uep bec installer.exe
  Problem Signature 02:    1.1.2.0
  Problem Signature 03:    54012ca8
  Problem Signature 04:    mscorlib
  Problem Signature 05:    4.0.30319.18408
  Problem Signature 06:    52310b91
  Problem Signature 07:    e85
  Problem Signature 08:    99
  Problem Signature 09:    System.InvalidCastException
  OS Version:    6.1.7601.2.1.0.272.7
  Locale ID:    1033
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

post-5581-0-70949300-1410282850_thumb.pn

Share this post


Link to post
Share on other sites

Thanks for the input guys, I went through the code and fixed the hang up problem. My IDE auto complete added something that wasn't suppose to be there the last time I made an edit. Thanks for your patience guys, the fix is live on my github it took me a while to post it since I just got the time to set up my desktop again.

Share this post


Link to post
Share on other sites

When you make your server you define a folder, whatever folder you copied your server files into is the same folder you put the program in.

 

ex:

 

mine is:  Z:\epoch_server\

 

all the arma 2 and arma 2 OA files are in that folder, so is the UEP BEC installer.exe. Run as administrator and after a few questions and a minute or so after picking the map type bec is ready to run. just find the "start.bat" in the folder and double click on it.

 

be sure your server is running before you click the "start.bat".

 

you can edit the messages or timed restarts at your leisure. 

When it says extract into server folder, which folder is this specifically?

Share this post


Link to post
Share on other sites

Well it installed fine and shut the server down, It then fails to restart it :unsure:

Some documentation would help, what needs done after install ?

 

*Edit*

Let it run a second time and same thing, server stops but never restarts.

Share this post


Link to post
Share on other sites

Well it installed fine and shut the server down, It then fails to restart it :unsure:

Some documentation would help, what needs done after install ?

 

*Edit*

Let it run a second time and same thing, server stops but never restarts.

Same issue here, it stops the server, but fails to start back up again, if i run restart.bat manually it works fine, any ideas ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By vbawol
      Open world survival mod set just two years after the mass extinction of billions of people. Those that remain are left with remnants of a once technological society. Try to survive, build, or explore your way through the harsh dynamic environment.
      Features
      Powerful persistence framework for Arma 3 with native Windows and Linux dedicated server support. Fully configurable script based security checks. Base Building re-envisioned for Arma 3 PhysX. Persistent secure and insecure storage devices. Upgradeable locking doors. Barter based economy and trading systems backed a single currency ¤ called "Krypto". Hostile Environment with several different types of antagonists, Air and Water temperature extremes, and Earthquakes. Hunting, Fishing, Tame Dogs, Explore & Loot: Wrecked ships, Abandoned vehicles and buildings, Perform task based missions and more! Open source APL-SA Epoch Survival MP gamemode. Open source APL-SA Modders resource configs and Class List. Assets can be used as a mod dependency on Steam workshop.
    • By Achef
      Greetings!
      So I recently started up in a new host and haven't gotten to make the server run, found that a ca/modules bis_fnc issue is recurring but doesn't affect players when running coop missions like the default arma 2 oa ones, but when trying with Epoch hive won't connect/start despite being configured.
      Hive error
      Meanwhile at line 23...
       
      I'm still bad with Pastebin, sorry.
       
      This error has been chasing me for 2 days now
    • By WeepiestLem0n
      So I've been wanting to create a private ArmA 2 DayZ Epoch server for a bunch of my mates to play on, however I dont have a dedicated machine and want to run it on my PC. So I looked at the server download files on the GitHub page and followed the ReadMe, however I absolutely cannot figure out how to get the MySQL server and DB set up. I have downloaded MySQL Server on my PC and created the admin role, root passwords and ran it as a windows service. I now have no clue how to create the database and am wondering if anyone can help me set this up or let me know if I've done anything wrong. 

      I can add on Steam or Discord if need be for convenience.
    • By WinterLuka
      Winter Gaming is a gaming community, that was created in early 2018. We're currently running DayZ Epoch 1.0.6.2 server.
      Winter Gaming is a project created with passion – for players from players.
      On our server, the rules are equal for all players – no Pay2Win, no benefits for donating.
       
      Server IP: 164.132.203.240:2302
      Discord: https://discordapp.com/invite/ECBVKGA
      Website: http://www.wintergaming.eu
      Forum: http://www.wintergaming.eu/forums
       
      Server Configuration:
      Building Maintain - 10 Days Abandoned Vehicle Unlock - 7 Days Abandoned Safes/Lockboxes Unlock - 10 Days Building Limit – 250 Objects Max Base Height - 30m  
      Features:
      High FPS XP System (with awesome Perks and Trader) JSRS Compatible Wear Zombie Skin Plot Management Door Management Snap and Vector Building 20k Starting Money Coin System Running Zombies Ai Missions Ai Convoys Custom Loot Custom Locations Custom Traders Hidden Trader Selling Rare Items Toggle Grass/Environmental Sounds Deploy Bike/Motorcycle/Mozzie Walk Amongst The Dead Harvestable Hemp Tow/Lift Repair/Rearm – Service Points Bury Bodies Take Clothes Locate Vehicle Paychecks every 30 minutes Spawn Selection Abandoned Safe Mission Indestructible Metal/Cinder Bases Blow up door and more!  
      I hope to see You on the server!
    • By Larkin993
      [GOM] Hardcore Sauerland
      Discord:https://discord.gg/Sx7FWQK
      IP: 185.251.226.35:2900
      Mods: Overwatch - Epoch
      Server name: [GOM] Hardcore Sauerland|AI/MISSIONS|TOW/LIFT|COINS|DEPLOYBIKE|
      Server Rules:
      No building 1000m from traders No glitching No Duping No voice in side chat Respect other players and admins Dont blow up locked vehicles Server features:
      Deploy Bike Scan GPS R/C Tools Blood Bag Self Roaming AI Missions Custom Trader Prices Coins - No Banks 6 Hours Restart 24 - 6 - 12 GMT Active Admins Groups [F5] Base Raiding 3hr Day and Night PVP Buy Cinder Walls Refuel / Repair Tools Break Tame Dogs Kill Messages Zombie Hordes Heli Crashes  
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...