Jump to content
grave867

[Release] UEP BattlEye Extended Controller Installer

Recommended Posts

Hi, i seemed to install the tool ok and everytime i run the start file the BEC splash window shows up. However i'm getting no restarts and the ingame messages are not woking. Any suggestions what it could be or where to start looking?

Share this post


Link to post
Share on other sites

I personally have no idea why the restarts or messages wouldn't work. When BEC starts does it say scheduled 42 tasks if so it should be working. If not then BEC can't find your scheduler and you will have to delete all those files and use the installer again. If it still doesn't show up after that then idk :huh:

Share this post


Link to post
Share on other sites

Make sure you have a bans.txt

 

Also for my problem i just changed it so it shutdown the server and runs the bat at the same time. This is ok becuase there is already a 7 sec delay built into the restart.bat

This solution may be caused by the fact that your computer takes longer to restart the server and bec is executed with not enough to time to locate the server since the server takes so long to start. 

Share this post


Link to post
Share on other sites

I personally have no idea why the restarts or messages wouldn't work. When BEC starts does it say scheduled 42 tasks if so it should be working. If not then BEC can't find your scheduler and you will have to delete all those files and use the installer again. If it still doesn't show up after that then idk :huh:

 

When I click on the start.bat in my main server folder, a black window comes up and with something about waiting so many seconds press any key. So I let that count down and then another couple of lines of text flash up in the black window but then the window closes itself before I get a chance to see what the lines say. Not sure if that is the 42 tasks thing you're on about?

 

After the window disappears I get a BEC splash window (red/silver) which stays on for a few moments, along with the boxes and ticks showing me that arma2oa is starting. After a short while the these disappear and I'm left with the usual server host box.

 

Make sure you have a bans.txt

 

Also for my problem i just changed it so it shutdown the server and runs the bat at the same time. This is ok becuase there is already a 7 sec delay built into the restart.bat

 

I didn't have this in my files so I added it in the same folder with whitelist, admins, scheduler etc, but it's made no difference. I still get no restarts, no messages or anything.

 

Any other thoughts before I have to try reinstalling it?

Share this post


Link to post
Share on other sites

This solution may be caused by the fact that your computer takes longer to restart the server and bec is executed with not enough to time to locate the server since the server takes so long to start. 

No becasue when i run the restart bat it works. It looks like to me that the delay between the server stopping and bec running the bat file is too long that bec shutsdown becasue it has lost connection to the armaserver.

Share this post


Link to post
Share on other sites

The simplest check to know if BEC is even running at all would be to see the messages come up in game. At least then I would know it's processing something. I am sure it's something extremely basic like my file paths are wrong but for the life of me, I've checked again and again. 

Share this post


Link to post
Share on other sites

The simplest check to know if BEC is even running at all would be to see the messages come up in game. At least then I would know it's processing something. I am sure it's something extremely basic like my file paths are wrong but for the life of me, I've checked again and again. 

The file paths shouldn't be wrong unless you changed file names from the default server install.

Share this post


Link to post
Share on other sites

No becasue when i run the restart bat it works. It looks like to me that the delay between the server stopping and bec running the bat file is too long that bec shutsdown becasue it has lost connection to the armaserver.

If anything the wait time would be too short since bec doesn't care when it starts just as long as the server is fully running when it starts.

 

However I recently updated the tool for people who don't have a database password, since before if you didn't have one the tool wouldn't work.

 

The best thing I can recommend is to do a fresh install of your server and then use the UEP BEC Installer again. This is not the first time I have had people not get it to work then they do a fresh install and then everything is fine. Generally if the tool doesn't work right out of the box it is something that you have done to your server that is causing it not to work.

Share this post


Link to post
Share on other sites

hey im having a problem i do every step and on the last one after the second message inpput box the next step comes up and its blank and ive tried putting the batch location and what not and after i proceed nothing seems to happen

Share this post


Link to post
Share on other sites

hey im having a problem i do every step and on the last one after the second message inpput box the next step comes up and its blank and ive tried putting the batch location and what not and after i proceed nothing seems to happen

I honestly don't know why that would happen, download it again and try again?....if the problem persists there may be something wrong with your windows interpreter.  :mellow:

Share this post


Link to post
Share on other sites

After the last step mine crashed, I had no idea what to enter so i left it blank.

It goes from step 7 of 7 and then opens up a blank box (See attached image), no idea what goes there, after pressing ok it crashes.

Problem signature:
  Problem Event Name:    CLR20r3
  Problem Signature 01:    uep bec installer.exe
  Problem Signature 02:    1.1.2.0
  Problem Signature 03:    54012ca8
  Problem Signature 04:    mscorlib
  Problem Signature 05:    4.0.30319.18408
  Problem Signature 06:    52310b91
  Problem Signature 07:    e85
  Problem Signature 08:    99
  Problem Signature 09:    System.InvalidCastException
  OS Version:    6.1.7601.2.1.0.272.7
  Locale ID:    1033
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

post-5581-0-70949300-1410282850_thumb.pn

Share this post


Link to post
Share on other sites

Thanks for the input guys, I went through the code and fixed the hang up problem. My IDE auto complete added something that wasn't suppose to be there the last time I made an edit. Thanks for your patience guys, the fix is live on my github it took me a while to post it since I just got the time to set up my desktop again.

Share this post


Link to post
Share on other sites

When you make your server you define a folder, whatever folder you copied your server files into is the same folder you put the program in.

 

ex:

 

mine is:  Z:\epoch_server\

 

all the arma 2 and arma 2 OA files are in that folder, so is the UEP BEC installer.exe. Run as administrator and after a few questions and a minute or so after picking the map type bec is ready to run. just find the "start.bat" in the folder and double click on it.

 

be sure your server is running before you click the "start.bat".

 

you can edit the messages or timed restarts at your leisure. 

When it says extract into server folder, which folder is this specifically?

Share this post


Link to post
Share on other sites

Well it installed fine and shut the server down, It then fails to restart it :unsure:

Some documentation would help, what needs done after install ?

 

*Edit*

Let it run a second time and same thing, server stops but never restarts.

Share this post


Link to post
Share on other sites

Well it installed fine and shut the server down, It then fails to restart it :unsure:

Some documentation would help, what needs done after install ?

 

*Edit*

Let it run a second time and same thing, server stops but never restarts.

Same issue here, it stops the server, but fails to start back up again, if i run restart.bat manually it works fine, any ideas ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By mudzereli
      Outdated, does not work with Epoch 1.0.7
      DEPLOYABLE BIKE 2.8.2
      all of this information is available in an easier-to-read format on github pages>>
      version 2.8.2 updates the code to work with Epoch Mod 1.0.6. Thanks @ebaydayz!
      version 2.8.1 should hopefully fix the long-standing non-moving-bike problem! Thanks @SchwEde!
      FYI: 2.8.0 adds the _condition and _ammo parameters to the config array so you will need to add a value for these parameter in each record of the DZE_DEPLOYABLES_CONFIG array in the appropriate spot if you are upgrading from 2.6
       
      Out of the box, it adds a deployable bike with a right click action on a toolbox and a couple other neat deployables.
      Really, it can be used to deploy just about anything. See the configuration section below.
      For some samples of what it can do, check out this gallery on imgur
       
      Installation
      download the files extract the addons and overwrites folder from the downloaded zip file into your mission file root find this line in your mission file init.sqf (warning: if you have a custom compiles file, find that line instead of the one below!) call compile preprocessFileLineNumbers "\z\addons\dayz_code\init\compiles.sqf"; place this line directly after the line you found call compile preprocessFileLineNumbers "addons\bike\init.sqf"; edit addons\bike\config.sqf to change some options or add different deployables (see configuration section for more info) Warning:
      due to the way the way arma handles numbers and the way addon is coded, using the save-to-database option may not allow you to re-pack some objects if you have Character ID's over 500,000 (which I don't think will be an issue for 99.99% of people).  
      Adding Your Own Custom Actions
      If you use another right click method like extra_rc.hpp and want to switch to my method, see my click actions configuration github page.
      The click actions script is included in the deploy script as part of the core, so you don't need to download anything, just follow the instructions for adding your own actions.
      * note: before attempting to troubleshoot issues with adding your own actions, make sure you are using the most recent version of the addon.
       
      Configuration
      This addon is highly configurable, you can deploy just about anything, not just bikes.
      open addons\bike\config.sqf and edit the array to add your own deployables.
       
      DZE_DEPLOYABLES_CONFIG format -- (note no comma after last array entry)
      DZE_DEPLOYABLES_CONFIG = [ [_clickItem,_deployOffset,_packDistance,_damageLimit,_packAny,_cargo,_hive,_plot,_simulation,_deployables,_near,_parts], [_clickItem,_deployOffset,_packDistance,_damageLimit,_packAny,_cargo,_hive,_plot,_simulation,_deployables,_near,_parts], [...more stuff here...] ]; DZE_DEPLOYABLES_CONFIG array values (view on github to read easier):
      parameter | description | type | example --------------|---------------------------------------------------------------------|--------|-------- _clickItem | class name of the item to click on | string | "ItemToolbox" _deployOffset | [_side,_front,_up] array to offset the deployable when buiding | array | [0,2,1] _packDistance | how close does the packer need to be to pack the object? | number | 5 _damageLimit | item can't be repacked if damage is > this. (-1 = no re-packing) | number | 0.1 _packAny | can anyone repack the deployable? | bool | false _cargo | clear the cargo of the deployable? | bool | false _ammo | should vehicle ammo be cleared? (does not persist through restart) | bool | true _hive | write deployable to database? | bool | false _plot | require a plot from the owner to build the deployable? | bool | false _simulation | enable simulation (movement/damage) for the object? (true for cars) | bool | true _road | enable road building for this object? | bool | true _deployables | array of class names that can be deployed with this method | array | ["MMT_Civ"] _near | array of items required nearby to build (workshop/fire/fueltank) | array | [] _parts | array of parts required to build (will be taken from player) | array | ["ItemToolbox"] _condition | string of code to evaluate to determine whether action is shown | string | "!(isNull player) && {(getPlayerUID player) in DZE_DEPLOYABLE_ADMINS}" DZE_DEPLOYABLE_NAME_MAP array -- allows you to rename the deployable (on the right click/messages)
      format (note no comma after last array entry)
      DZE_DEPLOYABLE_NAME_MAP = [ [_class,_name], [_class,_name], [... more ...] ];  array parameters
      parameter    | description                                                         |  type  | example --------------|---------------------------------------------------------------------|--------|-------- _class        | class name of the item you want to replace the name of              | string | "Notebook" _name         | new name to display when right clicking                             | string | "Macbook Pro" Change Log
      version | change --------|------- 2.8.2 | updates for 1.0.6! Thanks @ebaydayz! 2.8.1 | fix from SchwEde that should fix bike not moving. Thanks @SchwEde! 2.8.0 | option to clear vehicle ammo 2.7.1 | better exit reasons 2.7.0 | option to add condition for showing action in config 2.6.1 | fix for unrideable bikes 2.6.0 | road building options, deployable name mapping 2.5.1  | fix a bug where preview items would sometimes disappear  2.5.0  | now uses a modified epoch building system to deploy the objects  2.4.3  | better click actions build conflict detection  2.4.2  | updated for new click actions handler build  2.4.1  | fixed deployables spawning in locked after restart  2.4.0  | multi-part deployables. yay!  2.3.1  | big fix on packing temp objects  2.3.0  | optional saving to database with post-restart memory of deployed items (see warning below about this) | configurable damage limits on re-packing | admin list for packing/deploying instantly & being able to remove all deployables  2.2.1  | positioning fix for deployed items  2.2.0  | option for clearing cargo of spawned items  2.1.0  | change way dependency call is made, only one line needed in init.sqf now for setup  2.0.0  | major update, allow multiple deployables, pretty much any class  1.1.0  | configuration options / code optimization  1.0.0  | release Issues/FAQ
      1) people are getting kicked for createvehicle restriction when building a stone wall
      open your battleye filter createvehicle.txt and change this line
      5 "Fort_" !="Fort_RazorWire" !="Fort_RazorWirePreview" to this:
      5 "Fort_" !="Fort_RazorWire" !="Fort_RazorWirePreview" != "Fort_StoneWall_EP1" 2) I am using "A Plot For Life" and this is not working!
    • By salival
      Hi,
      Here's my version of  @OtterNas3 vehicle key changer.  It was subsequently modified by @Grahame for epoch 1.0.6. Updated for 1.0.7.
      This adds support for briefcases, gems and coins as well as using the epoch vehicle upgrade system to do the key changing/claiming.
      * original discussion url: https://epochmod.com/forum/topic/5972-release-vehicle-key-changer-for-making-masterkey-v-14-updated-06152014/
      * updated discussion url: https://epochmod.com/forum/topic/43048-release-vehicle-key-changer-for-making-masterkey-v-141-updated-for-epoch-106/
      Github link with install directions: https://github.com/oiad/vkc
      **EDIT* Link to a working locate Vehicle script that is able to find multiple vehicles per key: 
       
      **** For Epoch 1.0.6.2 only **** >> Download <<
      Visit this link: https://github.com/oiad/vkc/tree/vkc-Epoch-1.0.6.2
    • By salival
      Hi guys,
      Here's my version of the bury/butcher body script. Focus'd on optimization and cleanliness.
      * Tested as working on a blank Epoch 1.0.7 server
      * Contains a server side scheduler module to clean up old weapon crates, graves and crosses after 25 minutes.
      * Removes the flies sound when body is buried for performance.
       
      To download: https://github.com/oiad/buryBodies
       
      **** For Epoch 1.0.6.2 only **** >> Download <<
      Visit this link: https://github.com/oiad/buryBodies/tree/Epoch_1.0.6.2
    • By salival
      Hi,
      Since Zabn is MIA I have updated his Take Clothes script to 1.0.7 compatible.
      Github with install instructions and download location: https://github.com/oiad/TakeClothes
       
       
      **** For Epoch 1.0.6.2 only **** >> Download <<
      Visit this link: https://github.com/oiad/TakeClothes/tree/Epoch_1.0.6.2
      (original install url: http://opendayz.net/threads/release-zabns-take-clothes-2-0.19290/)
      (original discussion url: http://opendayz.net/threads/help-discussion-zabns-take-clothes.13198/)
       
    • By salival
      Hi,
      With Axe Cops permission I am releasing my updated version of his amazing Service Points script. 
      This includes support for original briefcases, gems (from epoch 1.0.7) and coins.
          (original github url: https://github.com/vos/dayz/tree/master/service_point)
          (original install/discussion url: https://epochmod.com/forum/topic/3935-release-vehicle-service-point-refuel-repair-rearm-script/)
          
      **** *REQUIRES DAYZ EPOCH 1.0.7* ****
          
      Major Changes:
          This version adds support for both single currency and gems (from the epoch 1.0.6 update) as well as the original epoch briefcase currency system. 
          Instead of pricing things like the original way, prices are now done on a "worth" similar to how coins are done. The price value of items are below.
          If you are using coins, I would recommend using the _currencyModifier variable since coins typically are 10x the value of briefcase based currency (1 brief == 100,000 coins)
          (You can either set this _currencyModifier variable to 1 then set the proper value or use the modifier, the modifier is mainly for dual currency servers)
          1 silver = 1 worth
          1 10oz silver = 10 worth
          1 gold = 100 worth
          1 10oz gold = 1,000 worth
          1 briefcase = 10,000 worth
          Please see dayz_code\configVariables.sqf for the value of gems (DZE_GemWorthArray) and their relevant worth if they are enabled.
          Example config settings for _refuel_costs, _repair_costs and _rearm_costs:
          All 3 sections can either be made free, disabled or a specifc price with the following examples:
          ["Air","free"] will make the vehicle config class of "Air" free for the specific action.
          ["Air","disabled"] will make the vehicle config class of "Air" disabled for the specific action.
          ["Air",2000] will make the vehicle config class of "Air" have a worth of 2000 for the specific action.
          ["Armored_SUV_PMC",2000] will make the specific vehicle have a worth of 2000 for the specific action.
          ["Armored_SUV_PMC","free"] will make the specific vehicle be free for the specific action.
          ["Armored_SUV_PMC","disabled"] will make the specific vehicle be disabled for the specific action.
          Valid vehicle config classes as an example: "Air", "AllVehicles", "All", "APC", "Bicycle", "Car", "Helicopter", "Land", "Motorcycle", "Plane", "Ship", "Tank"
      Visit my Github page to download and read the README.MD : https://github.com/oiad/service_points
      Old Epoch 1.0.6.2 Version can be found here: https://github.com/oiad/service_points/archive/refs/tags/Epoch_1.0.6.2.zip
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...