Jump to content
salival

[Release] Vehicle Service Point (Refuel, Repair, Rearm) [Updated for 1.0.6.1]

Recommended Posts

Hi,

 

With Axe Cops permission I am releasing my updated version of his amazing Service Points script. 

This includes support for original briefcases, gems (from epoch 1.0.6.1) and coins.

    (original github url: https://github.com/vos/dayz/tree/master/service_point)
    (original install/discussion url: https://epochmod.com/forum/topic/3935-release-vehicle-service-point-refuel-repair-rearm-script/)
    
**** *REQUIRES DAYZ EPOCH 1.0.6.1* ****
    
Major Changes:

    This version adds support for both single currency and gems (from the epoch 1.0.6 update) as well as the original epoch briefcase currency system. 
    Instead of pricing things like the original way, prices are now done on a "worth" similar to how coins are done. The price value of items are below.
    If you are using coins, I would recommend using the _currencyModifier variable since coins typically are 10x the value of briefcase based currency (1 brief == 100,000 coins)
    (You can either set this _currencyModifier variable to 1 then set the proper value or use the modifier, the modifier is mainly for dual currency servers)

    1 silver = 1 worth
    1 10oz silver = 10 worth
    1 gold = 100 worth
    1 10oz gold = 1,000 worth
    1 briefcase = 10,000 worth

    Please see dayz_code\configVariables.sqf for the value of gems (DZE_GemWorthArray) and their relevant worth if they are enabled.

    Example config settings for _refuel_costs, _repair_costs and _rearm_costs:

    All 3 sections can either be made free, disabled or a specifc price with the following examples:

    ["Air","free"] will make the vehicle config class of "Air" free for the specific action.
    ["Air","disabled"] will make the vehicle config class of "Air" disabled for the specific action.
    ["Air",2000] will make the vehicle config class of "Air" have a worth of 2000 for the specific action.
    ["Armored_SUV_PMC",2000] will make the specific vehicle have a worth of 2000 for the specific action.
    ["Armored_SUV_PMC","free"] will make the specific vehicle be free for the specific action.
    ["Armored_SUV_PMC","disabled"] will make the specific vehicle be disabled for the specific action.

    Valid vehicle config classes as an example: "Air", "AllVehicles", "All", "APC", "Bicycle", "Car", "Helicopter", "Land", "Motorcycle", "Plane", "Ship", "Tank"

Visit my Github page to download and read the README.MD : https://github.com/oiad/service_points

Share this post


Link to post
Share on other sites

found a error

 

3) Place the files that you've downloaded below into the "scripts/service_points" folder

the service_points folder needs to be service_point 

your calling for 

if (!isDedicated) then {
    // ... some other stuff ...
    // add the next line somewhere in this block
    execVM "service_point\service_point.sqf";
};

so dont add the s to the map name

Share this post


Link to post
Share on other sites

this is how it should be 

if (!isDedicated) then {
    // ... some other stuff ...
    // add the next line somewhere in this block
    execVM "scripts\service_point\service_point.sqf";
};

 

also 

// general settings
_folder = "scripts\service_point\"; // folder where the service point scripts are saved, relative to the mission file

in the service_point.sqf

Share this post


Link to post
Share on other sites

Hi Sorry Bad English :-)

The Skript are god but no Funktion on Namalsk

_servicePointClasses = ["Map_A_FuelStation_Feed","Land_A_FuelStation_Feed","FuelPump_DZ","Land_A_FuelStation_Feed","Land_Ind_FuelStation_Feed_EP1",
"Land_FuelStation_Feed_PMC","FuelStation","Land_ibr_FuelStation_Feed","Land_fuelstation_army","Land_fuelstation","land_fuelstation_w",
"Land_benzina_schnell"]; // service point classes (can be house, vehicle and unit classes)

i put more Fuelstations in the Skript the 3 green are the original ... Namalsk in Funktion :-) 

Wallnuss

Share this post


Link to post
Share on other sites

when used with 106 some players are able to repair just fine and others are not.. the players who are not able to repair do see the animations and have  the gold removed, even get the "vehicle repaired" message but vehicle still has same damage as prior to the repair... i have tested this with three separate accounts from the same pc so i am sure this is not a file issue.... refuel seems to work for everyone

Share this post


Link to post
Share on other sites
57 minutes ago, [email protected] said:

when used with 106 some players are able to repair just fine and others are not.. the players who are not able to repair do see the animations and have  the gold removed, even get the "vehicle repaired" message but vehicle still has same damage as prior to the repair... i have tested this with three separate accounts from the same pc so i am sure this is not a file issue.... refuel seems to work for everyone

Are there any client RPT errors? I have not seen that/heard of that before and i've repaired/rearmed hundreds of vehicles with this version.

Also, what vehicles were being repaired to try and narrow it down

Share this post


Link to post
Share on other sites
2 hours ago, salival said:

Are there any client RPT errors? I have not seen that/heard of that before and i've repaired/rearmed hundreds of vehicles with this version.

Also, what vehicles were being repaired to try and narrow it down

i said the same thing to more than half a dozen players on my server. i had them try uninstall and reinstall arma2 and the epoch 106 mod, removed their id's from the db thinking maybe some glitch associated with their server side profile all without fixing it on their end... then i attempted it with all three of my steam accounts, from the SAME pc and was proven wrong....  currently there is  a pt.1 video showing that it works flawlessly from my main steam account here:

i work tomorrow but have the weekend off, i will add pt.2 video to my youtube that will show in great detail what is happening along with an accurate visual account of all vehicles and fuel stations that i have attempted this with and failed, i will post the rpt file into the details section of this video and upload it by the end of the day Saturday proving that it has nothing to do with the client side files as i had previously thought... thank you for your time and any ideas you may come up with

-peace- 

Share this post


Link to post
Share on other sites

Same issue here - I didn't notice myself, but it looks like repair is intermittent. Worked just fine for me yesterday on my mi17, but a friend reported he was not able to repair so I watched logs and he tried his armored suv, little bird and his humvee and no repair and unfortunately nothing in the RPT or hive logs. Not sure if it matters but it was at a pump at their base, not at a gas station, same for my pump.

Share this post


Link to post
Share on other sites
1 minute ago, _Lance_ said:

Same issue here - I didn't notice myself, but it looks like repair is intermittent. Worked just fine for me yesterday on my mi17, but a friend reported he was not able to repair so I watched logs and he tried his armored suv, little bird and his humvee and no repair and unfortunately nothing in the RPT or hive logs. Not sure if it matters but it was at a pump at their base, not at a gas station, same for my pump.

in the rpt file over several days of testing, i found that repairs from multiple uid's looked identical... the only noticeable difference was on the end users end the repairs didn't actually happen even though they had the gold removed.... for me the easiest solution was to simply remove the option to repair in an effort to make it fair to all players.

Share this post


Link to post
Share on other sites
30 minutes ago, _Lance_ said:

Yeah I disabled repair too but that's just a workaround. Any ideas Salival? Did anything even have to be converted in regards to the repair function to update the mod for 1.0.6?

Honestly, I repaired hundreds of vehicles testing this script, my players have done the same, enevr seen this bug before

Without steps to reproduce it or client / server rpts I'm at a loss as to where the problem lies.

 

The repair function changed with 1.0.6 but as I said, it works perfectly for me. Not to say others don't have an issue though.

I'm keen to fix it just need more information

Share this post


Link to post
Share on other sites

I'll do some add/remove mods and testing this sunday and report back if I can figure out what the deal is, or if I can get server or client rpt to spit something out. I think it has something to do with plot pumps, stations never failed for me on any vehicle. Just at my plot a few times. Anyways I'll report back..thanks man.

Share this post


Link to post
Share on other sites

I have updated the git repo with some tidyness fixes and removing a function that shouldn't have been included (This could have been causing the problems people were describing)

Please update to this version and see if the repair problem still exists.https://github.com/oiad/service_points

@_Lance_ @[email protected] 

Share this post


Link to post
Share on other sites
38 minutes ago, DAKA said:

I am unable to get this to work at all. I have no RPT errors. I have followed the instructions to the T, even changed service_points to point and still nothing?

You must have done something wrong because it does work fine. If you can rar/pbo up your mission file and private message me I can have a look at it.

That script should work straight out of the box.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Harkness
      Mods;
      DayZ_Epoch 1.0.6.2 / Namalsk 0.75
      Scripts/Features;
      EMP Storms and ASPI Protection Device
      Freezing Weather and Slow Zombies
      Warm Clothing and APSI @ Traders
      Refuel, Repair, Rearm Stations
      Remove Clothing From Dead
      AI Missions and Events
      Super Mutant Attacks
      Trader Safe-Zones
      Player Kill Feed
      Custom Map
      Alien Rifle
      Raiders
      Snow
      Extras;
      Click Here For Custom Server Settings
      Visit Time2Kill.co.uk for more info
      Discord Invite Link

    • By [email protected]
      Im setting up a new epoch 1.0.6 server with very little addons/mods installed, and when i was testing i realized safes/plotpoles/walls etc werent saving to the server database. Anyone got any ideas what might be wrong?
    • By THAC0_Gewch
      https://github.com/OlofTheBald/DayZ-Humanity-Loadout-Granter/tree/Epoch_1.0.5.1
       
      Updated for 1.0.6.x
    • By THAC0_Gewch
      Many years ago, I made a Humanity Loadout script for 1.0.5.x. The script is basic, it checks your players' humanity and grants a pre-set loadout when they spawn depending on their humanity level.
      I've now updated and optimized this script for 1.0.6.x:
      https://github.com/OlofTheBald/DayZ-Humanity-Loadout-Granter
       
       
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...