Jump to content
  • 0
Sign in to follow this  
speaR

Traderzones not working on 1.0.5.1

Question

Hello, i've got problems getting the traders working..

Every time a normal player tries to open the trader window it closes instantly. For me (admin with infiSTAR it is working). Anyone knows what that could cause ? Need to get it working. My players want to trade again :D

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Ok, found a temporary fix on opendayz, thanks to ebay, its not a solution but its better to deactivade the complete AH.

delete this code

if ((isNull (findDisplay 106)) && (isNull (findDisplay -1)) && (isNull (findDisplay 41144))
         && (isNull (findDisplay 6902)) && (isNull (findDisplay 6903)) && (isNull (findDisplay 6904)) && (isNull (findDisplay 6905))
         && (isNull (findDisplay 65431)) && (isNull (findDisplay 65432)) && (isNull (findDisplay 65433)) && (isNull (findDisplay 65434))
         && (isNull (findDisplay 65440)) && (isNull (findDisplay 65441)) && (isNull (findDisplay 65442)) && !(ctrlEnabled 1900)
         && (isNull (findDisplay 24000)) && (isNull (findDisplay 24011)) && (isNull (findDisplay 24001)) && (isNull (findDisplay 24101))
         && (isNull (findDisplay 24020)) && (isNull (findDisplay 24030)) && (isNull (findDisplay 24040))
         && (isNull (findDisplay 10667)) && (isNull (findDisplay 10668)) && (isNull (findDisplay 10669))
         && (isNull (findDisplay 10670)) && (isNull (findDisplay 10671)) && (isNull (findDisplay 10672)) && (isNull (findDisplay 10673))
         && (isNull (findDisplay 10674))) then
         {
           closeDialog 0;
         }
         else
         {
           if (!isNull (findDisplay 106) and !(ctrlEnabled 6902) and (lbSize ((findDisplay 106) displayCtrl 105) < 1)) then {closeDialog 0;};
         };

its dont look like this, but you should find it

Share this post


Link to post
Share on other sites
  • 0

Yep, also solved it for me. It was infiSTAR. But now all is working correctly. But still one problem.. the new Helicopter ch53 doesnt spawn in if I buy or spawn him. Had the same problem with the vodnik and fixed it removing it from the banned vehicles in the overwatch files. (running an overpoch server) but now it's the ch53.. think it isnt banned there. Any idea ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By Harkness
      DayZ Expansion Namalsk Mods/Features;
      ATM Banking
      More Weapons
      More Cars
      More Loot
      Namalsk Igloo
      Light Saber Mod
      No-Vehicle-Crash-Damage
      Trader Wallet - Money/Item Storage
      Custom Namalsk Spawn Selection
      Custom Trader City at Sebjan Factory
      All items added to traders
      Namalsk Airdrops
      Notification System
      Territories System
      Auto-run System
      No Stamina System
      Safezone System
      Mission System
      Skin System
      Map UI and 2D/3D Markers System
      KillFeed System
      Towing System
      Player Attachement
      Custom lighting
      Custom interiors
      Custom ocean
      Working Street lights
      Builderitems
      Gravecross
      KillFeed
      Notifications
      Gravecross
      Horn
      Autorun
      No stamina
      MoreGuns
      Street lights
      Car Keys
      CodeLock
      Map UI and 2D/3D Markers
      Global/Transport/Party Chat
      Book (Server Info, Rules, player stats, party management , territory management) System
      Extras;
      Address: 86.10.6.13 Port: 2402
      Discord Invite Link
    • By AntZ
      Hey there! I just set up an Overpoch Chernarus server on a server provider but the vehicle traders aren't spawning the vehicles when you buy them. The trader takes your gold bars, gives you a key, then a red arrow appears over where the vehicle Should spawn, but nothing appears. After restarting the server all the vehicles that were bought appear right on top of the spot where they were Suppose to show up.
      -I Do Not have infistar installed
      -I'm using worldwidesorrow's admin tools from here: https://github.com/worldwidesorrow/Epoch-Admin-Tools/tree/TestBranch
      -But just in case I removed the admin tool and tested the vehicle traders again but still no luck.
      Here is my server RPT: 
       
      Can someone please look into this. This is the exact issue discussed in this post but the solution doesn't apply in my case.
       
    • By THAC0_Gewch
      https://github.com/OlofTheBald/DayZ-Humanity-Loadout-Granter/tree/Epoch_1.0.5.1
       
      Updated for 1.0.6.x
    • By Brian Soanes
      To unlock vehicles left in your traders over a server restart, open your epoch_server.pbo

      In epoch_server\compile\epoch_vehicle\EPOCH_load_vehicles.sqf
      Find
      if (_allowDamage) then { Just above that, add this
      A3E_SafeZonePosArray = [ [[18451.9,14278.1,0]], //Altis East trader [[13333.5,14494.3,0]], //Altis Central trader [[6192.46,16834,0]] //Altis West trader ]; { if (_vehicle distance (_x select 0) < 200) then { _vehicle lock false; diag_log format["Vehicle %1 left in trader unlocked @ %2", _class, mapGridPosition _vehicle]; }; } forEach A3E_SafeZonePosArray; Pack pbo and you're good to go
    • By Thug
      In the file server_spawnTraders.sqf
      private "_trader"; { _trader = createAgent [_x select 0,_x select 1,[],0,"CAN_COLLIDE"]; {_trader removeMagazine _x;} count magazines _trader; removeAllItems _trader; // removeAllWeapons _trader;//this is commented out so traders have weapons removeBackpack _trader; _trader switchMove ""; _trader setDir (_x select 2); _trader setVehicleInit "this disableAI 'ANIM'; this disableAI 'AUTOTARGET'; this disableAI 'FSM'; this disableAI 'MOVE'; this disableAI 'TARGET'; this setBehaviour 'CARELESS'; this forceSpeed 0; this allowDamage false;"; _trader setUnitAbility 0.6; _trader disableAI "ANIM"; _trader disableAI "AUTOTARGET"; _trader disableAI "FSM"; _trader disableAI "MOVE"; _trader disableAI "TARGET"; _trader setBehaviour "CARELESS"; _trader forceSpeed 0; _trader allowDamage false; _trader enableSimulation false; } count _this; processInitCommands; What would I have to do to get the Traders to move like they did in v1.0.5.1
      I have tried but can not get it to work.
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...