Jump to content
RimBlock

[Release] - A Plot for life v2.5. Keep your buildables on death. Take plot ownership

Recommended Posts

Most likely. Whilst I can not ensure this will work with all mods out there I will try to help.

If you can find out where it is getting the characterid and why then I can try to suggest some options.

 

Not exactly sure what you mean but in the callevac.sqf

//Setting needed variables to check which Evac-Field the player owns
_evacCallerID = (player getVariable ["CharacterID","0"]);
_evacCallerUID = (getPlayerUID player);
_playerEvacField = [];

Would love to get Evac working again

Share this post


Link to post
Share on other sites

Not exactly sure what you mean but in the callevac.sqf

//Setting needed variables to check which Evac-Field the player owns
_evacCallerID = (player getVariable ["CharacterID","0"]);
_evacCallerUID = (getPlayerUID player);
_playerEvacField = [];

Would love to get Evac working again

 

Possibly.

 

Where is _evacCallerID used after it is populated.  If it is used to check an objects characterID then that is why there will be a missmatch.  All build items will have the converted playerUID in the characterID object_data field.  The comment with the code about "which evac field" would seem to indicate a placed helipad or something like it being needed.

 

If you can provide a link to the mod then I can take a quick look but ifthe mod is big then it will be difficult and very time consuming trying to find a solution.  If the mod not working is not related to my plot pole mod then the auther really needs to be informed and to take a look.  I will have a scan over it though.

Share this post


Link to post
Share on other sites

Thanks for your help it's the poular JAEM by Otter: 

 

Only 4 relatively small files, Thanks for your help again you are a great part of this community Rimblock :)

 

Thanks, will take a look when home tonight.

 

I need to get back in to working on my refueling mod as well (Wolfenstien has been taking up my free time since the weekend) so this will be a good exercise to get back in to 'it'.

 

Will report back when I have something...

Share this post


Link to post
Share on other sites

Thanks for your help it's the poular JAEM by Otter: 

 

Only 4 relatively small files, Thanks for your help again you are a great part of this community Rimblock :)

 

Sorry man, the download link for the evac is dead.  If someone would make it available then I will take a look.

Share this post


Link to post
Share on other sites

 

Thanks.

 

DANGER !!!

This has not been tested.  Please test before putting any changes on your production servers.

 

First observation

SetEvacChopper.sqf

 

Line 111 

_object setVariable ["CharacterID",_playerUID,true];

So what this is doing is trying to set the characterID field of the heli marker to the players PlayerUID.  The problem is that the characterID field is only numerical and the playerUID field is varchar.  For people who have bought the Anniversary edition they have a characters as part of the PlayerUID which will then not go in to the object characterID field.

 

If you search for (should be line 19).

_playerUID = (getPlayerUID player);

change to 

_playerUID = [player] call convertPlayerUID; 

This will sort out that issue / potential issue in that file.  Of course you need this plot pole mode installed for it to work.

 

I will continue to look through the other files.

Share this post


Link to post
Share on other sites

Second change

 

EvacChopper_init.sqf

 

Find (should be line 41).

_evacCallerUID = (getPlayerUID player);

change to 

_evacCallerUID = [player] call convertPlayerUID;

That should now align with change above to SetEvacChopper.sqf 

Share this post


Link to post
Share on other sites

Last item from my quick check.

 

CallEvacChopper.sqf

 

Search for (should be line 34).

_evacCallerUID = (getPlayerUID player);

Change to 

_evacCallerUID = [player] call convertPlayerUID;

That should sort out any issues with playerUID -> object characterID conversions.

 

Note: I see nothing so far that would be affected by my plot pole mod from this quick check.  This is an inherent issue with the evac chopper code.

 

Let me know how it goes.  I will look a bit deeper if this does not sort the issue out.  I would also advise removing any current evac sites and remake them as they may not be setup correctly.

 

If you check your character_data table and have no playerUIDs with letters then this will most likely not do anything.

Share this post


Link to post
Share on other sites

Ok Thanks for looking into it but it seems to now work but only until you die?

 

Thanks

 

I would imagine that is how it is meant to work ??.  How did it work before (I though it was not working) ?.

 

It can, of course, be amended to work by relating the evac point only to the playerUID fairly easily.  I have PM's OtterNas3 regaring his JAEM script and if he has no more real interest in supporting or he is fine with it then I will look at doing that and putting out there as a seperate "JAEM for life" release (obviously with full credits to OtterNas3).  That way people can decide which way then want to run their servers (persistant to the playerUID or loose it all on character death).

 

RB

Share this post


Link to post
Share on other sites

Anyone have "show plot boundary" staying after you use it whether you're looking at plot or not? I'm triple checking but I'm pretty sure I followed the instructions on that part correctly.

 

Anyone else seeing this ?.

 

The scroll wheel options can be a bit touchy sometimes and not refresh when they should especially if you have lots of stuff in the fn_selfactions.sqf or fn_damageactions.sqf files.

 

I don't recall seeing this problem myself but if others are also seeing then I will have a dig and see what may be going on or how it could be improved.

 

Thanks

RB

Share this post


Link to post
Share on other sites

I would imagine that is how it is meant to work ??.  How did it work before (I though it was not working) ?.

 

It can, of course, be amended to work by relating the evac point only to the playerUID fairly easily.  I have PM's OtterNas3 regaring his JAEM script and if he has no more real interest in supporting or he is fine with it then I will look at doing that and putting out there as a seperate "JAEM for life" release (obviously with full credits to OtterNas3).  That way people can decide which way then want to run their servers (persistant to the playerUID or loose it all on character death).

 

RB

 

I'm afraid not they stay forever and you can call for an evac if a heli is on the field.

 

Thanks

Share this post


Link to post
Share on other sites

Ok, 

 

So exactly where is it not working.  

  • It works fine multiple times until you die and then it will not work at all ?.  
  • Does it delete the heli evac marker ?. 
  • Are you able to remove the heli evac marker ?.
  • Is "evac_needRadio" in EvacChopper_init.sqf set to 0 or 1 ?.
  • Does the new character have a radio ?.
  • Is the option to call the ecav chopper in the new characters scroll wheel menu ?.
  • If you place the evac marker and then exit the game and login again doe sit still work ?.
  • Anything else strange happening ?.

 

Another thought is that when you first login the script looks for evac points you own within 40,000 mtrs.  If you are further away it will not find them and it only checks at your first login.  What you can try is...

  • Die  ;) .
  • Login as a new character.
  • Move to where your previous character placed the heli evac point.
  • Logout.
  • Login (should be at the heli evac point).
  • Go somewhere and try to call an evac.

 

That will prove if it is a range issue or not.

 

Those questions may help me narrow down the issue without having to breakdown the entire set of scripts.

 

Thanks.

Share this post


Link to post
Share on other sites

Ok will test them but 

 

- The helipad stays 

 

- THe option to call persists for everyone regardless if they have a helipad

 

- The script is supposed to work after death 

 

- No i haven't got it set to require a radio

 

- The script is supposed to let you be able to delete your helipads but i've only ever seen that once

 

Thanks

Share this post


Link to post
Share on other sites

Anyone else seeing this ?.

 

The scroll wheel options can be a bit touchy sometimes and not refresh when they should especially if you have lots of stuff in the fn_selfactions.sqf or fn_damageactions.sqf files.

 

I don't recall seeing this problem myself but if others are also seeing then I will have a dig and see what may be going on or how it could be improved.

 

Thanks

RB

 

I'm also seeing this.  I haven't started digging myself, it's not so annoying to make it a priority :)  However, the only thing I installed from this thread is that plot boundary action, since I had already converted to playerUID.

Share this post


Link to post
Share on other sites

I'm also seeing this.  I haven't started digging myself, it's not so annoying to make it a priority :)  However, the only thing I installed from this thread is that plot boundary action, since I had already converted to playerUID.

 

Having taken a look on my own server, the "show plot area" does not easily disappear but it will disappear if you look at another object.  Maintain area is using the exact same method and also gets stuck if you do not look at another object.

 

The remove object (i.e. block wall or doorway) disappears when you stop looking as the object but if you look from one object to another quickly then it will also stick.  This sometimes leads to removing a section of floor or wall next to the one you wanted to remove.

 

The upgrade option from buildables seems to work much better than the others and quick looking from buildable object to another buildable switches the option accurately.  The upgrade menu item code checks the current item against another global variable of the "s_player_lastTarget" to see if the cursor target has changed since the last upgrade item was added.

 

So, the current restriction that you need to look at anther object for the menu item to disappear and as it will take a fair amount of effort to improve that I am inclined at this point to leave it like that.  I plan to rewrite the whole playerUID for buildables function so would rather limit my work on this one to big(ish) bug fixes if any more are seen.

 

If anyone wants to look at a more robust way of doing this then please feel free and if you want to make it available tne post it here and I will put it in the first post with full credits. 

Share this post


Link to post
Share on other sites

Hello,

 

I have recently added this mod to my server as it is a amazing addon, a must have imo! As i added the addon, i keep having the same problem. 

 

You can only build after the server restarts, normaly you place the plot pole and you build. Now this does not work anymore.

 

The plot pole saves after the restart tough, and you can die as much as you want and you can still build with the same plot pole.

 

I have followed the instructions and have looked through them over and over and over again but couldn't find the reason why this is happening and/or how to fix this. Anyone got a idea?

 

Problem:

 

Plot poles only work after a server restart.

 

Its a serious problem but i am happy that it works after the restart.

 

Regards,

 

Dutchy

Share this post


Link to post
Share on other sites

 

Problem:

 

Plot poles only work after a server restart.

 

Its a serious problem but i am happy that it works after the restart.

 

Regards,

 

Dutchy

 

Hi Dutchy,

 

That is not how it should work.

 

What happens is that the plot pole will be generated in the world your client version of Epoch sees.  This new item is then sent to the server, asking the server to notify all the other clients looking at the same Epoch world that a new item now exists.  Then, based on set triggering events, the item will be written to the database.  The database is just used for persistence between server restarts and is not used for every time you use various items.  The copy of the world is modified in your computers memory and only updated to the DB every now and then to reduce network traffic and lag.

 

So in order to assist, I will need to know a bit more.

 

When you build a plot pole, does it appear ?.

What message do you get if you try to build if it does appear ?.

 

Any other information you could give would be good, step by step.

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

I have been reading all posts in this "plot for life" as well as the the original thread for the last hour. I have decided to install your implementation as it is the more efficient one (& also more actively supported one from what I see).

 

Unfortunately just at PreCheck step 3, I got an error message. I don't know if something is different in my MySQL server/client but I would very much appreciate if you can take a look and advise please.

 

 

Steps to reproduce: I simply copied the SQL pre-check code and pasted into a new SQL query window in Navicat client. 

MySQL server version info: "D:\MySQL\Program\MySQL Server 5.6\bin\mysql.exe  Ver 14.14 Distrib 5.6.19, for Win64 (x86_64)"

 

Client info: Navicat v.9.0.11

 

Thanks!

 

 

 

UTQJ6mU.png

 

 

Share this post


Link to post
Share on other sites

...

 

 

Unfortunately just at PreCheck step 3, I got an error message. I don't know if something is different in my MySQL server/client but I would very much appreciate if you can take a look and advise please.

 

 

Steps to reproduce: I simply copied the SQL pre-check code and pasted into a new SQL query window in Navicat client. 

MySQL server version info: "D:\MySQL\Program\MySQL Server 5.6\bin\mysql.exe  Ver 14.14 Distrib 5.6.19, for Win64 (x86_64)"

 

Client info: Navicat v.9.0.11

 

 

 

Hi MGM,

 

I use MySQL Workbench as it comes with the MySQL install (inc. the free community version) and is pretty powerful (although still far from perfect).  It also gives a baseline as everyone has it, just like vi on UNIX servers.

 

My suspicion is that NaviCat is not seeing the direct delimeter as the start of a code block and is therefore complaining at the end delimeter.

 

Suggestions

You could try MySQL Workbench and it should work without issue.

Run the first "drop" command and then run the second "create" block of code without the delimeters around it (take out the "DELIMITER | " at the start and the "| DELIMITER ; " at the end).  Worst that will happen is that it will not create the function.  If it fails try adding a ";" after the "END".

 

I am not near a MySQL server so cannot test for you so this is a bit of testing by proxy ;) .

 

Let me know which way you have tried and the result and we can go from there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By vbawol
      Open world survival mod set just two years after the mass extinction of billions of people. Those that remain are left with remnants of a once technological society. Try to survive, build, or explore your way through the harsh dynamic environment.
      Features
      Powerful persistence framework for Arma 3 with native Windows and Linux dedicated server support. Fully configurable script based security checks. Base Building re-envisioned for Arma 3 PhysX. Persistent secure and insecure storage devices. Upgradeable locking doors. Barter based economy and trading systems backed a single currency ¤ called "Krypto". Hostile Environment with several different types of antagonists, Air and Water temperature extremes, and Earthquakes. Hunting, Fishing, Tame Dogs, Explore & Loot: Wrecked ships, Abandoned vehicles and buildings, Perform task based missions and more! Open source APL-SA Epoch Survival MP gamemode. Open source APL-SA Modders resource configs and Class List. Assets can be used as a mod dependency on Steam workshop.
    • By McLovin
      NOTICE: Duplicate of another question posted in the wrong section.
       
      So I've been playing this server that has a number of mods installed. I've been playing it for quite a while with the only errors I've been getting are regarding a 45 round RPK mag being missing, but other than that I've had no errors or any issues loading. Upon trying to place a plot pole, nothing happens; absolutely nothing, like no preview shows up, no prompt saying "starting construction" or anything like that, just blankness. When I try to do it again it says "building already in progress" and I can't do anything, not even lock my vehicle. Is there anything that can be done, or that can explain this phenomenon? To further the understanding of how this came to be, I bought a plot pole from the trader in Trader City Stary and tried placing it near Stary, but not too near it (near a thicket of bushes in the distance). Upon right clicking and hitting the build option, that's when I face my issue.
    • By victorks
      my first work in editin :) https://uploaddeimagens.com.br/imagens/20180307202515_1-jpg https://uploaddeimagens.com.br/imagens/20180307202245_1-jpg DOWNLOAD: https://www.dropbox.com/s/oq97j7x59362kqe/CASTLEai.sqf?dl=0 AI M2 NEED WAI: https://pastebin.com/GJMnPvZP ON THE MAP: https://pastebin.com/cyqH9rNV  
       
      https://www.dropbox.com/s/oq97j7x59362kqe/CASTLEai.sqf?dl=0
       
       
       
       
       
       
       
       
       
    • By totis
      Hi
      This is a restriction to vehicle seat according to humanity.
      It may be handy to PVE servers out there.
      Special thanks to Juandayz with his fantastic skills and salival. Both sometimes working unseen for the benefit of this community.
      Step 1.
      Make a new file, Name it veh_hum.sqf with the below contents and put into dayz_epoch/addons folder. If you dont have addons just create one.
      In this example we have a hero superhero and agenthero traders with 20k/40k/60k humanity respectively. Adjust according to your needs.
       
      private ["_vehicle","_inVehicle","_driver","_humanity","_txt"]; while {true} do { _vehicle = vehicle player; _inVehicle = (_vehicle != player); if (_inVehicle) then { _driver = driver (vehicle player); if (({(isPlayer _driver) && (alive _driver)} count (crew _vehicle) > 0)) then { _humanity = _driver getVariable["humanity",0]; if (typeOf _vehicle in DZE_heroHumanity && _humanity <= 20000 || (typeOf _vehicle in DZE_superHeroHumanity && _humanity <= 40000) || (typeOf _vehicle in DZE_agentHumanity && _humanity <= 60000)) then { player action ["getOut", (vehicle player)]; titleText ["","WHITE IN"]; _txt = "<img image='addons\vehicon.paa' /><br/><t size='0.7' color='#ea2828' align='center'>prohibited vehicle</t>"; [_txt, [safezoneX, safezoneW], [0.20 * safezoneH + safezoneY, 0.3 * safezoneH], 2, 0.5] spawn BIS_fnc_dynamicText; }; }; }; sleep 3; };  Step 2: Download this file http://www.mediafire.com/file/bdpt5d96o5cttk3/vehicon.rar
      Unzip and put paa file into addons folder.
      Step 3: Edit your custom variables file    dayz_code/init/variables.sqf
      Put the vehicles you want to restrict below call dayz_resetselfactions; ike this:
      // Custom below s_givemoney_dialog = -1; s_bank_dialog = -1; s_player_checkWallet = -1; s_bank_dialog1 = -1; s_bank_dialog2 = -1; s_player_copyToKey = -1; s_player_claimVehicle = -1; s_collect_heli = -1; }; call dayz_resetSelfActions; DZE_heroHumanity = ["Mi17_rockets_RU","Mi24_D","UH1Y_DZE"]; DZE_superHeroHumanity = ["Mi24_V","Mi24_P","Ka52"]; DZE_agentHumanity = ["AV8B2","AV8B","A10","F35B"]; DZE_safeVehicle = DZE_heroHumanity + DZE_superHeroHumanity + DZE_agentHumanity +["ParachuteWest","ParachuteC"]; Step 4: Edit your init file to exec the script. Above the   (false,12)execVm.... like below
          [] execVM "addons\veh_hum.sqf";
          //[false,12] execVM "\z\addons\dayz_code\compile\local_lights_init.sqf";
      Thats it. Enjoy!
        Hide contents
    • By Kovicson
      Hi Folks!
      I was wondering if theres a way to stop players from removing plot poles that aren't theres?
      Using a toolbox, crowbar and Etool players can remove Plot poles that dont belong to them, anyway to fix and remove that option?
       
      Thanks :)
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...