Jump to content
  • 0
Blakedahlia

Vehicles and content within them/safes will not save to database.

Question

So i have my server running fine, at least it was up until I installed the Blue Phoenix Admin Tools. 

That is literally the only thing that I can see messing with the database.

The problem is exactly as the topic title reads. I server restart and everything is back to how it was.

I installed the admin tools, got them working (besides the vehicles blowing up when i get in them and the ESP/Tele not working)

The problem might be that I didnt change the correct lines of code when installing it.

http://doom56.com/dayz/admin-tool-1-7-7-1

This link shows that I'm supposed to change certain lines that i can't seem to find!

https://www.youtube.com/watch?v=Mil0hgZzvJo

This is the video that I tried to follow in order to install it.

 

 

This is the method i used to make my server if that helps at all 

https://www.youtube.com/watch?v=O3vgAWLF-8M

 

PLEASE don't let this get buried with no answers.

Not getting vehicles or stuff in safes to save is literally driving me crazy 

 

And also;

Buildings that ive made within the game save (concrete walls, floors, basic epoch crafting)

And vehicles bought from traders save but when i move them they go right back to the trader on restart.

So, STUFF IS SAVING TO THE DB.(navicat) but certain things arent.

 

 

 

 

thank you!

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Just look athe official instructions, why do you need some video on how to edit text files that is stupid (sorry but I hate youtube videos to explain stuff like this, takes 5 times longer to follow them then just a list of text instructions haha):

https://github.com/BluePhoenix175/DayZ-Admin-Tools-

 

I'M MISSING LINES THAT IT SAYS I SHOULD HAVE

It's hard to follow steps when they say i should have things that i don't.

its like putting on new brakes and you're missing the pads.

Share this post


Link to post
Share on other sites
  • 0

The lines are there, just a little different because they may change with every new epoch update, so you cant do a 1:1 search and replace sadly. I am not on my computer atm but there are many posts about that in this forum, maybe look around a little or learn what the line actually means and not just replace something? Just a tip

Share this post


Link to post
Share on other sites
  • 0
Blakedahlia

The problem you may be having is the Blue Phoenix depends on the "Sarge" variable.  So if you are running DZAI, or Mission or some other AI type program, you still have to add this to your cleanup file.   If you dont have that in there...try it and see if that helps.

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

I am running Blue Phoenix and Mission for my AI mission?  Can you please post what the server_updateObject.sqf should look like?  Do you include both like this?

if (_object getVariable "Mission" == 1) exitWith {};
if (_object getVariable "Sarge" == 1) exitWith {};

 

Thanks

Share this post


Link to post
Share on other sites
  • 0

I managed to fix this annoying issue last night. I replaced the Server_updateobject.sqf with a default one and now objects(&vehicles) are updating.

For those with the same issue, repeat the step above. Make sure to backup just incase!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By 2DayZ2Retirement
      -PROBLEM SOLVED-
       
      G'day, Survivors.
      I am having an issue on my server where vehicles which spawn randomly around the map repair themselves upon server restart.
      I use this config in my init.sqf which successfully spawns the vehicles in damaged and with low fuel...
      DynamicVehicleDamageLow = 75;
      DynamicVehicleDamageHigh = 100;
      DynamicVehicleFuelLow = 0;
      DynamicVehicleFuelHigh = 25;
      ...However upon each server restart the vehicles repair themselves (the fuel remains low however) and for the life of me I can't figure out why this is happening. 
      DayZ Version -DayZ Epoch 1.0.6.2
      Scripts Used -DZAI | -DZMS | -Right Click Actions (Suicide, Smoke Drugs, GPS Scan)
      AntiHack - InfiSTAR
      Server Host - GTXGaming
      My HiveEXT.log and arma2oaserver.RPT logs are not showing anything out of the ordinary.
      I'm not sure if it matter, but all Planes/Helicopters and Boats have been removed from the server via the dynamic_vehicle.sqf.
      In addition, all of the traders and trader cities being removed by removing the call for the CfgServerTrader.hpp in the description.ext.
      If there is any other info I can show to assist in fixing this problem please let me know, any help would be greatly appreciated.
      Cheers.
    • By Brian Soanes
      To unlock vehicles left in your traders over a server restart, open your epoch_server.pbo

      In epoch_server\compile\epoch_vehicle\EPOCH_load_vehicles.sqf
      Find
      if (_allowDamage) then { Just above that, add this
      A3E_SafeZonePosArray = [ [[18451.9,14278.1,0]], //Altis East trader [[13333.5,14494.3,0]], //Altis Central trader [[6192.46,16834,0]] //Altis West trader ]; { if (_vehicle distance (_x select 0) < 200) then { _vehicle lock false; diag_log format["Vehicle %1 left in trader unlocked @ %2", _class, mapGridPosition _vehicle]; }; } forEach A3E_SafeZonePosArray; Pack pbo and you're good to go
    • By JakeQue
      Is there anyway to add a disable footsteps for admins?
       
      Also I would love to be able to spawn a mission in from the admin menu, I tried some code but it just breaks Infistar, it would seem it is executing it automatically.
       
       
      Thank you!
    • By NoxSicarius
      NOTICE For those who want to use this in 1.0.6
      Instead of using this one, I suggest visiting the following thread for game version 1.0.6 and up
       
      The tools are partially updated for the new release. Most features are working so far and it can be downloaded from here (follow the readme for install): https://github.com/noxsicarius/Epoch-Admin-Tools/tree/TestBranch

       
       
      IMPORTANT:
      Under NO circumstances should you download this tool from a different source. I have been notified of numerous virus downloads listed as my work (usually second page of google and farther). I have petitioned to have all of the ones I know of blacklisted and have sent virus profiles to all major antivirus companies. If you find a .exe in any work claiming to be mine, it is a virus and should be shredded. 
      Please only download from MY github link or the links in this post.
      My github repo will NEVER be removed and if I leave the project and someone wishes to take over, they will be given rights to the repo.
       
      Features:
       
      For help with Administration:
      Multiple Admin levels Spectate players "Display code" for locked vaults/doors "Create key" for vehicles with lost keys Force lock and unlock vehicles without keys Base Destruction - Destroy all buildables/vehicles within a customizable radius Spawnable crates with weapons, items, and supplies Spawn locked or temporary vehicles via the menu or a custom-made graphical vehicle menu (screenshot) Other features:
      Godmode Teleport self (or others to you) Flying Invisibility Delete and repair/refuel vehicle on crosshairs ESP - display players, zombies, safes, tents, vehicles, and AI on the map ...and more! Installation, changes, additional information, FAQ, credits, issues and everything else can be found at the project page on Github:

      Epoch Admin Tools on GitHub
      Click here for an install tutorial video for the tool
      I have been informed that some places block GitHub, so here are direct links hosted by me:
      Newest full release: https://www.dropbox.com/s/pjvj07u5yemo7we/Epoch-Admin-Tools-master.zip?dl=0
      Beta build: https://www.dropbox.com/s/xm6t1k3gvp3t8ex/Epoch-Admin-Tools-TestBranch.zip?dl=0


      If you have an improvement you would like to add, make a pull request and make these tools even better!


      Error Reporting:
       
      BEFORE posting an issue on Github or on this forum:
      If you think you might have installed it incorrectly, follow the YouTube Video Install Tutorial Try reinstalling the tool. You more than likely missed something important. Do a quick search on this forum for a fix to your problem. Check your server's RPT log for errors. This will identify 99% of problems with the menu. Be ready to copy/paste the RPT log into Pastebin or Gist in an issue or in the discussion forum for help with troubleshooting. If your problem persists after doing the above:
      Open your arma2oaserver.rpt file in a text editor and copy/paste the RPT log into Pastebin and post your issue in this forum with the rpt log. If you post something like "It doesn't work" I will not acknowledge you. Not giving all possible details in the first post simply makes it take longer to resolve and will waste everyone's time. I am hard pressed for time these days so if you won't take the initiative to provide information, I won't ask for it either. I am not trying to be mean, but I am quite tired of getting 5 or less word posts that provide no information other than this person has some kind of problem somewhere on their server that may or may not be related to this mod. If the problem you are posting is a bug and not a general install problem then post it to this forum AND to the github issues page.  
      I have been asked by someone if they can donate to the project so I am adding the link here.
       
       
      I have invested a good deal of time into this so if you find it useful please give a little donation.
      (DONATE)
      I also accept Crypto Currency: 
      Bitcoin: 1GkzMzwnVwVpnUCVFaAyLDsgD9cqSfigdm
      Litecoin: LbUrUxXzA557VeTWXM8jP7hNf3uZHEqW5b
       
      A sincere thanks to those who made a monetary contribution to this project: calamity, CRHASH, BMovieQueen, zixxel, 8BitSigdom, Anarior, f3cuk, Caveman1, Nathan, [member=WootyWoop], [member=Terrance Smith]
      A huge thanks to those who make the community a better place by answering questions on this project: @juandayz, @EditedSnowHD
      Please leave your name in a note if you donate so that I can list you above.
    • By Tricks
      I have been browsing the forums looking for unique mods to add to my server. I noticed Juandayz deleted a lot of his mods before leaving the community. Just curious if anyone has them all and would possibly repost them giving him full credit? I am particularly interested in his "Admin Skin" and "Debug" mods.
       
      Thanks community, here's hoping someone will step up!
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...