Jump to content
Halvhjearne

Custom Spawn Dialog with Gear & HALO Selection, moving Map, Credits, Custom spawns and more ...

Recommended Posts

can someone with default antihack check if players are still teleported up in the air when they halo?

 

I can confirm this still happens. You are teleported back up into the sky when you reach a certain elevation.  Sometimes you are teleported to a new location

Share this post


Link to post
Share on other sites

I can confirm this still happens. You are teleported back up into the sky when you reach a certain elevation.  Sometimes you are teleported to a new location

 

I can confirm this still happens. You are teleported back up into the sky when you reach a certain elevation.  Sometimes you are teleported to a new location

The same thing is happening on our servers unless the player is an admin.

Share this post


Link to post
Share on other sites

I can confirm this still happens. You are teleported back up into the sky when you reach a certain elevation.  Sometimes you are teleported to a new location

 

Hey Halv,

 

Got stock AH on my Server , and yes they still get teleported back in the air if they use Halo.

 

Greets klinGiii

 

The same thing is happening on our servers unless the player is an admin.

 

i belive it is possible to edit the default antihack file yourself now and fix the halo problem, in server securityfunctions.sqf try find this line (should be 951):

if (((_distance/(_curTime-_lastTime)) > 10) && _notNearbySpawn && (player == vehicle player)) then {

change it to this:

if (((_distance/(_curTime-_lastTime)) > 10) && _notNearbySpawn && (player == vehicle player) && animationState player != 'halofreefall_non') then {

if it works, pls report back here.

 

regards

Halv

Share this post


Link to post
Share on other sites

Hey Halv,

 

I am now running Australia, and this script seems to work great. My only issue is I can't seem to figure out how to add coords for additional spawn locations. I added the spawn locations from the Australia.h file, which do show, but when I add the others I get nothing additional to choose from.

 

 //create new world spawns, use lower case letters only or it will not be detected (only [x,y] needed)
	case "Australia":{
		[
			[[-0.286865,8.17383]],//locked for everyone but lvl 2
			[[-0.415527,-7.05298]],
			[[13.5127,0.410156]],
			[[-14.4316,0.112793]],
			[[16784,33842.9]], //Darwin
			[[22098.8,25658.6]], //Alice Springs
			[[26768.2,28071.3]], //Mount Isa
			[[31984,29807.4]], //Cairns
			[[28603.6,35171]], //Weipa
			[[31885.8,22248.3]], //Queensland
			[[31022.4,19973.5]], //Toolwoomba
			[[37989.9,19991.8]], //Brisbaine
			[[25018.8,12777.2]], //Adelaide
			[[31405.5,11487.6]], //Victoria
			[[35390.7,8518.17]], //Eden
			[[22409.4,13958.1]], //Central Trader
			[[5532.18,18522.9]]	//Perth
		]
	};

	default{[]};
}; 

 

I'm obviously doing something wrong, just not sure what yet. I haven't had a lot of time to test out other options. Figured you might see something right away.

 

Thanks!

Share this post


Link to post
Share on other sites

Hey Halv,

 

I am now running Australia, and this script seems to work great. My only issue is I can't seem to figure out how to add coords for additional spawn locations. I added the spawn locations from the Australia.h file, which do show, but when I add the others I get nothing additional to choose from.

 

 //create new world spawns, use lower case letters only or it will not be detected (only [x,y] needed)
	case "Australia":{
		[
			[[-0.286865,8.17383]],//locked for everyone but lvl 2
			[[-0.415527,-7.05298]],
			[[13.5127,0.410156]],
			[[-14.4316,0.112793]],
			[[16784,33842.9]], //Darwin
			[[22098.8,25658.6]], //Alice Springs
			[[26768.2,28071.3]], //Mount Isa
			[[31984,29807.4]], //Cairns
			[[28603.6,35171]], //Weipa
			[[31885.8,22248.3]], //Queensland
			[[31022.4,19973.5]], //Toolwoomba
			[[37989.9,19991.8]], //Brisbaine
			[[25018.8,12777.2]], //Adelaide
			[[31405.5,11487.6]], //Victoria
			[[35390.7,8518.17]], //Eden
			[[22409.4,13958.1]], //Central Trader
			[[5532.18,18522.9]]	//Perth
		]
	};

	default{[]};
}; 

 

I'm obviously doing something wrong, just not sure what yet. I haven't had a lot of time to test out other options. Figured you might see something right away.

 

Thanks!

 

the top 4 are not coords but offsets for the teleporters, you need to use the last entry from that array, however the script can add these for you.

 

besides this i just exactly updated the script with positions for australia, thanks to Tophi.

Share this post


Link to post
Share on other sites

the top 4 are not coords but offsets for the teleporters, you need to use the last entry from that array, however the script can add these for you.

 

besides this i just exactly updated the script with positions for australia, thanks to Tophi.

 

your welcome

Share this post


Link to post
Share on other sites

I just updated to your latest code. I saw in the thread a few pages back you were having issues with spawning near the jammer. Is that still an issue? 

 

Also, I have the spawn near group leader function enabled and it worked previously, however no one is getting the option in the list now.

Share this post


Link to post
Share on other sites

I just updated to your latest code. I saw in the thread a few pages back you were having issues with spawning near the jammer. Is that still an issue? 

 

Also, I have the spawn near group leader function enabled and it worked previously, however no one is getting the option in the list now.

 

yes, i disabled that so its cannot be activated in the settings currently.

 

i did not change anything about spawning on group leaders, the problem is most likely a nearby corpse or the player is the leader.

Share this post


Link to post
Share on other sites

 

 

 

 

i belive it is possible to edit the default antihack file yourself now and fix the halo problem, in server securityfunctions.sqf try find this line (should be 951):

if (((_distance/(_curTime-_lastTime)) > 10) && _notNearbySpawn && (player == vehicle player)) then {

change it to this:

if (((_distance/(_curTime-_lastTime)) > 10) && _notNearbySpawn && (player == vehicle player) && animationState player != 'halofreefall_non') then {

if it works, pls report back here.

 

regards

Halv

 

Tried this Halv and no go. Normal players get banned for Epochmod.com autoban. I do have the above fix in. Its only the Halo jump currently it has a problem with.

Share this post


Link to post
Share on other sites

with Stock AH epochban is happening each jump

 

 

 

 

 

 

i belive it is possible to edit the default antihack file yourself now and fix the halo problem, in server securityfunctions.sqf try find this line (should be 951):

if (((_distance/(_curTime-_lastTime)) > 10) && _notNearbySpawn && (player == vehicle player)) then {

change it to this:

if (((_distance/(_curTime-_lastTime)) > 10) && _notNearbySpawn && (player == vehicle player) && animationState player != 'halofreefall_non') then {

if it works, pls report back here.

 

regards

Halv

 

did you try this?

Share this post


Link to post
Share on other sites

yes, i disabled that so its cannot be activated in the settings currently.

 

i did not change anything about spawning on group leaders, the problem is most likely a nearby corpse or the player is the leader.

 

Hello, in future release, will it be possible to spawn near jammer or group again?

Ty, Rui

Share this post


Link to post
Share on other sites

Does anyone have Esseker spawn coords?

 

Or can tell me how I can get them.

 

Cheers.

 

EDIT: Also I guess it would be good to ask would this even work on Esseker. I have put it in already and it removes the default teleporters. It places the infostands and I get the select spawn on mousewheel. But when I click nothing happens. No dialog or anything.

 

Cheers again :D

Edited by matrixmark

Share this post


Link to post
Share on other sites

EDIT: Also I guess it would be good to ask would this even work on Esseker. I have put it in already and it removes the default teleporters. It places the infostands and I get the select spawn on mousewheel. But when I click nothing happens. No dialog or anything.

 

Cheers again :D

 

 
  • will work on any map that spawns a "Debug_static_F" (even unsupported maps, alltho you might need to add spawn locations)

Share this post


Link to post
Share on other sites

 

woops my bad :lol:

 

How do I get the coords?

 

Edit: Nevermind I think i got it using:

 

 

hintSilent str getPos player;

 

 

  I added a test spawn option in and it works but it spawned me around 1.2k from the coords I picked. Is this normal. It seems most of the spawn options tp you a ways from the location you chose.

Edited by matrixmark

Share this post


Link to post
Share on other sites

woops my bad :lol:

 

How do I get the coords?

 

Edit: Nevermind I think i got it using:

 

 

 

  I added a test spawn option in and it works but it spawned me around 1.2k from the coords I picked. Is this normal. It seems most of the spawn options tp you a ways from the location you chose.

 

 

here:

	case "esseker":{
		[
			[[9500,5600]],	//esseker
			[[11900,7950]],	//Novi Grad
			[[11082,10280],2],	//Camp Spencer
			[[2655,1269]],		//Grozna Mountain
			[[2000,4180]],	//Krupa
			[[6470,5445],1],	//Neptun Resort
			[[6660,3850]],		//Plava Vrana
			[[9950,10725]]	//Gromada Caves
		]
	};

Share this post


Link to post
Share on other sites

woops my bad :lol:

 

How do I get the coords?

 

Edit: Nevermind I think i got it using:

 

 

 

  I added a test spawn option in and it works but it spawned me around 1.2k from the coords I picked. Is this normal. It seems most of the spawn options tp you a ways from the location you chose.

In spawn_settings.sqf look for

//Spawn area radius, setting this low might make bis_fnc_findsafepos fail and place the player in the middle of the map

_area = 1500;

this is a radius of the coords you select so it would up to a 1500m radius. Use a smaller number and see if that does the trick.

Share this post


Link to post
Share on other sites

https://gyazo.com/ab6e293e838618c62b6b10981db6320e

 

Huh, what did i forget?

I read the instructions over and over again and i got everything.

I installed 3 times and always worked first time.

Now i reinstalled the server and i failed.

Do someone knows whats going on? nothing in the logs or rpt accept the screenshot i added here.

 

Thnx

 

https://gyazo.com/ab6e293e838618c62b6b10981db6320e

Share this post


Link to post
Share on other sites

I allready solved it!

 

Does anyone know why i must add all the backpacks in the createvehicle.txt?

cuz i get kicks of every backpack now.

anyone got a sollution so all the items get accepted?

 

Thnx

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By THAC0_Gewch
      https://github.com/OlofTheBald/DayZ-Humanity-Loadout-Granter/tree/Epoch_1.0.5.1
       
      Updated for 1.0.6.x
    • By THAC0_Gewch
      Many years ago, I made a Humanity Loadout script for 1.0.5.x. The script is basic, it checks your players' humanity and grants a pre-set loadout when they spawn depending on their humanity level.
      I've now updated and optimized this script for 1.0.6.x:
      https://github.com/OlofTheBald/DayZ-Humanity-Loadout-Granter
       
       
    • By Restiphani
      Our server is running however when someone gets killed it looks like it's using the standard revive with the defibrillator and you can only revive once per spawn. How do you change that to unlimited revives or to use the multigun with the heal player attachment?
    • By JakeQue
      Is there anyway to add a disable footsteps for admins?
       
      Also I would love to be able to spawn a mission in from the admin menu, I tried some code but it just breaks Infistar, it would seem it is executing it automatically.
       
       
      Thank you!
    • By JakeQue
      Hi, me again.
       
      For some reason when i spawn in and collect coins or loadout the next time i disconnect and come back it puts me back into spawn and money is all disappeared. 

      There's no hive errors.
      The only error in the Server RPT is :
      And I have 2 errors in my client RPT. Looks like they relate to zsc but I have reinstalled it from scratch and still the same.
      and 
       
      Sorry to be such a noob with this one!!
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...