Jump to content
JasonTM

[Release] Wicked AI 2.2.3 [1.0.6+]

Recommended Posts

9 minutes ago, houst said:

hey all..i have the overpoch version on 1.0.6.1 and i have a issue..the m2 gunners seem to be killing the other AIs when the missions spawn in? any idea what i can do to stop this??

 

Thanks.

Do you mean that they shoot other AI's or do they spawn in the other AI's and kill them trough suffocating in an object?

Share this post


Link to post
Share on other sites
On 10/16/2017 at 10:01 AM, houst said:

hey all..i have the overpoch version on 1.0.6.1 and i have a issue..the m2 gunners seem to be killing the other AIs when the missions spawn in? any idea what i can do to stop this??

 

Thanks.

are you make a custom mission? if so 

look at 

    //Static Guns
    [[
        [(_position select 0) + 0.1, (_position select 1) + 20, 0],
        [(_position select 0) + 0.1, (_position select 1) - 20, 0]
    ],"M2StaticMG","Easy","Bandit","Bandit",0,2,"Random","Random",_mission] call spawn_static;
 

you notice the    "Bandit","Bandit"

    ],"M2StaticMG","Easy","Bandit","Bandit",0,2,"Random","Random",_mission] call spawn_static;

 

change it to ur likings and DONE!

Share this post


Link to post
Share on other sites
On 17/10/2017 at 5:40 PM, (AOW)Recon said:

are you make a custom mission? if so 

look at 

    //Static Guns
    [[
        [(_position select 0) + 0.1, (_position select 1) + 20, 0],
        [(_position select 0) + 0.1, (_position select 1) - 20, 0]
    ],"M2StaticMG","Easy","Bandit","Bandit",0,2,"Random","Random",_mission] call spawn_static;
 

you notice the    "Bandit","Bandit"

    ],"M2StaticMG","Easy","Bandit","Bandit",0,2,"Random","Random",_mission] call spawn_static;

 

change it to ur likings and DONE!

sorry for late reply............no this is just when missions spawn in...i had my admins keep an eye out on them and as they spawned in with m2 gunners they started shooting at the other AI that spawned in with them on that said mission...lol 

Share this post


Link to post
Share on other sites

Hello,

Does anyone know why WAI is stopping some of the trader menu scroll options from working on some traders I have to right click/zoom on them to get an option for the trader menu. I tested it on a default server no mods and my traders was working correctly but once WAI is installed the problem begins.

thanks.

Share this post


Link to post
Share on other sites
43 minutes ago, Dr.Killmore said:

Hello,

Does anyone know why WAI is stopping some of the trader menu scroll options from working on some traders I have to right click/zoom on them to get an option for the trader menu. I tested it on a default server no mods and my traders was working correctly but once WAI is installed the problem begins.

thanks.

Change the skins of the traders to ones not holding guns

Didnt know this would be related to WAI in any way as you dont modify Fn_SelActions which is what controls you targeting something to be scrollwheel-able

Share this post


Link to post
Share on other sites
On 02/11/2017 at 1:03 PM, Dr.Killmore said:

Hello,

Does anyone know why WAI is stopping some of the trader menu scroll options from working on some traders I have to right click/zoom on them to get an option for the trader menu. I tested it on a default server no mods and my traders was working correctly but once WAI is installed the problem begins.

thanks.

Thanks for you're response it is very much appreciated and i apologise for being a bit vague in the first post.

 

The traders don't have weapons it is a standard default epoch chernarus 1.0.6.1 server. First I tried default no infistar no mods installed and traders work fine but when WAI 2.2.1 is installed the issue occurs. There is no client side rpt or server side rpt errors giving any clues as to why this is happening.

 

I will post the traders chernarus11 and fn_selfActions but as you will see they are default I do not know how this can be happening on a default server? On my modded server I also have this problem since 1.0.6.1 this is what made me do a default test clean database clean files and i had the same issue with black market stary, Boat dealer south, vehicle parts bash & bandit trader all have no menu unless you right click/zoom on them. 

I have checked all the skins for sale at traders and i made sure no traders or AI in WAI had conflicting skins.

Thanks.

Edited by Dr.Killmore
removed traders chernarus11 and fn_selfActions from the post as it was irrelevant

Share this post


Link to post
Share on other sites
6 hours ago, DieTanx said:

Change the skins of the traders to ones not holding guns

Didnt know this would be related to WAI in any way as you dont modify Fn_SelActions which is what controls you targeting something to be scrollwheel-able

Thanks again for you're reply I have quoted with a response to my own post by accident lol so instead of spamming twice I thought I would let you know so I am sure you have seen it.

Share this post


Link to post
Share on other sites
On 2. 11. 2017 at 2:03 PM, Dr.Killmore said:

Hello,

Does anyone know why WAI is stopping some of the trader menu scroll options from working on some traders I have to right click/zoom on them to get an option for the trader menu. I tested it on a default server no mods and my traders was working correctly but once WAI is installed the problem begins.

thanks.

@Dr.Killmore, and other, maybe this will help:

When you experience situation at trader that you have to zoom on trader - which happens mostly when you customized them - this situation IMO is not bug at all. Let me explain.
fn_selfAction is using command 'cursorTarget'. It's in a nature of this command return only targets that are known to player. Let me cite:
 

"While friendly targets are usually known to the player, enemy targets can be totally unknown,
especially if "auto-spotting" (or sometimes called "auto-reporting") is switched off."

Now I will skip some further techicalities and go directly to solution, that might be helpfull:
So what I would to do is check your user config if "auto-spotting" is set to 1. If you are using veteran level, not sure if you can change it.
So, you can customize your "regular" level, or use "veteran" level and consider zoom on trader as normal behavior - by zooming you are revealing target to be known to player.
Recently I helped someone with this kind of problem and above solution worked. If not, probably "reveal" command is the key...

Cheers...

Share this post


Link to post
Share on other sites
On 07/11/2017 at 5:50 PM, iben said:

@Dr.Killmore, and other, maybe this will help:

When you experience situation at trader that you have to zoom on trader - which happens mostly when you customized them - this situation IMO is not bug at all. Let me explain.
fn_selfAction is using command 'cursorTarget'. It's in a nature of this command return only targets that are known to player. Let me cite:
 

"While friendly targets are usually known to the player, enemy targets can be totally unknown,
especially if "auto-spotting" (or sometimes called "auto-reporting") is switched off."

Now I will skip some further techicalities and go directly to solution, that might be helpfull:
So what I would to do is check your user config if "auto-spotting" is set to 1. If you are using veteran level, not sure if you can change it.
So, you can customize your "regular" level, or use "veteran" level and consider zoom on trader as normal behavior - by zooming you are revealing target to be known to player.
Recently I helped someone with this kind of problem and above solution worked. If not, probably "reveal" command is the key...

Cheers...

YES... thank you so much my config was on Veteran autoSpot=0; now I changed it to Regular with veteran settings and autoSpot = 1; and all traders work without zoom you are a star thanks again :)

I can't say thank you enough cheers...

Share this post


Link to post
Share on other sites
1 hour ago, Dr.Killmore said:

YES... thank you so much my config was on Veteran autoSpot=0; now I changed it to Regular with veteran settings and autoSpot = 1; and all traders work without zoom you are a star thanks again :)

I can't say thank you enough cheers...

Your resume is going to help a lot of people, I guess! Thx for coming back with result...
Cheers...

Share this post


Link to post
Share on other sites

could someone please explain  me how blacklist custom zones?

for example i have this coord : [8246,15485,0]

Ho do i introduce it?

use_blacklist				= true;			// use blacklist
		blacklist					= [
			[[0,16000,0],[1000,-0,0]],				// Left
			[[0,16000,0],[16000.0,14580.3,0]]      // Top
			
		];

 

Share this post


Link to post
Share on other sites
9 hours ago, gernika said:

could someone please explain  me how blacklist custom zones?

for example i have this coord : [8246,15485,0]

Ho do i introduce it?

use_blacklist				= true;			// use blacklist
		blacklist					= [
			[[0,16000,0],[1000,-0,0]],				// Left
			[[0,16000,0],[16000.0,14580.3,0]]      // Top
			
		];

 

Just add it to the array:

use_blacklist = true;								// use blacklist
		blacklist = [
			[[0,16000,0],[1000,-0,0]],				// Left
			[[0,16000,0],[16000.0,14580.3,0]],		// Top
			[[8246,15485,0],[square coords here]]	//custom 1
		];

But you need another point. The blacklist defines areas so you need 2 points that act like the edges for a square.

Share this post


Link to post
Share on other sites
On 11/29/2017 at 12:43 PM, Kimzer said:

Someone that can share some nice mission notifications??

Been testing alot of things lately, but maybe im just too daft to get it working.

Ive seen several servers with very nice notifications, such as the one DTR and RED has. But tbh id settle for just a hintbox at this point. But even that i cant get to work. Im sure i had that working when i used to host a few years back.

 

		_hint = parseText format["<t align='center' color='#088A85' shadow='2' size='1.75'>MISSION</t><br/><t align='center' color='#ffffff'>%1</t>", _msglose];
		customRemoteMessage = ['hint', _hint];
		publicVariable "customRemoteMessage";

Above does not work.

Also tried with calling infistars mass message stuff. But a no go there aswell.

If i call it clientside it will run fine. But not from mission side. 

Can i call a script from server.pho while its located in mission.pbo at all to get around it?

Share this post


Link to post
Share on other sites

Got weird error on my test server that Spam my RTP I never had that before.

13:56:32 "WAI DEBUG: FINDPOS: Checking nearby mission markers: ["DZMSMajMarker","DZMSMinMarker","DZMSBMajMarker","DZMSBMinMarker","MainHero0","MainHero1"]"
13:56:32 "WAI: Invalid Position (Marker: "MainHero0")"
 

 

Share this post


Link to post
Share on other sites
On 2.12.2017 at 10:16 AM, Kimzer said:

Been testing alot of things lately, but maybe im just too daft to get it working.

Ive seen several servers with very nice notifications, such as the one DTR and RED has. But tbh id settle for just a hintbox at this point. But even that i cant get to work. Im sure i had that working when i used to host a few years back.

 

		_hint = parseText format["<t align='center' color='#088A85' shadow='2' size='1.75'>MISSION</t><br/><t align='center' color='#ffffff'>%1</t>", _msglose];
		customRemoteMessage = ['hint', _hint];
		publicVariable "customRemoteMessage";

Above does not work.

Also tried with calling infistars mass message stuff. But a no go there aswell.

If i call it clientside it will run fine. But not from mission side. 

Can i call a script from server.pho while its located in mission.pbo at all to get around it?

What you are trying to do there is executing a client-sided script from server-side which won't work. If you want to notify everyone on the server with a custom method, you need to create an eventhandler on the server when the notification should appear, same eventhandler on the client with the actual notifcation script and you are done.

Basically you need something on the server that triggers a script that's running on each client.

Share this post


Link to post
Share on other sites
20 minutes ago, Petite said:

Got weird error on my test server that Spam my RTP I never had that before.

13:56:32 "WAI DEBUG: FINDPOS: Checking nearby mission markers: ["DZMSMajMarker","DZMSMinMarker","DZMSBMajMarker","DZMSBMinMarker","MainHero0","MainHero1"]"
13:56:32 "WAI: Invalid Position (Marker: "MainHero0")"
 

 

WAI has a method which checks whether the mission points are valid or not. You normally don't see these messages because it's debug.

Debug mode is made to help developers find errors and stuff. I guess you accidently turned the debug mode/dev mode on in WAI.

Share this post


Link to post
Share on other sites

Since so many people are asking about a custom notification system on WAI, I am ready to share my old system for that. As I am not hosting a server anymore, I don't need these files anyways.

@JasonTM Could you put a link to this post in your main topic so people can watch it if they are interested:

Spoiler

 

Btw, you can also use my Update Panel to broadcast these messages but here is a way for dynamic messages on right half of the screen (optional sound aswell):

1. First you need to edit the file of WAI that handles all the notifications which is "dayz_server\WAI\compile\mission_winorfail.sqf". For us, this part is interesting: 

	if (wai_radio_announce) then {
		RemoteMessage = ["radio","[RADIO] " + _msgstart];
		publicVariable "RemoteMessage";
	} else {
		[nil,nil,rTitleText,_msgstart,"PLAIN",10] call RE;
	};

To make the message a bit configurable, we replace the whole codeblock with:

	if (wai_radio_announce) then {
		RemoteMessage = ["radio","[RADIO] " + _msgstart];
		publicVariable "RemoteMessage";
	} else {
		_msgColor = '#0080FF';
		_msgSize = '0.7';
		_msgText = "<t align='center' color='"+_msgColor+"' size='"+_msgSize+"'>"+_msgstart+"</t>";
		_msgDuration = 7;
		_msgFade = 1;
		_msgDelta = 0;
		fnc_dynamicTextNotification = [_msgText,_msgDuration,_msgFade,_msgDelta];
			{(owner _x) publicVariableClient "fnc_dynamicTextNotification";} forEach playableUnits;
	};

2. Now you can set your own values to have your favorit style of the message.
_msgColor = the color of the text (the default value is blue I guess, you can get color html codes on the internet), i made 3 different colors for all notifications,
_msgSize = size of the text, 0.7 is already pretty big
_msgText = wouldn't edit this because it automatically uses the variables it was using before
_msgDuration = time the message is shown (always add 2 seconds for fade time)
_msgFade = fade in and fade out time of the text

3. Now we replace all instances of the notifications with this type of code, just one variable is different (the text variable). The next codeblock is around line 200 and looks like this:

		if (wai_radio_announce) then {
			RemoteMessage = ["radio","[RADIO] " + _msgwin];
			publicVariable "RemoteMessage";
		} else {
			[nil,nil,rTitleText,_msgwin,"PLAIN",10] call RE;
		};

We replace the whole block again with:

		if (wai_radio_announce) then {
			RemoteMessage = ["radio","[RADIO] " + _msgwin];
			publicVariable "RemoteMessage";
		} else {
			_msgColor = '#00FF40';
			_msgSize = '0.7';
			_msgText = "<t align='center' color='"+_msgColor+"' size='"+_msgSize+"'>"+_msgwin+"</t>";
			_msgDuration = 7;
			_msgFade = 1;
			_msgDelta = 0;
			fnc_dynamicTextNotification = [_msgText,_msgDuration,_msgFade,_msgDelta];
				{(owner _x) publicVariableClient "fnc_dynamicTextNotification";} forEach playableUnits;
		};

And now the last codeblock around line 280 which looks like:

		if (wai_radio_announce) then {
			RemoteMessage = ["radio","[RADIO] " + _msglose];
			publicVariable "RemoteMessage";
		} else {
			[nil,nil,rTitleText,_msglose,"PLAIN",10] call RE;
		};

Again, replace the whole codeblock with:

		if (wai_radio_announce) then {
			RemoteMessage = ["radio","[RADIO] " + _msglose];
			publicVariable "RemoteMessage";
		} else {
			_msgColor = '#DF0101';
			_msgSize = '0.7';
			_msgText = "<t align='center' color='"+_msgColor+"' size='"+_msgSize+"'>"+_msglose+"</t>";
			_msgDuration = 7;
			_msgFade = 1;
			_msgDelta = 0;
			fnc_dynamicTextNotification = [_msgText,_msgDuration,_msgFade,_msgDelta];
				{(owner _x) publicVariableClient "fnc_dynamicTextNotification";} forEach playableUnits;
		};

4. Now, after we replaced all notifcation instances, we need to create the eventhandler this system uses now. Because the notifications have to be shown on the client-side, we need to create this in the mpmissions. Everything this does is checking the variable we sent to the client now.

What I have done for that (you can do that different) is setting a new file in the init.sqf in the !isDedicated codeblock. Search for this line:

	execFSM "\z\addons\dayz_code\system\player_monitor.fsm";

and write your custom line below:

_nil = [] execVM "eventHandlers\customEventHandlers.sqf";

As you see, my file is located in "mission\eventHandlers" and is called customEventHandlers.sqf. Now create that file in the location your specified and write the following into it

//Dynamic Text
	"fnc_dynamicTextNotification" addPublicVariableEventHandler {
		_msg = _this select 1 select 0;
		_duration = _this select 1 select 1;
		_fade = _this select 1 select 2;
		_delta = _this select 1 select 3;
		
		playSound "Dynamic_Message_Sound";
		[_msg,0.5,0.1,_duration,_fade,_delta,789] spawn BIS_fnc_dynamicText;
	};

This should be everything but as you can see there is a line "playSound ....". That's becaue I made the notifications playing a sound. If you don't want that, remove that line but if you want it keep it and follow the next steps.

5. To add a sound you need to open the description.ext and find the following codeblock

class Header
{
	gameType = COOP;            //DM, Team, Coop, ...
	minPlayers = 1;             //min # of players the mission supports
	maxPlayers = 100;           //Max # of players the mission supports
};

Below that we create a new codeblock:

class CfgSounds
{
    sounds[] =
    {
		Dynamic_Message_Sound
    };
	class Dynamic_Message_Sound
	{
		name = "Dynamic_Message_Sound";
		sound[] = {sounds\dynamic_message.ogg,0.4,1};
		titles[] = {};
	};
};

You can also specify a custom path there. Now in the direction you chose, create a dynamic_message.ogg file. If you want mine, here it is: https://www.dropbox.com/s/szoxcls48e0b477/dynamic_message.ogg?dl=0

Have fun with this!

 

 

Share this post


Link to post
Share on other sites
1 hour ago, DAmNRelentless said:

WAI has a method which checks whether the mission points are valid or not. You normally don't see these messages because it's debug.

Debug mode is made to help developers find errors and stuff. I guess you accidently turned the debug mode/dev mode on in WAI.

Doh, god damn how did I not notice that. I was trying to add my own coord for Namalsk.. Thanks.

Share this post


Link to post
Share on other sites

How i call an eventhandler if i have a premade notification file in my mission files?

In mission file its called from compiles and then i just need to trigger it from mission_winorfail.sqf

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Adam1911
      TWZ - The Walking Z Overpoch Server
      Server IP: 54.37.244.16:2302
      Discord: Discord
      Website: Website
      Top Server Features:
      PvE Only Server.
      Dedicated server for max performance.
      6 Hour Restarts.
      Full day/night cycle. (No Voting)
      Indestructible bases.
      Custom AI Missions.
      High loot spawns.
      Slow (Walking) Zombies.
      Custom Traders. (10k/50k/100k/500k humanity)
      Paychecks every hour. (Scales with humanity)
      Humanity Quests.
      Anit Stealing for all vehicles. (Prevents anyone from stealing your vehicles)
      Simi Militarised.
    • By Pickle Rick
      ip - 192.154.248.253
      Discord.gg/9m99XxM
      NEW SERVER UP AND RUNNING.. FULL OF AI, PVP HELL...  Stop in and ask Pickle Rick or OTROD for a free tank

    • By Vitor99
      Hi everyone, i would like to know if there is any torrent links for Epoch and Overpoch, if you know some send me the link here
    • By Voltan
      Hey guys, (@salival hoping you can assist here buddy)
      I will preface this by saying that I am using Epoch 1.0.5.1 and server files provided by @Ultima_weapon
      I am getting this error in my console from WAI:
      I found something related here on page 7 here:
      https://epochmod.com/forum/topic/43666-release-wicked-ai-223-106/page/7/
      But this did not fix my issue.
      Here is the spawn_group.sqf:
      and the spawn_static.sqf:
      Anyone know what could cause this?
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...