Jump to content
  • 0
Sign in to follow this  
red_ned

Exploding ATV's

Question

Hi, I added some atv's to a racetrack I installed at the bandit base (Ghost of Chernarus - Bandit Trader: Cutthroat's Corner).

I added some vehicles to the end of the map so I could spawn in something for people to race on but now the ATV's spawned explode randomly. Anyone got any ideas how to fix or do diffferently?

Thanks

ned

_bldObj = objNull;
if (true) then
{
  _bldObj = createVehicle ["ATV_CZ_EP1", [1647.37, 7735.2, 0.002], [], 0, "CAN_COLLIDE"];
  _bldObj setDir 210;
  _bldObj setVehicleArmor 1;
  _bldObj setFuel 1;
  _bldObj setVehicleLock "UNLOCKED";
  _bldObj setPos [1647.37, 7735.2, 0.002];
  _bldObj setVectorUp [0,0,1];
};

_bldObj = objNull;
if (true) then
{
  _bldObj = createVehicle ["ATV_CZ_EP1", [1644.17, 7737.58, 2.441e-04], [], 0, "CAN_COLLIDE"];
  _bldObj setDir 210;
  _bldObj setVehicleArmor 1;
  _bldObj setFuel 1;
  _bldObj setVehicleLock "UNLOCKED";
  _bldObj setPos [1644.17, 7737.58, 2.441e-04];
  _bldObj setVectorUp [0,0,1];
};

_bldObj = objNull;
if (true) then
{
  _bldObj = createVehicle ["ATV_CZ_EP1", [1641.24, 7739.32, 0.059], [], 0, "CAN_COLLIDE"];
  _bldObj setDir 210;
  _bldObj setVehicleArmor 1;
  _bldObj setFuel 1;
  _bldObj setVehicleLock "UNLOCKED";
  _bldObj setPos [1641.24, 7739.32, 0.059];
  _bldObj setVectorUp [0,0,1];
};

_bldObj = objNull;
if (true) then
{
  _bldObj = createVehicle ["ATV_CZ_EP1", [1638.12, 7741.64, 9.155e-05], [], 0, "CAN_COLLIDE"];
  _bldObj setDir 210;
  _bldObj setVehicleArmor 1;
  _bldObj setFuel 1;
  _bldObj setVehicleLock "UNLOCKED";
  _bldObj setPos [1638.12, 7741.64, 9.155e-05];
  _bldObj setVectorUp [0,0,1];
};

_bldObj = objNull;
if (true) then
{
  _bldObj = createVehicle ["ATV_CZ_EP1", [1640.77, 7746.97, -9.155e-05], [], 0, "CAN_COLLIDE"];
  _bldObj setDir 210;
  _bldObj setVehicleArmor 1;
  _bldObj setFuel 1;
  _bldObj setVehicleLock "UNLOCKED";
  _bldObj setPos [1640.77, 7746.97, -9.155e-05];
  _bldObj setVectorUp [0,0,1];
};

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

The anti-hack is blowing them up, you have to add them to the allowed list to spawn them in.

Search around, the answer is posted, look at the deploy bike scripts, i'd explain more but i've forgotton what file needs editing.

Share this post


Link to post
Share on other sites
  • 0

Cheers i worked it out, 

 

for anyone looking to do same (I have a loadout for donators and non donators with bike, motorbike, or mozzie):

MPMissions>DayZ_Epoch_11.Chernarus>custom> variables.sqf

 

find 

EVDVehicleArray = ["MMT_Civ","TT650_Civ","CSJ_GyroC"]; 

 

Change to

EVDVehicleArray = ["MMT_Civ","TT650_Civ","CSJ_GyroC","ATV_CZ_EP1"];

 

 

I didnt have the other line just:

 

if(isServer) then {
DZE_safeVehicle = DZE_safeVehicle + EVDVehicleArray;
};

 

 

 

Cheers for fix DangerRuss.

Share this post


Link to post
Share on other sites
  • 0

oh i could probably have just added before the If server line:

DZE_safeVehicle = ["ATV_CZ_EP1"];

 

but i didn't think about till after i found it worked anyway and it adds into the same string so no probs for my server

Share this post


Link to post
Share on other sites
  • 0

Open init/server_functions.sqf and replace this:

if(vehicle _x != _x && !(vehicle _x in PVDZE_serverObjectMonitor) && (isPlayer _x)  && !((typeOf vehicle _x) in DZE_safeVehicle)) then {

with this:

if(vehicle _x != _x && !(vehicle _x in PVDZE_serverObjectMonitor) && (isPlayer _x)  && !((typeOf vehicle _x) in DZE_safeVehicle) && (vehicle _x getVariable ["MalSar",0] !=1)) then {

open your compile/server_updateObject.sqf and place this:

if (_object getVariable "MalSar" == 1) exitWith {};

above this:

if (!_parachuteWest and !(locked _object)) then {

And when you create vehicles it look like this

if (isServer) then {

_vehicle_1 = objNull;
if (true) then
{
  _object = createVehicle ["ATV_CZ_EP1", [6605.9946, 2400.3362, 2.8610229e-006], [], 0, "CAN_COLLIDE"];
  _vehicle_1 = _object;
  _object setDir -65.831406;
  _object setVehicleArmor 1;
  _object setFuel 1;
  _object setVehicleAmmo 1;
  _object setPos [6605.9946, 2400.3362, 2.8610229e-006];
  _object setVariable ["malsar",1,true];
  _uniqueid = str(round(random 999999));
  _object setVariable ["ObjectID", _uniqueid, true];
  _object setVariable ["ObjectUID", _uniqueid, true];
};
};

Tested and working 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By Bloodthirsty
      Hey I just need some files for this server, any and all you guys can come up with and think it deserve post that shit in chat rn. I want to see some crazy ideas and additions if you got em :) Lets see what you guys can come up with

    • By Dzhabrailov
      Hello! How to change the mapping of traders or 1.0.6.1 ?
    • By Tricky
      where do i put the a3_epoch_custom file in my epoch server once i made it a cqf and all that 
    • By armyant
      Hello All  hope someone can help :)
       
      I'm having trouble with mapping ie Boats and Jet ski, I got them on my test server ok. but when I get in /on one I die? 
      Is there something i'm missing when editing the code ? 
                           Here is two examples of the code.
       
      _vehicle_3 = objNull; if (true) then {   _this = createVehicle ["JetSkiYanahui_Green", [13259.347, 18508.629, 2.6702881e-005], [], 0, "CAN_COLLIDE"];   _vehicle_3 = _this;   _this setDir 41.757809;   _this setPos [13259.347, 18508.629, 2.6702881e-005]; };       _vehicle_5 = objNull; if (true) then {   _this = createVehicle ["PBX", [13256.8, 18516.707, -0.44596094], [], 0, "CAN_COLLIDE"];   _vehicle_5 = _this;   _this setDir 224.62543;   _this setPos [13256.8, 18516.707, -0.44596094]; };        
    • By SoCalSlaughter
      Hey guys, I have WickedAI and DZMS installed on my server. Went into the config for WickedAI and set ai with launcher true, restarted the server and the ai dont have any RPG's or launchers. The minefeilds work, I have also added in more weapons for them to use (M107's and such) and those show up. This is my current script setup
       
      wai_use_launchers            = true;            // add a rocket launcher to each spawned AI group
      wai_remove_launcher        = true;            // remove rocket launcher from AI on death
       
       
      ai_wep_launchers_AT            = ["M136","RPG18","JAVELIN"];
      ai_wep_launchers_AA            = ["Strela","Igla","STINGER"];
       
      Thanks for the help!
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...