Jump to content
  • 0
Ghostrider-GRG

[How To] Set up an Arma 3 Epoch Server on a Client PC

Question

Setting up an Epoch for Arma 3 server on your PC.

 

Below is the procedure I have used to set up A3 Epoch servers on my desktop PC. These servers are useful as a test bed when I try out things like the many scripts being released for Epoch. 

 

Updated for Epoch RC 0.3.0.3

 
This How To is based upon the Install.txt provided with the Epoch server files. If your server does not start up you may have missed a step or be lacking essential software.
 
For additional information, please refer to the Epoch developer's Wiki which provides considerable additional information.

http://epochmod.gamepedia.com/A3Epoch:Arma_3_Epoch#Server_Setup_.26_Information

 

For an excellent guide on troubleshooting, refer to the FAQ at

 

For another take on this How To, which provides a more comprehensive discussion of the different things you need to consider for server setup.

 

What you will need:
 
A good text editor like Notepad ++ (freeware)

Visual C++ Redistributable Packages for Visual Studio 2013:
http://www.microsoft.com/en-us/download/details.aspx?id=40784

 

 

30 min
a bit of patience.

Stage I: create a server directory and add all needed files to your server directory.
 
 
1) Create a new directory on the disk you wish  to use for your server.  Mine is on an SSD drive E:
Lets call it: E:\Arma3Server for this tutorial.

2) Open your ..Steam\SteamApps\Common\Arma3 directory. Mine happens to be in E:\Steam\SteamApps\Common\Arma3.

3) Copy everything from that directory to your new server directory E:\Arma3Server.

4) Download Epoch Mod from here http://epochmod.com/download.php. Unpack the .rar file.

5) Copy @Epoch to your new server directory E:\Arma3Server.

6) Download the Epoch Server files https://github.com/EpochModTeam/Epoch/tree/master/Server_Install_Pack.

7) Extract the archive, and copy all files and folders in it to your E:\Arma3Server directory.
 
Stage II: Adjust the settings for your database:
8) Open the DB folder of your E:\Arma3Server directory.

9) Open redis.conf using Notepad ++ or another text editor. It will look like this.
 

bind 127.0.0.1
maxmemory 4gb
save 900 1
save 300 10
save 60 1000
requirepass Changeme9832

10) Change Changeme9832 in the "requirepass" field to a password you wish to use for your database server such as client321.

11) In your E:\Arma3Server folder, find and open @EpochHive.

12) Open EpochServer.ini using Notepad++. In it there will be a section titled [Redis] which looks like this:
 

[Redis]
IP = 127.0.0.1
Port = 6379
DB = 0
Password = foobared

13) now change the password to the one you set above for redis.conf, which for this example was client321.
 
Stage III: Complete configuration of Epoch Server Settings.
14) Next, in EpochHive.ini you need to specify the path to be used when starting the battleye on the serverside. Look for the following section:
 

[EpochServer]
BattlEyePath = C:\BattlEye
InstanceID = NA123

Change the BattlEyePath to the one appropriate for your server.  In our example, this would be E:\Arma3Server\SC\BattlEye
Now save and close EpochHive.
 
Stage IV: Configuring Automatic Restarts and other related issues.

 

In the past automatic restarts have usually been accomplished using BEC, a freeware tool. For reasons outside the scope of this how-to, development and support of BEC was discontinued and Epoch has been moving to integrated Battleye in various ways including providing functions for automatic restarts. If you wish to use BEC, you can download it using the link below:

 

http://www.armaholic.com/page.php?id=15716

 

In order to run BEC, you will need to redirect its efforts to phone home. Instructions on how to do so are listed in the post by Dwarfer in this thread.

 

 

You will also need to set the correct path to your Arma3Server\SC\Battleye folder in the configuration file for BEC which normally would be:  Arma3Server\BEC\Config\Config.cfg.

 

BEC does still provide valuable functionality such as the ability to play certain messages periodically, but you can also schedule server restarts or utilize other features if you wish. .

 

Alternatives to BEC for automated server restarts:

Please see the release notes for Epoch 0.3.0.3 for details on  the built in automated server restart functions. The new method for automated server restarts is recommended if you are setting up a new server.

 

To use the built in server restart functions, open @epochhive\epochconfigs.hpp

In the first line, change

 

serverRestart         = false; // true sends #shutdown command to server after the time specified in ForceRestartTime

 

to

 

serverRestart         = true; // true sends #shutdown command to server after the time specified in ForceRestartTime

 
17) Stage V: Create your server startup file.
18) Open a blank document and past the following into it then save it in your E:\Arma3Server directory as something like A3Epoch.bat. Note that if you are using Notepad++, its default is to save files as text files. Select *.* from the drop down menu for choosing the file type before saving you A3Epoch.bat:  Again, the you will need to adjust the paths in this file to suit those for your server.
 

@echo off
start "arma3" "arma3server.exe"  [email protected];@EpochHive; -config=E:\Arma3Server\SC\config.cfg  -port=2302 -profiles=SC -cfg=E:\Arma3Server\SC\basic.cfg -name=SC 

 
 
20) Stage VI: Configure BattlEye
 
21) Open the SC\Battleye folder and rename example-BEServer.cfg to BEServer.cfg and change the RConPassword.
22) Create an empty text file and save it as bans.txt in the SC\Battleye folder. Save and close the above configuration files.
 
23) Stage VII: Starting and joining your server.
 
24) In your E:\Arma3Server folder find and open the DB folder then click start-redis.

24) If you will be using BEC, go to your E:\Arma3Server\BEC folder find BEC, and start it.

25) Start Arma 3, select Play, then multiplayer and finally in multiplayer select remote. Enter the IP and port for your server, which in our example is 127.0.0.1:2302.

 

26) Also in your E:\Arma3Server directory should be the A3Epoch file you created above under step 18. Find it and click it.
    When you do, the Arma3server console should open after slight delay, and you should see information including the port number you used above in your A3Epoch startup file.  If you are using BEC, once the   Arma3server is running, BEC should go through a few steps then indicate it has successfully connected to the server.
   
27) You should now be able to join your server.

Share this post


Link to post
Share on other sites

146 answers to this question

Recommended Posts

  • 0

Hey, really nice guide. The problem im currently having is that when i launch the server and try to join it gets stuck on "starting epoch..." (server not ready 02 error). And im unable to play.

Share this post


Link to post
Share on other sites
  • 0

Like a lot of the users above, I have followed this excellent tutorial to the letter, and the server starts and seems to run fine. However, I still can't join thanks to damn Battleye.

 

1 - I've tried loading into game numerous times, then going into the scripts.txt and changing the kicks I get to '1'. It stops the kick, but then I just get a different one. Now I'm stuck with one that won't go away no matter what I do.

MPEventHandler RemoteExec Restriction #0

2 - Like Dishner above, I get vote map coming up every time (which adds another 50 secs to the logging in process). 

Share this post


Link to post
Share on other sites
  • 0

@Kroenen,

 

Sounds like you do not have the correct files someplace in your installation. Have you tried starting the server using the stock files provided by the Devs with BE disabled? Are you using the latest BE filters provided by the devs?. Are you, by chance running an antihack or admin tool other than that provided by the devs?

Share this post


Link to post
Share on other sites
  • 0

Thanks Ghostrider - I've been using the files exactly as they are in the installation guide. I tried setting the battleye switch to 0, which didn't appear to do anything at all, and I've tried both with the default BE filters, and the ones which are running on my live server.

 

However, since then, I've managed to get connected on a Chernarus map with BE enabled, so I'm guessing it has something to do with the map (Napf) I was testing. That said, even though I can connect to the Chernarus map wthout problems, it still initiates a map vote every time I connect, which is frustrating. The relevant configs are detailed below;

// VOTING
voteMissionPlayers	= 200;    // Prevents Votes.
voteThreshold		= 2; // Prevents Votes.

and...

// MISSIONS CYCLE (see below) epoch.Altis epoch.Stratis epoch_noZ.Altis
class Missions
{
	class Epoch {
		template = epoch.Altis; // DO NOT CHANGE THIS, IT WILL BREAK YOUR SERVER
		difficulty = "veteran";    // difficulty settings: veteran == NORMAL, mercenary == HARDCORE
	};
};

Share this post


Link to post
Share on other sites
  • 0

I have the weirdest problem.
I went over all steps as described and got everything working.

Though, when I connect to my server i get stuck on the satelite view image of Altis.

Both the arma3server.exe and bec.exe log that i connect but thats it.

Ive been searching for answer on these forums and couldnt find anything similair, sorry if i missed anything :)

Share this post


Link to post
Share on other sites
  • 0

Since no one else seems to have brought this up I feel like I am just overlooking something obvious so please bear with me.

 

Stage IV, #16.  I do not have a config folder.  The only config.cfg I can find is in the SC folder that comes as part of the server files pack.  That config does not contain any of the pathways or port settings that are described in steps 16 or 17.

 

Can anyone provide some insight into what I am missing or overlooking?

Share this post


Link to post
Share on other sites
  • 0

Since no one else seems to have brought this up I feel like I am just overlooking something obvious so please bear with me.

 

Stage IV, #16.  I do not have a config folder.  The only config.cfg I can find is in the SC folder that comes as part of the server files pack.  That config does not contain any of the pathways or port settings that are described in steps 16 or 17.

 

Can anyone provide some insight into what I am missing or overlooking?

 

This step refers to configuring BEC. The How To assumes you copied the config folder for BEC to your arma3server directory. If instead, you copied the contents of the unpacked BEC download package to a BEC directory, then you will find the config folder inside the BEC directory. I hope that helps.

Share this post


Link to post
Share on other sites
  • 0

I have the weirdest problem.

I went over all steps as described and got everything working.

Though, when I connect to my server i get stuck on the satelite view image of Altis.

Both the arma3server.exe and bec.exe log that i connect but thats it.

Ive been searching for answer on these forums and couldnt find anything similair, sorry if i missed anything :)

Did you start the Redis server? You do that by running the start_redis.bat in the DB folder. This will start a small console window inside which you should be able to tell when the server connects to Redis. This occurs once a player tries to join the server. I assume you are using the default pbos provided with the download of the server.

Share this post


Link to post
Share on other sites
  • 0

is someone willing to skype or TS with me, i have tried so many times to get the server up, i have a vps running windows server 2008, im having problems running the redis server, and having problems connecting when i use TADST. i can veiw the server when i use TADST but when i join it closes the server.

Please help my teamspeak is NxRE.enjinvoice.com and my skype is me15connor

Share this post


Link to post
Share on other sites
  • 0

This step refers to configuring BEC. The How To assumes you copied the config folder for BEC to your arma3server directory. If instead, you copied the contents of the unpacked BEC download package to a BEC directory, then you will find the config folder inside the BEC directory. I hope that helps.

 

 

It seems that BEC is unavailable.  I clicked the link in step 15 and I see a message saying BEC has been terminated.  I found another post here talking about it however I think that solution is for people who already had the files downloaded.  I guess it comes down to a couple basic questions.

 

Is there a way to get the BEC files and still use the work around found in the BEC post?

 

Can that section of the server tutorial be skipped and if so is the port config still necessary and simply done another way?

 

Anything else relevant that I should know now that aspects of this tutorial are out of date?

Share this post


Link to post
Share on other sites
  • 0

Did you start the Redis server? You do that by running the start_redis.bat in the DB folder. This will start a small console window inside which you should be able to tell when the server connects to Redis. This occurs once a player tries to join the server. I assume you are using the default pbos provided with the download of the server.

 

Yes, the Redis server is running and I tried doing a clean install multiple times now, all with the same result.

When i connect, it takes a little and then the ambient sound like rain or wind get stuck in a loop.

I do see that I connected in the arma 3 server window but no messages in the Redis window other then the server is now ready to accept connections.

Also yes, all the files i am using are default files provided with the download of the server :)

 

Hmm, this is a much repeated line in my rpt files:

Server error: Player without identity Lucchese (id 304040685)

I've googled this error without having much luck.

It seems the server can not connect to steam to get my character or something?

Share this post


Link to post
Share on other sites
  • 0

Hi, I'm having problems installing... or rather running a epoch server to test and develop scripts. I've follwed the instructions inside the Epoch Server files and also the files posted on this thread to install a server, but it won't let me in. Every time I click my server on the multiplayer list it just gives me a "You were kicked from the game" message and I go back to the server list. I've double check passwords, disabled Battleye and also disabled my firewall just to test it out and nothing works.

I checked all of the logs and I do not see any errors whatsoever, just the regular stuff when the server loads... and my client name of course.

Share this post


Link to post
Share on other sites
  • 0

Thanks for nice guide.

I installed latest epoch server and got altis work.

Played on server with client on same machine(hd)

 

Then i changed to Bornholm map.

 

Now i can't run server and play from same machine(hd), my friends can join my server but i can't.

 

I can play on other Bornholm servers so both server and client files are ok, not just same time.

 

What gives, any tips  ?

Share this post


Link to post
Share on other sites
  • 0

I cant say for sure but I can say this;

Dedicated servers generally dont support loopback clients by design. That is what listen servers are for.

If you really really want to do this imo the only way is to use some sort of VM or isolator software like sandboxie.

good luck

Share this post


Link to post
Share on other sites
  • 0

I cant say for sure but I can say this;

Dedicated servers generally dont support loopback clients by design. That is what listen servers are for.

If you really really want to do this imo the only way is to use some sort of VM or isolator software like sandboxie.

good luck

Thanks for the idea, it worked, i had IP in start up file, i removed it and only left port, that removed the loop !

Share this post


Link to post
Share on other sites
  • 0

hey,dude.thanks for the jobs,the server works well and i can join the server in local.but the quesion is the charaters can not be save when the server close.i have to create new charater every time when i start the server.can you tell me how to do the save works,please.thanks for the all.

Share this post


Link to post
Share on other sites
  • 0

hey,dude.thanks for the jobs,the server works well and i can join the server in local.but the quesion is the charaters can not be save when the server close.i have to create new charater every time when i start the server.can you tell me how to do the save works,please.thanks for the all.

check Redis installation and that passwords match :

 

9) Open redis.conf using Notepad ++ or another text editor. It will look like this.

 

Quote

bind 127.0.0.1

maxmemory 4gb

save 900 1

save 300 10

save 60 1000

requirepass Changeme9832

10) Change the "requirepass" to a password you wish to use for your database server such as client321.

11) In your E:\Arma3Server folder, find and open @EpochHive.

12) Open EpochServer.ini using Notepad++. In it there will be a section titled [Redis] which looks like this:

 

Quote

[Redis]

IP = 127.0.0.1

Port = 6379

DB = 0

Password = foobared

13) now change the password to the one you set above for redis.conf, which for this example was client321 "

Share this post


Link to post
Share on other sites
  • 0

check Redis installation and that passwords match :

 

9) Open redis.conf using Notepad ++ or another text editor. It will look like this.

 

Quote

10) Change the "requirepass" to a password you wish to use for your database server such as client321.

11) In your E:\Arma3Server folder, find and open @EpochHive.

12) Open EpochServer.ini using Notepad++. In it there will be a section titled [Redis] which looks like this:

 

Quote

13) now change the password to the one you set above for redis.conf, which for this example was client321 "

thank you for reply.i do this step like you say,but it  still can not save when the server close.i do everything like the post,i dont know what is going wrong.

Share this post


Link to post
Share on other sites
  • 0

What does Redis say when you open it ?

[4084] 01 Apr 00:57:04.957 # server started, Redis version 2.8.12

[4084] 01 Apr 00:57:04.958 # DB loaded from disk: 0.000 seconds

[4084] 01 Apr 00:57:04.959 # The server is now ready to accept connections on port 6379

[4084] 01 Apr 01:02:05.001 # 10 changes in 300 seconds. saving...

[4084] 01 Apr 01:02:05.250 # fork operation complete

[4084] 01 Apr 01:02:05.434 # Backgroud saving terminater with success

[4084] 01 Apr 01:07:06.069 # 10 changes in 300 seconds. saving...

[4084] 01 Apr 01:07:06.615 # fork operation complete

[4084] 01 Apr 01:07:06.791 # Backgroud saving terminater with success

Share this post


Link to post
Share on other sites
  • 0

Nice guide.

I have an issue though - I run the database, BEC and then the server and they all look like they start, but nothing appears in my 'Remote' section when I'm in the game itself. Anyone have any ideas? I've been through and checked the files a few times already...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By WeepiestLem0n
      So I've been wanting to create a private ArmA 2 DayZ Epoch server for a bunch of my mates to play on, however I dont have a dedicated machine and want to run it on my PC. So I looked at the server download files on the GitHub page and followed the ReadMe, however I absolutely cannot figure out how to get the MySQL server and DB set up. I have downloaded MySQL Server on my PC and created the admin role, root passwords and ran it as a windows service. I now have no clue how to create the database and am wondering if anyone can help me set this up or let me know if I've done anything wrong. 

      I can add on Steam or Discord if need be for convenience.
    • By jackalopeday
      Every time i try and join my server its stuck at waiting for authorization and the logs say "failed to get id". Any idea whats going on here. I am very new to server hosting so please explain in easy terms. :)
    • By JasonTM
      Some time ago I started a youtube channel doing DayZ Epoch tutorials. Surprisingly, my DayZ Epoch 1.0.6.1 server install video has amassed over 2500 views (and people say this game is dead).
      Here are some updated videos for 1.0.6.2. There are other videos on my channel that are still relevant.
      How to Install a DayZ Epoch 1.0.6.2 Server
      Things you will need to download:
      PBO Manager
      MySQL Community Server 5.7.22
      HeidiSQL
      Notepad++
      Notepad++ SQF Highlighter (optional, but highly recommended)
      7-Zip
       
      How to Upgrade Your DayZ Epoch 1.0.6.2 Server to an Overpoch Server
      Things you will need to download:
      Overwatch Server Key
      Overwatch mission.sqm (to copy and paste from)
      My Overpoch Loot Tables
      My Non-ZSC Overpoch Trader Files
      Midget Porn (Just kidding)
       
      How to Install Epoch Admin Tools
      Do not install these with infistar.
       
      How to Install Wicked AI for DayZ Epoch and Overpoch
       
      How to install infistar admin tools/antihack and infistar's free BRC rcon tool
      Fix for the unfortunate error in infistar v1448
       
       
      How to make Battleye filter exceptions for Infistar and other mods
      Downloads
      Eraser1's scripts.txt Exception Generator
      Ebay's Guide to Battleye Filters
       
      How to Install Ebay's Testkit
      Download
       
      Battleye Filter Tutorial using Ebay's Testkit and infistar's BRC rcon tool
       
      Server Install: Troubleshooting "session lost" and "wait for host" type issues.
       
      How to install BattlEye Extended Controls for automatic restarts
       
       
       
      I am planning on doing more of these when I get time.
       
       
       
       
    • By Cyrus
      I have been finding that some people on my server has been losing base walls and floors even though DZE_godmodebase = true; , it has no effect on anything built inside the plot radius. So i have come to the conclusion that base items might receive damage on age and this ultimately being removed by server cleanup script. So my question is if I drop this event below will that stop me and others from losing base walls and floor? Or at the minimum update it without any cinder wall items?
      like this  and set damage to 0.001:
       
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...