Jump to content

Question

Just recently added new scripts to my epoch server had change a few lines in my debug monitor script and got Public Variable Restriction #0.. so ok reverted my changes re-packed pho uploaded it restarted server tried again.

again got kicked for Public Variable Restriction #0..

is there new BE filters that i'm not aware of or?

 

any help would be appreciated on the matter

:)

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Zupa
      ZBot ( An experimental project. ) -> For any BattlEye rcon game supported!
       
      Current version: 1.0.1
       
      A Discord bot that can roam your Discord server and function as an RCON client for your BattlEye game servers. 
      Screenshots at the bottom.
       
      What can it do?
       
      Print all chats in different discord text channels in their respective colours ( Side, Vehicle, Global, ... ). (Tip: Print sidechat in a channel that everyone can read !) Execute RCON & Server commands to your arma server in the assigned Command channel. Protect these commands with an appropriate Discord Role. Reply to user commands when they type ingame. These replies can be printed ingame and in discord. ( eg: !admin -> Admins can be found on discord -> @Admin some asked for an admin ingame. ) Webpanel to configure your rcon-game servers. List players, admins & bans trough rcon commands. ( All BattleEye commands supported ). UPCOMING in next version: Schedule text commands for ingame/discord through the web panel.  
      How to add it to my server?
       
      https://bot.devzupa.be/
       
      Follow the flow of the site. It should be straightforward. Always remember to save a page if needed before navigating to another page!
      Add the bot before or after you filled in all the info. ( The button on top ).
      Always be sure the chosen roles and channel exist in your discord server! ( channel names are without the # )
       
      Whenever you make changes in the config panel you need to reload the config of your server onto the bot. 
      This can be easily done by just typing in a channel:
      !zbot reload This commands also refreshes your rcon instance if it would have stopped for some reason.
       
      All rcon commands can be viewed in the assigned 'command' discord channel. List these commands by typing
      !rcon All commands are prefixed with that aswell.
      1 example for a global message by the bot:
      !rcon say all Welcome you our server! All rcon commands:
      # ZBot BattlEye RCON commands **All commands are prefixed with !rcon** ## Commands players List all players admins List all admins bans List all bans load scripts Reloads al BE scripts load events Reloads al BE events say all [text] Sends text to all users say [playerId] [text] Sends text to specific user id MaxPing [ping] Sets the maxping of the serve. kick [playerId] [reason] Kicks player (eg: kick 32 Language pls.) ban [playerId] [minutes] Bans online player (eg: ban 11 0 Duping) 0 = forever [reason] addBan [GUID|IP] Bans on/off player (eg: addBan 127.0.0.1 0 Duping) [minutes] [reason] removeBan [banId] Remove bans (eg: ban 11 ) version Display the BattlEye version update Check for a newer BattlEye version loadBans Reload Bans from bans.txt writeBans Rewrite Bans to bans.txt disconnect Disconnects the rcon exit Exits the whole rcon client ## Server Commands **All commands are prefixed with !rcon** #shutdown Shutdown the GAME server #lock Locks the GAME server #unlock Unlocks the GAME server #missions Stops current missions and goes to mission list #reassign Moves all players back into the lobby #userlist Displays the list of users on the server #kick [serverPlayerId] Kicks an online player #exec ban Bans an online player [serverPlayerId]  
       
      Please provide as much feedback as possible ! 1 mistake by myself can crash the whole bot. So if there are still use cases where it fails we can finetune it!
      You can join our discord server to discuss or report bugs ( or the topics ).
       
      https://discord.gg/WYbeSKR
       
       
      Technical info about the bot.
      Hosted in france on a good server. Coded in NodeJS ( Ecmascript 6 ). Modular build  
       
      The bot will be hosted by myself until we encounter any problems we can't solve that way.
      If i ever stop hosting the bot i will release the sourcecode.
      I might also release the sourcecode earlier. ( If i know you, you can ask me for access to the code).
       
      Credits - Testers
       
      MGT -> DB Edge of Sanity -> Tobias Solem  
      Screenshots
       

       
       

       

       

    • By uniflare
      Just thought I would do a good deed and try get thread spam lower :).
       
      Here I will cover the most common problems for installing 0.2.5.1 on a Windows Server;
      START WITH VANILLA (NO CUSTOM MODS ETC). ONCE THE SERVER WORKS, THEN EDIT WHAT YOU WANT / ADD ADMIN ETC. ONE THING AT A TIME.
      Battleye: Public Variable Restriction #0 When a player joins they get kicked
      Check the RPT log, probably mentions something like SERVER VERSION MISMATCH or something. Client doesnt have the same version as the server.
      When using the admin tool you get kicked:
      Make sure you are using the latest server files and the latest BE Filters included in the SC/Battleye Folder.
      Check the Paths to your Battleye folder (in files @EpochHive/EpochServer.ini and BEC/Config/Config.cfg) point to the SC/BattlEye Folder.
      Check to make sure BEC has loaded the Watchdog plugin correctly (It should say in the BEC console window).
      If you still get kicked there may be a bug (unconfirmed) where your txt filters will be overridden with incorrect values every restart, If this is the case, be patient for a fix.
      Workarounds modifying publicvar.txt manually can cause security issues.
      (Could be the log rotator, need confirmation).
      Mission Read From Bank / Server Auto-Closes or Crash Upon Joining / Stuck at Server Initializing / Server not Ready (Error 02) This occurs when there is a problem loading the mod. This could be due to several causes:
      Redis Database Server Problems:
      Check Redis Database Server Issues below for the solution.
      Incorrect Configuration of Database:
      Check your DB/Redis.conf file and make sure the ip/port and the password you chose is correct;
      Then check your @EpochHive/EpochServer.ini file and make sure the ip/port and password are the same as in redis.conf.
      Incorrect Configuration of Server/Mod Files:
      Check that anything you modified in any of the following files didnt cause any syntax errors/problems (best to start fresh just to get it working):
      @EpochHive/epochAH.hpp
      @EpochHive/epochconfig.hpp
      SC/config.cfg
      SC/basic.cfg
      SC/Users/SC/SC.Arma3Profile
      Check that you have placed all the files (DB/SC/MPMissions/@EpochHive/Keys Folders etc) in the correct locations in the correct place etc, just copy the entire contents of the server file zip to your arma 3 main directory, where your arma3server.exe is located.
      Redis Database Server Issues Nothing is saving to the database:
      Either your configuration (ip/port/passsword) dont match (check Mission Read From Bank ->Incorrect Configuration of Database)
      or the redis-server.exe in not running. If the redis-server.exe is not in the process list then check below;
      Redis-Server.exe not in Process list/No Console window:
      There are two causes I know of for this, the first is to check if you have all the redistributables required (it is like extra Microsoft files that the program needs to work).
      To do this, check your event log (start menu->type event viewer. On the left pane click Windows Logs->Application). Look for "Side-By-Side" Errors, you need to find the part of the error description that gives you a package name, for ex. "Dependent Assembly Microsoft.VC90.CRT".
      Put that string in google and you should find the package you need quite easily.
      The second cause could be a low filespace/virtual memory/ram issue. To check this, Hold shift and right click in the redis-server.exe folder (DB folder) and select "Open Command Line Here". Type "redis-server.exe redis.conf". You should get and error or some kind of output stating a process fork failed due to space/memory issues.
      If this is the case you can either lower the "maxmemory" config in redis.conf (Minimum I would say 2gb, but personally I prefer the second option next) or you can increase your Paging File Size, You may need to experiment with this to get it stable, I currently have 16gb page file and it seems to run perfectly fine with maxmemory=4gb on a 3gb RAM machine.
      BEC Closes/Wont Connect/Scheduler Issues BEC Auto Closes when you try to run it
      Make sure you have the correct Visual C++ Redistributables, vc 2008 and vc 2003 should be sufficient, you can check your event log (windows->startmenu->type event viewer) under windows logs->applications and look for "side by side" errors for bec.exe. Google the description you find.
      BEC Wont connect to the server
      Make sure your ip from your command line is your actual IP address, also make sure the IP in the BEC/Config/Config.cfg file is correct.
      Or alternatively you can try omitting the -ip parameter from your command line and using the IP 127.0.0.1 in the BEC Config file.
      BEC Scheduler is not working, no messages/restarts/errors
      First thing to check is that you have un-commented the Scheduler Path line in your BEC Config. If not simply remove the # from start of the line
      If you setup your scheduler paths correct and it still will not work you should get some "error loading scheduler.xml" in the BEC Console window. If not, then maybe your timings are off? Consult the Scheduler Help File inside the BEC Config Directory.
      Some things to note: The scheduler must be in _precise_ format. eg,
      Id starts at 0 and increments by one for each new job.
      Older syntax from BEC prior to 1.6 will not work, they need to be modified (very simple)
      Data type none
      You might have forgotten to rename "example_BEServer.cfg" to "BEServer.cfg" in "Arma/SC/Battleye" folder. (Thanks to hogscraper)
       
       
      I can add some scheduler templates if people find it necessary though the scheduler has a very nice readme that explains everything you need to know.
      Admin Menu Wont Show/Spawn Menu Greyed Out etc No admin menu when F1 is pressed:
      Basically put - assuming you havn't disabled the anti-hack, your steamid64 is not in the admin list in epochAH.hpp
      You need to get your steamid64 (You can get your normal steam id here, you can then convert that to steamid64 here.
      Admin menu shows, but Spawn or other options are greyed out (Server is currently disabled)
      Looks like you put your steamid64 into the wrong admin slot, make sure you just put your id into the owner slot, once, that will give you full permissions. for ex;
      adminMenu_Owner[] = {{"7656xxxxxxxxxxx21","Any name you like (will go in admin log)"}}; Mission Select Screen Joining Server Server Files Is out of date
      If you have access to the server file system and can execute, update your server files using STEAMCMD.
      Plenty of tutorials online on updating dedicated arma 3 servers, same routine.
      ex. http://forums.bistudio.com/showthread.php?147537-Tutorial-How-to-run-ArmA3-on-a-dedicated-server
      Startup Command-line Incorrect (Not loading SC/Config.cfg File)/Servername not same as in config.cfg
      Either you have something wrong with your startup parameters, or
      A problem with your config.cfg file, or - more likely;
      Your command line parameters are setup incorrectly.
      To remedy this:
      Make sure you copied the SC folder from the zip file to your arma3 server directory. Then use this command line to start your server:
      arma3server.exe [email protected];@EpochHive; -config=C:\Path\to\Arma3server\SC\config.cfg -ip=xxx.xxx.xxx.xxx -port=2302 -profiles=SC -cfg=C:\Path\to\Arma3server\SC\basic.cfg -name=SC
      Be sure to replace "C:\Path\to\Arma3server" with the correct path to your arma 3 server directory. (With arma3server.exe inside)
      Also replace "xxx.xxx.xxx.xxx" with the servers remote IP address. (The one the public see, not your lan/local address, you can use http://whatismyipaddress.com/).
      Note: You may omit the "-ip=xx... parameter completely if BEC still wont connect after reading the above tips.
      Note: You can also omit the full path to your config params, (Thanks to Scoo) eg
      -config=SC\config.cfg -cfg=SC\basic.cfg Feel free to post anything that I may have missed or that you would like to contribute to this faq.
      I can guaruntee there are spelling errors but this will do for now :).
       
      Good Luck!
    • By DangerRuss
      Similar to this post
      I try to join my server, I dont even make it to lobby before Im kicked to the main menu with the BE message displayed.
      I leave the game open and it never seems to "install" or update.. nothing.
      Things I've tried.
      Completely deleting both local BE files and in my SteamApps directory.
      Redownloading both the client.dll and the entire BE service manually.
      Allowing the game to reinstall both. ^^
      Verifying the integrity of Arma 2, and Arma 2 OA.
      Launching both to main menu and back before trying to launch overpoch. 
       
      I've pretty much tried everything I've ever had to do to fix BE problems and Im still having this issue. Thanks in advance.
       
    • By Just_R
      I know, we as admins, always have to deal with flood of hackers that love to run into a server and trash it for entertainment purposes.  I was getting feedback from people saying BattleEye wasn't banning people for months or at least for a month on the min. I broke down and wrote to BE about this subject.  BE (BattleEye) responded back with some very encouraging emails stating they are actively after users that are "hacking".  They are very aware of the top gentlemen who are producing the bypasses.  I find it encouraging that I did get good responses back from BE.  I was honestly expecting a cut and paste response, no response, or some type of angry response.
      I've had conversations with Punk Buster about their system always failing which I was told in not so many words to choke on a summer sausage.
      NO anti-hack is 100% nor will it every be, but if you had complaints or concerns about BattleEye,. . . you shouldn't. They are keeping toe-to-toe with these guys (hackers/scripters).  I know a few of the members of this forum are some of the more well known scripters: I expect some trollin' from this.
      BE in combination with some of the tools out there will help admins with their jobs but never expect to be 'hack' free.

       (Don't ask me to post my emails - I'm not going to)
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...