Jump to content
  • 0
Sign in to follow this  
Schalldampfer

AI Bus stucking to invisible obstacles

Question

https://github.com/andgregor/dayZ-AI-Bus-Route
While testing this old script in Epoch 1.0.6.1, I got an issue:

When I ride on the bus which an AI is driving, the bus start driving well.
But after running about some ten or hundred meters away,
the bus suddenly stop and damage me as if there's an invisible barrier in front of me, 
and it starts bouncing like a football there.
 

I want any idea to make the script works well.

---

I have changed a part of init_bus.sqf from

Spoiler

 //Uncomment for normal dayZ
 //dayz_serverObjectMonitor set [count dayz_serverObjectMonitor,_axeBus];
 //For Epoch - Comment out for normal dayZ | Credit to Flenz
 PVDZE_serverObjectMonitor set [count PVDZE_serverObjectMonitor,_axeBus];

to

Spoiler

 //Uncomment for normal dayZ
 dayz_serverObjectMonitor set [count dayz_serverObjectMonitor,_axeBus];
 //For Epoch - Comment out for normal dayZ | Credit to Flenz
// PVDZE_serverObjectMonitor set [count PVDZE_serverObjectMonitor,_axeBus];

to make it work in 1061, and player_axebus.qf to

Spoiler
private["_axeBusDriver","_nrBuses","_getInEvent","_getOutEvent","_survivors","_pos_bus"];
_nrBuses=[];
while {alive player}
do
{
 while {count _nrBuses <1}do{_nrBuses = nearestObjects [getPos player, [axeBusType], 600];sleep 3;};
 
 {
  if(_x getVariable["isAxeAIBus",0]==1)then{ 
   _getInEvent = _x addEventHandler ["GetIn", {_this execVM "busroute\player_join_bus.sqf"}];
   _x setVariable ["axeGetInBusEv",_getInEvent,false];
   _getOutEvent = _x addEventHandler ["GetOut", {_this execVM "busroute\player_leave_bus.sqf"}];
   _x setVariable ["axeGetOutBusEv",_getOutEvent,false];
   _x setVariable ["isAxeAIBus",2,false];
   
  //Nearby Survivors
  _pos_bus = getpos _x;
  _survivors = {isPlayer _x && _x distance _pos_bus < 250} count playableunits > 0;
  
   if (_survivors) then{
    _axeBusDriver = driver _x;
    _axeBusDriver stop true;
    
    _axeBusDriver setBehaviour "STEALTH";
    _axeBusDriver action ["LightOn",_x];
    sleep .2;
    _axeBusDriver action ["LightOff",_x];
    sleep .2;
    _axeBusDriver action ["LightOn",_x];
    sleep .2;
    _axeBusDriver action ["LightOff",_x];

    _axeBusDriver setBehaviour "CARELESS";
    _axeBusDriver stop false;
   };
  };
 }forEach _nrBuses;
_nrBuses=[];
};

to make it work for any player skin.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I guess that the debris are causing this issue. Sure you have them disabled and they are not visible for you but maybe the AI uses the default map with the debris and that's why they are stuck there. I guess they are crashing into a lot of trash (the debris).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By FG_Trap
      Made a quick static ai mission that spawns on restart. 
      12 ai patrol the compound 
      4 Static m2's
      1 Heli Patrolling the compound 
      Crate for who ever clears all the ai.
      Some screenshots of the compound 


       
      https://github.com/Trapxxgods/Wai-Static-Mission 
    • By Harkness
      Happy to announce the launch of our new custom server. 
      DayZ Epoch Chernarus 
      To connect search for "v666" in your DayZ Launcher
      Server Modes/Mods/Addons
      Romero Style Zombies
      Snow & Cold Weather Effects (temp+breath)
      Custom Intro Radio Broadcast
      Spawn Location Options
      Safe Trader Areas
      Roaming/Driving/Flying AI Excursions
      AI Mission System
      Random Events
      Auto Re-fuel at any Gas Station
      Day/Night Cycle w/6 Hourly Reboots
      ++Many more to come! Want something added? Request it here
      Don't forget to register here for your own custom load-out and access to our community forums
       
      Note:
      This server is both PVP and PVE. We dont believe in giving players rules but cheating in any way will result in lifetime ban from whole community.
    • By thegdog
      2:08:04 Error Type Any, expected String 2:08:04 File z\addons\dayz_server\compile\server_playerSync.sqf, line 41 2:08:12 Server: Object 3:54 not found (message 70) 2:08:12 "Server_PublishVehicle2 error: Wrong parameter format" 2:08:12 "Trader Menu: jeffdog (76561198147272349) purchased 1x BAF_Merlin_DZE into gear at Aircraft Trader for 1 ItemObsidian" 2:08:12 Error in expression <ceFoot = 0; trying to buy aircraft from the default aircraft trader.  never touched any of it and it giving this error.  no vehicle spawns.  it shows the arrow.  EDIT:  i tried other traders, all vehicles dont spawn when bought.
    • By JakeQue
      Usually it would state 
       
      "You cannot gut this animal without a knife"
       
      but now the scroll  action is dead and I don't get an error.
       
      Please help!
    • By webbie
      Hi all, Ive been looking for a while now for a vehicle flip script for a single player.
      Ive tried stuff ive used on previous servers but its not allowing the option so im guessing epoch has something that interferes with it.
      If anyone knows of a simple script to allow players to do this could you link it to me please,
      Thanks in advance.
      PS. Im aware the jacks flip vehicles but I actually  find this to be incredibly painstaking unless theirs a trick to it.
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...