Jump to content
  • 0
harcosgoogle

Locked vehicles bug and trader

Question

Hi.

There is a problem with closed vehicles,

Example: Spawn locked vehicle bug,Buy locked vehicles,Sell locked vehicles (error code)

No one writes that I could shut it down.

Photos links:

https://prntscr.com/f8ut13 - No lock menu

https://prntscr.com/f8utap - trader spawn bug

https://prntscr.com/f8utjo - lost car,added key

 

Quote
13:09:07 Error in expression < _array select 5;
			_pos = _worldspace select 1;
			_txt = getText (configFile >
13:09:07   Error position: <select 1;
			_txt = getText (configFile >
13:09:07   Error select: Type String, expected Array,Config entry
13:09:07 Server: Object 3:38 not found (message 94)
13:09:07 "Trader Menu: harcosgoogle (myid) purchased 1x ArmoredSUV_PMC_DZE into gear at Bandit Camp for 200,000 Coins"

1(one) he was able to lay down the vehicle,But it does not work afterwards

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I had the problem that vehicles don't spawn back in 1.0.5.1. Only the red arrow was visible. My problem was that my database was messed up but as you are using coins I guess you are using config traders.

Could you post the whole server.rpt and client.rpt because this error can't be everything. There is not even a file name or path given. It would help a lot if you just show us the whole files. If you can't upload them anywhere then use spoilers please.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By 2DayZ2Retirement
      -PROBLEM SOLVED-
       
      G'day, Survivors.
      I am having an issue on my server where vehicles which spawn randomly around the map repair themselves upon server restart.
      I use this config in my init.sqf which successfully spawns the vehicles in damaged and with low fuel...
      DynamicVehicleDamageLow = 75;
      DynamicVehicleDamageHigh = 100;
      DynamicVehicleFuelLow = 0;
      DynamicVehicleFuelHigh = 25;
      ...However upon each server restart the vehicles repair themselves (the fuel remains low however) and for the life of me I can't figure out why this is happening. 
      DayZ Version -DayZ Epoch 1.0.6.2
      Scripts Used -DZAI | -DZMS | -Right Click Actions (Suicide, Smoke Drugs, GPS Scan)
      AntiHack - InfiSTAR
      Server Host - GTXGaming
      My HiveEXT.log and arma2oaserver.RPT logs are not showing anything out of the ordinary.
      I'm not sure if it matter, but all Planes/Helicopters and Boats have been removed from the server via the dynamic_vehicle.sqf.
      In addition, all of the traders and trader cities being removed by removing the call for the CfgServerTrader.hpp in the description.ext.
      If there is any other info I can show to assist in fixing this problem please let me know, any help would be greatly appreciated.
      Cheers.
    • By Brian Soanes
      To unlock vehicles left in your traders over a server restart, open your epoch_server.pbo

      In epoch_server\compile\epoch_vehicle\EPOCH_load_vehicles.sqf
      Find
      if (_allowDamage) then { Just above that, add this
      A3E_SafeZonePosArray = [ [[18451.9,14278.1,0]], //Altis East trader [[13333.5,14494.3,0]], //Altis Central trader [[6192.46,16834,0]] //Altis West trader ]; { if (_vehicle distance (_x select 0) < 200) then { _vehicle lock false; diag_log format["Vehicle %1 left in trader unlocked @ %2", _class, mapGridPosition _vehicle]; }; } forEach A3E_SafeZonePosArray; Pack pbo and you're good to go
    • By calinova22
      How would I go about adding custom vehicles to my server? I want to have an F35B with no weapons. I know how to remove the weapons, just cant find the file for the jet itself to edit.
    • By Thug
      In the file server_spawnTraders.sqf
      private "_trader"; { _trader = createAgent [_x select 0,_x select 1,[],0,"CAN_COLLIDE"]; {_trader removeMagazine _x;} count magazines _trader; removeAllItems _trader; // removeAllWeapons _trader;//this is commented out so traders have weapons removeBackpack _trader; _trader switchMove ""; _trader setDir (_x select 2); _trader setVehicleInit "this disableAI 'ANIM'; this disableAI 'AUTOTARGET'; this disableAI 'FSM'; this disableAI 'MOVE'; this disableAI 'TARGET'; this setBehaviour 'CARELESS'; this forceSpeed 0; this allowDamage false;"; _trader setUnitAbility 0.6; _trader disableAI "ANIM"; _trader disableAI "AUTOTARGET"; _trader disableAI "FSM"; _trader disableAI "MOVE"; _trader disableAI "TARGET"; _trader setBehaviour "CARELESS"; _trader forceSpeed 0; _trader allowDamage false; _trader enableSimulation false; } count _this; processInitCommands; What would I have to do to get the Traders to move like they did in v1.0.5.1
      I have tried but can not get it to work.
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...