Jump to content
  • 0
DangerRuss

Corpses instantly, or very quickly, disappearing (sometimes)

Question

I have an issue on my overpoch server with corpses occasionally disappearing instantly or very quickly after death and more often then not, not leaving a skull and crossbones. This doesn't happen on every death and I can't seem to recreate it, it just happens sporadically. Where do I even start to try to find this issue? No errors in the RPT.

 

Some mods I have installed

Souls custom coin system

NPC Bankers

Custom kill messages (pictures) with updated deathboard.

InifiStar safe zones

Snap Building Pro

Vectoring

Precise base building

Service points

Indestructible locked vehicles near plot poles

Take Clothes

DZMS

Welcome Credits

Basic mission side spawn loadout script

 

That should be all, not 100% sure if  Ilisted everything but this is definitely 99% of what I have installed. Any pointers would be a huge help thanks.
 

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

I believe I had this happen on my server (Overpoch) yesterday. A player died, went back to retrieve his gear, his body was gone. Couldn't find anything on the admin map either, but he definitely died because I saw it in the logs. It's the first time I have ever seen something like this happen, but I just chalk it down to "because Dayz".

Share this post


Link to post
Share on other sites
  • 0

Sorry to bring up an old thread, I'm getting this issue on my Overpoch server too all of a sudden, no clue as to why, all i can tell is its as the player logs back into the server, they'll spawn and as soon as they notify me they've spawned their body disappears

Share this post


Link to post
Share on other sites
  • 0

Definitely not related to death messages or the server side/client side files being mixed up etc, thats functioning 100% fine, its after they die, get forced to lobby and then join back in, once they've respawned their body disappears.

Share this post


Link to post
Share on other sites
  • 0

Just to update everyone that I have solved the issue but its VERY unlikely that you will have made the same mistake I have

I recently went through all my files optimizing things and adding error handling to things, and completely overlooked a aspect of the AI system when adding error handling, in ai_monitor I had this:
 

if (ai_clean_dead) then {
	{
		_killedat = _x getVariable ["killedat", 0];
		if (!isNil "_killedat") then {
			if ((time - _killedat) >= ai_cleanup_time) then {
				deleteVehicle _x;
			};
		};
	} count allDead;
};

When it was supposed to be:

 

if (ai_clean_dead) then {
	{
		_killedat = _x getVariable "killedat";
		if (!isNil "_killedat") then {
			if ((time - _killedat) >= ai_cleanup_time) then {
				deleteVehicle _x;
			};
		};
	} count allDead;
};

Effectively I had basically forced killedat to always return 0 meaning it'd never be nil, thus when it looped over all dead bodies it'd be returning 0 for players bodies, and as per the condition for deleting the body it would return true, and delete the body.

Edited by KamikazeXeX

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Zer0Cool0
      I'm running Zupa coins on my dayz overpoch server. And whenever server restarts (and I assume when a player logs out) the player's coins disappear from their inventory .
      If anyone could help, I would appreciate it.
       
      Edit : I am missing banking_data in my db. How would I impliment it?
    • Guest
      By Guest
      Updated server to 1.0.5.1 and everything is going well except for one issue... There is a player on my server who has a fairly large base built on Skalisty Island. His base is 100% maintained and paid for on his plot pole. After every restart for the past 4-5 restarts, anywhere from 2-10 built walls/doors/floors just vanish. They are getting deleted from the database as well, so I know it's not an issue with it just not rendering. The items never reappear.
       
      Any thoughts on what might be causing it? I feel like it has something to do with being over our vehicle limit, so I purged all unlocked vehicles with empty inventory and took the server below the max vehicle limit, but parts of his base still disappeared after the next reboot. Now I don't know where to look next. It seems to only be happening to this one player whose base is nowhere near any other player's base. Where should I look next to try to resolve this issue?
       
      Cheers.
    • By Liqu1dShadow
      Hi All,
       
      I am having an odd problem on my server where people who remove 10oZ bars from a BC or when breaking a 10oZ gold into 1oZ gold have them disappear.
       
      I have had to spawn in a lot of 10oZ and 1oZ gold to a dedicated safe and offer banking services to my players so they don’t lose money :/
       
      I don’t have this problem and I’m SuperAdmin on InfiSTAR so I’m thinking it’s got something to do with Infi for normal players??
       
      Thanks
       
      Azz
    • By Liqu1dShadow
      Hi All,


      I have logged into my server twice now and the bases has disappeared including all safes across the map for everyone. is this a normal problem or am I being hacked


      the bases are a day old on the first instance, then 4 days then last night at 5 days old, but it’s the lot, every single brick and even people who made a base the night before!


      Really don’t know where to start :/


      I don’t have Admintools or Anti hack SW installed yet which makes me think someone could be doing it
       
      (I can’t get InfiStar to install - is why I haven’t done it)


      Thanks
       
      Aaron
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...