Jump to content
gamesation

[HowTo] Add new Cars

Recommended Posts

I will show you how you can add Cars like Ifrit or so !!

 

1. Go on http://wiki.7thcavalry.us/wiki/ARMA_3_Vehicles and pick up the class for the Car you want add !!

2. Open @EpochHive/epochconfig.hpp

3 If you wannt a Ifirt add this code 

//search for that code
allowedVehiclesList[] = {
//and now under that code add this code to add a Ifrit !!
{"O_MRAP_02_F",3},

4. Add all your Cars that you wannt add !!

 

5. Now we set the max. Spawn on Restart

//You see that code
{"O_MRAP_02_F",3},
//this ,3 is the Max. Spawn of this Car. Change it for more or lower max. Spawn

6. Restart

 

If you have any Question feel free to ask !!

Share this post


Link to post
Share on other sites

I added the vehicles I wanted for my map as posted above. @Epoch hive and then in the epochconfig.hpp  . The vehicles do not spawn on the map.. 
Here's what I added :

{"B_Heli_Transport_01_EPOCH",2},
{"B_Heli_Transport_01_camo_EPOCH",2},
{"B_G_Offroad_01_F",2},
{"B_G_Offroad_01_armed_F",2},
{"O_MRAP_02_hmg_F",2},
{"I_Heli_Transport_02_EPOCH",2}

Any thoughts?

Share this post


Link to post
Share on other sites

I think there is a upper limit of max vehicles on the map. You may have hit that so until you clean up some of the old vehicles the new ones won't spawn.

 

I deleted all the old vehicles after edit (following this guide) and now there I NO choppers on the map. So I edited it back to the default list and still NO choppers on the map . Any thoughts as to why vehicles are not spawning. I know in Arma 2 I had this all run with the dynamicvehicle.sqf but I don't see that in any of my PBOs for A3

Share this post


Link to post
Share on other sites

You can't without editing the core Epoch server files which is against the TOS.

 

I don't know who told you it was against the TOS, but it's not.. Seriously dude, you shouldn't spew things out, you know nothing about.

 

As long as you follow:

http://creativecommons.org/licenses/by-nc-nd/4.0/

 

You can do what you want as long as you follow the creative commons license. 

Share this post


Link to post
Share on other sites

so Armed vehicles is giving the script # 20 error?

 

atm I'm getting this error:

 

#20 "(_this select 0) execVM "\A3\soft_f_gamma\Hatchback_01\scripts\randomize_sports.sqf""

 

(Then Im Kicked for #20 Script Restriction, I look up Line 20 in scripts and it only has the Player damage variable... so is there any way to add these script to be whitelisted? obviously I'm doing this all on the wrong line? its line 21-23?

Share this post


Link to post
Share on other sites

so Armed vehicles is giving the script # 20 error?

 

atm I'm getting this error:

 

#20 "(_this select 0) execVM "\A3\soft_f_gamma\Hatchback_01\scripts\randomize_sports.sqf""

 

(Then Im Kicked for #20 Script Restriction, I look up Line 20 in scripts and it only has the Player damage variable... so is there any way to add these script to be whitelisted? obviously I'm doing this all on the wrong line? its line 21-23?

 

Don't forget to add the ammo for those vehicles into your loot spawner setup :)

Share this post


Link to post
Share on other sites

so Armed vehicles is giving the script # 20 error?

 

atm I'm getting this error:

 

#20 "(_this select 0) execVM "\A3\soft_f_gamma\Hatchback_01\scripts\randomize_sports.sqf""

 

(Then Im Kicked for #20 Script Restriction, I look up Line 20 in scripts and it only has the Player damage variable... so is there any way to add these script to be whitelisted? obviously I'm doing this all on the wrong line? its line 21-23?

 

Probably line #21 for exec, you need to add a line with BE filters..

Share this post


Link to post
Share on other sites

Don't forget to add the ammo for those vehicles into your loot spawner setup :)

Lol where is that located? and I can never get Lootspawner script to work get BE filter issues :( lol i got SEM working, but thats probably about it, but thanks, if ya know the filter to add? to get that to work or im lost and its somewhere on this forum right? :P

 

Probably line #21 for exec, you need to add a line with BE filters..

thanks

 

Paste !="execVM "scripts\randomize_sports.sqf" at the end of line 21 in scripts.txt sorry this was from my iPhone but you should get the idea

and also thanks, Lol trying this now

Share this post


Link to post
Share on other sites

someone have a fix for this everything i tried simply is wrong :/

 

"okeg setVectorUp (_Gvel call BIS_fnc_unitVector);
_smokeg setVelocity _Gvel;
_shells set [count _shells, _smokeg];
};
 
 
_shells "
 
 
cheers
 
 
thats fireing smoke shells from O_MRAP_02_F

Share this post


Link to post
Share on other sites

 

someone have a fix for this everything i tried simply is wrong :/

 

"okeg setVectorUp (_Gvel call BIS_fnc_unitVector);
_smokeg setVelocity _Gvel;
_shells set [count _shells, _smokeg];
};
 
 
_shells "
 
 
cheers
 
 
thats fireing smoke shells from O_MRAP_02_F

 

 

ya, you didnt add a Filter in your CreateVehicle.txt file.... it looks, I had to add my weapons from my Blackfoot chopper for the Bombs :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...