Jump to content
  • 0
speaR

[Solved]How to reset the DB ?

Question

17 answers to this question

Recommended Posts

  • 0

hei mate the dump.rdb is also contain player & money data ? I want to reset it (start from beginning state) so how I must to do

Yes the dump.rdb contains all the player, bank, vehicle, buildables (bases) , and trader inventory data.

Share this post


Link to post
Share on other sites
  • 0

go to DB folder that it is on arma 3 root folder and delete "dump.rdb"

Yeah...  that doesn't work.

You can also grab the redis DB manager from here

 

Connect to your redis db while its running...

 

Go to console and type FLUSHDB (This will wipe the entire database).

http://redis.io/commands

 

Restart Redis, restart your server and it will start to generate new key's.

Neither does this...

 

Share this post


Link to post
Share on other sites
  • 0

MMh Dump.rdb is the database so if u remove/delete it then all in recorded history is GONE....


So stop the server (start-redis.cmd) and delete dump.rdb from the folder u read IN the database , coz if u delete dump.rdb from C:\uthinkitshere
But load it from D:\noitsreallyhere then u get my point

 

Edited by umfufu

Share this post


Link to post
Share on other sites
  • 0

I get your point.  But it doesn't change the fact that the above proposed solutions are not working.  It fails to recreate a a dump.rdb file inside the DB folder.  I've used this resolution before...  Since the Arma 3 1.50 update, my shit is fucked up.  Can't connect to either of my servers anymore.

Edited by JediChris816

Share this post


Link to post
Share on other sites
  • 0

Looks like the redisserver aint started hence the fact u cant connect ( do u see them in the browser of arma3 ? )

1 start redis-servers 2. start arma3-server ~  (u login on same port? ) if no Db running the server just bails out

/Quote

It fails to recreate a a dump.rdb file inside the DB folder.

Look for it inside the user whom started redis Users/username/appdata/local/redis

 

 

Edited by umfufu

Share this post


Link to post
Share on other sites
  • 0

 

As you can see, there should be a Dump.rdb in E:\arma3server\DB\ folder, if the above instruction to recreate the database, by deleting it, hold true.  So there is obviously an unknown issue preventing the Dump.rdb from being recreated.

screenShot.jpg

Edited by JediChris816

Share this post


Link to post
Share on other sites
  • 0

No read the start-redis.cmd   Start redis-server E:\armaserver\DB\redis.conf means start redis READ redis.conf

As i said before it DB is stored in the User that started the redis  aka c:\Users\'USERNAME'\appdata\local\redis

u see there a largefile 1.5 gb  (dump.rdb only after the server has accepted a client)

The old redis-server 2.8.12 and Below uses the DB folder as  far i know after 2.8.16 it went to Users\'USERNAME'\appdata\local\redis

Mstech team did that , to overcome some issues (not arma3 related)

Edited by umfufu

Share this post


Link to post
Share on other sites
  • 0

You have got to be kidding me..  I see it now.  That is so fucked up.  It was perfectly fine running from the DB folder.  I wonder when Mstech changed the location?  Frustrating.  And that makes sense now because I did have a DumpOLD.rdb (renamed that one a couple months back when this fix worked and it recreated the database in the DB folder) and Dump.rdb in my DB folder when I originally setup my Bornholm server back in May.  Anyhow, I've already reverted back to a snapshot on 8/8 for that particular server.  Thanks for straightening that out for me.  Really irritating because there was really no reason, in my opinion, to run the database from the user's appdata\local folder when it was running fine previously.  Day wasted.  Thanks again, umfufu.

 

 

***EDIT***

Looking back on my snapshot, it looks like my database that was in the DB folder was last modified on 8/7 which means just recently the Mstech team had moved it to the appdata\local folder. 

Edited by JediChris816
because I can

Share this post


Link to post
Share on other sites
  • 0

Glad to see u got it working/fixed

Altho the revert of PATH is i believe from epoch-0.3.0.1 , unless u stayed with the older version of redis (wich is fine i still use 2.8.12 the issues dont relate to A3 or Epoch)

Just a few fixes ,and if the Devs know them i hope they want to comment to that to sort it out (but as i said i dont have any problems wich in no means prove there aint 1or more)

Mstech has a github so if u need to u can look into there

Share this post


Link to post
Share on other sites
  • 0

This is what annoys me about the Arma Community. How bloody vague you all are in explaining anything, expecting everyone to know what youre talking about with no simplification or examples of where to find directories etc. Just find the file..... yeah sure and when it comes up with no results? hmmmm?

here is the most easiest way to solve this that took me all night to figure out because of all the run around trying to find a simple answer on how to reset the frikkin DB.

Go into Arma 3 eden editor, load up the map like you're going to edit it. go into your campaign init/module and untick "Load from DB". once thats done activate the save option (can't remember where, maybe under settings but it should be there. My brain is scattered from the all nighter), Play the map in through the editor, check to see that the map has in fact reset eg: previously controlled sectors are now neutral etc, Save, Abort, Go back into editor, Turn back on "load from BD", run the game. done and you get to keep all your inventory, money, garage shit too, it should just reset the playing field.
I'm also using MCC4 because I don't know what I'm doing but this mod works for me right now if that helps a little bit too.

So as my closing. Maybe take a note from the great ole Einstein "If you can't explain it to a 5 year old. You know know what you're talking about"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...