Jump to content
Ghostrider-GRG

Rate of Hunger Decay

Recommended Posts

Hi @Ghostrider-DbD-, not sure whether you sorted this yourself (sure you did) but for others, the rate of hunger/thirst decay seems to be set in this line:

_baseHTLoss = ["CfgEpochClient", "baseHTLoss", 8] call EPOCH_fnc_returnConfigEntryV2;

in <mission file>/epoch_code/compile/setup/masterLoop/init.sqf. Many other decay and other variables together with their CfgEpochClient overrides are there too.

Share this post


Link to post
Share on other sites
7 minutes ago, Grahame said:

Hi @Ghostrider-DbD-, not sure whether you sorted this yourself (sure you did) but for others, the rate of hunger/thirst decay seems to be set in this line:

_baseHTLoss = ["CfgEpochClient", "baseHTLoss", 8] call EPOCH_fnc_returnConfigEntryV2;

in <mission file>/epoch_code/compile/setup/masterLoop/init.sqf. Many other decay and other variables together with their CfgEpochClient overrides are there too.

Hi Grahame,

Many thanks for sharing this information. I think that the issue may have been the change in the hunger/thirst at spawn which I did adjust. I will check with our playerbase and look at the code you mentioned as well.

Best

Ghost

 

Share this post


Link to post
Share on other sites
8 minutes ago, Ghostrider-DbD- said:

Hi Grahame,

Many thanks for sharing this information. I think that the issue may have been the change in the hunger/thirst at spawn which I did adjust. I will check with our playerbase and look at the code you mentioned as well.

Best

Ghost

 

I made the same adjustments but put 5000 for thirst not 2500 and got all my players banned by InfiStar. Had to fix it by increasing max thirst to 5000 in the InfiStar code for the moment (which I am not unhappy with since thirst should actually have a higher value than hunger).

One thing I might change from these settings is the max distance to an energy source so that people have to build more than one solar generator in a base...

Share this post


Link to post
Share on other sites

class CfgEpochClient
{
    epochVersion = "0.4.0.0";
    baseHTLoss = 4;      <<<<<<< add this with your value in \mpmissions\epoch.Altis\epoch_config\Configs\CfgEpochClient.hpp
    sapperRngChance = 100;

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...