Jump to content
  • 0
Sign in to follow this  
Jyggs

New Server Install Auto Kick

Question

Hi, I've been having this problem for weeks now and I'm about to give up since I cannot find a solution. I have downloaded Arma 3 server and Epoch on my home computer to make a simple testing server to run scripts on it and troubleshoot any issues. However I've bumped on a problem that I cannot solve. Each time I try to join my own server, the multiplayer screen says "You were kicked from the game" and goes back to the multiplayer server list.

 

I followed the instructions provided on the TXT file inside the Epoch server files on this page, but no dice. So I thought I was doing something wrong and kept looking for tutorials on how to do the correct setup procedure.  Examples of said tutorials can be found on this forum under:

 

And

 

 

 

I noticed that I didn't screwed up on the previous setup, but I did a clean install just to make sure. After several attempts, I am still getting the  "You were kicked from the game" message and I cannot enter my own server no matter what I do. So far I've tried disabling battleye, disabled my firewall, disabled my anti-virus, port forwarded the server.... but still I keep getting the same results. The weird thing is that I get no errors on any logs, so I can't trace my problem to it's source. The only thing I've noticed is that the console says this everytime I try to connect...
 

 
 
19:58:18 Dedicated host created.
19:58:20 BattlEye Server: Initialized (v1.198)
19:58:20 Host identity created.
19:58:20 Game Port: 2302, Steam Query Port: 2303
20:00:13 James May uses modified data file
20:00:13 BattlEye Server: Player #0 James May (XXXXXXXXXX) connected
20:00:13 Player James May connecting.
20:00:13 Mission Epoch Mod read from bank.
20:00:15 Player James May connected (id=XXXXXXXXXXXXXX).
20:00:15 Player James May disconnected.
20:00:15 BattlEye Server: Player #0 James May disconnected
20:00:15 All users disconnected, waiting for users

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Normally that would be a version conflict or addon conflict.. When you're kicked without any report you normally just don't have the same mods loaded.

Wait, so the current client version (0.2.5.2) is not compatible with the server 0.2.5.2b? I'm asking since I downloaded both file from EpochMods and this problem seems to do it on my local server and not on a rental/hosted one. My cousin has a hosted server and I can log in fine with no kicks. Both servers are using the same Epoch version and Im using the same client version to connect to them both which is why I don't understand the problem at all.

Right now Arma 3 is setup to start with the Heli/Kart DLC and with Epoch 0.2.5.2 active. Nothing else is added on my addons and I can connect fine on other Epoch servers, just not on my local server.

Share this post


Link to post
Share on other sites
  • 0

Somehow I fixed the problem by overwriting the Steam_AppID.txt file from Arma 3 Server with my Arma 3 Steam_AppID.txt. Still not sure what was the problem at all..... just glad I got it running to do some local test on some scripts that aren't working properly on a hosted server.

Share this post


Link to post
Share on other sites
  • 0

Thks for the info. I've been having the same problem between a Headless Client and a dedicated server. Instant and repetitive kick. It works fine in one directory but not in the other. Both were downloaded with steamcmd. I'll try replacing the file in the directory that won't work and post back.

**edit**

<sigh> no go. Both are the same.

**edited edit**

Ok, just clear this issue up, I discovered my problem. I had included asm.pbo in the server files (only to remove @asm from the command line). Removing asm.pbo and running it with @asm on the server command line cured the HC kick problem. I guess because the HC and the server are pulling from the same files, the unsigned asm.pbo the client loaded got it kicked.

I'll do a work around later, but at least that problem was solved.

Share this post


Link to post
Share on other sites
  • 0

:lol:

 

After several attempts, I am still getting the  "You were kicked from the game" message and I cannot enter my own server no matter what I do. 

So far I've tried disabling battleye, disabled my firewall, disabled my anti-virus, port forwarded the server.... but still I keep getting the same results.

 

Somehow I fixed the problem by overwriting the Steam_AppID.txt file from Arma 3 Server with my Arma 3 Steam_AppID.txt.

 

Removing asm.pbo and running it with @asm on the server command line cured the HC kick problem. 

 

Jyggs, Floyd, 
guys thanks to both of you, seriously
I signed up to the forum just to say thanks, you saved my bacon.
I dunno whose trick did it,
but you avoided all the work from last night setting up a local server being wasted,
as Jyggs was saying,
I too had followed those two tutorials to the letter only to find myself kicked every single time,
but then,
changed  Steam_AppID.txt file (how did  u come up with that?)
and removing @asm (don't even know why i bothered with it in the first place) 
and voilà,
i'm in Epoch on my local server,
biggest smile on my face, thanks guys. :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...