Jump to content
  • 0
Sign in to follow this  
anthonypull

Trouble with starting BEC - Problem seems to be with BEServer.cfg

Question

I can't get BEC to start and run correctly. If I open the BEC.exe it says "Did not find the BEServer.cfg file", and if I open the shortcut I made to bec.exe with the parameter "-f BEServer.cfg" it says "Your config file has a misconfigured section header, recheck config file format!"

 

A little bit of background info here....

 

-The reason I added "-f BEServer.cfg" was the section about options in the BEC README txt file. I wasn't sure if that was required so I tried both ways.

 

-I tried putting the BEC files into a few different locations, both the root of the server, the BEC folder, and the Tools folder. I've also thrown extra copies of the BEServer.cfg file all over the place just to see if maybe I misread something and misplaced it.

 

-As far as the "misconfigured header", this is the content of my BEServer.cfg file...

 

 

RConPassword password123

MaxPing 350

-I deleted and started fresh to see if maybe I messed up and didn't find anything wrong. I used two different sets of instructions to get to this point. My first attempt, I used The second time around I strictly followed instructions provided in the bundled readme files for the epoch server files and BEC. Both times I ended with the same result.

 

-I can start redis and run my start a3 server batch file and actually run and connect to the server, but no bec.exe

 

-In case this is relevant to anyone, I have set up and run a few Arma 2 servers but this is my first attempt at A3.

 

 

Thanks in advance for any assistance.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

You start BEC with -f Config.cfg

BEC resides outside arma, where it's config file is in the bec/config folder

 

 

The beserver.cfg sits in your battleye folder in Arma3

(There's a template there, rename it and use the 2 lines you put in the OP).

Share this post


Link to post
Share on other sites
  • 0
 

You start BEC with -f Config.cfg

BEC resides outside arma, where it's config file is in the bec/config folder

 

 

The beserver.cfg sits in your battleye folder in Arma3

(There's a template there, rename it and use the 2 lines you put in the OP).

 

 

 

 

This was the problem, it wasn't in the Battle Eye folder. Sorry I guess when I read that in the readme I assumed it meant "the folder you're currently working in pertaining to battleye". Thanks a lot, now to figure out the next problem! :p

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...