Jump to content
Clatter

"Fixed(?)" Player database cache load issue

Recommended Posts

Edit:  See post #4

 

Original post:

 

I am running a linux server on a spare machine i have and I keep getting this:

14:25:50 Client: Remote object 3:40 not found
14:25:55 BattlEye Server: Player #0 Owner disconnected
14:25:55 Warning: Cleanup player - person 3:42 not found14:26:00 Owner uses modified data file
14:26:00 Player Owner connecting.
14:26:14 "LOAD PLAYER: \cache\players\3\000000934.sqf"
14:26:14 Warning Message: Script cache\players\3\000000934.sqf not found
14:26:14 "PLAYER CACHE: "
14:26:14 "BACKLOAD PLAYER: \cache\players\2\000000934.sqf"
14:26:14 Warning Message: Script cache\players\2\000000934.sqf not found
14:26:14 "PLAYER CACHE: "
14:26:14 "PLAYER DEFAULT CACHE: ["PASS",false,"1",[],[["ItemFlashlight","ItemMap","ItemGPS","MeleeCrowbar"],["ItemBandage","ItemPainkiller","ItemSodaPepsi","ItemSodaCoke","FoodbeefCooked"]],["DZ_Patrol_Pack_EP1",[],[]],[0,0,0],"Survivor2_DZ",0.96]"
14:26:14 "CHILD:11:4:"

14:26:14 "LOAD CHARACTER: \cache\players\4\000000934-char.sqf"
14:26:14 Warning Message: Script cache\players\4\000000934-char.sqf not found
14:26:14 "CHARACTER CACHE: "
14:26:14 "BACKLOAD CHARACTER: \cache\players\3\000000934-char.sqf"
14:26:14 Warning Message: Script cache\players\3\000000934-char.sqf not found
14:26:14 "CHARACTER CACHE: "
14:26:14 "CHARACTER DEFAULT CACHE: ["PASS",[],[0,0,0,0],[],[],2500,"1"]"
14:26:14 "_characterID: 1"
14:26:14 "WORLDSPACE: []"
14:26:14 "LOGIN: Location: [] doRnd?: true"

Player data seems to be saving correctly (.sqf file contents match location and inventory i had when logging out), but the server won't load it. I end up as a fresh spawn almost every time i log.

I managed to retain location and inventory on relog by manualy creating the folders it would look for and copying the .sqf files in after logout.

If I keep logging out and in, the folder number it tries to load from /cache/players keeps going up, usually one number beyond what it saved.

Everything else saves and loads fine (vehicles, tents, and their contents etc).

 

I have already done a complete re-install of the server, and have since wiped the database a few times without improvement.

 

 

Sometimes when I die and respawn it has reverted to where I last logged before I died.

A few times after logging it has spawned me in as a new player, but retained my inventory.

 

This is a server i set up just to mess around and try stuff, I am the only player.

 

Edit: Messed around some more, seems it isn't saving correctly all the time, may be hardware performance issue? (2ghz, 2 core processor, 2gb ram, everything seems to run smoothly though, player/character data is all that is affected).C

Edit2: correct data shows up in database, not always in cache though. Even when correct in cache, the game still tries to load

the wrong folder/file.

Would be nice to know where the player and character id's are stored too.

Share this post


Link to post
Share on other sites

Did you stop the server with #shutdown ingame as admin?

I had issues with doing so.

Only use restarter.pl to stop/restart the server.

Character data is stored in the mysql db in table character_data.

You could delete the characters in db and cache files for which that happens and ./restarter.pl.

Or figure out the 'right' one and delete the others...maybe that also helps.

Share this post


Link to post
Share on other sites

I did shut the server down as admin through the server control section of the lobby (once), but the problem has been happening

pretty much the whole time iirc. (I normally use restarter.pl.  Since I don't leave the machine running all the time I have been

running restarter.pl and then ending the process when I shut the machine down)

 

I'll try editing the character data, maybe put in a dummy player id, guid etc to make it see me as a new player (on my server)?

I saw someone else on here had similar player save issues and 'fixed' it by buying a cd key?

 

Thanks for the reply.

 

edit: Been fooling around with things some more. Truncated player_login, player_data, character_data, and wiped /cache/player. Then I

logged in, got new character etc.  After running around for a few minutes, I logged out and then back in. It still tried to load /cache/player data that wasn't there, and spawned me as a new player with default stuff. I checked the database through workbench, and all of it matched what I had at logout (and had seen go by on the terminal/log).

Share this post


Link to post
Share on other sites

Weird issue this is, probably to do with permissions?

If I run restarter.pl from a root terminal with screen -r, everything works.

If I run epoch.sh from a root terminal, everything works.

If I run restarter pl from a root terminal and use cat /proc/{pid}/fd/1 to monitor epoch.sh from 

a second terminal, I get this issue. It only has to do with the player, not objects or anything else.

 

Fixed I guess.

Share this post


Link to post
Share on other sites

If you are running this on a user e.g. 'dayzepoch' and do a 'chown -R dayzepoch:users *' in your server directory...everything should be fine (without using the root user).

 

 

I have a similar issue with my cache dir (maybe that is how it was designed): after a restarts my cache/players directory looks like:

 

./

../

4/

 

in forlder 4 I have some cache files and an additional folder 4/. In this folder there is an folder 3/...in there 2/ and so on.

 

I am not sure if this is correct how it is and what I still need from these files. I mean if I can delete all subfolders in folder 4/ in the main cache/player directory.

 

Anyone knows how to handle this?

 

regards,

jahan.

Share this post


Link to post
Share on other sites

Still have a good bit to learn about linux I guess. I am hoping it gains more users so companies

will put more effort into making stuff work better with it as well as improving ease of use.

 

A far as the player cache, the log indicates the game generates a folder and file when player logs

in, restarter.pl has a section that backs up the player cache, which may be generating the subfolders?

Share this post


Link to post
Share on other sites

Sorry for necro)

23:30:10 "DZAI Monitor :: Server Uptime: 0:21:37. Active AI Groups: 1."
23:30:10 "DZAI Monitor :: Static Spawns: 0. Respawn Queue: 0 groups queued."
23:30:10 "DZAI Monitor :: Dynamic Spawns: 0. Random Spawns: 0. Air Patrols: 0. Land Patrols: 1."
23:34:00 "TIME SYNC: Local Time set to [2012,6,6,17,23]"
23:34:10 "CHILD:101:76561198015211482:11:switcher:"
CHILD:101 Save player: /home/epoch/cache/players/3/76561198015211482.sqf
23:34:10 "LOAD PLAYER: \cache\players\3\76561198015211482.sqf"
23:34:10 "PLAYER CACHE: ["PASS",false,"200",[],[["8Rnd_9x18_Makarov","8Rnd_9x18_Makarov","ItemBandage","ItemPainkiller"],["ItemMap","ItemCompass","ItemRadio","Makarov","ItemSodaCoke","FoodbeefCooked"]],["DZ_Patrol_Pack_EP1",[],[]],[0,0,0],"Survivor2_DZ",0.96]"
23:34:10 "CHILD:11:4:"
23:34:11 Server: Object 3:75 not found (message 94)
23:34:11 "CHILD:102:200:"
CHILD:102 Save character: /home/epoch/cache/players/4/76561198015211482-char.sqf
23:34:11 "LOAD CHARACTER: \cache\players\4\76561198015211482-char.sqf"
23:34:11 "CHARACTER CACHE: ["PASS",[],[0,0,0,0],[],[],2500,"200",0]"
23:34:11 "_characterID: 200"
23:34:11 "_cashMoney:0:"
23:34:11 "WORLDSPACE: []"
23:34:11 "LOGIN: Location: [] doRnd?: true"
23:34:11 "SETUP WORLDSPACE: [0,[4827.37,2029.38,0]]"
23:34:11 "CHILD:298:76561198015211482:"
CHILD:298 Save bank: /home/epoch/cache/players/4/76561198015211482-bank.sqf with BankSaldo: 0
23:34:11 "LOAD BANK: \cache\players\4\76561198015211482-bank.sqf"
23:34:11 "BANK CACHE: ["PASS",0]"
23:34:15 "CHILD:103:76561198015211482:200:0:"
23:34:31 "CHILD:201:200:[43,[4834.44,2040.87,0.00131316]]:[]:[]:[false,false,false,false,false,false,false,12000,[],[0,0],0,[0,0]]:false:false:0:0:21262:0:["","aidlpknlmstpsnonwnondnon_player_idlesteady02",36,[]]:0:0:Survivor2_DZ:0:0:"
23:34:34 "CHILD:201:200:[45,[4834.4,2040.75,0.00131321]]:[[],["ItemSodaCoke","FoodbeefCooked"]]:["DZ_Patrol_Pack_EP1",[[],[]],[[],[]]]:[false,false,false,false,false,false,false,12000,[],[0,0],0,[0,0]]:false:false:0:0:0:0:["","aidlpknlmstpsnonwnondnon_player_idlesteady02",36,[]]:0:0::0:0:"

Players spawns  with next: "ItemSodaCoke","FoodbeefCooked" only

but default: 8Rnd_9x18_Makarov","8Rnd_9x18_Makarov","ItemBandage","ItemPainkiller"],["ItemMap","ItemCompass","ItemRadio","Makarov","ItemSodaCoke","FoodbeefCooked"

Can anybody help me?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...