Jump to content

Narines

Member
  • Content Count

    7
  • Joined

  • Last visited

About Narines

  • Rank
    Newbie

Recent Profile Visitors

866 profile views
  1. Woah. Guess I was more tired than I thought when I posted this last night. I forgot a ';' at the end of 'if(isServer)then{};'. The code you should put at the top of your init.sqf is the following : if (isServer) then { execVM "\q\addons\traderATMs\init.sqf"; }; Will update the info in my previous posts. Real sorry for that.
  2. If it kicks you players, it is because you didnt call the sqf inside the "if(isServer)then{}" condition. Make sure you put the exact code below on the first line of your init.sqf **NOTE - I changed the installation method so make sure you are using the new method or the following code won't work. Check initial post for installation instructions.** if (isServer) then { execVM "\q\addons\traderATMs\init.sqf"; };
  3. It would be a better place since it wouldn't add to the mission file size. Thx for the suggestion, I am just starting with arma 3 scripting. **EDIT - I applied your suggestions and changed the installation instructions in initial post. Thanks**
  4. I don't have this problem. I even made tests on my local server where I kill AI, get vehicle, lock vehicle, delog, restart server, relog and wait for 1h before interacting with it. Still working fine.
  5. Hi ! First, thank you for your great script ! I've been using it on my server and I made a few modifications that solves a couple of problems. More precisely, I found why the AI was not behaving normally. It had to do with the fact that you were calling setcombatmode "RED"; on a unit instead of a group. (https://community.bistudio.com/wiki/setCombatMode). Thanks to Mister T for his script "Roaming AI in towns". That's where I got the hint from. I also changed how spawnVehicle is called to make sure that the AI controlling the vehicles are in the same group than the other AIs. This way, they strat chasing the player if he hits any other target. I thought I would share this with the community so here is the link for the updated "custom_server.pbo" file. https://dl.dropboxusercontent.com/u/63143678/custom_server.zip Here is, in more details, the modifications I made (I added comments starting with //NARINES// for every modification I made): AI.sqf (same with AI1.sqf) spawnVehicle.sqf spawnai.sqf (same with spawnai1.sqf)
  6. Hi, This script is extremely simple. 1 - In '@epochhive/addons' add the following pbo (traderATMs.pbo) : https://dl.dropboxusercontent.com/u/63143678/epoch_scripts/traderATMs.pbo 2 - In your 'MPMissions' folder, unpack 'epoch.Altis.pbo' 3 - In your unpacked 'epoch.Altis' folder, open init.sqf and add the following at the very top : if (isServer) then { execVM "\q\addons\traderATMs\init.sqf"; }; Note : if there is no init.sqf in the root of your unpacked 'epoch.Altis' folder, just create one. 4 - Repack 'epoch.Altis' into 'epoch.Altis.pbo' That's it ! **EDIT** Optimized following Kroenen's suggestions
×
×
  • Create New...