Jump to content
MuhKuh

Trader Change Tool

Recommended Posts

Then 11 is the correct instance; you might be having similar issues as I am. I have not had a chance to look at the database yet to see if Capt-O is correct. Sorry I cannot be of any more help at the moment. If I do find out anything I will pass it along though.

Share this post


Link to post
Share on other sites

Hi, thanks for this great utility, it is exactly what i was looking for..

BUT..

I can't make it works.. its really confusing, i'm pretty sure that i filled all form fields correct, so login data should be ok.

Also, im hosted by Vilayer and i have no problem to connect to my database trough f.e. HeidiSQL, so external connection to database is IMHO not problem.. 

If i try to connect to the database with same login data as i have in HeidiSQL, Trader Editor shows me this:

MySql.Data.MySqlClient.MySqlException: Unable to connect to any of the specified MySQL hosts.
   at MySql.Data.MySqlClient.NativeDriver.Open()
   at MySql.Data.MySqlClient.Driver.Open()
   at MySql.Data.MySqlClient.Driver.Create(MySqlConnectionStringBuilder settings)
   at MySql.Data.MySqlClient.MySqlPool.CreateNewPooledConnection()
   at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection()
   at MySql.Data.MySqlClient.MySqlPool.TryToGetDriver()
   at MySql.Data.MySqlClient.MySqlPool.GetConnection()
   at MySql.Data.MySqlClient.MySqlConnection.Open()
   at TraderEditor.DatabaseConnector.getTraders(String instance)

Here is screenshot of my database & trader editor together just for control that i don't mess up something..

https://www.dropbox.com/s/epweo6c8pp781ey/Screenshot%202014-03-14%2014.06.45.png

 

I have Epoch ver. 1.0.4.2 and map Chernarus

 

Can you help me please? Thank you..

Share this post


Link to post
Share on other sites

Are you sure all parameters are coorect ?

 

- the port is not the standard one, may its 3306 ?

- take care fore case sentitivity, may "Root" have to be "root" ?

- try to create another identity instead of root, in my case I had some kind of problem.

- are you using encryption in HeidiSQL?

 

Good luck.

Share this post


Link to post
Share on other sites

Tkanks for reply..

yes, i'm pretty sure that i filled correct host, password, port, database name and user name.. (because it works in HeidiSQL and Vilayer reports me that login data).

Unfortunetly, i don't know how to create another identity under Vilayer hosting :( I'll try to contact them if is it possible..)

And not, I dont use encryption in Heidi SQL...

 

Maybe is some problem on my server side by Vilayer.. I really don't know..

Share this post


Link to post
Share on other sites

Thanks for the nice tool!

I can get this to work just fine with my localhost server (Cherno with instance 17, not 11, some patches ago there was a revision of trader handling, but I haven't understood the whys or whats).

 

Trying to connect to our Vilayer DBs, however, does not work (the same error messages as shown by 2 people in the previous posts) even though I use the same connection parameters as in my working phpMyAdmin config.inc.php....

 

There seems to be a thing 'password hashing' that is mysql version dependent?....

Share this post


Link to post
Share on other sites

Where does it pull the currency types from? Is that hard coded into the program, or from a list somewhere?

 

Lots of servers have additional currency options, such as Topaz, Emerald, Ruby....So, if I add that to my my server, will they become selectable in the list?

Share this post


Link to post
Share on other sites

I have a little problem. I can see the traders and what they sell but when I click on the category nothing shows up on the right side

 

c843e342c227f88b9dd961283b857e9b.png

same here - only black market ammo/weapons shows me the items (chernaros)

Share this post


Link to post
Share on other sites

Help, I can see the trader and the categories, but I can't see the items... I am 100 procent sure the settings are right, and I even rewrote the database once to see if that makes any difference... It does not. Help? :P

Share this post


Link to post
Share on other sites

 

 

I am wondering if this is intended or not; maybe vbAWOL will see this and chime in (or maybe someone else knows). It appears (I think I am looking at this right) the Epoch Chernarus 11 (the one I am using) is using the TID's of Epoch Chernarus 17. I put in the instance ID of 17 in the Trader Config Tool and all is well with the world.

 

Epoch Chernarus 11 server_traders.sqf (GITHUB)

// Aircraft Dealer
menu_Soldier_Sniper_PMC = [
	[["Airplanes",517],["Helicopter Unarmed",519]],
	[],
	"neutral"
];

Epoch Chernarus 17 server_traders.sqf (GITHUB)

 

// Aircraft Dealer
menu_Soldier_Sniper_PMC = [
	[["Airplanes",517],["Helicopter Unarmed",519]],
	[],
	"neutral"
];

Weird, same for me. I suggest anyone else having probs with empty menus tries instance 17 and edit away....lol

Share this post


Link to post
Share on other sites

I coded some new application because I couldn't find a (good) non web based one :)

 

All you need:

- MYSQL login data

- instance number (found in table Server_TRADERS)

 

 

Suggestions and bugs to [email protected]

 

 

https://www.dropbox.com/sh/nxf0l24lgaaqbdh/60beSYJqAD

 

 

uvb5cah6wuaa.png

Nice work dude! Works a charm, once I got my head round actually using instance 17...lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...