Jump to content
noobienater

Battleye kicks more than 1 admin

Recommended Posts

Hey Guys.

Ok, ive got a epoch server up and running with linux and yeah thats good, and i have installed infiSTAR antihack and admintool to my server and it is working, but there is just this problem that, it is only the first admin who joins the server and opens the admintool that can use it??? everytime that more than 1 admin tryes to use it the other admins get kicked and this message comes up:

HackMenu with id 3030???

EDIT

Okay i've got something right now, i moved the BEFilters to the right folder and i get a log and evrything but more than 1 admin using admintool still gets kicked just by publiccvarible restriction #0 now. I have looked up in the log and found this:

07.02.2016 14:04:09: BeepBeepImaJeep (xxx.xx.xx.xx:xxxx) - - #5 "PVAH_AdminReq" = [1234,<NULL-object>,"76561198061701725"]
07.02.2016 14:04:16: BeepBeepImaJeep (xxx.xx.xx.xx:xxxx)(ip of the user - just with x for security) - - #0 "HACK_MENU_FOUND" = "BeepBeepImaJeep(76561198061701725) - HackMenu with ID 3030 found! (by dialog id!)"

Anyone know how to fix this?

Share this post


Link to post
Share on other sites

Not sure why its saying beepbeepimajeep..thats kinda funny .   but on a serious note.  any dialog you've created, must be added in this list in the ahconfig.sqf of infreestore (infistar)

_ALLOWED_Dialogs = _ALLOWED_Dialogs + [81000,88890,20001,3030.....

add your custom dialog number in there. ONLY if its something you've added or created. otherwise its a hack menu.

If thats not the case, then your BE filters might not be in the right place.

pay attention to your server launch command, 

this "profiles=instance_11_Chernarus" is where the server looks for the BattleEye Folder.

I would recommend using the BE filters from infistar, then adding to them if need be.

Share this post


Link to post
Share on other sites

k, first off yeah beepbeepimajeep is the name of one of my admins xD

and sorry i dont really fully understand what you mean by the dialogs? like do i have to make some custom allowed dialogs or?

then the befilters im pretty sure is the right place... well i hope so and yeh i added infistar filters.

you sound like you kinda know what to do here would you be able to help over teamspeak?

Share this post


Link to post
Share on other sites

if you didnt create a custom dialog then i wouldnt worry about the dialog part.  But hes getting kicked for opening a dialog, the dialog number is 3030.

I do understand it a bit, but you are also on linux, so im not sure exactly how similar the files are.

Share this post


Link to post
Share on other sites

well i dont really know either i've never tryed on windows really lol but it should be pretty similar :)

so do you have any suggestions what do do here? because i thought i was something about the BEFilters too with tha PVAH thing... and ingame it just give the message publicvariable restriction#0 you know.

Share this post


Link to post
Share on other sites

with that kick its definitely a BattleEye issue.

Ill be honest ive never seen the 3030 dialog, its not even in the list of infistar allowed dialogs.  So im not sure what dialog 3030 is.

But its a BE kick, if your filters are good, then it might be a hack menu dunno.

 

Share this post


Link to post
Share on other sites

"but there is just this problem that, it is only the first admin who joins the server and opens the admintool that can use it??? everytime that more than 1 admin tryes to use it the other admins get kicked and this message comes up"

Did you try to change the order of admins logging in or is it always you logging in as the first admin user and your friend is always the second?

What happens if you do NOT login and just let your friend login as an admin...is it then working for him?

Just want to ensure that your hint with the 2nd admin does not lead to a completely wrong idea of what the problem really is. But I do not really get this information out of what you wrote so far. But I think it will be helpful if you mention what you've already tested to isolate the issue?

 

Share this post


Link to post
Share on other sites

K, i have tryed alot of different test:

test 1 - i joins my server right after a restart and testing all myself and admin tool works whole time... until i die and respawn then i cant use it.

test 2 - i join my server right after a restart and im the first one to open it and i can use it but my other admins cant, and i cant eirther after i respawn.

test 3 - Another admin joins and opens the tool first he can use untill he dies and all other admins including me cant use it either after he opened it first

okay, i think you got and idea of what is going on now? xD

Share this post


Link to post
Share on other sites

Just wanted to make sure the friend might have any Hack Menu (whatever tool) installed client side which always kicks him if it's always him joining as the second player ;)

I think I did read that wrong initially. You are using the infistar admintool, not the Noxsicarius one, I guess. I would say you are not using the correct battleye filter files which are needed by the infistar version you use.

Not sure how to get these but I saw some posts where people asked infistar for the files...after that server was working as normal without kicks.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...