Jump to content
Metalfoundry

Performance is awful

Recommended Posts

14 FPS with 38 players......sometime 8-9 FPS with 15 players... with NO Scripts, No sappers, no drones... took all scripts and addons except MAS Weapons out today!

 

this is not normal!

 

We will have a XEON E5 next week, but i dont think, the problems will be solved with a stronger CPU. I think, Epoch is the main problem, Its since the Epoch 0.3 version!

 

 

Xeon E3 3,5 GHz

16GB RAM

SSD

Share this post


Link to post
Share on other sites

You were right the first time, my tests when public 0.3.0.1 were released, i posted them here specifically that with all public options for antagonists turned off was broke and we are still getting 3 to 5 uav drones over one town with only one player looting and only a dozen people online.

Currently 15 players on, 2 are HC'S and I'm counting 4 sapper, 8 uav drones, besides any of my addon ai there are about 20 on the map from prior drones after only 45 minutes of uptime.....

All that with no options above 0.01 or at 0 percent chance to spawn, plus removed from their lists of whichantagonists to spawn.

Even added in a cleanup script that removed all antagonists as they spawned in and still performance issues, not as bad but still there, 40+players hit server fps of 1.

Restarts are now 2 hours.

Share this post


Link to post
Share on other sites

I have noticed a slight performance decrease with the latest update but nothing like what is being described here. 11 players online, A3EAI, Earplugs, Supply Drops,IgiLoad, SEM Missions, Custom Map Additions, Convoys, And more ask running from 45 to 60 fps with no complaints. I heard somewhere 40 was the magic number for huge performance drop offs but I've not been lucky too hit that number yet.

Share this post


Link to post
Share on other sites

v5fs2dprfrpe.jpg

What´s the problem, Arma or Epoch? Any official statements?

 

You rent a server from Nitrado, you think about it to maybe change the hosting Service?

Nitrado is a popular hoster i know but that's why you should think about that.

 

As far as I know thei runing multiple game servers on one single root and that eats a lot of traffic.

I could of also be fully wrong and it is located at the Epoch mod or Arma 3 itself,

I have unfortunately not the population to test it and my server is running quite some time with 50-60 FPS.

Share this post


Link to post
Share on other sites

I've seen many users reporting issues on Wasteland and KotH too, so it's not just Epoch.  If I had to guess I'd say it's probably in the way Arma changes it's network transmission methods when player counts get above a certain level.  As you can see in the graph above, once the player count gets above a certain point the server FPS goes straight into the toilet.  As many Arma veterans know, network processing bottlenecks drastically affect overall server performance.  Those bottlenecks don't have to be caused by the connection itself.  Arma's own netcode has a lot to do with it.  The 1.42 changelog showed that they made some changes to the network code, so they will have to "fix" whatever it is they "broke".  According to today's dev changelog they made some optimizations to how AI updates are sent over the network, so that may be the fix we need.  We will have to wait and see.  

Share this post


Link to post
Share on other sites

You rent a server from Nitrado, you think about it to maybe change the hosting Service?

Nitrado is a popular hoster i know but that's why you should think about that.

 

As far as I know thei runing multiple game servers on one single root and that eats a lot of traffic.

I could of also be fully wrong and it is located at the Epoch mod or Arma 3 itself,

I have unfortunately not the population to test it and my server is running quite some time with 50-60 FPS.

 

I can confirm, that he don´t rented a server from Nitrado. He has got a quite good dedicated root server. For me there are similar issues of this performance shit. And like many ppl said, with 1.40/0.2.5.2 everything was great. So we only can hope for a new Arma patch and find some new players, which don´t want to wait for performance fixes. They just want to play. I don´t understand the solution of this last Arma patch to 1.42, because it´s related with so many issues of hell :/

Share this post


Link to post
Share on other sites

@Salutesh: Nitrado is our brutalized past, which ended in January 15...

@Darth_Rogue, correct me, when I´m wrong, but this shit started with Epoch 0.3, didnt it? And this was BEFORE 1.42.

 

ok, it could be the preparation of Epoch for the Arma version 1.42 ...

Share this post


Link to post
Share on other sites

It's hard to say.  A lot changed pretty quickly.  We got the 0.3 update and I don't recall seeing a lot of complaints about performance.  Then not two weeks later Arma 1.42 hit and Epoch 0.3.0.2 on the same day and then all hell broke loose.  If there were issues in 0.3 we didn't get much time to see them due to the quick succession of updates.

Share this post


Link to post
Share on other sites

The update to the 1.42(v1) binary has helped quite a bit (it seems to be as fast as 1.40)

 

You can get them from Dwardens Dropbox:

http://forums.bistudio.com/showthread.php?169944-Arma-3-STABLE-server-1-40-quot-performance-binary-quot-feedback

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

Share this post


Link to post
Share on other sites

Well I applied that .exe update and I think it made it worse a lot of up and down versus steady like I was use to, maybe a coincidence but I reverted back just to be safe. I may try it later just for me it wasn't a improvement but it could be for others like Brian stated

And it's just an update to the server .exe it doesn't affect clients, it's just to launch the server.

Share this post


Link to post
Share on other sites

Applied exe to server, using client exe and noticed slight fps increase, 1 admin gained 10-15fps, he suffered from previous updates making it unplayable. 2 others reporting better performance also..  We have no playerload to say for sure serverside.

Share this post


Link to post
Share on other sites

Try this basic.cfg, it reduces network traffic slightly and caps the max bandwidth. It improves server performance over the stock Epoch basic.cfg

language="English";
adapter=-1;
3D_Performance=1.000000;
Resolution_W=800;
Resolution_H=600;
Resolution_Bpp=32;
MinBandwidth = 768000;
MaxBandwidth = 104857600;
MaxMsgSend = 256;
MaxSizeGuaranteed = 640;
class sockets{maxPacketSize = 1400;};
MaxSizeNonguaranteed = 256;
MinErrorToSend = 0.004;
MinErrorToSendNear = 0.03;
MaxCustomFileSize = 0;

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...