Jump to content

Recommended Posts

Did anyone notice about that massive performance decrease?

I got an image for you:

The top window is the live server with my own modified version of an realy old WAI.

The botom is with this 2.2.0 and every mission has been nerfed by the half of bots spawning, i run 2 missions a time and have 2 static Ai camps:

 

c29f21333e.png

Share this post


Link to post
Share on other sites

Finished missions dont cleanup buildings any solution for this?

WAI 2.2.0 running

My config is this

 

wai_clean_mission            = true;   

wai_clean_mission_time        = 300;  

 

btw AI corpse get deleted after set time.

 

Only error in RPT:

 

WARNING: Function 'name' - Abdul-Basir Jalali is dead (seems to be an AI)

 

Same problem here. I have reinstalled the script twice but still not cleaning the mission buildings. Is it maybe an infistar or battleye problem? I'd be very glad if someone has a solution for this problem.

Share this post


Link to post
Share on other sites

Same problem here. I have reinstalled the script twice but still not cleaning the mission buildings. Is it maybe an infistar or battleye problem? I'd be very glad if someone has a solution for this problem.

same here

Share this post


Link to post
Share on other sites

Same problem here. I have reinstalled the script twice but still not cleaning the mission buildings. Is it maybe an infistar or battleye problem? I'd be very glad if someone has a solution for this problem.

 

I had the same problem with one mission, and my server is closed (private) so I dont have Infistar or battleeye.

 

I had a mission the other day, that wouldt not clear, so after running around, i teleported away, and back again, and then the mission completed at the same second I was back.

 

I have the 13 other missions, but i was not one of them that did not clear.

Share this post


Link to post
Share on other sites

For some reason Bandit AI missions wont attack players on the server. The hero missions will attack players but the bandits wont. I tried changing my humanity, changing skins, but nothing worked, the bandit AI just won't attack players. Anyone know why?

Share this post


Link to post
Share on other sites
ai_friendly_behaviour = false;		// make ai friendly towards comrades

player_bandit = -5000;		        // this is the amount you declare someone to be a bandit on your server, bandit AI will not attack you if ai_friendly_behaviour is true
player_hero = 5000;			// this is the amount you declare someone to be a hero on your server, hero AI will not attack you if ai_friendly_behaviour is true

?

Share this post


Link to post
Share on other sites

hello..

 

 

How would i implement all the overwatch weapons  with the epoch ones in WIA 

also in the mission creates ? in DZMS i put my list in but i cant seem to find where to do it in ehre 

also i run napf was wondering since i have a static lsit in DZMS if i could add those in here also .. 

 

thanks 

Share this post


Link to post
Share on other sites

 

hello..

 

 

How would i implement all the overwatch weapons  with the epoch ones in WIA 

also in the mission creates ? in DZMS i put my list in but i cant seem to find where to do it in ehre 

also i run napf was wondering since i have a static lsit in DZMS if i could add those in here also .. 

 

thanks 

 

 

In the WAI folder there's a config.sqf There you can change all the settings.

Share this post


Link to post
Share on other sites

I ended up doing it myself :)

 

For anyone else running Napf, here are waypoints for the patrol missions. Just copy them over to the bandit and hero patrol.sqf files.

                ["Awol's Airfield",[15169.4,15993.1,0]],
		["Meggen",[16495.6,15184.5,0]],
		["Luzern",[14644.8,13925.9,0]],
		["Liestal",[12686.7,9690.67,0]],
		["Schangen",[9095,5463.93,0]],
		["Lausen",[12383.3,15544.1,0]],
		["Nordsten",[10225.5,18324.3,0]],
		["Olten",[10103.6,16452.9,0]],
		["Freidorf",[8444.87,17092.6,0]],
		["Lenzburg",[8856.77,16227.9,0]],
		["Neue Welt",[5896.81,13498.5,0]],
		["Hutwill",[4562.94,12273.5,0]],
		["Bubendorf",[3816.99,14328.9,0]],
		["Hindelbank",[3163.71,12157.5,0]],
		["Ittingen",[2071.93,9789.94,0]],
		["Munsingen",[3765.5,7873.42,0]],
		["Munchenstein",[6453.07,9588.99,0]],
		["Signau",[5990.02,9022.92,0]],
		["Worb",[2109.19,7652.99,0]],
		["Hero Airfield",[5222.55,4472.25,0]],
		["Homberg",[3110.12,7455.2,0]],
		["Buckten",[6119.85,5075.97,0]],
		["Goldwil",[10990.7,1977.74,0]],
		["Brienz",[14443.9,2952.2,0]],
		["South Airfield",[18088.3,2563.68,0]],
		["Giswil",[16784.9,5161.39,0]],
		["Rorenpass",[14801.5,5282.07,0]],
		["Sorenberg",[13528.8,5302.98,0]],
		["Ramisbode",[8332.47,7782.21,0]],
		["Milan",[10313.5,7983.55,0]],
		["Farnen",[13072.8,6947.73,0]],
		["Alpnach",[18694.9,9420.17,0]],
		["Emmen",[15859,13286.5,0]],
		["Wolhusen",[14274,12636.1,0]]

All tested working.

 

:wub:  oh boy that will save me some time! thank you so much El Dub

Share this post


Link to post
Share on other sites

Did anyone notice about that massive performance decrease?

I got an image for you:

The top window is the live server with my own modified version of an realy old WAI.

The botom is with this 2.2.0 and every mission has been nerfed by the half of bots spawning, i run 2 missions a time and have 2 static Ai camps:

 

c29f21333e.png

 

 

I have notice this also.

I found out, that this has something to do with the mines.

 

I have changed my minefield.sqf:

 

old:

if(isServer) then {

private["_bomb","_area_max","_area_min","_position", "_area", "_num_mines","_allmines"];

_position  = _this select 0;

_area_min  = _this select 1;

_area_max  = _this select 2;

_num_mines = _this select 3;

_allmines  = [];

for "_x" from 1 to _num_mines do {

  private["_mine_pos","_mine"];

  _mine_pos = [_position,_area_min,_area_max,10,0,2000,0] call BIS_fnc_findSafePos;

  _mine = createVehicle ["Mine", _mine_pos, [], 0, "CAN_COLLIDE"];

  _mine spawn {

   private["_vehicle_near","_bomb"];

   waitUntil

   {

    _vehicle_near = false;

    {

     if((isPlayer _x) && (vehicle _x != _x) && (vehicle _x distance _this < 4)) then {

      _vehicle_near = true

     };

    } count playableUnits;

    (_vehicle_near)

   };

   _bomb = "Bo_GBU12_lgb" createVehicle (getPosATL _this);

   sleep 3;

   deleteVehicle _bomb;

   deleteVehicle _this;

  };

  _allmines set [(count _allmines), _mine];

};

_allmines;

};

 

new:

if(isServer) then {

private["_bomb","_area_max","_area_min","_position", "_area", "_num_mines","_allmines"];

_position  = _this select 0;

_area_min  = _this select 1;

_area_max  = _this select 2;

_num_mines = _this select 3;

_allmines  = [];

for "_x" from 1 to _num_mines do {

  private["_mine_pos","_mine"];

  _mine_pos = [_position,_area_min,_area_max,10,0,2000,0] call BIS_fnc_findSafePos;

  _mine = createVehicle ["Mine", _mine_pos, [], 0, "CAN_COLLIDE"];

  _mine spawn {

   private["_vehicle_near","_bomb"];

   waitUntil

   {

    sleep 0.5;

    _vehicle_near = false;

    {

     if((isPlayer _x) && (vehicle _x != _x) && (vehicle _x distance _this < 4)) then {

      _vehicle_near = true

     };

    } count playableUnits;

    (_vehicle_near)

   };

   _bomb = "Bo_GBU12_lgb" createVehicle (getPosATL _this);

   sleep 3;

   deleteVehicle _bomb;

   deleteVehicle _this;

  };

  _allmines set [(count _allmines), _mine];

};

_allmines;

};

 

Now my ASM look like this:

wu78ako5pchm.png

Share this post


Link to post
Share on other sites

I have been enjoying this AI Mod. WAI is so far my favorite as it is far more easily customized. Not to mention it seems to have no impact on other AI systems and works a treat with Overpoch weapons and arma. I even found new missions for this hear  I found even if you don't customize the system it works well enough :) however i had a lot of fun customizing it to be more militarized with armored vehicles and more powerful statics :) I used this system to be the "end game" AI missions. 

Share this post


Link to post
Share on other sites

Hi, i recently installed a overpochins server on taviana, and i noticed that almost everytime missions are spawning on mountains?

 

How can i change that? For missions not to spawn high on mountains?

 

Cheers! :)

Share this post


Link to post
Share on other sites

Hi, i recently installed a overpochins server on taviana, and i noticed that almost everytime missions are spawning on mountains?

 

How can i change that? For missions not to spawn high on mountains?

 

Cheers! :)

 

You need custom location coords.

 

This is what I use in my mission files:

 

Below     _mission         = count wai_mission_data -1;

 

Put this:

 

_coord1         = [856.919,9370.11,0.001];

_coord2         = [3468.97,9430.79,0.001];

_coord3         = [4721.69,1951.64,0.001];

_coord4         = [8586.69,7174.76,0.001];

_coord5         = [869.732,5158.03,0.001];

_position       = [_coord1, _coord2, _coord3, _coord4, _coord5] call BIS_fnc_selectRandom;

 

 

You need to remove or comment out this too: 

 

//_position        = [40] call find_position;

 

 

You'll need to get your own location coords and you can have as many as you like.

Share this post


Link to post
Share on other sites

Hi, i recently installed a overpochins server on taviana, and i noticed that almost everytime missions are spawning on mountains?

 

How can i change that? For missions not to spawn high on mountains?

 

Cheers! :)

 

I have make it another way then Hux.

 

I have changed my "compile/find_position.sqf"

 

Search:

markerready = false;

Add below:

if(wai_static_mission_locs) exitWith {
  _position = wai_mission_locations call BIS_fnc_selectRandom;
  _position set [2, 0];
  _position
};

And open "config.sqf"

Search for:

/* STATIC MISSIONS CONFIG */

Add before:

wai_static_mission_locs  = true;
wai_mission_locations  = [
  [856.919,9370.11,0.001],[3468.97,9430.79,0.001],[4721.69,1951.64,0.001],
  [8586.69,7174.76,0.001],[869.732,5158.03,0.001]
];

in the wai_mission_locations array you can add as many locations you want.

 

Greets

Rotzloch

Share this post


Link to post
Share on other sites

 

I have make it another way then Hux.

 

I have changed my "compile/find_position.sqf"

 

Search:

markerready = false;

Add below:

if(wai_static_mission_locs) exitWith {

  _position = wai_mission_locations call BIS_fnc_selectRandom;

  _position set [2, 0];

  _position

};

And open "config.sqf"

Search for:

/* STATIC MISSIONS CONFIG */

Add before:

wai_static_mission_locs  = true;

wai_mission_locations  = [

  [856.919,9370.11,0.001],[3468.97,9430.79,0.001],[4721.69,1951.64,0.001],

[8586.69,7174.76,0.001],[869.732,5158.03,0.001]

];

in the wai_mission_locations array you can add as many locations you want.

 

I've never seen that...thats a nice way to do it so it applies to all missions...

 

I just make positions for the missions that have buildings spawn in so the spawn on a flat open area.

 

 

Thanks for posting that.

Share this post


Link to post
Share on other sites

I have make it another way then Hux.

 

I have changed my "compile/find_position.sqf"

 

Search:

markerready = false;

Add below:

if(wai_static_mission_locs) exitWith {
  _position = wai_mission_locations call BIS_fnc_selectRandom;
  _position set [2, 0];
  _position
};

And open "config.sqf"

Search for:

/* STATIC MISSIONS CONFIG */

Add before:

wai_static_mission_locs  = true;
wai_mission_locations  = [
  [856.919,9370.11,0.001],[3468.97,9430.79,0.001],[4721.69,1951.64,0.001],
  [8586.69,7174.76,0.001],[869.732,5158.03,0.001]
];

in the wai_mission_locations array you can add as many locations you want.

 

Greets

Rotzloch

 

Thanks very much, i`ll look into it :D btw how can i search fo the coords of the place where i want the missions to spawn? :)

Share this post


Link to post
Share on other sites

I have had issues with this mission system relating to the find_suitable_ammo, missions would bug out and not spawn  until a restart.

 

I have  had problems with the hero and bandit behavior relating to "aggressors" even when i turned friendly ai behavior off and would stop spawning.

 

I  have trouble with server FPS running 3 missions at once, server FPS would be in the low 20's.

 

I have had issues where the launchers are not removed from the AI on death, probably related to low server FPS.

 

I have had issues where the static gunners are bugged and you can never kill them because they are invisible.

 

 

So after many hours of time trying to fix the issues I redid alot of the mission system, it is a mishmash of new and old WAI,, a mission from DZMS and a mission from ZEV missions I found in ARMA 3.

 

I decided to share it to see if it can help people who

 

A. Having to restart because of a bug

B. Having FPS issues

 

This is not for people who want friendly AI because it has been removed.

 

Included is a config for EPOCH and a config for Overpoch. Overpoch the AI are restricted to using guns that will allow them to use night vision, but most of the guns will be in the ammo boxes.

 

I also included missions with and without static guns, you can just copy and paste everything from "missions with M2" to "missions" folder.

 

I changed how you spawn ai, if you want ai with RPG's use call spawn_rpg, if you want AI with Stingers use call spawn_stinger. Launchers are removed on death always but can be changed easily.

 

I changed the spawn locations of the AI relative to the mission location to change their pathing a little so they don't all go the same route.

 

I included a basic readme to help.

 

If anyone wants to try this I would appreciate some feed back, I have been able to run 4 missions with server FPS in the low 30's after doing all this.

 

Link Updated on 9/17

http://www.mediafire.com/download/vrn246xfsqflsl6/Redone+WAI.zip

 

 

 

Edited by Phail

Share this post


Link to post
Share on other sites

 

Thanks very much, i`ll look into it :D btw how can i search fo the coords of the place where i want the missions to spawn?

 

If you have Infistar just go to the menu & choose "Copy worldspace(coords)to RPT & chat"

 

Simply copy and paste to your mission file.

 

 

If you don't have infistar, you can use your database to get worldspace.

 

Get your character UID & look in your character data to find your worldspace.

 

Make sure to refresh your database when you go to a new location to get new worldspace.

Share this post


Link to post
Share on other sites

I have had issues with this mission system relating to the find_suitable_ammo, missions would bug out and not spawn until a restart.

I have had problems with the hero and bandit behavior relating to "aggressors" even when i turned friendly ai behavior off and would stop spawning.

I have trouble with server FPS running 3 missions at once, server FPS would be in the low 20's.

I have had issues where the launchers are not removed from the AI on death, probably related to low server FPS.

I have had issues where the static gunners are bugged and you can never kill them because they are invisible.

So after many hours of time trying to fix the issues I redid alot of the mission system, it is a mishmash of new and old WAI,, a mission from DZMS and a mission from ZEV missions I found in ARMA 3.

I decided to share it to see if it can help people who

A. Having to restart because of a bug

B. Having FPS issues

This is not for people who want friendly AI because it has been removed.

Included is a config for EPOCH and a config for Overpoch. Overpoch the AI are restricted to using guns that will allow them to use night vision, but most of the guns will be in the ammo boxes.

I also included missions with and without static guns, you can just copy and paste everything from "missions with M2" to "missions" folder.

I changed how you spawn ai, if you want ai with RPG's use call spawn_rpg, if you want AI with Stingers use call spawn_stinger. Launchers are removed on death always but can be changed easily.

I changed the spawn locations of the AI relative to the mission location to change their pathing a little so they don't all go the same route.

I included a basic readme to help.

If anyone wants to try this I would appreciate some feed back, I have been able to run 4 missions with server FPS in the low 30's after doing all this.

http://www.mediafire.com/download/vg1tadta2uqj51r/Redone+WAI.zip

sounds great. :)

I also had to remove the new WAI system because of low fps with a medium-high population. So, will try your version when I get back from holiday.

Couple of quick questions; what is your player population when running your version of WAI and getting low 30's fps? Also, how many Ai are on the server when you get that reading?

Are you going to start a new thread?

Thanks

Share this post


Link to post
Share on other sites

Hello all been going thru the topic a bit but with so much pages and the forum wont let me search for some words seen some things about it but never a clear answer .

 

My lootboxes spawn up in the air when the mission finishes and players go in to take the loot .

 

Is there any solution yet to that ?

 

Best regards Creativv

Share this post


Link to post
Share on other sites

Hello all been going thru the topic a bit but with so much pages and the forum wont let me search for some words seen some things about it but never a clear answer .

 

My lootboxes spawn up in the air when the mission finishes and players go in to take the loot .

 

Is there any solution yet to that ?

 

Best regards Creativv

 

Have you installed Infistar?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...