Jump to content
higgibaby

[Outdated][Release] Epoch-OriginsMod-Server-Package (Epoch 1.0.7 & Origins Mod 1.8.3)

Recommended Posts

Epoch-OriginsMod-Server-Package (Version 1.0)

Updated: 08.07.2021

Have FUN!

>>>>>   Download: https://github.com/h1gg1baby/Epoch-OriginsMod-Server-Package
 

Epoch 1.0.7 & Origins Mod 1.8.3 (Taviana 3.0)

No Credit for me. Here, you see the list, you must send Credit to.

Special Credit to MigSDev5 for inspirations. GitHub repo

  • Tested with infiStar Admin Panel.

 

Used mods:

Custom Tradercities

I added custom traders! Taviana-Zoo, Antonovka, Ilya, Shtangrad, Aliencamp, Sevastopol ...

(WAI) Custom static events with rewards ;-)

  1. Bandit Camp
  2. SectorB

 

Known problem:

Origins-Status-Menu must be hidden.

Users, who join the server, gets a "blood.paa-error". The error must be confirmed. Then the user can toggle with the key "F3" the Origins-Status-Menu for hiding. This setting will be saved in the client "ArmA 2 Profile".

 

Install:

  1. Copy the DayZ_Epoch_13.Taviana folder (or *.pbo / use "PBO tool" for packing) to your Arma2 OA\MPMissions folder

    1.1 Enabling or disableing your own settings: dayz_code\configVariables.sqf

  2. Copy the dayz_server.pbo folder to your Arma 2 [email protected]_epoch_server\addons folder

  3. The file "HiveExt.dll" is custom! For using "Virtual Garage", you must change it. So, replace the offical HiveExt.dll! You can find it in my package. Attention: Look in the area "mySQL database setup fresh install" at https://github.com/oiad/virtualGarage for more Install instructions.

  4. Import the SQL\virtualGarage.sql into your database

  5. Replace the Battleye-filters on your server with the package files.

  6. Copy the Bikey-Key "OriginsMod.info_by_Hades_1.8.3.bikey" into your server key folder.

  7. Mod serversettings for start order: ca, @originsmod, @dayz_epoch, @dayz_epoch_server

 

infiStar

If you use infiStar then deactivate the following setting in your dayz_code\configVariables.sqf

Set it from "1" to "0"

like this:

dayz_antihack = 0;

 

You use ESSV3 & InfiStar?

You have a Problem at spawning with HALO? Clients spawn left down the map into water?

Then use the following fix. Credits to Cherdenko for fixing that bug! klick me!

Look at your AH.sqf in your dayz_server.pbo (infiSTAR folder). Open that file and seach for:

					_driver = driver _curVeh;
						_aidriver = false;
						if(!isNull _driver)then
						{
							if(!isPlayer _driver)then
							{
								_aidriver = true;
								
								player setVectorUp [0,0,1];
								player setVelocity [0,0,0];
								player setPosATL _lastPos;
							};
						};
						if(_aidriver)exitWith{hint 'Bad boys, bad boys whatcha gonna do? Whatcha gonna do when they come for you?';systemchat 'AI Drivers not allowed!';}; 

 

Delete it!

 

Extra/optional:

You don`t want to use any launcher? Then use "Start - Oripoch.bat". Set your own Arma2-path and set your IP with server-port. Dubbleklick to start.

Serverstart with "Steamlink":

steam://run/33930//-connect=99.999.999.99%20-port=2302%20-mod=EXPANSION;@OriginsMod;@DayZ_Epoch;%20-nosplash%20-world=empty%20-nopause

 

with password usage:

steam://run/33930//-connect=99.999.999.99%20-port=2302%20-PASSWORD=password%20-mod=EXPANSION;@OriginsMod;@DayZ_Epoch;%20-nosplash%20-world=empty%20-nopause

 

Contact

seppo{at}posteo.de | No support for used mods! Send your Server-IP. I will visit you! ;-)

Share this post


Link to post
Share on other sites
On 7/16/2021 at 4:08 AM, CyberWarden said:

Tried to run this but it seems the the bikey is no good.

There is no problem. You have the following options in server.cfg.  2 = Original Key Verified, 1 = Self-created Key, 0 = No Key Verification

Use the following variant: verifySignatures = 1

Share this post


Link to post
Share on other sites

I sure could use a hand with this,  just can't seem to connect to the database no matter what I do.

Database names, passwords are all exactly as per the HiveEXT.ini (the only bit that might be wrong is the bits relating to the Virtual Garage)

I get stuck at the "waiting for server to start authentication" screen until it times out.

Any thoughts?

EDIT:

Never mind, found my error - I'd forgotten to copy over all the .dll files to the server directory.

 

Edited by Eric the Viking
update

Share this post


Link to post
Share on other sites

Hi all. Before I begin, I must state. I am still very much learning how to do server things for Arma 2 Dayz. I'm managed ok so far.

But a friend I help with his server asked me to try installing this package on his server. I followed the guide provided and the server starts and runs, well sort of.

It loads into Chernarus and not Taviana. 

I get this error when loading in no *entry 'bin\config.bin/CfgWorlds.Tavi'.*

Could anyone at all please point me in the direction of how to fix this please. 

Many Thanks. 

Share this post


Link to post
Share on other sites
41 minutes ago, higgibaby said:

Hi!

Look for the right mod starting parameters (note the correct spelling from your files):

@originsmod;@dayz_epoch;@dayz_epoch_server

Also check the mission.sqm. Use it form the package.

 

 

Hi.

Thanks for the reply. The starting parameters are as you have typed them. @originsmod;@dayz_epoch;@dayz_epoch_server

I used the mission.sqm from the package download. 

It all works in a sense. All the icons are on the map. It's just the map that loads is Chernarus and not Taviana. Still getting the same error as above. *no entry 'bin\config.bin/CfgWorlds.Tavi'.*

I uploaded the origins mod file from my pc which I have taken from the DayzLauncher. Using the Origins mod 1.8.3. 

That is correct isn't it?

 

Share this post


Link to post
Share on other sites

Test the following option. Stop the server.

Copy the files (server side) dayz_code.pbo and dayz_anim.pbo (with .bisign) from @DayZ_Epoch to your @Origins-Folder. Rename the files in your @Origins-Folder (for backup) like dayz_code.pbo_old (.bisign too). 

 

 

Share this post


Link to post
Share on other sites

Hi again. Sorry I took so long to reply.

I figured it out. It was partly my fault. I was using the drop down menu's on the control panel. The server thought it was using Instance 13.Tavi.

So I manually edited it to use instance 13.Taviana and it is now working. 

Noob error so I apologise. Lesson learned I guess lol

But again. Thanks for taking the time to reply to me. :)

Share this post


Link to post
Share on other sites
On 4/16/2022 at 5:28 PM, devils_toy said:

is it possible to disable the helipatrol, if so where? have tried it in dzai but unfortunately did not work

Dzai -->  init -->  dzai_config -->  DZAI_maxHeliPatrols = 0;

:wink:

Share this post


Link to post
Share on other sites
On 11/16/2021 at 12:56 AM, l1nkrx7 said:

okay i did start on that code a while back i will get it to work

any update on this? i would love to add the hero and bandit bases plus the big wood fort.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...