Jump to content
salival

salivals mod pack (All my mods tested & working)

Recommended Posts

Hi guys,

I've had requests for a pack of all my mods that i've written or updated tested and working so here it is.

Everything is tested as working but there may be little things I have missed, I've done all the installs the way I like to do them (super anal ocd)

Infistar is implemented, please see: https://github.com/oiad/modPack#infistar-install

THERE ARE CURRENTLY NO BATTLEYE FILTERS FOR 1.0.6.2 FOR ANY OF MY MODS. Feel free to submit!

# Supported mods:

  • Bury Bodies
  • Community Localizations
  • Click Actions
  • Deploy Anything
  • Garage Door Opener
  • Locate Vehicle
  • Safe Zone Relocate
  • Service Points
  • Take Clothes
  • Virtual Garage
  • Vehicle Key Changer
  • ZSC

Please visit: https://github.com/oiad/modPack for more information.

Share this post


Link to post
Share on other sites

Hi i have tested the script pack, but now i become an error message ingame and the login crashed.

 

Warning Message: Script z\addons\dayz_code\system\mission\chernarus\hideGlitchObjects.sqf not found

 

I looked in my server dayz_code and there is no file called  hideGlitchObjects

Share this post


Link to post
Share on other sites
10 minutes ago, Kimarik said:

Hi i have tested the script pack, but now i become an error message ingame and the login crashed.

 

Warning Message: Script z\addons\dayz_code\system\mission\chernarus\hideGlitchObjects.sqf not found

 

I looked in my server dayz_code and there is no file called  hideGlitchObjects

Hi,

This means you are still running 1.0.6.1 as the file is definitely there in 1.0.6.2

https://github.com/EpochModTeam/DayZ-Epoch/blob/master/SQF/dayz_code/system/mission/chernarus/hideGlitchObjects.sqf

Share this post


Link to post
Share on other sites

Hi Guys,

I merged ZSC and global banking in as toggleable options now, this works quite well and i've tested it

You can disable ZSC/coins/global banking and run briefcases if you want, I just don't have any of the Overwatch .hpp files (someone want to donate some for briefcases?)

Please see this commit for more information: https://github.com/oiad/modPack/commit/b8edb7d35a27d1e93e4caf6d13f5a7c91ef41da6

Share this post


Link to post
Share on other sites

Having a nightmare with this. The problem Im sure lies with the fact Im trying to add it to a GTX hosted server for someone Im helping out, and Im sure GTX screw the file system up so nothing works properly.

I started with a completly fresh install of 1062 through thier CP (probably where the issue starts  going on my past experience).

I deleted thier dayz_server.pbo and thier mission folder and replaced both with yours.

I added the EXTDB folder and ameded the database details. (I cant upload the.dll file yet as they dont allow it,you have to email it to them to upload but Im sure this wouldnt cause these issues, as Ive had that problem before and all that happened is VG wouldnt work).

I added the VG table to the database.

I changed nothing else.

Server wont work and getting a butt ton of rpt errors regarding zsc, server monitor, server_spawnCarePackages.sqf

https://pastebin.com/S0pCqCmQ

Pulling my hair out, as this shouldnt be hard. I dont know why hosts make life so bloody difficult.

Share this post


Link to post
Share on other sites

Im trying to adds salivals mod pack, nothing to do with ess or bots. The server wont work with a base install and just his mod pack. In fact now the stupid think wont even work with a complete wipe back to default gtx files. They are a joke, Ive had this issue so many times with them. They cant even get a base install right. Everytime Ive tried to mod a gtx server, Ive had to wipe it all and upload all the base files directly from the epoch mod github. Thier files are always messed up or a mix of old files and new files.

Share this post


Link to post
Share on other sites

Good luck uploading that size files with ftp...

If it doesnt work just do a reinstall through their panel and give it some time before u start adding.

Check if it works with the base install first as u said cause u are right sometimes installs may go wrong.

Good luck

Share this post


Link to post
Share on other sites

Hello! I am having problems with the remote vehicle option. For the players, the menu goes up for a second and they can not use it.

Furthermore, players can not search for coins in their corpses. They do not get an option an mouswheel. Everything works fine for the admins.

Share this post


Link to post
Share on other sites
3 minutes ago, Kimarik said:

Hello! I am having problems with the remote vehicle option. For the players, the menu goes up for a second and they can not use it.

Furthermore, players can not search for coins in their corpses. They do not get an option an mouswheel. Everything works fine for the admins.

Infistar for the first one, its blocking the dialogs. Second one would have to see rpt

Share this post


Link to post
Share on other sites

@salival  You have an error in the mission_check.sqf.

Line 10 you have an erroneous ];  Thats causing my issue, it screws the whole server up! Will teach me for not reading the whole rpt. Been trying to figure this out for 4 hours lol.

 

Spoiler
//Temporary check for A2OA mission override exploit.
//This bug should be fixed in the next EOL patch.
//Put this code at the bottom of dayz_server\init\server_functions.sqf

//List of files in your mission to check. For example, you may want to add 'custom\variables.sqf' etc.
//Remove any you aren't using
_files = [
	'dayz_code\compile\fn_selfActions.sqf','dayz_code\compile\remote_message.sqf','dayz_code\compile\ui_selectSlot.sqf','dayz_code\init\compiles.sqf','dayz_code\init\variables.sqf','description.ext','init.sqf','mission.sqm','rules.sqf','scripts\buryActions.sqf','scripts\clickActions\config.sqf','scripts\clickActions\init.sqf','scripts\deployAnything\config.sqf','scripts\deployAnything\deploy.sqf','scripts\deployAnything\functions.sqf','scripts\deployAnything\init.sqf','scripts\deployAnything\pack.sqf','scripts\deployAnything\player_deploy.sqf','scripts\deployAnything\wrapper.sqf','scripts\garageDoorOpener.sqf','scripts\locateVehicle.sqf','scripts\remoteVehicle\remoteVehicle.sqf','scripts\remoteVehicle\vehicleInfo.sqf','scripts\servicePoints\init.sqf','scripts\servicePoints\servicePointActions.sqf','scripts\takeClothes.sqf','scripts\traders\server_traders.sqf','scripts\virtualGarage\player_getVehicle.sqf','scripts\virtualGarage\player_removePad.sqf','scripts\virtualGarage\player_storeVehicle.sqf','scripts\virtualGarage\vehicleInfo.sqf','scripts\virtualGarage\virtualGarage.sqf','scripts\vkc\vehicleInfo.sqf','scripts\vkc\vehicleKeyChanger.sqf','scripts\zsc\atmDialog.sqf','scripts\zsc\bankDialog.sqf','scripts\zsc\checkWallet.sqf','scripts\zsc\givePlayer.sqf','scripts\zsc\playerHud.sqf','scripts\zsc\zscInit.sqf'
];
];

_list = [];
{
	_file = toArray (toLower(preprocessFile _x));
	_sum = 0;
	_count = {_sum = _sum + _x; true} count _file;
	if (_count > 999999) then {_count = _count mod 999999}; //Prevent scientific notation when converting to string below
	if (_sum > 999999) then {_sum = _sum mod 999999};
	_list set [count _list,[_count,_sum]];
} forEach _files;

//Check mission integrity on all clients
_temp = "HeliHEmpty" createVehicle [0,0,0];
_temp setVehicleInit (str formatText["
	if (isServer) exitWith {};
	
	_list = [];
	{
		_file = toArray (toLower(preprocessFile _x));
		_sum = 0;
		_count = {_sum = _sum + _x; true} count _file;
		if (_count > 999999) then {_count = _count mod 999999};
		if (_sum > 999999) then {_sum = _sum mod 999999};
		_list set [count _list,[_count,_sum]];
	} forEach %1;
	
	_file = -1;
	{
		if ((_x select 0 != (_list select _forEachIndex) select 0) or (_x select 1 != (_list select _forEachIndex) select 1)) then {
			_file = _forEachIndex;
		};
	} forEach %2;

	if (_file != -1) then {
		MISSION_CHECK = if ((_list select _file) select 0 < 49999) then {preprocessFileLineNumbers (%1 select _file)} else {'TOO BIG'};
		publicVariableServer 'MISSION_CHECK';
		[] spawn {
			uiSleep 1;
			{(findDisplay _x) closeDisplay 2;} count [0,8,12,18,46,70];
		};
	};
",_files,_list]);

processInitCommands;

 

Share this post


Link to post
Share on other sites

This probably will need more work on the install documentation, it's quite easy to forget things like infistar exemptions etc.

Unfortunately my holiday is over and i'm back to work today so my time will be a lot less from now on

Share this post


Link to post
Share on other sites
On 1/7/2018 at 12:46 PM, lwbuk said:

Having a nightmare with this. The problem Im sure lies with the fact Im trying to add it to a GTX hosted server for someone Im helping out, and Im sure GTX screw the file system up so nothing works properly.

I started with a completly fresh install of 1062 through thier CP (probably where the issue starts  going on my past experience).

I deleted thier dayz_server.pbo and thier mission folder and replaced both with yours.

I added the EXTDB folder and ameded the database details. (I cant upload the.dll file yet as they dont allow it,you have to email it to them to upload but Im sure this wouldnt cause these issues, as Ive had that problem before and all that happened is VG wouldnt work).

I added the VG table to the database.

I changed nothing else.

Server wont work and getting a butt ton of rpt errors regarding zsc, server monitor, server_spawnCarePackages.sqf

https://pastebin.com/S0pCqCmQ

Pulling my hair out, as this shouldnt be hard. I dont know why hosts make life so bloody difficult.

you don't need to give them the dll files to upload have to do it via there file manager ;p

Share this post


Link to post
Share on other sites
4 hours ago, mrjingles14 said:

you don't need to give them the dll files to upload have to do it via there file manager ;p

Not on mine you cant. Says access is denied.  Last time I installed VG for someone on GTX, I had to send it to them to scan it first.

Share this post


Link to post
Share on other sites
53 minutes ago, mrjingles14 said:

@lwbuki told them i needed access to the dll files they granted me it no problem, maybe they are selective 

I havent asked, so probably is the case if you have a long standing account. I believe I have access to do it on the live server Im Helping someone with now as I moaned to them about having to email them all the time, but I bought 10slot for myself to test stuff on and it doesn’t work there. 

If I ran my own server it certainly wouldn’t be hosted on gtx so I can’t  be arsed keep emailing them. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Advertisement
  • Donation Box

    Please donate to support the community.
    We appreciate all donations!
  • Advertisement
  • Supporters
  • Latest Donations

  • Advertisement
  • Discord

×