Jump to content
  • 0
Sign in to follow this  
kingpapawawa

FPS issue #1926 - If you missed this fix read up

Question

Getting about average 10 more FPS on 3 servers.

I believe @BigEgg gets the credit for figuring out this one. @ndavalos wrote the code below to temp fix it and @icomrade patched it for the next update.... but unless you follow the github issues, (and you should)  you may have missed this one as its buried in a post i made several weeks ago.

this code goes at the bottom of your init.

see this for more info https://github.com/EpochModTeam/DayZ-Epoch/issues/1926

edit:  this code will need to be removed when 1.0.6.2 comes out.

Posting this because ive spoken with 2 other server owners who hadn't seen this info.

if (hasInterface) then {
dayz_rollingMessages = {
	private "_showText";
	disableSerialization;
	_showText = {
		private "_textLine";
		15 cutRsc ["RSC_DZ_Messages","plain"];
		_textLine = (uiNamespace getVariable "DZ_Messages") displayCtrl 4099998;
		_textLine ctrlSetStructuredText (parseText _this);
		_textLine ctrlCommit 0;
	};
	if (typeName _this == "ARRAY") exitWith {(_this select 0) call _showText}; //Special or multi-line message
	if ((diag_ticktime - Message_1_time) < 5) then {
		if ((time - Message_2_time) < 5) then {
			Message_3 = Message_2;
			Message_3_time = Message_2_time;
		} else {
			Message_3 = "";
		};
		
		Message_2 = Message_1;
		Message_2_time = Message_1_time;
	} else {
		Message_2 = "";
		Message_3 = "";
	};

	Message_1 = _this;
	Message_1_time = diag_ticktime;
	(format ["%1<br></br>%2<br></br>%3", Message_1, Message_2, Message_3]) call _showText;
};
};

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
3 hours ago, kingpapawawa said:

Getting about average 10 more FPS on 3 servers.

I believe @BigEgg gets the credit for figuring out this one. @ndavalos wrote the code below to temp fix it and @icomrade patched it for the next update.... but unless you follow the github issues, (and you should)  you may have missed this one as its buried in a post i made several weeks ago.

this code goes at the bottom of your init.

see this for more info https://github.com/EpochModTeam/DayZ-Epoch/issues/1926

edit:  this code will need to be removed when 1.0.6.2 comes out.

Posting this because ive spoken with 2 other server owners who hadn't seen this info.

if (hasInterface) then {
dayz_rollingMessages = {
	private "_showText";
	disableSerialization;
	_showText = {
		private "_textLine";
		15 cutRsc ["RSC_DZ_Messages","plain"];
		_textLine = (uiNamespace getVariable "DZ_Messages") displayCtrl 4099998;
		_textLine ctrlSetStructuredText (parseText _this);
		_textLine ctrlCommit 0;
	};
	if (typeName _this == "ARRAY") exitWith {(_this select 0) call _showText}; //Special or multi-line message
	if ((diag_ticktime - Message_1_time) < 5) then {
		if ((time - Message_2_time) < 5) then {
			Message_3 = Message_2;
			Message_3_time = Message_2_time;
		} else {
			Message_3 = "";
		};
		
		Message_2 = Message_1;
		Message_2_time = Message_1_time;
	} else {
		Message_2 = "";
		Message_3 = "";
	};

	Message_1 = _this;
	Message_1_time = diag_ticktime;
	(format ["%1<br></br>%2<br></br>%3", Message_1, Message_2, Message_3]) call _showText;
};
};

Also throw some credit to @MG-Maximus - he was the one that lead me to test the issue ;)

Share this post


Link to post
Share on other sites
  • 0

@salival   I always had the same scripts on my servers before and my FPS was much better than now. Except for DZAI that I have an little error there is nothing in my RTP. I am going to take a test server to see what the hell is going on. Actual scripts on the server are;

Air Raid
Group management 
IT module
trader safe zone
harvest hemp
Ikea/treasure hunt
Loadout
binocular vector
dance
single currency
spawn selection
logistic
deployable
backpack anti thef
no weight
slow zeds
1 step building     
para spawn
plot 4 life
snap building vector
scan eyes
Advance trading
DZAI
WAI
DZMS
ear plugs 
self bloodbag
study body

In server side bunch building added, Roads and village I made.

I think thats it. Some are there by default. I had more scripts before and FPS was always nice.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By blueTesla
      Hello Survivors,
       
      I play on a server which has arround 60~80 FPS for me. Ping is 130ms. Hardware is i7-6700k, GTX 1080, 16GB RAM and I tested the game on a HDD and SSD. Both the same failure.
      Expansions/Mods: Arma 2, Arma 2 Operation Arrowhead, Arma 2 PMC, Arma 2 BAF, Epoch 1.0.6.2, Overwatch 0.2.5
      Deinstalled and downloaded again 3 times. Still the same bug. Nvidia Driver is uptodate!
       
      I just have my regular survival, when suddenly this appears:




       
      I need some help I have no idea how I can solve the problem!
      Goodspeed,
       
      ~blue~
    • By EditedSnowHD
      Hey,
       
      Im looking for a way to automaticly restart my Dayz Epoch server after a few hours.
      I already looked at some tutorials/scripts and stuff.
      But there all talking about this scheduler.xml file, but i dont have that.
      Do i need to create it myself? or can some one link me to an updated BEC restarts tutorial?
       
      Thank you for your time
      Greets
      -EditedSnowHD
    • By Thoron
      I have some issues with my server fps.

      I hope you guys can help me, already tried to change:
      basic.cfg
      start-parameters
      I have some cleanups running on my db, so I hope thats not the problem.
      here are some infos:
      Server:
      Windows 2012 R2 i7-6700 @ 3.8Ghz 32 GB Ram SSD Connection speedtest.net (tested on diffent servers):
      700-900 Mbps up and down

       
      start parameters:
       
      -config=xxx\config.cfg -ip=xx.xx.xx.xx -port=" + $port + " -profiles=xxx -cfg=xxx\basic.cfg -name=xxx -loadMissionToMemory -maxMem=2047 -exThreads=1 -world=Tavi -noCB -autoinit [email protected];@DayzOverwatch;@DayzOrigins1795;@DayZ_Epoch1061;@DayZ_Epoch_Server"  
      current basic.cfg:
       
      current basic.cfg: language="English"; adapter=-1; Windowed=0; 3D_Performance=1; Resolution_W=800; Resolution_H=600; Resolution_Bpp=32; MinBandwidth=1097152; MaxMsgSend=128; MaxBandwidth=524288000; MaxSizeGuaranteed=256; MaxSizeNonguaranteed=64; MinErrorToSend=0.0049999999; MinErrorToSendNear=0.025; MaxCustomFileSize=0; class sockets { maxPacketSize=1430; };  
       
      i've modified my s_fps.sqf to see number of objects in diag_log like this:
      while {true} do { diag_log format["SERVER FPS: %1 PLAYERS: %2 OBJECTS: %3",round diag_fps,playersNumber west,count allMissionObjects "All"]; uiSleep 60; };
      WITHOUT WAI Missions:
      Line 496: 0:01:15 "SERVER FPS: 29 PLAYERS: 1 OBJECTS: 1723" Line 730: 0:02:18 "SERVER FPS: 45 PLAYERS: 2 OBJECTS: 5919" Line 748: 0:03:18 "SERVER FPS: 47 PLAYERS: 5 OBJECTS: 5929" Line 782: 0:04:18 "SERVER FPS: 48 PLAYERS: 7 OBJECTS: 5937" Line 814: 0:05:18 "SERVER FPS: 48 PLAYERS: 8 OBJECTS: 6117" Line 848: 0:06:18 "SERVER FPS: 47 PLAYERS: 9 OBJECTS: 6144" Line 870: 0:07:18 "SERVER FPS: 46 PLAYERS: 11 OBJECTS: 6218" Line 903: 0:08:18 "SERVER FPS: 39 PLAYERS: 13 OBJECTS: 6334" Line 953: 0:09:18 "SERVER FPS: 45 PLAYERS: 12 OBJECTS: 6426" Line 976: 0:10:18 "SERVER FPS: 40 PLAYERS: 12 OBJECTS: 6478" Line 1005: 0:11:18 "SERVER FPS: 35 PLAYERS: 12 OBJECTS: 6517" Line 1031: 0:12:18 "SERVER FPS: 38 PLAYERS: 12 OBJECTS: 6508" Line 1048: 0:13:18 "SERVER FPS: 38 PLAYERS: 13 OBJECTS: 6537" Line 1062: 0:14:18 "SERVER FPS: 39 PLAYERS: 13 OBJECTS: 6540" Line 1080: 0:15:18 "SERVER FPS: 35 PLAYERS: 15 OBJECTS: 6543" Line 1106: 0:16:18 "SERVER FPS: 33 PLAYERS: 15 OBJECTS: 6612" Line 1126: 0:17:19 "SERVER FPS: 30 PLAYERS: 15 OBJECTS: 6645" Line 1230: 0:18:19 "SERVER FPS: 30 PLAYERS: 15 OBJECTS: 6671" Line 1259: 0:19:19 "SERVER FPS: 30 PLAYERS: 15 OBJECTS: 6722" Line 1278: 0:20:19 "SERVER FPS: 28 PLAYERS: 15 OBJECTS: 6824" Line 1372: 0:21:19 "SERVER FPS: 26 PLAYERS: 15 OBJECTS: 6991" Line 1434: 0:22:19 "SERVER FPS: 25 PLAYERS: 16 OBJECTS: 7124" Line 1452: 0:23:19 "SERVER FPS: 25 PLAYERS: 16 OBJECTS: 7185" Line 1509: 0:24:19 "SERVER FPS: 23 PLAYERS: 16 OBJECTS: 7250" Line 1536: 0:25:19 "SERVER FPS: 23 PLAYERS: 16 OBJECTS: 7350" Line 1546: 0:26:19 "SERVER FPS: 22 PLAYERS: 16 OBJECTS: 7363" Line 1586: 0:27:19 "SERVER FPS: 22 PLAYERS: 16 OBJECTS: 7425" Line 1612: 0:28:20 "SERVER FPS: 22 PLAYERS: 16 OBJECTS: 7434" Line 1631: 0:29:20 "SERVER FPS: 23 PLAYERS: 16 OBJECTS: 7434" Line 1660: 0:29:49 "infiSTAR.de PVAH_WriteLog: B 1-1-B:1 (Thoron) REMOTE Thoron - Fixing FPS" Line 1671: 0:30:20 "SERVER FPS: 28 PLAYERS: 16 OBJECTS: 6226" Line 1705: 0:31:20 "SERVER FPS: 28 PLAYERS: 16 OBJECTS: 6211" Line 1727: 0:32:20 "SERVER FPS: 31 PLAYERS: 16 OBJECTS: 6222" Line 1762: 0:33:20 "SERVER FPS: 34 PLAYERS: 15 OBJECTS: 6281" Line 1783: 0:34:20 "SERVER FPS: 33 PLAYERS: 14 OBJECTS: 6309" Line 1810: 0:35:20 "SERVER FPS: 47 PLAYERS: 9 OBJECTS: 6329" Line 1828: 0:36:20 "SERVER FPS: 47 PLAYERS: 7 OBJECTS: 6342" Line 1836: 0:37:20 "SERVER FPS: 47 PLAYERS: 7 OBJECTS: 6345" Line 1848: 0:38:20 "SERVER FPS: 48 PLAYERS: 7 OBJECTS: 6360" Line 1874: 0:39:20 "SERVER FPS: 46 PLAYERS: 1 OBJECTS: 6323" Line 1875: 0:40:20 "SERVER FPS: 46 PLAYERS: 2 OBJECTS: 6323" WITH WAI:
      Line 624: 0:42:12 "SERVER FPS: 44 PLAYERS: 3 OBJECTS: 3552" Line 1227: 0:43:14 "SERVER FPS: 48 PLAYERS: 8 OBJECTS: 6099" Line 1261: 0:44:14 "SERVER FPS: 47 PLAYERS: 10 OBJECTS: 6129" Line 1292: 0:45:14 "SERVER FPS: 43 PLAYERS: 13 OBJECTS: 6246" Line 1324: 0:46:14 "SERVER FPS: 42 PLAYERS: 14 OBJECTS: 6372" Line 1378: 0:47:14 "SERVER FPS: 32 PLAYERS: 14 OBJECTS: 6422" Line 1448: 0:48:14 "SERVER FPS: 30 PLAYERS: 14 OBJECTS: 6438" Line 1468: 0:49:14 "SERVER FPS: 30 PLAYERS: 15 OBJECTS: 6562" Line 1504: 0:50:15 "SERVER FPS: 28 PLAYERS: 15 OBJECTS: 6682" Line 1524: 0:51:15 "SERVER FPS: 29 PLAYERS: 15 OBJECTS: 6681" Line 1558: 0:52:15 "SERVER FPS: 28 PLAYERS: 15 OBJECTS: 6757" Line 1587: 0:53:15 "SERVER FPS: 28 PLAYERS: 14 OBJECTS: 6781" Line 1668: 0:54:15 "SERVER FPS: 24 PLAYERS: 14 OBJECTS: 6943" Line 1704: 0:55:15 "SERVER FPS: 23 PLAYERS: 14 OBJECTS: 6978" Line 1728: 0:56:15 "SERVER FPS: 24 PLAYERS: 14 OBJECTS: 6976" Line 1744: 0:57:15 "SERVER FPS: 23 PLAYERS: 15 OBJECTS: 6967" Line 1763: 0:58:15 "SERVER FPS: 23 PLAYERS: 15 OBJECTS: 6961" Line 1788: 0:59:15 "SERVER FPS: 21 PLAYERS: 15 OBJECTS: 7044" Line 1836: 1:00:16 "SERVER FPS: 20 PLAYERS: 15 OBJECTS: 7062" Line 1876: 1:01:16 "SERVER FPS: 21 PLAYERS: 15 OBJECTS: 7078" Line 1894: 1:02:16 "SERVER FPS: 20 PLAYERS: 15 OBJECTS: 7084" Line 1927: 1:03:16 "SERVER FPS: 21 PLAYERS: 15 OBJECTS: 7091" Line 1955: 1:04:16 "SERVER FPS: 21 PLAYERS: 15 OBJECTS: 7091" Line 1961: 1:04:35 "infiSTAR.de PVAH_WriteLog: B 1-1-C:1 (Thoron) REMOTE Thoron - Fixing FPS" Line 1977: 1:05:17 "SERVER FPS: 23 PLAYERS: 15 OBJECTS: 6393" Line 2004: 1:06:17 "SERVER FPS: 22 PLAYERS: 15 OBJECTS: 6388"  
    • By harcosgoogle
      Hi.
      How can server-side fps be increased?
       
      Database clean?
      Script?Mod?
      Clean?
       
      (Not game settings)
       
      Thanks
    • By Jl0BuT0n0p
      Hey. Update 1.0.6 is very low FPS. graphics settings do not help. FPS blocked about 15-25. + not included steam overlay
       
      windows 7 home base sp1
      amd FX(tm)-8120 Eight-core processor 3.10 GHz   (8cores)
      8gb
      nvidia GTX 1050 palit
       
      old version 1.0.5.1 60+ fps (40+ city)
      plz, help!
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...