Jump to content
  • 0
Sign in to follow this  
Skyler95

Custom buildings vanish/underwater

Question

Ok so I have a few map additions one is being ran through the server pbo and the other through the mission pbo. I noticed on 99% of restarts a bridge going across skalisty isn't spawning until I relog which isn't to big of a deal but everything else in that script spawns correctly the first time. I also have excelsiors bridge which is the one being ran in the mission file and I notice it just recently started spawning in under the water, I tried relogging but it still remains under the water.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Any map additions should ALWAYS be run serverside and called from the bottom of the server_monitor.sqf, just above allowConnection = true; . I have all this running and everything loads perfectly everytime : 

    [] ExecVM "\z\addons\dayz_server\WAI\init.sqf";
    [] ExecVM "\z\addons\dayz_server\DZMS\DZMSInit.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\coptrader.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\pook_trader.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\awols.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\origins_air.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\origins_land.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\origins_boat.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\trader_road.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\server_heli_patrol.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\cave_trader.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\random_info.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\signs.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\aunty_jack.sqf";    
    [] ExecVM "\z\addons\dayz_server\buildings\speed_plants.sqf";    

Share this post


Link to post
Share on other sites
  • 0
44 minutes ago, Buck0 said:

Map additions should not always be run server side

 

Only thing you would ever run server side is high end loot spawns

good luck with having serverside AI which do not recognize clientside buildings. and having players complaining about dead bodies falling trough clientside buildings.

the only mapadds I dont run serverside are the safezone traderareas.

Share this post


Link to post
Share on other sites
  • 0
On 15/04/2016 at 8:30 AM, ElDubya said:

Any map additions should ALWAYS be run serverside and called from the bottom of the server_monitor.sqf, just above allowConnection = true; . I have all this running and everything loads perfectly everytime : 

    [] ExecVM "\z\addons\dayz_server\WAI\init.sqf";
    [] ExecVM "\z\addons\dayz_server\DZMS\DZMSInit.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\coptrader.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\pook_trader.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\awols.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\origins_air.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\origins_land.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\origins_boat.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\trader_road.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\server_heli_patrol.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\cave_trader.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\random_info.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\signs.sqf";
    [] ExecVM "\z\addons\dayz_server\buildings\aunty_jack.sqf";    
    [] ExecVM "\z\addons\dayz_server\buildings\speed_plants.sqf";    

 

i've always had them at the bottom of server_functions and never had problems

Share this post


Link to post
Share on other sites
  • 0
20 hours ago, ElDubya said:

Ummmm ...... whaaaaat?

Not sure why you guys think map additions are required to run server side. 

Its much more efficient to run non essential buildings client side.

Share this post


Link to post
Share on other sites
  • 0

Very True what Buck0 says , i even run traderzones from clients in compact sqf file size , but traders themselves from server side .

Nowadays people have better pc's so if you can offload it please do .

Since most filesizes for custom buildings sometimes are huge you might want to look into ebaydayz's compact sqf .

Share this post


Link to post
Share on other sites
  • 0

I can honestly say i run 99% map additions client side, with the only exception being barracks and mil spawns.

 

I have never had a complaint of ai shooting through walls ect, maybe your not defining them eairly enough

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By Thug
      UPDATED 2/20/2018
      Click here for files from Github
      Hello all
      I have been asked to post this so here goes. The island is surrounded by 20m high walls. Only 4 ways in, well you could try and land a heli,  There is two weapon creates and a lottery box behind the palace.
      M2s waiting to greet you.
      If you would like the files, please PM me and I will send them to you.  Don't forget to leave email in PM. I am looking to find a new way to post links since DropBox changed the way they share.
      You have to update the items in the crates to the new class names in Epoch 1.0.6.2  DONE
    • By naz
      I've got a script set up on my server that add's a few custom buildings.  They all work very nicely, except for the fact that I can't see the bridge that goes to Skalisty Island.  Other players can, everyone else who I have asked is able to see it and cross it, but all I see is a dock :-(
       
      This is what everyone else sees

       
      and that player over there is me, standing on the edge of the dock that I can see.  If I go any further, I fall into the water.  If I'm in a vehicle while another player drives across, They fall to the surface of the water and drive across it as if it were a road.  I'm at a loss regarding what to do to fix this issue.  Do you have any suggestions?
       
    • By Radec59437
      This is a small base/military outpost I've built on Skalisty Island, with the purpose of being used in conjunction with DZAI's custom spawns.
       
      The Mi17 doesn't spawn in as default (it would be wiped by the "kill a hacker" function), so spawn in your own via the database, or if you use InfiSTAR's AH you can spawn and save it manually.
      Most people will raid the base for basic tent loot and the bandits' weapons anyway, but the Mi17 is what really motivates people to go in usually.
       
      Also, Skalisty is only reachable by boat unless you use a custom bridge, I use the Excelsior Bridge (couldn't find the original thread to the author :|)
       
      Pics:






       
      Download:
       
      skalisty.sqf
       
      Installation is as usual:
      Make a custom folder in your missionfile's main folder named "map" (or use your own if you have one). Put "skalisty.sqf" into this folder. Then add the following line at the bottom of your "init.sqf" file: [] execVM "map\skalisty.sqf";
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...