Jump to content
Sign in to follow this  
Zedmag

[Help] Private Server Kicking players or Session Lost

Recommended Posts

Ok guys, this is racking my brain. Ill set a few things first
This is not my first rodeo. 
I have privately hosted servers long before Epoch. 
Then i got bored.
Currently im hosting an Epoch with Overwatch server (Overpoch)
Here is my current Server launch bat: (working)
"
start arma2oaserver.exe -port=2302 "-config=instance_11_Chernarus\config.cfg" "-cfg=instance_11_Chernarus\basic.cfg" "-profiles=instance_11_Chernarus" -name=instance_11_Chernarus "[email protected];@DayZ_Epoch1051;@DayZ_Epoch_Server"
"
Here is my client launch params in steam: (working)
"
-window -nosplash -mod=C:\@ArmaMODS\@DayzOverwatch;C:\@ArmaMODS\@Dayz_Epoch1051
"
You will notice in the Server and Client params that i am not referencing the Arma 2 directory OR the Expansion directory. The Addons (from Arma2) folder is copied into the Arma OA directory on both the Server and the Client. 
The Server and Client are on 2 diff machines.
This current configuration works perfectly with NO issues. Lets get that straight. 
Now with this said, Ive had friends join with out issues using this same client method.
What ive noticed is people trying to join thru out the day and getting kick almost immediately OR sitting in debug (used spectate to watch).
Yes, verify sigs are enabled. 
This got me wondering why? Had another friend try joining and they used DayzLauncher. He would log in, then get sent to debug right after the lobby. 
if he switched back to my method, joins right in with no issues. 
Ok, so i tried joining with DayzLauncher, same thing, i get stuck in debug. 
Ok this got me thinking how DZL is loading, its referencing the Arma 2 directory and the Expansion folder such as:
"
"-mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion"
"
ok, so maybe thats my problem on my server. so I attempt to use this param on the server:
"
start arma2oaserver.exe -port=2302 "-config=instance_11_Chernarus\config.cfg" "-cfg=instance_11_Chernarus\basic.cfg" "-profiles=instance_11_Chernarus" -name=instance_11_Chernarus "-mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion;@DayzOverwatch;@DayZ_Epoch1051;@DayZ_Epoch_Server"
"
And this one on the Client thru steam:
"
-window -nosplash -mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion;C:\@ArmaMODS\@DayzOverwatch;C:\@ArmaMODS\@Dayz_Epoch1051
"
no dice, Session Lost. 
Ok, Lets try DZL, nope, same thing, Session Lost. 
Ok, lets try DZL and connect to someone else's Overpoch server, 
SAME THING. Ask my buddy to try, Same result. 
Reinstall EVERYTHING fresh.
SAME THING. only a hand full of servers are able to be joined with DZL, and I tried almost EVERY Overpoch server i could find in DZL.
Now, back to my method, I am able to join EVERY overpoch server i can find in the Server browser with out issue. 
So im asking all the server owners and gamers to fill me in on the secrete here?
People say the whole copy the Addons folder no longer works, but it seems to be the ONLY method that works for me in any configuration. Clients shouldn't have to do anything special to connect to my server, so how are all the Servers on DZL getting people to connect with out issues?
Any help would be appreciated, though ive probably tried it. If you comment, ill respond with results.

Share this post


Link to post
Share on other sites

since the arma 2 "corepatch" update, connecting with a batch line doesnt seem to work the way it used to. since you are using steam, its a bit different, i use a windows bat file to connect to all servers. So im not sure how this will apply, but it might help. This fix did fix the "session lost" issue.

First you will need to revert the arma2 update, by going in steam, Right click on arma 2 OA, click on the betas tab, in the dropdown select LEGEACY.

Doing that will allow you to launch arma like we've been doing for years. (imo the recent update messed up alot)

As for your mods, its not hard once if you understand what the client and server is calling for. so for example:

server launch

"[email protected];@DayZ_Epoch1051;@DayZ_Epoch_Server"

in the root of your server, you have these folders. The NAME of the folder @DayZ_Epoch1051, must match exactly the same as in your server launch line.

The same goes for your client. The folder must be named EXACTLY as in your ...SteamApps\common\Arma 2 Operation Arrowhead folder.

 

So its possible that you might have @day_epoch, or @Dayzepoch, or @abcd.  As long as the launch line calls the proper mod it will work.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By kuibi1234
      Hey im not sure if im in the right forum, but i've been struggling with this problem for about 3 days now and google searches haven't gotten anything out for me, since my problem isnt really described other than that my server crashes after i join and start loading in.
      im running 1.0.7 Epoch with a few scripts/mods (DZSM, WAI, Lift&Tow, clickActions, remoteVehicle, marker_Manager, custom safezones script) + infistar.
      it was working all fine until i made a change to dynamic_vehicle.sqf in the dayz_server, after that the server kept crashing and i even made a backup and moved the old file back, but it kept crashing after that too, so i dont know what the problem is, i do have an rpt. but its basically no use since it doesnt show any errors.

       
      I left last few lines out, because its infistar stuff that is keys and other things im not supposed to show. After that it just cuts off from there because it crashes.


      Edited dynamic_vehicle.sqf (only AllowedVehiclesList changed):
       
    • By FG_Trap
      Made this in my free time awhile ago thought id make it public.
      Right Alt is the key to open the menu.
      Install instructions are inside the download.
      https://github.com/NWDZ-Trapxxgods/traps-menu
       
       
      here is a picture of the server menu
       
    • By Shermanator
      Devils Brigade offers a unique experience.  We offer a PVP style server with options of multiple maps.  Fully Customized.  Custom Traders, Custom Military Zones, Custom High Capacity Clothing and Packs, Custom Anti Raid Bot that offers 24/7 notification when your base is being raided it will send u a DM via discord, Custom vehicles, Base Garages and trader garages, Hacking tablets, Key Card Vaults with High Value Loot, KOTH, Airdrops and much much more.  Come join the community and have some fun.  We encourage Looting, Raiding, and PVP.
      Search for us : Devils Brigade MultiMap
      Discord Invite: https://discord.gg/hQUeHPjaWZ

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...