Jump to content
BoleParty

Client FPS Drops

Recommended Posts

After playing around with some files and reading through different forums we found a solution which at least prevents our server fps for most players.

 

 

We are still rolling with Arma 1.48/ Epoch 0.3.0.4

 

 

Disable the UAV`s and all Sappers in loot.h being located in @epochhive\a3_epoch_server_settings.pbo\configs\

 

class CfgMainTable
{
    class Default
    {
        chance = 1;
        lootMin = 1;
        LootMax = 1;
        tables[] = { "Food" };
        antagonists[] = {
                { "UAV", 0 },
                { "Cloak", 30 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F
                { "Sapper", 0 },
                { "SapperB", 0 },
                { "PHANTOM", 70 }
        };

 

 

 

 

 

 

Put this in your init.sqf and as well in your onPlayerRespawn.sqf to resolve the enviromental sound issues. This might not be related to the fps drops but since we are using this command server fps increased.

 

enableEnvironment true;

 

 

In your epochconfig.hpp set this function to "true"

 

simulationHandler = true;

 

 

Also we took out VEMF as this mission was causing drops too.

 

 

What might be very interesting is that players who are using Nvidia GPU`s still are experiencing fps drops and players who are using AMD GPU`s almost got no fps drops or dont have any at all.

 

Even when i spawned in 10 Sappers at my pos i didnt have any drops.

 

So either Arma or Epoch updates or both might be interfering with Nvidia GPU´s.

 

 

Maybe this helps at least some of you guys.

 

Best regards

 

 

 

Share this post


Link to post
Share on other sites

we still had some sappers spawning during nighttime so i changed to this:

 

class CfgMainTable
{
    class Default
    {
        chance = 1;
        lootMin = 1;
        LootMax = 1;
        tables[] = { "Food" };
        antagonists[] = {
                { "UAV", 0 },
                { "Cloak", 0 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F
                { "Sapper", 0 },
                { "SapperB", 0 },
                { "PHANTOM", 100 }
        };

 

class Trash : Default
    {
        chance = 0.33;
        lootMin = 1;
        LootMax = 6;
        tables[] = {
                { "Items", 5 },
                { "Backpack", 5 },
                { "Pistols", 3 },
                { "Uniforms", 9 },
                { "Vests", 7 },
                { "Headgear", 9 },
                { "Food", 9 },
                { "Hand", 10 },
                { "Equipment", 10 },
                { "Generic", 15 },
                { "GenericLarge", 18 }
        };
        antagonists[] = {
                { "UAV", 100 }, // I_UAV_01_F
                { "Cloak", 0 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F
                { "Sapper", 0 }, // Epoch_Sapper_F
                { "SapperB", 0 }  // Epoch_SapperB_F

 

 

no more sappers and even players with nvidia gpu are fine.

 

server fps now capped out at 50-53 and no more client side fps drops.

 

we didnt apply any changes brian mentioned in his post tho.

Share this post


Link to post
Share on other sites

we still had some sappers spawning during nighttime so i changed to this:

 

class CfgMainTable

{

    class Default

    {

        chance = 1;

        lootMin = 1;

        LootMax = 1;

        tables[] = { "Food" };

        antagonists[] = {

                { "UAV", 0 },

                { "Cloak", 0 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F

                { "Sapper", 0 },

                { "SapperB", 0 },

                { "PHANTOM", 100 }

        };

 

class Trash : Default

    {

        chance = 0.33;

        lootMin = 1;

        LootMax = 6;

        tables[] = {

                { "Items", 5 },

                { "Backpack", 5 },

                { "Pistols", 3 },

                { "Uniforms", 9 },

                { "Vests", 7 },

                { "Headgear", 9 },

                { "Food", 9 },

                { "Hand", 10 },

                { "Equipment", 10 },

                { "Generic", 15 },

                { "GenericLarge", 18 }

        };

        antagonists[] = {

                { "UAV", 100 }, // I_UAV_01_F

                { "Cloak", 0 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F

                { "Sapper", 0 }, // Epoch_Sapper_F

                { "SapperB", 0 }  // Epoch_SapperB_F

 

 

no more sappers and even players with nvidia gpu are fine.

 

server fps now capped out at 50-53 and no more client side fps drops.

 

we didnt apply any changes brian mentioned in his post tho.

Thanks, giving this a whirl now. So basically you think it's sappers and cloaks that's doing it...?

Share this post


Link to post
Share on other sites

sappers definetely are a reason for big fps drops yes. we are testing since 2 days to find the cause and what we know so far is that sappers causing drops and that nvidia gpu`s encounter more issues than amd gpu`s.

 

 

what you guys could try also is:

 

/ Control the epoch ai limit per player
// 1. Epoch_Cloak_F = Cultist
// 2. GreatWhite_F = Great White Shark
// 3. Epoch_Sapper_F = Regular Sapper
// 4. Epoch_SapperB_F = Super Sapper (dark)
// 5. I_UAV_01_F = UAV (that spawns the AI)
// 6. PHANTOM = Invisible phantom
// 7. B_Heli_Transport_01_F = Transport helicopter for the mission system

EPOCH_spawnLimits = [0, 0, 0, 0, 0, 0, 0];
//
This is the default: EPOCH_spawnLimits = [1, 2, 2, 1, 2, 1, 1];

 

just put the Epoch_spawnLimits line into your init and edit to your needs. dunno if this is working by now tho.

 

i got another thing what might work but i need to do some more testing before i can talk bout it.

Share this post


Link to post
Share on other sites

For us the sappers have been the cause for the most recent issues so i just disabled them. This is what i did:

 

 

Put  enableEnvironment true; in your init.sqf and as well in your onPlayerRespawn.sqf to resolve the enviromental sound issues. This might not be related to the fps drops but since we are using this command server fps increased.

 

In your epochconfig.hpp set simulationHandler = true;

 

 

This i changed in loot.h:

 

class CfgMainTable
{
    class Default
    {
        chance = 1;
        lootMin = 1;
        LootMax = 1;
        tables[] = { "Food" };
        antagonists[] = {
                { "UAV", 0 },
                { "Cloak", 0 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F
                { "Sapper", 0 },
                { "SapperB", 0 },
                { "PHANTOM", 100 }
        };

 

class Trash : Default
    {
        chance = 0.33;
        lootMin = 1;
        LootMax = 6;
        tables[] = {
                { "Items", 5 },
                { "Backpack", 5 },
                { "Pistols", 3 },
                { "Uniforms", 9 },
                { "Vests", 7 },
                { "Headgear", 9 },
                { "Food", 9 },
                { "Hand", 10 },
                { "Equipment", 10 },
                { "Generic", 15 },
                { "GenericLarge", 18 }
        };

 

antagonists[] = {
                { "UAV", 100 }, // I_UAV_01_F
                { "Cloak", 0 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F
                { "Sapper", 0 }, // Epoch_Sapper_F
                { "SapperB", 0 }  // Epoch_SapperB_F

 

 

it might be that there is no needs to do it when you put this in your init.sqf:

 

/ Control the epoch ai limit per player
// 1. Epoch_Cloak_F = Cultist
// 2. GreatWhite_F = Great White Shark
// 3. Epoch_Sapper_F = Regular Sapper
// 4. Epoch_SapperB_F = Super Sapper (dark)
// 5. I_UAV_01_F = UAV (that spawns the AI)
// 6. PHANTOM = Invisible phantom
// 7. B_Heli_Transport_01_F = Transport helicopter for the mission system

EPOCH_spawnLimits = [0, 0, 0, 0, 0, 0, 0];
<---just this line is important. above is just additional info so that you know what can be changed.

 

Then i took out VEMF as this mission script was causing massive fps drops.

 

Further i forced static weather with: {75.5,0,{0,0,0},0,{1,1}};

 

 

These changes resolved all our issues. We dont have any server/ client fps drops and no more glitches.

 

 

Maybe this is a usable temporary solution or "hotfix" until the issues will be officially eliminated and i really hope that this might help at least some of you guys.

 

 

 

Best regards

 

 

Share this post


Link to post
Share on other sites

Tested and i can not confirm your toughts. Does not matter. Seems like all the "solutions" out there (included mine) are no solution but just luck some times.

After all BI or the devs have to bring a patch otherwise there will be no fix. It seems like arma did that fps drop thing because it is shown on many other mods also.

 

Sad but true. Another great bohemia patch like always :D Maybe they copied from SA :D :D

Share this post


Link to post
Share on other sites

For us the sappers have been the cause for the most recent issues so i just disabled them. This is what i did:

 

 

Put  enableEnvironment true; in your init.sqf and as well in your onPlayerRespawn.sqf to resolve the enviromental sound issues. This might not be related to the fps drops but since we are using this command server fps increased.

 

In your epochconfig.hpp set simulationHandler = true;

 

 

This i changed in loot.h:

 

class CfgMainTable

{

    class Default

    {

        chance = 1;

        lootMin = 1;

        LootMax = 1;

        tables[] = { "Food" };

        antagonists[] = {

                { "UAV", 0 },

                { "Cloak", 0 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F

                { "Sapper", 0 },

                { "SapperB", 0 },

                { "PHANTOM", 100 }

        };

 

class Trash : Default

    {

        chance = 0.33;

        lootMin = 1;

        LootMax = 6;

        tables[] = {

                { "Items", 5 },

                { "Backpack", 5 },

                { "Pistols", 3 },

                { "Uniforms", 9 },

                { "Vests", 7 },

                { "Headgear", 9 },

                { "Food", 9 },

                { "Hand", 10 },

                { "Equipment", 10 },

                { "Generic", 15 },

                { "GenericLarge", 18 }

        };

 

antagonists[] = {

                { "UAV", 100 }, // I_UAV_01_F

                { "Cloak", 0 }, // Night = Epoch_Cloak_F, Day = Epoch_Sapper_F

                { "Sapper", 0 }, // Epoch_Sapper_F

                { "SapperB", 0 }  // Epoch_SapperB_F

 

 

it might be that there is no needs to do it when you put this in your init.sqf:

 

/ Control the epoch ai limit per player

// 1. Epoch_Cloak_F = Cultist

// 2. GreatWhite_F = Great White Shark

// 3. Epoch_Sapper_F = Regular Sapper

// 4. Epoch_SapperB_F = Super Sapper (dark)

// 5. I_UAV_01_F = UAV (that spawns the AI)

// 6. PHANTOM = Invisible phantom

// 7. B_Heli_Transport_01_F = Transport helicopter for the mission system

EPOCH_spawnLimits = [0, 0, 0, 0, 0, 0, 0]; <---just this line is important. above is just additional info so that you know what can be changed.

 

Then i took out VEMF as this mission script was causing massive fps drops.

 

Further i forced static weather with: {75.5,0,{0,0,0},0,{1,1}};

 

 

These changes resolved all our issues. We dont have any server/ client fps drops and no more glitches.

 

 

Maybe this is a usable temporary solution or "hotfix" until the issues will be officially eliminated and i really hope that this might help at least some of you guys.

 

 

 

Best regards

 

As far as I am aware this only controls antagonists while looting and not ambient/random ones.

Share this post


Link to post
Share on other sites

As far as I am aware this only controls antagonists while looting and not ambient/random ones.

since i applied mentioned changes not a single sapper spawned and nobody is encountering or experiencing any glitches or fps drops.

Share this post


Link to post
Share on other sites

EPOCH_spawnLimits = [0, 0, 0, 0, 0, 0, 0]; removes them completely

 

Unfortunately not for me I have been running that line at the end of my init since the UAV problem and it did not stop those nor has it stopped the sappers the only thing I can think is it is not being read somehow.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...