Welcome to Epoch Mod Community

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

mgm

Taxi & Bus | Transport for Arma

199 posts in this topic

8 hours ago, theftgun said:

custom\mgmTfA\psczvuznuilitltt.sqf no found.
 



I found out that there is nothing psczvuznuilitltt.sqf on mgmtfa

okay my bad.
here is the situation, from day one, I intended to make this script GNU GPL Free Software meaning anyone can see/modify/redistribute the source code.
however, in the early days, I did not license it under GPL, instead distributed in obfuscated and minimized form until I clean up the code.
now the code is cleaned up, licensed under GPL, source code made available, including all in line comments.

the problem you are experiencing is because you downloaded an ancient (obfuscated) copy with crazy file names.
the solution is downloading the latest (unobfuscated) version.

I will update this post in a few minutes, will give you the correct latest download link and will also update the README. sorry for the trouble!


EDIT:
I will try to get version 0.5.0 out this weekend but until then here is the latest available version: https://gitlab.com/themgm/Transport_for_Arma/tree/stable/release_packages/0.4.8-hotfix1
This was a rushed release, let me know if you experience any issues?

theftgun and lesvieuxcrevards like this

Share this post


Link to post
Share on other sites
3 hours ago, mgm said:

okay my bad.
here is the situation, from day one, I intended to make this script GNU GPL Free Software meaning anyone can see/modify/redistribute the source code.
however, in the early days, I did not license it under GPL, instead distributed in obfuscated and minimized form until I clean up the code.
now the code is cleaned up, licensed under GPL, source code made available, including all in line comments.

the problem you are experiencing is because you downloaded an ancient (obfuscated) copy with crazy file names.
the solution is downloading the latest (unobfuscated) version.

I will update this post in a few minutes, will give you the correct latest download link and will also update the README. sorry for the trouble!


EDIT:
I will try to get version 0.5.0 out this weekend but until then here is the latest available version: https://gitlab.com/themgm/Transport_for_Arma/tree/stable/release_packages/0.4.8-hotfix1
This was a rushed release, let me know if you experience any issues?

Thank you! You have worked hard for our sake. Respect. I will give you update on my server:) I'm not home until Wednesday. 

Share this post


Link to post
Share on other sites
1 hour ago, theftgun said:

Thank you! You have worked hard for our sake. Respect. I will give you update on my server:) I'm not home until Wednesday. 

no worries. if you are doing it next week, then you can probably use the upcoming 0.5.0 version. remember to check this thread before you install...


EDIT: temporarily removed the rushed release, updated the 1st post as follows:

Currently there is no "recommended version" available - I will try and release version 0.5.0 this weekend.
Until then, if you wish to play with existing code grab the 0.4.1 from GitLab however I would recommend on waiting as so much has changed!

Share this post


Link to post
Share on other sites
4 minutes ago, mgm said:

no worries. if you are doing it next week, then you can probably use the upcoming 0.5.0 version. remember to check this thread before you install...

I will do it:)

Share this post


Link to post
Share on other sites
1 hour ago, mgm said:

no worries. if you are doing it next week, then you can probably use the upcoming 0.5.0 version. remember to check this thread before you install...

I haven't seen info on that update. Is there a post I've missed?

*edit* are you referring to 0.5.0 of this script or Epoch?

Share this post


Link to post
Share on other sites
38 minutes ago, BetterDeadThanZed said:

I haven't seen info on that update. Is there a post I've missed?

*edit* are you referring to 0.5.0 of this script or Epoch?

I was referring to Transport for Arma as OP is trying to install/test TfA

Share this post


Link to post
Share on other sites

...so called a Taxi, got the radio message "Your taxi has arrived - please get in!"

as expected...

but after checking all sides of  building twice, no taxi??

 

then this...

 

I guess it's time to add a "nearest building must be >=50  m condition for spawn points"  :blush:


aTAp2wn.jpg

Grahame likes this

Share this post


Link to post
Share on other sites

18th May - New version v.0.6.5b2 available!

 

Release package direct link to 7zip archive file: https://gitlab.com/themgm/Transport_for_Arma/blob/master/release_packages/_autogenerated/v.0.6.5.build2/mgmTfA_v.0.6.5.build2.7z
Installation Instructions: https://gitlab.com/themgm/Transport_for_Arma/blob/master/documentation/INSTALLATION_INSTRUCTIONS.txt
Link to release directory where you can download the three additional files to verify integrityhttps://gitlab.com/themgm/Transport_for_Arma/tree/master/release_packages/_autogenerated/v.0.6.5.build2

 

If you try this script, please let me know what you think :)

Share this post


Link to post
Share on other sites
22 hours ago, mgm said:

18th May - New version v.0.6.5b2 available!

 

Release package direct link to 7zip archive file: https://gitlab.com/themgm/Transport_for_Arma/blob/master/release_packages/_autogenerated/v.0.6.5.build2/mgmTfA_v.0.6.5.build2.7z
Installation Instructions: https://gitlab.com/themgm/Transport_for_Arma/blob/master/documentation/INSTALLATION_INSTRUCTIONS.txt
Link to release directory where you can download the three additional files to verify integrityhttps://gitlab.com/themgm/Transport_for_Arma/tree/master/release_packages/_autogenerated/v.0.6.5.build2

 

If you try this script, please let me know what you think :)

I have installed. nothing happened..

I have installed:

Server-side mgmTfA.pbo to epochhive addon
Client-side Epoch.altis: I have copied Custom, mgmTfA_c_CO_defines.hpp, mgmTfA_c_CO_dialogs.hpp 

AND

description 

// BEGIN:	mgmTfA Required description.ext additions
#include "mgmTfA_c_CO_defines.hpp"
#include "mgmTfA_c_CO_dialogs.hpp"
// END:	mgmTfA Required description.ext additions

but what about batleye scripts?

Still same script previous version?

Share this post


Link to post
Share on other sites
1 hour ago, theftgun said:

I have installed. nothing happened..

I have installed:

Server-side mgmTfA.pbo to epochhive addon
Client-side Epoch.altis: I have copied Custom, mgmTfA_c_CO_defines.hpp, mgmTfA_c_CO_dialogs.hpp 

AND

description 


// BEGIN:	mgmTfA Required description.ext additions
#include "mgmTfA_c_CO_defines.hpp"
#include "mgmTfA_c_CO_dialogs.hpp"
// END:	mgmTfA Required description.ext additions

but what about batleye scripts?

Still same script previous version?

 

1 hour ago, theftgun said:

problem solved.

but...


GUI taxi show up still same problem. 
I haved press 3-8 map 

 

If you open/close map three times quickly, still see no Transport for Arma custom GUI popup on your screen, it has got to be the BE filters.

There is no BattlEye filters sadly - I never got around to creating the boring filters partly because such a dreadful task.
Don't use the old BE filters from the depths of git repo as they are too old and were never fully ready either. They were created by a user of the script, nice attempt but never completed. 
So I suggest you "test" with BE turned off and see if everything else is working?

I will see if I can get proper BE filters this weekend - no promises though because I just bought Stellaris today & it's addictive :)

Share this post


Link to post
Share on other sites
20 minutes ago, mgm said:

 

 

If you open/close map three times quickly, still see no Transport for Arma custom GUI popup on your screen, it has got to be the BE filters.

There is no BattlEye filters sadly - I never got around to creating the boring filters partly because such a dreadful task.
Don't use the old BE filters from the depths of git repo as they are too old and were never fully ready either. They were created by a user of the script, nice attempt but never completed. 
So I suggest you "test" with BE turned off and see if everything else is working?

I will see if I can get proper BE filters this weekend - no promises though because I just bought Stellaris today & it's addictive :)

I have removed old BE filters. still same problem.
It should up GUI with wheelscroll after  open/close map three times quickly?

Share this post


Link to post
Share on other sites
6 hours ago, theftgun said:

I have removed old BE filters. still same problem.
It should up GUI with wheelscroll after  open/close map three times quickly?

No connection to mouse or any other keyboard key (except map key). It is all about MAP_OPENED & MAP_CLOSED states of your Arma3. If this happens too quickly, it fires up the custom Transport for Arma GUI.

Can you try with your server's BattlEye off? Just to test. I mean turn it off in server cfg file completely with be = false. If all the issues go away as soon as you turn BattlEye completely off, it will confirm the cause.

Share this post


Link to post
Share on other sites
6 hours ago, mgm said:

No connection to mouse or any other keyboard key (except map key). It is all about MAP_OPENED & MAP_CLOSED states of your Arma3. If this happens too quickly, it fires up the custom Transport for Arma GUI.

Can you try with your server's BattlEye off? Just to test. I mean turn it off in server cfg file completely with be = false. If all the issues go away as soon as you turn BattlEye completely off, it will confirm the cause.

Still same problem :/ 

Share this post


Link to post
Share on other sites
59 minutes ago, theftgun said:

Still same problem :/ 

same problem  = your server's  battleye is completely turned off (& server restarted since the change). you open & close the map three times, still no TfA GUI comes up, is that right?

 

if the answer is YES, can you help with troubleshooting by providing logs?  procedure is below if you are happy to assist...

 

  1.  unPBO serverside mgmtfa.pbo file
  2. open the CONFIGURATION file with a good text editor such as Notepad++
  3. change the server-side verbosity & client-side verbosity both to 10
  4. rePBO the serverside, and restart the server
  5. do the same test again it will write a lot of information to both logs
  6. and after the tests, please provide the contents of server-side and client-side log files. by posting their contents to pastebin separately and give me 2 separate links.

 

edit:
do you have any 3rd party "security" software that might be interfering? infiSTAR or something similar?
If you do have, again for test purposes, for 5 minutes, try turning it off so that we can understand what exactly is causing this issue.
I develop and test with BattlEye off and Epoch AntiHack on. I do not have any other 3rd party software.

Share this post


Link to post
Share on other sites
2 hours ago, mgm said:

same problem  = your server's  battleye is completely turned off (& server restarted since the change). you open & close the map three times, still no TfA GUI comes up, is that right?

 

if the answer is YES, can you help with troubleshooting by providing logs?  procedure is below if you are happy to assist...

 

  1.  unPBO serverside mgmtfa.pbo file
  2. open the CONFIGURATION file with a good text editor such as Notepad++
  3. change the server-side verbosity & client-side verbosity both to 10
  4. rePBO the serverside, and restart the server
  5. do the same test again it will write a lot of information to both logs
  6. and after the tests, please provide the contents of server-side and client-side log files. by posting their contents to pastebin separately and give me 2 separate links.

 

edit:
do you have any 3rd party "security" software that might be interfering? infiSTAR or something similar?
If you do have, again for test purposes, for 5 minutes, try turning it off so that we can understand what exactly is causing this issue.
I develop and test with BattlEye off and Epoch AntiHack on. I do not have any other 3rd party software.

where can i find log files?

Share this post


Link to post
Share on other sites
1 hour ago, theftgun said:

where can i find log files?

it writes to the standard arma 3 server and arma 3 client log files - there is no special tfa log file.

 

Standard log locations are:

Server: under sc/ directory if I remember correctly.

Client log: is under user profile. On windows 7, c:\users\USERNAME\appdata\local\arma3 << something like that. I am on the phone now have a look and you should be able to find it easily.

If you're having difficulty just google and copy paste the exact path. This is all I remember.

Share this post


Link to post
Share on other sites

Look awesome. Have ever try Lyft for your real ride. Lyft has feature to calculate estimated fare that will help to find your estimated lyft fare before starting your lyft ride. So feel free to use Lyft Fare Estimate to estimate your Lyft ride. For user guide you may watch this youtube video at:

 

Share this post


Link to post
Share on other sites

Hi, I am veeery new to this, but if i overwrite the existing server epoch.altis.pbo and restart, people get a black screen if they try to play.

Share this post


Link to post
Share on other sites
On 1/19/2017 at 2:05 PM, StefanRed said:

Hi, I am veeery new to this, but if i overwrite the existing server epoch.altis.pbo and restart, people get a black screen if they try to play.

Hi,

This mod is quite old now (last update was in 2016-05) so it won't work unless you go through the files & update it.
Personally I still didn't give up on this idea and I will at some point come back to this project and finish it however not anytime soon.

If you or anyone would like to work on this, I will be more than happy to answer any questions.

Thanks

Share this post


Link to post
Share on other sites
On 13/04/2017 at 2:19 PM, lazyusuf said:

ok 

Thanks

so did you try running it on latest version of arma3/epoch? how did it go?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Moist_Pretzels
      Yesterday I was playing with a couple of friends on a private epoch server, and it seemed like every 10-15 minutes some of us would get kicked. Reason for it? Script Restriction #29, I'm wondering if this is a client or server issue, I'm not a big coder so I wasn't able to find where exactly the problem was. If anyone can give me feedback I would appreciate it greatly.
    • By harcosgoogle
      Hi.
       
      Death messages script? 1.0.6.1?
    • By harcosgoogle
      Hi.
      How can server-side fps be increased?
       
      Database clean?
      Script?Mod?
      Clean?
       
      (Not game settings)
       
      Thanks
    • By Gabriel12237
      Hello Community 
       
      Sorry for my bad English.
       
      I Search a lingor Script With 2 mods. (Plot4life and plotmanagement) .can you send me pls a Script for Lingor With the 2 or more scripts? Thank you very much guys.
       
       
       
      Cheers 
    • By Birgitte
      Is there a script to slow the zombies for 1.0.5.1 like the setting in 1.0.6?
  • Latest Donations

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!
  • Advertisement
  • Supporters
  • Advertisement
  • Forum Statistics

    • Total Topics
      26318
    • Total Posts
      242930
  • Member Statistics

    • Total Members
      29362
    • Most Online
      1497

    Newest Member
    [Z]EnDoh
    Joined