Jump to content

Recommended Posts

Problem..Maybe

 

When you add/adjust any player items You get "\" on all items. DB no likely and basically deletes your inventory. 

 

BAD DB from the tool: 

[[\"NVGoggles\",\"ItemFlashlight\",\"ItemCrowbar\",\"ItemCompass\",\"ItemMap\",\"ItemKnife\",\"ItemHatchet\",\"Binocular_Vector\",\"ItemToolbox\",\"ItemWatch\",\"ItemGPS\",\"Colt1911\",\"ItemKeyKit\",\"ItemFlashlightRed\",\"ItemEtool\"],[\"ItemWaterbottle\",",\"forest_large_net_kit\",\"forest_large_net_kit\"]]

 

 

Good DB: (After deleted the leading "\")

[["NVGoggles","ItemFlashlight","ItemCrowbar","ItemCompass","ItemMap","ItemKnife","ItemHatchet","Binocular_Vector","ItemToolbox","ItemWatch","ItemGPS","Colt1911","SCAR_H_LNG_Sniper_SD","ItemKeyKit","ItemFlashlightRed","ItemEtool"],["ItemWaterbottle","forest_large_net_kit","forest_large_net_kit"]]

Share this post


Link to post
Share on other sites

maybe a issue by a setting in the "php.ini" because i have this not...

 

 

please check your "php.ini" settings file if:
{
magic_quotes_gpc =On;
magic_quotes_runtime =On;
magic_quotes_sybase =On;
}
then set all to "Off" and restart your apache/xampp/lamp ...

Share this post


Link to post
Share on other sites

I have not done it for a while but i used to run a local webserver on my pc to test websites before uploading them to the internet. Ill look up how to do it again as it would mean free hosting of this for people on there own computers.

Share this post


Link to post
Share on other sites

I have not done it for a while but i used to run a local webserver on my pc to test websites before uploading them to the internet. Ill look up how to do it again as it would mean free hosting of this for people on there own computers.

 

 

That would be perfect, i have 2 spare rigs & a fat pipe connection, that would help a lot!

Share this post


Link to post
Share on other sites

i have not tried it on my laptop yet so cant confirm it works but this link (http://www.ultraedit.com/support/tutorials_power_tips/uestudio/local_php_mysql_dev_environment.html) tells you what you need etc (Apache, PHP & Mysql) to get it working on your local computers.

 

Personally i have a NAS that is capable of running websites so ill prob just install it on there for myself but the above link should help people set it up on there own computers

Share this post


Link to post
Share on other sites

It's alot easier, if you're on Windows and don't know what you're doing, to just grab the Wampserver package (http://www.wampserver.com/en/).  That sets up Apache, MySQL, and PHPMyAdmin.  From there, you just toss the folder in to the WWW directory and access the setup page with your browser (http://127.0.0.1/privatehivetools/setup.php).

 

If you already have MySQL on this box for running the server, start just Apache when you launch Wampserver.

Share this post


Link to post
Share on other sites

It's alot easier, if you're on Windows and don't know what you're doing, to just grab the Wampserver package (http://www.wampserver.com/en/).  That sets up Apache, MySQL, and PHPMyAdmin.  From there, you just toss the folder in to the WWW directory and access the setup page with your browser (http://127.0.0.1/privatehivetools/setup.php).

 

If you already have MySQL on this box for running the server, start just Apache when you launch Wampserver.

 

 

If i am connecting to my server supplied by my provider (vilayer) do i need Apache,MySQL & PHP on the machine that i install this Wampserver package to here at home?

 

Thanks

Share this post


Link to post
Share on other sites

If i am connecting to my server supplied by my provider (vilayer) do i need Apache,MySQL & PHP on the machine that i install this Wampserver package to here at home?

 

Thanks

 

i think your problem may be your confusing a game server (where you host your dayz server) and a web server (where websites are hosted)

 

Vilayer does do web hosting as well as game hosting and at 1.95 euros a month its quite cheap.

Share this post


Link to post
Share on other sites

Forgive my noobness ;)

 

I just need to be able to connect to my sql database hosted by vilayer using this tool & want to find the least technical way of resolving my problem, i know little about hosting as you can tell, i can connect to it from here using Navicat & edit on the fly etc but this tool would make the process easier & faster for me from an admin point of view.

 

I have a home office/gaming room, my server is hosted on vilayer, i'm typing this on my gaming rig & i have a backup rig & screen beside me that runs dart recon tool & navicat to admin from.

 

I want to access the tool on that rig beside me along with dart to admin from.

 

So whats the route i need to go down please?

 

Thanks again for the support.

Share this post


Link to post
Share on other sites

I think your best bet would be to contact your game server host and ask them about integrating the tool.  Opening up your MySQL server for outside connections generally isn't a good idea from a security standpoint, which is what would have to be done.  Likely they have it restricted to localhost only (meaning only software on that same OS installation can access it) or a specific other server installation as many hosts do to spread load.

Share this post


Link to post
Share on other sites

Well, then.  Easiest method is still going to be using Wampserver, so that you don't have to deal with configuring Apache.

  • Install Wampserver
  • Start Wampserver from the desktop icon (or in the system tray, click and select start all services).
  • Extract the zip file for the admin tools to C:\wamp\www
  • In your browser, go to http://127.0.0.1/setup.php
  • Enter your database and server information
  • And...Done.

From then on, you'll just go to http://127.0.0.1/index.php

Share this post


Link to post
Share on other sites

Lool, not so fast..

 

get to tools install screen fine now but after entering details just goes back to Wampserver main screen, is there a way to test the details i'm entering are correct? is this why it's going straight back to wampserver main screen?

 

Is there a log i can check?

 

Also getting "Wrong hive schema" if i click on PrivateHiveTools_1.01 in Wamp home page.

Share this post


Link to post
Share on other sites

Lool, not so fast..

 

get to tools install screen fine now but after entering details just goes back to Wampserver main screen, is there a way to test the details i'm entering are correct? is this why it's going straight back to wampserver main screen?

 

Is there a log i can check?

 

Also getting "Wrong hive schema" if i click on PrivateHiveTools_1.01 in Wamp home page.

 

delete all WAMP files in "/htdocs" because is not needed..... and then copy the hivetool files to htdocs again...

 

 

you can test your database connection with "Navicat Lite" or "HeidiSQL" ..

Share this post


Link to post
Share on other sites

My databse connection to the sql server thru navicat is fine & working, can you give me some clarity on the exact info required below the database details in the setup window of the tool?

 

Database settings are fine, it's the detail below i need clarity on please?

 

Server IP: Clearly i know that

Server port: no problem

Server Rcon? is that my Rcon password? (which i have)

Server  iinstance: My server instance ID (which i have)

World ID: is this neccesarry for Epoch? (again i have that info from my database if needed)

Hive Schema: Set to Epoch?

Secure: ? what does that mean & what do i select yes or no?

HeadAdmin Login name: Do i create this or is it anything to do with my server or rcon details?

HeadAdmin Login password: as above.

 

 

thanks again for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By NoxSicarius
      NOTICE For those who want to use this in 1.0.6
      Instead of using this one, I suggest visiting the following thread for game version 1.0.6 and up
       
      The tools are partially updated for the new release. Most features are working so far and it can be downloaded from here (follow the readme for install): https://github.com/noxsicarius/Epoch-Admin-Tools/tree/TestBranch

       
       
      IMPORTANT:
      Under NO circumstances should you download this tool from a different source. I have been notified of numerous virus downloads listed as my work (usually second page of google and farther). I have petitioned to have all of the ones I know of blacklisted and have sent virus profiles to all major antivirus companies. If you find a .exe in any work claiming to be mine, it is a virus and should be shredded. 
      Please only download from MY github link or the links in this post.
      My github repo will NEVER be removed and if I leave the project and someone wishes to take over, they will be given rights to the repo.
       
      Features:
       
      For help with Administration:
      Multiple Admin levels Spectate players "Display code" for locked vaults/doors "Create key" for vehicles with lost keys Force lock and unlock vehicles without keys Base Destruction - Destroy all buildables/vehicles within a customizable radius Spawnable crates with weapons, items, and supplies Spawn locked or temporary vehicles via the menu or a custom-made graphical vehicle menu (screenshot) Other features:
      Godmode Teleport self (or others to you) Flying Invisibility Delete and repair/refuel vehicle on crosshairs ESP - display players, zombies, safes, tents, vehicles, and AI on the map ...and more! Installation, changes, additional information, FAQ, credits, issues and everything else can be found at the project page on Github:

      Epoch Admin Tools on GitHub
      Click here for an install tutorial video for the tool
      I have been informed that some places block GitHub, so here are direct links hosted by me:
      Newest full release: https://www.dropbox.com/s/pjvj07u5yemo7we/Epoch-Admin-Tools-master.zip?dl=0
      Beta build: https://www.dropbox.com/s/xm6t1k3gvp3t8ex/Epoch-Admin-Tools-TestBranch.zip?dl=0


      If you have an improvement you would like to add, make a pull request and make these tools even better!


      Error Reporting:
       
      BEFORE posting an issue on Github or on this forum:
      If you think you might have installed it incorrectly, follow the YouTube Video Install Tutorial Try reinstalling the tool. You more than likely missed something important. Do a quick search on this forum for a fix to your problem. Check your server's RPT log for errors. This will identify 99% of problems with the menu. Be ready to copy/paste the RPT log into Pastebin or Gist in an issue or in the discussion forum for help with troubleshooting. If your problem persists after doing the above:
      Open your arma2oaserver.rpt file in a text editor and copy/paste the RPT log into Pastebin and post your issue in this forum with the rpt log. If you post something like "It doesn't work" I will not acknowledge you. Not giving all possible details in the first post simply makes it take longer to resolve and will waste everyone's time. I am hard pressed for time these days so if you won't take the initiative to provide information, I won't ask for it either. I am not trying to be mean, but I am quite tired of getting 5 or less word posts that provide no information other than this person has some kind of problem somewhere on their server that may or may not be related to this mod. If the problem you are posting is a bug and not a general install problem then post it to this forum AND to the github issues page.  
      I have been asked by someone if they can donate to the project so I am adding the link here.
       
       
      I have invested a good deal of time into this so if you find it useful please give a little donation.
      (DONATE)
      I also accept Crypto Currency: 
      Bitcoin: 1GkzMzwnVwVpnUCVFaAyLDsgD9cqSfigdm
      Litecoin: LbUrUxXzA557VeTWXM8jP7hNf3uZHEqW5b
       
      A sincere thanks to those who made a monetary contribution to this project: calamity, CRHASH, BMovieQueen, zixxel, 8BitSigdom, Anarior, f3cuk, Caveman1, Nathan, [member=WootyWoop], [member=Terrance Smith]
      A huge thanks to those who make the community a better place by answering questions on this project: @juandayz, @EditedSnowHD
      Please leave your name in a note if you donate so that I can list you above.
    • By azzdayz
      Hey guys,
      Just wanna kinda bring this up and throw this out there for anyone that might know more.
      I have a small server and wanted to have a smaller map. I have been looking at some of the other maps and they are all quite big. Utes is really small and I almost thought about messing around with that one, but I wanted it to be at least a little bigger, LOL
      Does anyone know what the deal is with Jade Groove? There is no clear information on it and doesn't really make a whole lot of sense. That would have been a great sized map, but I cant find the bikeys for it or anything.
      Other than that would anyone have a suggestion as to a good map to use if you have a low end server?
      Thanks,
    • By ReidenXerx
      Greetings! I need some help
      in running arma 3 epoch mod server on a napf map.
      I found out that I need a file with the coordinates of map buildings for spawn loot like this one used in altis map (if I understood correctly).

      altis.h
      I found it in the file "epoch_server_settings.pbo" in the folder "epoch_server_settings\configs\maps", there is also a file for napf, but the problem is it is almost empty.
      napf.h
      I do not know what to do.
    • By EBEALIEN
      Good evening at all!
      I'm Antonio, and I've already built servers with Nitrado, to have fun with friends, and we say they were pretty good.
      Now after a few months I still subscribe to a server with Nitrado and I saw that I also have Infistar Admin tools.
      I can not find the configuration procedures, and even a list of keys to use or how to get into the admin tools.
      Anyway I came in and with the F2 button I see the menu, when I close it with the esc key then it does not let me enter. I probably make mistakes or misses. Where can I find a step-by-step setup guide ???

      Thanks to who has time to devote to me.

      Antonio - Italy
      Good job everyone, and very very  thanks
      Sorry - google tralator
    • By harcosgoogle
      Hi.(Sorry no speak English)
       
      I do not understand how one could solve,Admin tools install  
      https://github.com/noxsicarius/Epoch-Admin-Tools
       
       
      };
      initialized = false;
      call compile preprocessFileLineNumbers "\z\addons\dayz_code\init\variables.sqf";
      progressLoadingScreen 0.05;
      call compile preprocessFileLineNumbers "\z\addons\dayz_code\init\publicEH.sqf";
      progressLoadingScreen 0.1;
      call compile preprocessFileLineNumbers "\z\addons\dayz_code\medical\setup_functions_med.sqf";
      progressLoadingScreen 0.15;
      call compile preprocessFileLineNumbers "\z\addons\dayz_code\init\compiles.sqf";
      call compile preprocessFileLineNumbers "server_traders.sqf";
      call compile preprocessFileLineNumbers "admintools\config.sqf"; // Epoch admin Tools config file
      call compile preprocessFileLineNumbers "admintools\variables.sqf"; // Epoch admin Tools variables
      if (_verCheck) then {
          #include "DZE_Hotfix_1.0.6.1A\init\compiles.sqf"
      };
       
       
      what's next?
       
      I do not really know what to :/  
      Thanks
  • Advertisement
  • Advertisement
  • Supporters
  • Advertisement
  • Discord

×