Jump to content
itsatrap

WAI: 1.0.0 - Alpha / Arma 3

Recommended Posts

was using this in with a3eai and sem on problem i seen with this WAI is that the A3EAI dynamic vehicle just despawns within 600m of you so you dont get see the vehicle

I removed this and there is no problem with any ai at the minute.

and some error on a file that is not found too  customsettings.sqf?

 

everything else seems ok and i removed the nuke mission as OTT for epoch

I would wait for a more stable version as i like WAI for a2 and wish it for a3 and work with other missions together

Share this post


Link to post
Share on other sites

Keep getting kicked battleye # 21 HELP PLEASE

 

remove/delete all filters from battleye folder and leave bans.epoch, bans, BEclient.dll ,BEserver.dll, BEserver

no more kicks for any script. Youll need to restart after removing them and make sure you backup all deleted files

 

There are tips/ways for adding the line to your filter on this site

hope this helps for you

Share this post


Link to post
Share on other sites

remove/delete all filters from battleye folder and leave bans.epoch, bans, BEclient.dll ,BEserver.dll, BEserver

no more kicks for any script. Youll need to restart after removing them and make sure you backup all deleted files

 

There are tips/ways for adding the line to your filter on this site

hope this helps for you

 

This is the worst advice ever.

Share this post


Link to post
Share on other sites

This is the worst advice ever.

 A*** for your ancer

 

you can find his needle in his haystack then

question was i get kicked for this i do not know what is this so delete to fix is an ancer === No kicks is what he wants??

 

 

my advice to keep BE filters go to the log of the kick publicvar or scripts etc and so and check the log of the publicvar or scripts etc and transfer that log from there to the file on the line erm #21 mabey #22  "cough" faf

 

i dont use BE so enjoy

Share this post


Link to post
Share on other sites

We are currently running VEMF, SEM & A3EIA on our server and by the sounds of it WAi would do all of these mission systems with just one script. Am i right with that assumption?

Share this post


Link to post
Share on other sites

Keep getting kicked battleye # 21 HELP PLEASE

Go to your scripts.log file in BE, and find what the kick was for, then add that exception to line 22 of your scripts.txt file. scripts.txt starts at 0, that is why you will place the exception on 22

Share this post


Link to post
Share on other sites

So found this in my server .rpt

 

11:22:41 Error in expression <index"];
_object = _this;

_object call EPOCH_server_setVToken;
_object setVaria>
11:22:41 Error position: <EPOCH_server_setVToken;
_object setVaria>
11:22:41 Error Undefined variable in expression: epoch_server_setvtoken

 

And it would seem the only mission we are getting right now is the bandit base camp, I am assuming this is because the other missions depend on vehicles?

 

Found the call on line 10 of functions.sqf

 

Anyone else have similar issues?

Share this post


Link to post
Share on other sites

So I've tried to install this to my Epoch Altis server, but I get a BattleEye Restriction #21 when trying to load into the server...

 

I've followed the instuctions, but there's one deviation... My mission pbo did NOT contain an init.sqf file, just three things:

 

$MIKERO$

description.ext

missions.sqm

 

I created a init.sqf in notepad and added the line of code required, [] execVM "wai\remote.sqf";

 

I also checked my scripts.log and this is all I came up with:

03.03.2015 12:20:48: Seldrad (xx.xx.xx.xx:xxxx) e5ffcfa57fac13af7f9bd7e37c72e8f8 - #21 "#line 1 "mpmissions\__CUR_MP.altis\init.sqf"
[] execVM "wai\remote.sqf";"

 

Replaced my IP with x's
 
Can anyone shed some light on what's going on?

Share this post


Link to post
Share on other sites

I've made some progress into my issue by adding an exception to remote.sqf in line 22 of the scripts.txt

 

That fixed the previous error, but now I'm getting:

03.03.2015 13:36:40: Seldrad (xx.xx.xx.xx:xxxx) e5ffcfa57fac13af7f9bd7e37c72e8f8 - #21 "xt;
sleep 1;
};
playsound "Alarm_BLUFOR";
};

0 = [_position] execVM "wai\nuke.sqf";
};

case "vehiclehit": {


diag_log("Blow f"

I've made an exception for nuke.sqf, but the error persists? What could be wrong now?

 

Still getting Script Restriction #21

Share this post


Link to post
Share on other sites

That's odd. Did you follow the instructions exactly? Like placing the wai folder with the two files in your epoch.Altis.pbo, and created a .pbo out of the a3_epoch_WAI.pbo file, and placed that in your @epochHive\adons folder? Well, exactly like the instructions of the OP.

Share this post


Link to post
Share on other sites

Yes, followed them at best I could here's a few screenshots:

 

 

7MuQKL7.png

YEvoHiA.png

 

 

This is my line 22 in scripts.txt

7 exec !="<execute expression=" !"RscDebugConsole_execute" !"execFSM" !"_executeStackedEventHandler" !"fn_execVM" !"fn_moduleExecute" !"fn_execRemote" !"fn_MPexec" !"bis_fnc_moduleExecute_activate" !"fn_tridentExecute" !"randomize_civ1" !"executed from" !"EPOCH_DebugGUI_exec" !"_handle = [_display] execVM _script;" !"execVM \"\A3\Structures_F\scripts" !="execVM \"\A3\Structures_F_EPC\Civ\PlayGround\scripts\Carousel_spin.sqf\"" !="execVM \"wai\remote.sqf\"" !="execVM \"wai\nuke.sqf\"" 

Any other suggestions?

Share this post


Link to post
Share on other sites

I have followed all instructions to the "T" made a pbo out of the wai file for the addons and placed it inside my epoch hive addons folder, and placed the wai folder into the mission pbo, also adding in the line of the init file... and tested it on my test server, nothing, updated to recent files, nothing, tested on main server... nothing ... wtf is wrong here? why some people can get it to run by just following these inscructions and mine just wont load? what am i doing wrong here?

Share this post


Link to post
Share on other sites

Yes, followed them at best I could here's a few screenshots:

 

 

7MuQKL7.png

YEvoHiA.png

 

 

This is my line 22 in scripts.txt

7 exec !="<execute expression=" !"RscDebugConsole_execute" !"execFSM" !"_executeStackedEventHandler" !"fn_execVM" !"fn_moduleExecute" !"fn_execRemote" !"fn_MPexec" !"bis_fnc_moduleExecute_activate" !"fn_tridentExecute" !"randomize_civ1" !"executed from" !"EPOCH_DebugGUI_exec" !"_handle = [_display] execVM _script;" !"execVM \"\A3\Structures_F\scripts" !="execVM \"\A3\Structures_F_EPC\Civ\PlayGround\scripts\Carousel_spin.sqf\"" !="execVM \"wai\remote.sqf\"" !="execVM \"wai\nuke.sqf\"" 

Any other suggestions?

 

Remove the = from the line so it will look like:

 

!"execVM "wai\nuke.sqf";"

 

Here's the explanation:

  • != The parameter must exactly match the exception. In scripts.txt the entire statement the keyword is found in must exactly match the exception.
  • ! The parameter must contain the exception. In scripts.txt the statement the keyword is found in must contain the exception.

Thanks, best regards

Share this post


Link to post
Share on other sites

So found this in my server .rpt

 

11:22:41 Error in expression <index"];

_object = _this;

_object call EPOCH_server_setVToken;

_object setVaria>

11:22:41 Error position: <EPOCH_server_setVToken;

_object setVaria>

11:22:41 Error Undefined variable in expression: epoch_server_setvtoken

 

And it would seem the only mission we are getting right now is the bandit base camp, I am assuming this is because the other missions depend on vehicles?

 

Found the call on line 10 of functions.sqf

 

Anyone else have similar issues?

 

Yes, it happens to me as well.

 

I have SEM and A3EAI running in parallel, so that's maybe why...

 

Missions and AI spawns, but I didn't yet tested if they are hostile towards players (I read someone else had issues with other missions AIs running at the same time).

 

Thanks, best regards

Share this post


Link to post
Share on other sites

We have had this running for a bit now, and yes they are hostile, and the missions seem to work pretty well all in all. There is an issue though that I can't seem to get sorted. It seems that the heli para issue conflicts with the A3AI mission, most times the choppers get close, and then disappear and send 3 or 4 AI shooting out, sometimes with parachutes, sometimes not. I've tried  slashing out the helidrop.sqf and helipatrol.sqf, dont have the names in front of me, so might not be exact names in the functions.sqf but they still seem to react the same way.

 

Its Alpha, and very early stages, so I expect lots of issues to work through as we continue to progress in this mod. Not even sure what will break when epoch deploys their update, so guess we will cross that bridge when we come to it. 

Share this post


Link to post
Share on other sites

I've installed it on a test server and it's working fine for me. The only problem I see so far is that I cannot get the Mission announcements to show up at all. I've changed it to Text and Radio but it doesn't say anything when a mission pops up. I have my global channel turned off so GLOBAL won't work either I assume. Not sure if there's an option that's blocking the mission announcements. If anyone has a suggestion I would greatly appreciate it.

Share this post


Link to post
Share on other sites

I also re-worked WAI from Arma 2 to Arma 3 platform. I run something like 15 different missions.

 

I recently added voting for a mission that has just started. Voting is based on addAction mouse wheel command on a Jammer object. It allows players to say it they are going for the current mission or they want to skip to the next. After 5 minutes the polling is closed and mission system keeps current mission or skips to the next one.

 

I don't run BE and I don't use stock AH on my server, so it might be a hassle for some of you to adapt my script to your environment. Anyway, let me know if you are interested to see how it works.

Share this post


Link to post
Share on other sites

We finally were on the server when the nuke went off last night. Holy crap, it was truly impressive. Not sure about overall range, but we did notice buildings over 600 meters away were leveled. It also left a fallout haze on the server until the next restart. Performance was slightly impacted, but nothing too bad, and it was for a very short time.

 

Not sure if you can edit things like that at this point SadBoy, and not even sure if any of these current settings won't break when the Epoch update comes out.

Share this post


Link to post
Share on other sites

I also re-worked WAI from Arma 2 to Arma 3 platform. I run something like 15 different missions.

 

I recently added voting for a mission that has just started. Voting is based on addAction mouse wheel command on a Jammer object. It allows players to say it they are going for the current mission or they want to skip to the next. After 5 minutes the polling is closed and mission system keeps current mission or skips to the next one.

 

I don't run BE and I don't use stock AH on my server, so it might be a hassle for some of you to adapt my script to your environment. Anyway, let me know if you are interested to see how it works.

I would be interested, I would just need to adapt something like this to the stock AH, which I can do, just time consuming.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By FG_Trap
      Made a quick static ai mission that spawns on restart. 
      12 ai patrol the compound 
      4 Static m2's
      1 Heli Patrolling the compound 
      Crate for who ever clears all the ai.
      Some screenshots of the compound 


       
      https://github.com/Trapxxgods/Wai-Static-Mission 
    • By Sandbird
      Dayz.Epoch.1.0.62 - 3d.Editor.Live.Mission with Database interaction


      -=Youtube Demo=-
       
      What is this
      A custom mission file for the purpose of testing/writing scripts for DayZ Epoch without the need of a server.
      It emulates the dayz_server and dayz_mission files, so you can write scripts using the 3d editor. No need to use a dayz_server for debugging anymore. We all know how time consuming that is.

      Features
      Full Database integration (yes thats right... [:)] I would suggest to have a maximum of 100 objects in your object_data table for faster results.
      Took 5 min to load 10000 objs from my real database, so also make sure you dont go crazy with the MaxVehicleLimit, MaxDynamicDebris values in the init.sqf Fully working GUI, zombies, hit registration, addactions, everything! Write code and execute it on the fly. No need to start a server and join with a client to test things. 100% of your scripts will work! (dynamic weather, default loadouts, custom scripts etc) 2 setups. A default 3d editor player with a default loadout or a Real database character based on your UID Includes most of BIS_fnc functions, so actions like BIS_fn_invAdd will work (i've added most common ones...more included though...check details bellow.) Everything works...when i say everything i mean EVERYTHING !. (Spawning objects on mission start, traders (buy/sell), maintenance, character update, events, stats...etc) New Features!
      All .FSM files have been converted to .SQF meaning the mission acts as a full fledged server / client merge. New character creation has been ignored though, so the server expects that the client that is about to connect exists in the database. The server will start, wait for a 'fake client connection to happen' (you pressing the Preview button), and then it will load your character from the database, spawn Hive objects and create new based on your MaxVehicleLimit values etc, then initialize the events and finally spawn the character to his worldspace location. Use AdminTools to spawn any Perm, Temp vehicle you want, including buildings, crates etc. Building objects is working as expected with a little AddAction trick. Unfortunately the primary display (eg: findDisplay 46) isnt working inside the editor. That means that building stuff or placing objects is very hard to do since we can't 'capture' keystrokes.
      Further details below after the Installation instructions. Arma2Net is not allowed by Battleye anymore, so i am using extDB3 now. Requirements:
      A mysql server on the same machine as your Arma2 editor. Well...a remote PC would work as well...just make sure YOU ARE NOT using your original database. Make a copy of it!. This mission will interact with your database !
      If you don't have a mysql server on your pc...i suggest you get WampServer. It's the easiest php/mysql server out there.
      Installation
      Head over to the GitHub where the project is. Click Download on the right sidebar, and extract the rar file. Copy the 3d.live1062.DayzEpochTemplate.Chernarus mission file in your \My Documents\ArmA 2\missions\ folder If your active Arma profile is not the default one, then you probably should extract it in the \My Documents\ArmA 2 Other Profiles 2\missions\ folder, otherwise you won't be able to find the mission inside the editor. Copy everything inside "Arma2OA root folder" in your root Arma2OA folder (the same folder where @DayZ_Epoch_Server, MPMissions are). The real_date.dll...(Thanks to killzonekid) is used to get your machine's date/time to be used for live day/night cycles inside the game (...you can set a fixed day if you want...details bellow). The tbbmalloc - tbbmalloc_x64.dll files are provided by extDB3. They shouldnt interfere with your normal game, but they are needed for the mission to be able to connect to your MySQL server. (Make a backup of your original ones if you want, just be safe.) EATbaseExporter is used by the AdminTools, and allows you to export bases to an .sqf format so you can import them afterwards to your server. Now edit -=START HIVE MISSION=-.bat which was placed in your Arma2 folder, and fix the paths to their proper values. If you are using DZLauncher then the @Dayz_Epoch folder is probably where i placed it myself.  Battleye needs to be disabled inside the editor otherwise the extDB3 addon will not work. The .bat is taking care of that. It will disable Battleye after 7 seconds. Depending on your machine, if you see that the time isn't sufficient, raise that value a little bit. A sample Database has been provided with me as a character and a basic loadout. You can of course use your own database, just remember to delete most of your Object_Data table vehicles. The more vehicles you have there, the longer it will take for the dayz_server to spawn them. If you just want to write a script independent of cars etc...why wait 5 minutes for the server to spawn 10000 vehicles :) Open "ArmaOA\@extDB\extdb3-conf.ini" and add your test database data there. I named the test SQL DB dayz_cherno [dayz_cherno] IP = localhost Port = 3306 Username = dayz Password = mypass123 Database = dayz_cherno # dayz_cherno is the name of the database (change it in both values) # localhost is your mysql server (could be an IP value as well) # 3306 your mysql port # dayz is your database username # mypass123 is your database password  
      When the game launches, press Alt+E, select Chernarus, then Load mission 3d.live1062.DayzEpochTemplate.Chernarus
      Open \My Documents\ArmA 2\missions\3d.live1062.DayzEpochTemplate.Chernarus\init.sqf
      Go to line 61 and start editing the values there. DB_NAME is the name of your database (same as the extdb3 config file).
      Add your PlayerUID value (same as the DB one) in line 72. (That the player you want to load from the database)
      Depending which map you want to use, you have to change the dayZ_instance variable and also the MarkerP values (line 62) based on your mission.sqm file. Its for the Hive to spawn random vehicles, roadblocks and mines at proper locations based on the map. Just read the comments there for how to get the values. Its really simple. Just copy paste stuff from your mission.sqm file.
      Default setup vs Database setup
      There are 2 ways of initializing your player.
      A live database player based on his UID in the character_data table (coordinates, medical states, inventory etc) A default 3d editor player with a basic loadout. (Ignores Hive Loadouts and initial vehicle spawns) Default setup (extDB3)
      [DefaultTruePreMadeFalse = true;] This option is now the default one, because it's so much easier to set up, plus a lot of things have changed in the 1062 Epoch version. I couldn't totally separate the server files from the client files, so in the end a Database is necessary for the Mission files to work properly. To setup your character with this method, leave DefaultTruePreMadeFalse to true;  Everything is database based..so no need to do anything else. The mission will start with all your stats, inventory, conditions and spawn you where your world coordinates are. Premade Character Setup
      [DefaultTruePreMadeFalse = false;] This setup DOES NOT initialize the character based on a database entry, or does any HIVE related queries on mission start. (like load objects etc). Instead it uses some premade stats that you set, and only uses the Database on updates (buy vehicles etc) The loadout of the player is set in the init.sqf in line 77  
      player setVariable ["CharacterID", "1", true]; // Set here the characterID of the player. It can be anything...just leave it 1 if you want. player setVariable ["playerUID", "111111", true]; // Set here the playerUID of the player you want to have. player setVariable["Z_globalVariable", 100000]; player setVariable["Z_BankVariable", 100000]; player setVariable["Z_MoneyVariable", 100000]; player setVariable["humanity", 11000]; player setVariable["humanKills", 10]; player setVariable["banditKills", 20]; player setVariable["zombieKills", 30]; player setVariable ["friendlies", ["222222","333333"], true]; //Both DZE_Friends and this must be set for friendlies to work properly DZE_Friends = ["222222","333333"]; Everything else should work fine with the database....like traders, salvaging, etc...Unfortunately since the 1062 ver had many differences from the 1051 one, i couldn't really make this Profile option a standalone one, without any Database interaction. So in order for you to minimize any errors in the log file, i would suggest you load my sample db file provided, and also change those CharacterID and PlayerUID values in PLAYER_Data and CHARACTER_Data tables to the ones you set up here, just in case.... The Premade character setup is for people that want to fast debug a script they are making and don't want to wait for the Hive to load all map objects and authenticate the player first. Further Details to change (in both Profile Cases)
      The description.ext, mission.sqf, mission.biedi files have your character's name in them. Just search for the word Sandbird in all of them and change it according to the PlayerName value you have in your Player_DATA table for your PlayerUID value.
      Example taken from description.ext. DONT change the actual My_Player text. The mission file needs that string to read what you typed in the name field.
      class My_Player { name="Sandbird"; face="Face20"; glasses="None"; speaker="Male01EN"; pitch=1.1; };  
      Important info
      Init.sqf values
      DefaultTruePreMadeFalse = true; // True: Read player's data from the database (based on UID), False: the normal player the editor has StaticDayOrDynamic = true; // A static date is set at the bottom of \dayz_server\init\server_function.sqf. Set this to false if you want real time/date inside the mission. DZEdebug = false; // Set to true if you want a more detailed log file Enable Keyboard actions (menu option) // (findDisplay 46) wont work inside the editor. That means that building stuff or placing objects is very hard to do since we cant 'capture' keystrokes. I kinda fixed this with a trick. In order to build something first you have to initiate the building action (holding the object in your hands) and then scroll with your mouse wheel and select Enable Keyboard actions. This will create a layer on your screen capturing your keystrokes thus allowing you to change orientations etc. Pressing ESC twice after and it will close the fake display and return to normal play mode. You will have to do this every time you want to build something. Related to coding
      Since the Editor has some limitations because its not a real server some things will never work. For example:
      _playerUID = getPlayerUID player; will never work in the editor. To get the _playerUID you have to do this:
      _playerUID = player getVariable ["playerUID", 0];
      This is the most important thing to remember. Lots of scripts use getPlayerUID. You have to remember to change it every time you want to use it.  Of course the player value is just an example here. If you were inside a loop and it had (getPlayerUID _x) then you have to rewrite it like this: (_x getVariable["PlayerUID",0]) findDisplay 46 does not work in the editor. If you are using/making a script that uses Display 46 try using my Enable Keyboard action. It might work in your case. publicvariableServercommands don't exist in the editor. There is no server to accept the command. If you want to use addpublicvariableeventhandler you can do it with call/spawn commands. You can find the handlers usually in the PublicEH.sqf.
      Example: PVDZE_plr_Save = [player,dayz_Magazines,false,true]; publicVariable "PVDZE_plr_Save"; can be written like:
      PVDZE_plr_Save = [player,dayz_Magazines,false,true]; publicVariableServer "PVDZE_plr_Save"; // keeping this so when you move the code to the real server you remember to add it. [player,dayz_Magazines,false,true] spawn server_playerSync; // what to call is usually inside publicEH.sqf. In this case search for PVDZE_plr_Save in the PublicEH file and check the call it makes in the end. You could also change the publicVariableServer to publicVariable. That should work inside the editor. But keep in mind these changes wont work on the live server, since one command broadcasts something to the server while the other just to the client running it. I would suggest you keep the original value and do the PublicEH call instead, marking it down with some debug comments next to it, so when you are done and want to transfer the files to your live server you just remove the call and everything should work as expected.
      Don't forget to change the paths when you are adding addons to test/modify them. For example, notice the differences here:  player_switchModel = compile preprocessFileLineNumbers "dayz_code\compile\player_switchModel.sqf"; player_checkStealth = compile preprocessFileLineNumbers "\z\addons\dayz_code\compile\player_checkStealth.sqf"; The first line will look up for player_switchModel.sqf inside the editor mission files, while the 2nd one will go to the @Dayz_Epoch map file and get the .sqf file. Same thing applies for the dayz_server files (server_functions.sqf). Once you are done with your script and you have added new compile lines, you need to fix them back to their proper values before you upload them to your live server.
        If you are missing any BIS_fnc functions then check the folder dayz_code\system\functions and see if it's available there to include it in the compiles.sqf. Set DZEdebug = true;  in the init.sqf. And ALWAYS check your RPT log file for debugging. Its located at : %AppData%\Local\ArmA 2 OA folder. Related to mission file included
      You'll notice when you start the mission there are 2 bots standing there. If you double click the soldier you'll see that he initiates this script scripts\BotInit.sqf. I left that in purpose in case you want to do some scripting that requires 'another player', and you want to initialize the fake player like that. The other bot can be deleted. I just left it there because i was testing a Tag Friendly script, and needed a 3rd 'player' that has me as a friend. I've included a simple Fireworks script i made a while back only this time i used some better effects taken from aliascartoons work. Just add a 'SMAW_HEDP' into your inventory and right click on it to test it out. Here is how the old script used to look like Fireworks. Also you'll find a little 'hat script' in the files, just right click a 'IRStrobe' item to add a hat to your player. Both script were written inside the editor using the mission file above...just a small example to show you how easy it is to write code there. The @extDB folder contains a folder called debug_files. These .dlls (when replaced the ones provided) activate a more detailed log file (found under arma 2 operation arrowhead\logs folder). It will show ALL MySQL queries going in/out of the database. Very useful if you are running any custom SQL queries and the RTP log file isn't enough.
      Final Notes
      These are heavily modified files...Dont overwrite them with your own files. Add to them instead of replacing them.
      If you are writing scripts that dont require the server to restart, then you can just go to 2D editor and press Preview again after you make the changes. No need to hit Restart. As long as you are doing changes that doesnt affect the Hive loading you can basically run things on the fly. For example in the init.sqf at the bottom i added a Add BankMonkey example. That command just loads the custom\money.sqf and shows a simple extDB3 example on how to select/update a DB table. Since this command doesnt require the server to restart, you can just hit Preview, test things out, and if you want to make changes, go back to 2D Editor, edit your changes in the money.sqf file and hit Preview again. No need to hit Restart and wait for the dayz_server functions to do their thing again.
      The whole purpose of this project was to not waste any more time trying to code on this god forsaken Arma engine.
      And a personal note....You will NEVER find an easier way to code stuff for Dayz....period. This is the fastest way to write code and see it in action.

      Hope this code will help you write code faster and easier !
      ### Credits
      This mission file would not be possible without the help of these addons/people

      DayzEpochTeam | http://epochmod.com
      killzonekid | http://killzonekid.com
      extDB3 | https://bitbucket.org/torndeco/extdb3/wiki/Home
      ebayShopper | https://github.com/ebayShopper/TestKit
      JasonTM (for the latest beta AdminTools)| https://epochmod.com/forum/topic/44863-release-epoch-admin-tools-v-1107-test-branch/
    • By gskyline203
      First off I'm sure this question would be more appropriate on the DayZ Launcher Forums, but their email servers are screwed and i cant login, so im hoping someone here might be able to help me.
      I used this youtube video to set up my bare bones epoch server.
      Everything went well, and the server runs with no errors in the .RPT file. I can join it through the LAN server browser within Arma 2 OA just fine. What I am trying to do now is make my server joinable in public server lists like dayz launcher.
      I have port forwarded the arma ports and steam client ports as well.
       
      I have also allowed arma 2, arma 2 OA, arma2oaserver, and steam client through my firewall. 
      My server does show up on dayz launcher but as "Offline" with 0/0 players and 9999 ping. ( I dont know if I can only see it because its on my own network maybe? ) *Linksys Router*
      but that is my issue.
      This server is running on my dedi box at home with high speed download and upload (should be plenty) .
      I also made my dedi box's ip static. ( i did this after i created the server so maybe thats a no no?)
      Like I said I can join in just fine but only through the LAN browser in game. 
      I used a port checker to ensure my ports were in fact open, and used the dayz launcher server checker to ensure it can be found, and it did find it and said it would be added to the server list within 30 minutes. ( it did! but it shows up as offline! and unjoinable)
      *I have no idea if this means anything but i used mySQL with HeidiSQL when setting up my server* (I also ensure that the mysql service is running when i start my server up).
      At this point I have no idea what to do, so any thoughts would mean the world to me, thanks!
      Server IP = 97.91.203.245:2302 (steam query = 2303)
      ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
      P.S. Here is my "11_chenarus.cfg" and "basic.cfg" (again, im not sure if these are helpful but ill include them anyway)

       
       
       
    • By JayJay
      Hi everyone,
      As you can see im a freshy, ive not played much of Arma3 but i played some epoch/ ryans zombies and fell in love :) 
      I have no experience in setting up a server but enjoy the epoch version so much so i had to try to set a server up and if im honest ive been struggling (alot) , ive managed to rent a server and put epoch onto it with ryans zombies, set the time so i play in day light.
      but now im having trouble with loot items not being in buildings and even though i have the zombie mod on i cant see any zombies :/  
      If anybody can help me it would be really appreciated , i do have discord if that helps and i dont mind paying for your time.
      I dont want anything to crazy just EPOCH and zombies with loot :D 
      Bitten off more than i can chew :/
    • By victorks
      my first work in editin :) https://uploaddeimagens.com.br/imagens/20180307202515_1-jpg https://uploaddeimagens.com.br/imagens/20180307202245_1-jpg DOWNLOAD: https://www.dropbox.com/s/oq97j7x59362kqe/CASTLEai.sqf?dl=0 AI M2 NEED WAI: https://pastebin.com/GJMnPvZP ON THE MAP: https://pastebin.com/cyqH9rNV  
       
      https://www.dropbox.com/s/oq97j7x59362kqe/CASTLEai.sqf?dl=0
       
       
       
       
       
       
       
       
       
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...