Jump to content
emwilsh

{Request} Vehicle Garage

Recommended Posts

wait one sec, just recognized a wired issue. When retrieving a vehicle with contents inside the spawn script throws and error and therefore no objectID is set.

Need to sort out if it could come from the fix or if it´s in general from ZSC 3

 

updated my OP.

 

Confirmed working, thanks a mill man.

Share this post


Link to post
Share on other sites

I have it working but got 2 problems

1st  is   No Enrty 'mpmission\__Cur_MP.Napf descripiton.ext/Vehicle_store_list/controls/vehicleList.soundSelect

 

2nd is when putting the vehicle in the garage the cost is not taking away from the player.

 

with no errors rpt client or server side

 

I know what the problems is with the number 2 issue its coded for SC 3.0 I'm using 2.0 trying to figure out how to recode it for 2.0

 

UPDATED

 

Issue 2 Solved still getting the 1 issue still not sure whats up with this one.

 

 

SOLVED ALL ISSUES

Share this post


Link to post
Share on other sites

This is probably a stupid question but i'm not to familiar with databases and am kinda stuck, can someone give the query i need to run to add the table and we add it in player data correct? 

Share this post


Link to post
Share on other sites

we can't store vehicles shielded?

 

What do you mean with shielded? Upgraded Vehicles?

 

This is probably a stupid question but i'm not to familiar with databases and am kinda stuck, can someone give the query i need to run to add the table and we add it in player data correct? 

 

The query is in the SQL.txt. (https://seafile.zombieapo.eu/d/1cdde343bd/files/?p=/Virtual%20Garage/SQL.txt)

Share this post


Link to post
Share on other sites

These files were stolen from my old Chernarus server...So 'HE' stole the files.....why else would he have 6months old files on his computer.... "not taking credit" my ass.

I mean wtf...i spend 3 weeks in making something to populate my clan's server and a 'SadPanda' type of guy comes and release it in public.

 

And @TehGunz .... good luck decoding them. The time you'll spend in decoding my mission files could be spent in learning how to code and do things yourself.

"Lets not get too dramatic here".....how about I join your server, steal anything custom you've made and release it in public...so you got nothing unique on your server anymore.

Would you like that? Unless of course you are just a copy/paster...with 0 coding knowledge....then yeah....i understand why you wouldnt get pissed off.

 

FFS i made the 3d.live.mission just for this reason...so people can learn to code and debug in dayz the fastest way possible, without having to start a server and test things....only to be backstabbed again by yet another guy....You stole the files? Fine....use them for your own server....dont make them public you noob without asking first.

 

Screw this.....i wont be releasing anything else until i see soulfinder banned.

no such thing as stealing its there for the downloading,stop being a bitch and pull your head out of your ass.

Share this post


Link to post
Share on other sites

I have it working but got 2 problems

1st  is   No Enrty 'mpmission\__Cur_MP.Napf descripiton.ext/Vehicle_store_list/controls/vehicleList.soundSelect

 

2nd is when putting the vehicle in the garage the cost is not taking away from the player.

 

with no errors rpt client or server side

 

I know what the problems is with the number 2 issue its coded for SC 3.0 I'm using 2.0 trying to figure out how to recode it for 2.0

 

UPDATED

 

Issue 2 Solved still getting the 1 issue still not sure whats up with this one.

 

 

SOLVED ALL ISSUES

What did you do for this?

Share this post


Link to post
Share on other sites

 

Hey GZA I get this in my rpt log when I try to remove a vehicle from the garage, the vehicle does come out but it spawns in the middle of the map, any ideas?

 

15:10:00 "HIVE: WRITE: "CHILD:388:71001774973095470:""
15:10:00 "CUSTOM: Selected "350""
15:10:00 Error in expression <)];
};
_countr = _countr + 1;
} forEach _objWpnTypes; 
 
 
_objWpnTypes = (_invent>
15:10:00   Error position: <_objWpnTypes; 
 
 
_objWpnTypes = (_invent>
15:10:00   Error Undefined variable in expression: _objwpntypes
15:10:00 File z\addons\dayz_server\compile\garage\server_spawnVehicle.sqf, line 129

 

I too get this error can anyone help on this?

Share this post


Link to post
Share on other sites

What did you do for this?

In the common.hpp file in the the garage folder in class Life_RscListBox add this soundSelect[] = { "", 0, 1 }; under this  sound[] ={ "", 0, 1 };

 

sound[] ={ "", 0, 1 };

soundSelect[] = { "", 0, 1 };

 

and the second issue was fixed by adding this

 

_removed = [player, 5000] call SC_fnc_removeCoins;

if(_removed = true)then{  GREAT SUCCES  }else{ IT FAILED, not enough money};

 

the 5000 is the set price change the value to what ever price you want to pay for.

 

at the very bottom of your player_storeVehicle.sqf

 

yes there is a call for SC_fnc_removeCoins near the top but it is coded for 3.0 not 2.0 so it works but you will need to add a new sqf file to make this work

 

Share this post


Link to post
Share on other sites

I figured out that this error only happens when you get the vehicle from the garage

 
 
16:15:18 "HIVE: WRITE: "CHILD:388:50396973530373:""
16:15:18 "CUSTOM: Selected "341""
16:15:19 Error in expression <)];
};
_countr = _countr + 1;
} forEach _objWpnTypes; 
 
 
_objWpnTypes = (_invent>
16:15:19   Error position: <_objWpnTypes; 
 
 
_objWpnTypes = (_invent>
16:15:19   Error Undefined variable in expression: _objwpntypes
16:15:19 File z\addons\dayz_server\compile\garage\server_spawnVehicle.sqf, line 129
 
I have been testing it for a while. The vehicle's do spawn and same for the key. 

Share this post


Link to post
Share on other sites

 

I figured out that this error only happens when you get the vehicle from the garage

 
 
16:15:18 "HIVE: WRITE: "CHILD:388:50396973530373:""
16:15:18 "CUSTOM: Selected "341""
16:15:19 Error in expression <)];
};
_countr = _countr + 1;
} forEach _objWpnTypes; 
 
 
_objWpnTypes = (_invent>
16:15:19   Error position: <_objWpnTypes; 
 
 
_objWpnTypes = (_invent>
16:15:19   Error Undefined variable in expression: _objwpntypes
16:15:19 File z\addons\dayz_server\compile\garage\server_spawnVehicle.sqf, line 129
 
I have been testing it for a while. The vehicle's do spawn and same for the key. 

 

 

You can ignore this error. It will fix this asap. It happens because the array is empty if the gear is empty.

 

EDIT: It's fixed. Redownload and replace server_spawnVehicle.sqf.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Advertisement
  • Advertisement
  • Supporters
  • Advertisement
  • Discord

×