Jump to content
OneManGang

[RELEASE] PackLockMove 1.0

Recommended Posts

I've seen this, I think it is the anti-hack that is not allowing the user to create a crate full of stuff. I haven't looked into solving it since it would probably break the anti-hack system too,

I don't use any antihack.... if I spawn a public crate in with the admin tools, the crate disappears as i release it. If I spawn a private crate, I can move, load, unload and release and the crate stays. I removed it from the servers that it doesn't work on and went back to R3F which works fine. Can't seem to put my finger on why PLM doesn't work when it's the code from R3F

 

-CJ-

Share this post


Link to post
Share on other sites

Can anyone provide any further advice. i have the same issue as CJ. I can pick up move, pack/load, lock/unlock and unload but as soon as I go to drop the item it disappears. I get the following error in RPT
 

22:35:51 "DELETE: Deleted by ID: 16113"


22:35:51 Error in expression } else {

_key >
22:35:51 Error position: <_activatingPlayer,_id];
} else {

_key >
22:35:51 Error Undefined variable in expression: _activatingplayer
22:35:51 File z\addons\dayz_server\compile\server_deleteObj.sqf, line 15

 

And the corresponding server_deleteObj.sqf

 

server_deleteObj.sqf



/*
[_objectID,_objectUID] call server_deleteObj;
*/
private[&quot;_id&quot;,&quot;_uid&quot;,&quot;_key&quot;];
_id = _this select 0;
_uid = _this select 1;
_activatingPlayer = _this select 2;

if (isServer) then {
//remove from database
if (parseNumber _id &gt; 0) then {
//Send request
_key = format[&quot;CHILD:304:%1:&quot;,_id];
_key call server_hiveWrite;
diag_log format[&quot;DELETE: %1 Deleted by ID: %2&quot;,_activatingPlayer,_id];
} else {
//Send request
_key = format[&quot;CHILD:310:%1:&quot;,_uid];
_key call server_hiveWrite;
diag_log format[&quot;DELETE: %1 Deleted by UID: %2&quot;,_activatingPlayer,_uid];
};
};


 

I appreciate any help. I am a complete novice at this and trying to learn as I go but I have been trying to get Tow and lift and pack move lock with either this script and logistic tow or with R3F for the last couple of days. I have got this one almost completely satisfactory except for the issue of dropping the box and it disappears.

 

Am i missing some BE Filters? I have added PLM and PLM_ to publicvariable

 

Thanks

Share this post


Link to post
Share on other sites
Guest

Can anyone provide any further advice. i have the same issue as CJ. I can pick up move, pack/load, lock/unlock and unload but as soon as I go to drop the item it disappears. I get the following error in RPT

 

22:35:51 "DELETE: Deleted by ID: 16113"

22:35:51 Error in expression } else {

_key >

22:35:51 Error position: <_activatingPlayer,_id];

} else {

_key >

22:35:51 Error Undefined variable in expression: _activatingplayer

22:35:51 File z\addons\dayz_server\compile\server_deleteObj.sqf, line 15

 

And the corresponding server_deleteObj.sqf

 

server_deleteObj.sqf

/*

[_objectID,_objectUID] call server_deleteObj;

*/

private[&quot;_id&quot;,&quot;_uid&quot;,&quot;_key&quot;];

_id = _this select 0;

_uid = _this select 1;

_activatingPlayer = _this select 2;

if (isServer) then {

//remove from database

if (parseNumber _id &gt; 0) then {

//Send request

_key = format[&quot;CHILD:304:%1:&quot;,_id];

_key call server_hiveWrite;

diag_log format[&quot;DELETE: %1 Deleted by ID: %2&quot;,_activatingPlayer,_id];

} else {

//Send request

_key = format[&quot;CHILD:310:%1:&quot;,_uid];

_key call server_hiveWrite;

diag_log format[&quot;DELETE: %1 Deleted by UID: %2&quot;,_activatingPlayer,_uid];

};

};

 

I appreciate any help. I am a complete novice at this and trying to learn as I go but I have been trying to get Tow and lift and pack move lock with either this script and logistic tow or with R3F for the last couple of days. I have got this one almost completely satisfactory except for the issue of dropping the box and it disappears.

 

Am i mission some BE Filters? I have added PLM and PLM_ to publicvariable

 

Thanks

 

 

In move_object.sqf search for:

PVDZE_obj_Delete = [_oldObjectID,_oldObjectUID];
			publicVariableServer "PVDZE_obj_Delete";
			if (isServer) then {
				PVDZE_obj_Delete call server_deleteObj;
			};

And change to:

 

PVDZE_obj_Delete = [_oldObjectID,_oldObjectUID,player];
			publicVariableServer "PVDZE_obj_Delete";
			if (isServer) then {
				PVDZE_obj_Delete call server_deleteObj;
			};

Share this post


Link to post
Share on other sites

Thanks for that UKMartin. The change removed error from RPT but item still disappears.

 

I have also fired up server with no BE filters (just to check) and get the same thing happen. As soon as i "drop object" it disappears.

 

Still scratching head.

Share this post


Link to post
Share on other sites

In move_object.sqf search for:

PVDZE_obj_Delete = [_oldObjectID,_oldObjectUID];			publicVariableServer "PVDZE_obj_Delete";			if (isServer) then {				PVDZE_obj_Delete call server_deleteObj;			};
And change to:

PVDZE_obj_Delete = [_oldObjectID,_oldObjectUID,player];			publicVariableServer "PVDZE_obj_Delete";			if (isServer) then {				PVDZE_obj_Delete call server_deleteObj;			};

That's not correct. I added that code to handle the moving of the object. Otherwise it would duplicate it.

The anti hack I'm referring to is the one that prevents a user from creating random boxes. I'm not sure where it is and you may have tom adjust it the same way you have to allow players to spawn vehicles like bikes and atv's, but the difference is players will be able to spawn crates too. That's why I did t really go after it, I did t feel like adding extra layers of security.

As to why R3F allows it and this doesn't, I couldn't tell you, i just translated it and fixed some logic errors that I was finding. If R3F works, you should use that since this is the same code, just without towing. You can disable towing in R3F I believe.

Share this post


Link to post
Share on other sites
Guest

That's not correct. I added that code to handle the moving of the object. Otherwise it would duplicate it.

The anti hack I'm referring to is the one that prevents a user from creating random boxes. I'm not sure where it is and you may have tom adjust it the same way you have to allow players to spawn vehicles like bikes and atv's, but the difference is players will be able to spawn crates too. That's why I did t really go after it, I did t feel like adding extra layers of security.

As to why R3F allows it and this doesn't, I couldn't tell you, i just translated it and fixed some logic errors that I was finding. If R3F works, you should use that since this is the same code, just without towing. You can disable towing in R3F I believe.

 

Well the code i posted is for the error, that an object is not being deleted properly, because server delete object expects 3 parameters (last is the player, who calls it!). Therefore it has to be called like that, otherwise it wouldn't delete the object, unless you call it directly from the server, which i would actually recommend.

 

Share this post


Link to post
Share on other sites

I don't understand how this works. How do you load something, such as a bicycle, into a vehicle? I added it to my test server but I don't see any options for this. Is there a video of this script in action?

if I remember correctly you scroll on the PLM_CFG_transporters (ural) and it gives option to load nearest PLM_CFG_transportable_objects (bicycle) 

 

just make sure the vehicle you scroll on is in your PLM_CFG_transporters list and your bicycle is in your PLM_CFG_transportable_objects list. array 

 

here is mine.....

 

config.sqf

 

PLM_CFG_transportable_objects =  [
["HMMWV_Base", 80],
["HMMWV_Avenger", 80],
["HMMWV_M998A2_SOV_DES_EP1", 80],
["USBasicAmmunitionBox",12],
["USOrdnanceBox",5],
["RUBasicAmmunitionBox",12],
["LocalBasicAmmunitionBox",12],
["GuerillaCacheBox",12],
["ReammoBox_EP1",12],
["USBasicWeaponsBox",12],
["BAF_BasicAmmunitionBox",12],
["RUVehicleBox",12],
["BAF_BasicWeapons",12],
["USSpecialWeaponsBox",12],
["TKBasicAmmunitionBox_EP1",12],
["RUBasicWeaponsBox",12],
["UNBasicWeapons_EP1",12],
["USBasicAmmunitionBox_EP1",12],
["BAF_OrdnanceBox",12],
["MMT_Civ",3],
  ["ATV_US_EP1", 20],
       ["CSJ_GyroC", 20],
       ["CSJ_GyroCover", 20],
       ["CSJ_GyroP", 20],
       ["Old_bike_TK_INS_EP1", 25],
       ["Old_moto_TK_Civ_EP1", 25],
       ["USVehicleBox_EP1", 12],
       ["TKSpecialWeapons_EP1", 12],
       ["BAF_VehicleBox", 12],
       ["USLaunchersBox", 12],
       ["RUOrdnanceBox", 12],
       ["M1030_US_DES_EP1", 25],
       ["TT650_Civ", 25],
       ["TT650_Ins", 25],
  ["Pchela1T", 25],
  ["Ka137_PMC", 25],
  ["Ka137_MG_PMC", 25],
       ["TT650_TK_CIV_EP1", 25]   
];


PLM_CFG_moveable_objects = [
"USBasicAmmunitionBox",
"USOrdnanceBox",
"RUBasicAmmunitionBox",
"LocalBasicAmmunitionBox",
"GuerillaCacheBox",
"ReammoBox_EP1",
"USBasicWeaponsBox", 
"FoodBox0",
  "LocalBasicAmmunitionBox", 
"BAF_BasicAmmunitionBox",  
"RUVehicleBox",  
"BAF_BasicWeapons",  
"USSpecialWeaponsBox",  
"TKBasicAmmunitionBox_EP1", 
"RUBasicWeaponsBox",  
"UNBasicWeapons_EP1", 
"USBasicAmmunitionBox_EP1", 
"BAF_OrdnanceBox", 
"MMT_Civ"

];

 

can somebody remind me how to make spoilers please ?

I seem to have forgot!

Share this post


Link to post
Share on other sites

if i move a object ( workbench) it flys after restart in the air

 

and any fix for this?

22:35:51 Error Undefined variable in expression: _activatingplayer
22:35:51 File z\addons\dayz_server\compile\server_deleteObj.sqf, line 15

 

with add player to the move_object it duplicated

Share this post


Link to post
Share on other sites

I've seen this, I think it is the anti-hack that is not allowing the user to create a crate full of stuff. I haven't looked into solving it since it would probably break the anti-hack system too,

Does anybody have any idea what would cause the crate to despawn when they are released? Not running any antihack and they they disappear when unloaded and released.

 

-CJ-

Did anyone manage to get a fix for this problem thanks thanks.....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By salival
      Hi,
      Here's a script I wrote that does the following from right clicking your key in your toolbelt:
      Unlock/lock vehicle. Turn engine on/off. Eject players not in your group. This uses @mudzereliclick actions mod as a dependency (https://github.com/mudzereli/DayZEpochDeployableBike/tree/master/overwrites/click_actions) because it's awesome.
      Thanks to @Pattohfor the idea for this script.
      For downloading and install instructions, see my github: https://github.com/oiad/remoteVehicle
    • By harcosgoogle
      Hi!
       
      How to lock server pbo file? (mpmission)
    • By harcosgoogle
      Hi.
      There is a problem with closed vehicles,
      Example: Spawn locked vehicle bug,Buy locked vehicles,Sell locked vehicles (error code)
      No one writes that I could shut it down.
      Photos links:
      https://prntscr.com/f8ut13 - No lock menu
      https://prntscr.com/f8utap - trader spawn bug
      https://prntscr.com/f8utjo - lost car,added key
       
      1(one) he was able to lay down the vehicle,But it does not work afterwards
       
    • By SryImAnooB
      Hey guys,
      i want to add the Bmp 2 ( BMP2_HQ_TK_EP1) but got the problem that there is no option for Lock or Unluck it.
      Any ideas?
    • By dztancem8
      Seen a couple of threads now linking to this problem of the server rolling back and not saving the object / vehicle COORDS on restart.
      - I use PRMS (Added by GamingDeluxe) which restarts the server like BEC
      Problem with this is that I have my server to restart every 4 Hours and it only restarts every 2 hours? This could be the cause?
       
      Threads such as: are similar to to my problem
      https://forums.dayz.com/topic/68181-1725-tents-and-vehicle-inventories-not-saving/
       
      So if I spawn in a vehicle using Infistar for a player
      Then the player drives this vehicle around the map anywhere
      After 2 hours the server will restart prematurely (when its set to 4 hour restarts on PRMS) 
      And will then move this spawn vehicle back to the position to where I spawned it
       
      This is the same with players creating bases, or adding items to safes or vehicles. The server simply rolls back to the start of the server restart. I think this could be a problem with a Server_update file as it is not saving the positions but I read on the other thread this is not the case...
      Any ideas?
      - Dztance
       
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...