Jump to content
  • 0
Sign in to follow this  
Externized

BEC Configuration

Question

24 answers to this question

Recommended Posts

  • 0

 Here is a slice of my scheduler.xml.

 

<job id='0'>
<day>1,2,3,4,5,6,7</day>
<start>002500</start>
<runtime>002500</runtime>
<loop>-1</loop>
<cmd>say -1 Your Message</cmd>
</job>

 

This will run 25mins after server start and loop forever at 25 min intervals.

 

Change the job id to suit.

Change "Your Message" to what ever.

 

Useful link

 

 

*Post your scheduler.xml

Share this post


Link to post
Share on other sites
  • 0

That's not the problem i understand the coding, and i think mine is right i'll post it under here 

<?xml version="1.0"?>

<Scheduler>
        <job id="0">
        <time>00:10:00</time>
        <delay>000000</delay>
        <day>1,2,3,4,5,6,7</day>
        <loop>1</loop>
        <cmd>say -1 Test Test Test!</cmd>    
        <cmdtype>0</cmdtype>            
    </job>
    <job id="1">
        <time>03:50:00</time>
        <delay>000000</delay>
        <day>1,2,3,4,5,6,7</day>
        <loop>1</loop>
        <cmd>say -1 Server Restart in 10 Minutes!</cmd>    
        <cmdtype>0</cmdtype>            
    </job>
    <job id="2">
        <time>03:55:00</time>
        <delay>000000</delay>
        <day>1,2,3,4,5,6,7</day>
        <loop>1</loop>
        <cmd>say -1 Server Restart in 5 Minutes!</cmd>    
        <cmdtype>0</cmdtype>        
    </job>
    <job id="3">
       <time>03:58:00</time>
        <delay>000000</delay>
        <day>1,2,3,4,5,6,7</day>
        <loop>1</loop>
        <cmd>say -1 Server Restart in 2 Minutes! LOGOUT NOW!</cmd>    
        <cmdtype>0</cmdtype>        
    </job>
        <job id="4">
       <time>04:00:00</time>
        <delay>000000</delay>
        <day>1,2,3,4,5,6,7</day>
        <loop>1</loop>
        <cmd>#shutdown</cmd>    
        <cmdtype>0</cmdtype>        
    </job>
</Scheduler>

 Here is a slice of my scheduler.xml.

 

<job id='0'>
<day>1,2,3,4,5,6,7</day>
<start>002500</start>
<runtime>002500</runtime>
<loop>-1</loop>
<cmd>say -1 Your Message</cmd>
</job>

 

This will run 25mins after server start and loop forever at 25 min intervals.

 

Change the job id to suit.

Change "Your Message" to what ever.

 

Useful link

 

 

*Post your scheduler.xml

 

Share this post


Link to post
Share on other sites
  • 0

Depends on BEC version. As of BEC 1.6 your setup wont work anymore. If your file doesnt work its safe to assume you are running on >= 1.6. You mention working restarts, since only #shutdown (which does not restart anything) is handled in this file i'm guessing restart are handled differently by your host.

Share this post


Link to post
Share on other sites
  • 0

Depends on BEC version. As of BEC 1.6 your setup wont work anymore. If your file doesnt work its safe to assume you are running on >= 1.6. You mention working restarts, since only #shutdown (which does not restart anything) is handled in this file i'm guessing restart are handled differently by your host.

I Made a support ticket and got the answer to do what i already did, so even my own host can't help me..

 

Code now;

<?xml version="1.0"?>
<Scheduler>
     <job id='0'>
<day>1,2,3,4,5,6,7</day>
<start>001000</start>
<runtime>002500</runtime>
<loop>1</loop>
<cmd>say -1 Test Test Test!</cmd>
</job>
</Scheduler>

Host reply at ticket;

Hi Thibo,

See our example scheduler with 4-hour restarts and warnings: http://pastebin.com/f3EF5ezH

You will need to put this in BEC\Config\Scheduler.xml. After that is done, please make sure that the bans.txt file exists in Bliss\BattlEye. If it does not, simply create a blank bans.txt file with no content and save it.

Regards,

Blake Irwin
[email protected]
Network Administrator

Share this post


Link to post
Share on other sites
  • 0

Don't solely rely on your host to be competent. Find out what BEC version you are running and report back. (You did ensure there is a bans.txt file in that directory?)

Share this post


Link to post
Share on other sites
  • 0

If you want to test quickly, change '<start>001000</start>' to '<start>000010</start>' = start after 10 seconds

Change '<runtime>002500</runtime>' to '<runtime>000010</runtime>' loop after 10 seconds from start.

 

Change '<loop>1</loop>' to '<loop>-1</loop>'    -1 = infinite loop

Share this post


Link to post
Share on other sites
  • 0

I have no idea what version it is, i search all my files/logs about BEC and the installers but nothing.. I found a error in my BEC log, and yes i added the bans.txt file in the right map. 

 

Error;

# 08:47:25 : Config Error : ConsoleHeight must be set a number, using height 55.
08:47:25 : Config Error : ConsoleWidth must be set to a number, using width 110
09:20:52 : Config Error : ConsoleHeight must be set a number, using height 55.
09:20:52 : Config Error : ConsoleWidth must be set to a number, using width 110
09:21:16 : Config Error : ConsoleHeight must be set a number, using height 55.
09:21:16 : Config Error : ConsoleWidth must be set to a number, using width 110
09:21:41 : Config Error : ConsoleHeight must be set a number, using height 55.
09:21:41 : Config Error : ConsoleWidth must be set to a number, using width 110
09:32:58 : Config Error : ConsoleHeight must be set a number, using height 55.
09:32:58 : Config Error : ConsoleWidth must be set to a number, using width 110
10:00:12 : Config Error : ConsoleHeight must be set a number, using height 55.
10:00:12 : Config Error : ConsoleWidth must be set to a number, using width 110
11:22:59 : Config Error : ConsoleHeight must be set a number, using height 55.
11:22:59 : Config Error : ConsoleWidth must be set to a number, using width 110

Share this post


Link to post
Share on other sites
  • 0

Did you try what kat suggested above?

--

 

Don't know how these shared hosters work. Are you able to Remote Desktop to your box or is everything done through some custom made control panel? In the latter i really do not know what you can and cannot do and your best bet is to let your hosting company take a look at what you did.

Share this post


Link to post
Share on other sites
  • 0

Support finally got their hands on it, still no answer from them what the issue was, i really love to know what the issua was since i spend 15+ hours to figure it.. :)

Would be curious if it was bans.txt instead of ban.txt. That was my problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By 2DayZ2Retirement
      -PROBLEM SOLVED-
       
      G'day, Survivors.
      I am having an issue on my server where vehicles which spawn randomly around the map repair themselves upon server restart.
      I use this config in my init.sqf which successfully spawns the vehicles in damaged and with low fuel...
      DynamicVehicleDamageLow = 75;
      DynamicVehicleDamageHigh = 100;
      DynamicVehicleFuelLow = 0;
      DynamicVehicleFuelHigh = 25;
      ...However upon each server restart the vehicles repair themselves (the fuel remains low however) and for the life of me I can't figure out why this is happening. 
      DayZ Version -DayZ Epoch 1.0.6.2
      Scripts Used -DZAI | -DZMS | -Right Click Actions (Suicide, Smoke Drugs, GPS Scan)
      AntiHack - InfiSTAR
      Server Host - GTXGaming
      My HiveEXT.log and arma2oaserver.RPT logs are not showing anything out of the ordinary.
      I'm not sure if it matter, but all Planes/Helicopters and Boats have been removed from the server via the dynamic_vehicle.sqf.
      In addition, all of the traders and trader cities being removed by removing the call for the CfgServerTrader.hpp in the description.ext.
      If there is any other info I can show to assist in fixing this problem please let me know, any help would be greatly appreciated.
      Cheers.
    • By rocalpha
      Bonjour, j’écris aujourd’hui parce que j’aimerais savoir si vous ne pourrez pas m'aider. Je loue un serveur via gportal et j’aimerais pouvoir être mon serveur en PvE, mais aussi créer des éléments de base pour la connexion et des choses simples comme . J'ai un autre problème lorsque j'achète une voiture chère à pied cela me met une flèche rouge puis rien non aucun véhicule il apparait qu'après un redémarrage du serveur
    • By Warburgg
      I installed the dynamic climate script and it happens that it rains on the server but only lasts 10 seconds and stops. Is it because I use the script that speeds server time? I currently use Control Time which allows the server to have 2 hours of day and 1 hour night.
      The other climates such as overcast and fog last the forecast time 5-20 minutes but the rain does not.
      In my logs show: 16:52:30 "39:2 Debug: Rain set to 0.92421 for 10.6582 minutes". It rains until it rains but soon stops.
    • By Tanita-Corp
      Hello guys)
      Tell me please how to make 
      spawned veh. unused 4 day deleted
      with key veh. unused 14 day deleted
       
      I broke my head
    • By Hanse
      Hello i am knew to this and i need someone to show me the ropes
      Steam
      IGN:Hanse
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...