Jump to content
grave867

[Release] UEP BattlEye Extended Controller Installer

Recommended Posts

Hi, i seemed to install the tool ok and everytime i run the start file the BEC splash window shows up. However i'm getting no restarts and the ingame messages are not woking. Any suggestions what it could be or where to start looking?

Share this post


Link to post
Share on other sites

I personally have no idea why the restarts or messages wouldn't work. When BEC starts does it say scheduled 42 tasks if so it should be working. If not then BEC can't find your scheduler and you will have to delete all those files and use the installer again. If it still doesn't show up after that then idk :huh:

Share this post


Link to post
Share on other sites

Make sure you have a bans.txt

 

Also for my problem i just changed it so it shutdown the server and runs the bat at the same time. This is ok becuase there is already a 7 sec delay built into the restart.bat

This solution may be caused by the fact that your computer takes longer to restart the server and bec is executed with not enough to time to locate the server since the server takes so long to start. 

Share this post


Link to post
Share on other sites

I personally have no idea why the restarts or messages wouldn't work. When BEC starts does it say scheduled 42 tasks if so it should be working. If not then BEC can't find your scheduler and you will have to delete all those files and use the installer again. If it still doesn't show up after that then idk :huh:

 

When I click on the start.bat in my main server folder, a black window comes up and with something about waiting so many seconds press any key. So I let that count down and then another couple of lines of text flash up in the black window but then the window closes itself before I get a chance to see what the lines say. Not sure if that is the 42 tasks thing you're on about?

 

After the window disappears I get a BEC splash window (red/silver) which stays on for a few moments, along with the boxes and ticks showing me that arma2oa is starting. After a short while the these disappear and I'm left with the usual server host box.

 

Make sure you have a bans.txt

 

Also for my problem i just changed it so it shutdown the server and runs the bat at the same time. This is ok becuase there is already a 7 sec delay built into the restart.bat

 

I didn't have this in my files so I added it in the same folder with whitelist, admins, scheduler etc, but it's made no difference. I still get no restarts, no messages or anything.

 

Any other thoughts before I have to try reinstalling it?

Share this post


Link to post
Share on other sites

This solution may be caused by the fact that your computer takes longer to restart the server and bec is executed with not enough to time to locate the server since the server takes so long to start. 

No becasue when i run the restart bat it works. It looks like to me that the delay between the server stopping and bec running the bat file is too long that bec shutsdown becasue it has lost connection to the armaserver.

Share this post


Link to post
Share on other sites

The simplest check to know if BEC is even running at all would be to see the messages come up in game. At least then I would know it's processing something. I am sure it's something extremely basic like my file paths are wrong but for the life of me, I've checked again and again. 

Share this post


Link to post
Share on other sites

The simplest check to know if BEC is even running at all would be to see the messages come up in game. At least then I would know it's processing something. I am sure it's something extremely basic like my file paths are wrong but for the life of me, I've checked again and again. 

The file paths shouldn't be wrong unless you changed file names from the default server install.

Share this post


Link to post
Share on other sites

No becasue when i run the restart bat it works. It looks like to me that the delay between the server stopping and bec running the bat file is too long that bec shutsdown becasue it has lost connection to the armaserver.

If anything the wait time would be too short since bec doesn't care when it starts just as long as the server is fully running when it starts.

 

However I recently updated the tool for people who don't have a database password, since before if you didn't have one the tool wouldn't work.

 

The best thing I can recommend is to do a fresh install of your server and then use the UEP BEC Installer again. This is not the first time I have had people not get it to work then they do a fresh install and then everything is fine. Generally if the tool doesn't work right out of the box it is something that you have done to your server that is causing it not to work.

Share this post


Link to post
Share on other sites

hey im having a problem i do every step and on the last one after the second message inpput box the next step comes up and its blank and ive tried putting the batch location and what not and after i proceed nothing seems to happen

Share this post


Link to post
Share on other sites

hey im having a problem i do every step and on the last one after the second message inpput box the next step comes up and its blank and ive tried putting the batch location and what not and after i proceed nothing seems to happen

I honestly don't know why that would happen, download it again and try again?....if the problem persists there may be something wrong with your windows interpreter.  :mellow:

Share this post


Link to post
Share on other sites

After the last step mine crashed, I had no idea what to enter so i left it blank.

It goes from step 7 of 7 and then opens up a blank box (See attached image), no idea what goes there, after pressing ok it crashes.

Problem signature:
  Problem Event Name:    CLR20r3
  Problem Signature 01:    uep bec installer.exe
  Problem Signature 02:    1.1.2.0
  Problem Signature 03:    54012ca8
  Problem Signature 04:    mscorlib
  Problem Signature 05:    4.0.30319.18408
  Problem Signature 06:    52310b91
  Problem Signature 07:    e85
  Problem Signature 08:    99
  Problem Signature 09:    System.InvalidCastException
  OS Version:    6.1.7601.2.1.0.272.7
  Locale ID:    1033
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

post-5581-0-70949300-1410282850_thumb.pn

Share this post


Link to post
Share on other sites

Thanks for the input guys, I went through the code and fixed the hang up problem. My IDE auto complete added something that wasn't suppose to be there the last time I made an edit. Thanks for your patience guys, the fix is live on my github it took me a while to post it since I just got the time to set up my desktop again.

Share this post


Link to post
Share on other sites

When you make your server you define a folder, whatever folder you copied your server files into is the same folder you put the program in.

 

ex:

 

mine is:  Z:\epoch_server\

 

all the arma 2 and arma 2 OA files are in that folder, so is the UEP BEC installer.exe. Run as administrator and after a few questions and a minute or so after picking the map type bec is ready to run. just find the "start.bat" in the folder and double click on it.

 

be sure your server is running before you click the "start.bat".

 

you can edit the messages or timed restarts at your leisure. 

When it says extract into server folder, which folder is this specifically?

Share this post


Link to post
Share on other sites

Well it installed fine and shut the server down, It then fails to restart it :unsure:

Some documentation would help, what needs done after install ?

 

*Edit*

Let it run a second time and same thing, server stops but never restarts.

Share this post


Link to post
Share on other sites

Well it installed fine and shut the server down, It then fails to restart it :unsure:

Some documentation would help, what needs done after install ?

 

*Edit*

Let it run a second time and same thing, server stops but never restarts.

Same issue here, it stops the server, but fails to start back up again, if i run restart.bat manually it works fine, any ideas ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Yoda
      Hello, I am apart of the Global Chaos Gaming community. We currently are hosting a modified Arma 3 Epoch server, we have very active staff aswell as active community members, I urge you to stop by and check us out! TeamSpeak: ts.globalchaos.net Website : http://www.GlobalChaos.net
    • By WinterLuka
      Winter Gaming is a gaming community, that was created in early 2018. We're currently running DayZ Epoch 1.0.6.2 server.
      Winter Gaming is a project created with passion – for players from players.
      On our server, the rules are equal for all players – no Pay2Win, no benefits for donating.
       
      Server IP: 164.132.201.34:2302
      Discord: discord.me/wintereu
      Website: http://www.wintergaming.eu
      Forum: http://www.wintergaming.eu/forums
       
      Server Configuration:
      Building Maintain - 10 Days Abandoned Vehicle Unlock - 7 Days Abandoned Safes/Lockboxes Unlock - 10 Days Building Limit – 350 Objects Max Base Height - 50m  
      Features:
      Plot Management Door Management Snap and Vector Building Coin System Running Zombies Ai Missions Ai Convoys High FPS Custom Loot Custom Locations Custom Traders Hidden Trader Selling Rare Items Toggle Grass/Environmental Sounds Deploy Bike/Motorcycle/Mozzie Walk Amongst The Dead Harvestable Hemp Tow/Lift Repair/Rearm – Service Points Bury Bodies Take Clothes Locate Vehicle Paychecks every 30 minutes Spawn Selection Abandoned Safe Mission Indestructible Metal/Cinder Bases Blow up door and more!  
      I hope to see You on the server!
    • By Tricks
      We are back! Ranked 7th overall in 2014! Classic DayZ Epoch PvP Server!! No stupid start bonus, no heavy military. Just classic Epoch gameplay with new updates!

       
      - Top of the Line Hardware - Overclocked 8700k servers with SSDs. Super high FPS!!

      - XP System & XP Trader - Acquire handy Perks, Skills, and Permits with our XP system!

      - Custom Traders - Totally custom traders unique to this server!

      - Military Bases - High Loot areas perfect for gearing up.

      - Custom Map Content - Aircraft Carriers, Secret Military Bases, New Towns, and more!

      - All The Major Mods - All the major mods like Coin System, Heli Evac, Hide from Zeds, and many more.

      - Lots of AI Missions - Challenging AI missions color-coded by difficulty.

      - Custom AI Missions for Groups - Static missions with super high difficulty and major loot rewards!

      - Realistic Loot Spawns - You wont find high-powered weapons while hunting for loot, realistic loot spawns.

      - No Heavy Weapons, Tanks, Attack Choppers, Jets - Just the classic Epoch vehicles with a few new additions!

      - Lots of Vehicles - Lots of vehicles scattered around the map. Some are ready to go, others need to be fixed first!

      - Base Building - Fully modular base building system with unique build items and crafting recipes.

      - Full Day/Night Cycle - Realistic day and night cycle, no stupid 24 hours daylight!!

      - Full Weather System - Rain, thunderstorms and snow in the winter!!

      - Destructible Base/Garage Doors - Base raiding without losing your whole base! Just the doors are destructible.

      - Abandoned Safes/Lockboxes - Abandoned bases will have their safes unlocked for you to raid!!

      - Fresh Server, All The Best Base Locations Still Available! - No more wipes, server is done and all progress will be saved.

      - Regular Updates/Suggestions Considered - Pass along ideas to the admin staff. We consider all changes.

      - Admin Events - Events with High Loot and great times! See pic below.

      - Active Admin Staff - Find us on Discord anytime or by email!





      Connect to us on DayZ Launcher or directly:

      [SHG]ClassicEpoch|XPSystem|CustomTraders|CustomAImissions|Coins|FPS++

      144.217.62.76:2302

      Discord: http://xn--discrd-zxa.com/join.php?v=OXHD95

      Email: [email protected]

      Website: Under construction


    • By Joseph Thompson
      Hello all,
      My name is Joseph. I am looking for active members on Arma 2-Overpoch to join a Team. You must have some knowledge in playing the game and  you must have a working mic (No Echo).
      We will be playing on a server that has recently started up but has big hopes for its self. The staff/Admins are really helpful and have helped to create other servers in the past.
      We will be working together as a team to attend and capture missions also Helping with base building ECT. How you play is entirely up to you if you (this meaning if you want to be a bandit or a hero)
      You must be over the ages of 16 and have a strong sense of humor.
      ------------------------------------------------------------------------------------------------------------------------------------------------
      Please ensure you have one of the following programs:
      ------------------------------------------------------------------------------------------------------------------------------------------------
      Team-speak
      Skype
      Discord
      ------------------------------------------------------------------------------------------------------------------------------------------------
      Please fill in this form if you are interested in joining us.
      ------------------------------------------------------------------------------------------------------------------------------------------------
      Age-
      Name
      SteamName-
      SkypeName-
      DiscordName-
      Playtime-
      And last one: Are you from the UK?-
      ------------------------------------------------------------------------------------------------------------------------------------------------
      If you would like to contact me
      Discord: Joseph_Richards#3973
       
       
    • By Cyrus
      I know of some questions in the forums regarding custom loot crates with available missions systems. I have managed to create a custom loot crate thanks to @DAmNRelentless help, that randomizes items and weapons from user customizable arrays and integrate this with the mission system. This for the time being works for DZAI on Epoch 1.0.6.2. 
      Following is my custom lootcrate.sqf , all the classnames used is from the official epoch 1.0.6.2 github repo with thanks to @salival found >here<
      From here I have added the following script to my custom DZAI spawns found in \z\addons\dayz_server\DZAI\init\world_spawn_configs\custom_spawns\cust_spawns_panthera2.sqf. Obviously you will use the sqf appropriate to your map etc.
      ["staticspawn",10,2,true] call DZAI_spawn_units; if {DZAI_spawn_units && DZAI_despawnWait == true} then { execVM "\z\addons\dayz_server\custom\lootcrate.sqf"; }; This method might need some tweaking and someone else might have a more effective way of doing this, but for me this works perfectly. Fully tested with random loot spawns after new AI group spawned.
  • Advertisement
  • Advertisement
  • Supporters
  • Advertisement
  • Discord

×