Jump to content
domuk

Official DayZLauncher Thread

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Zedmag
      Ok guys, this is racking my brain. Ill set a few things first This is not my first rodeo.  I have privately hosted servers long before Epoch.  Then i got bored. Currently im hosting an Epoch with Overwatch server (Overpoch) Here is my current Server launch bat: (working) " start arma2oaserver.exe -port=2302 "-config=instance_11_Chernarus\config.cfg" "-cfg=instance_11_Chernarus\basic.cfg" "-profiles=instance_11_Chernarus" -name=instance_11_Chernarus "[email protected];@DayZ_Epoch1051;@DayZ_Epoch_Server" " Here is my client launch params in steam: (working) " -window -nosplash -mod=C:\@ArmaMODS\@DayzOverwatch;C:\@ArmaMODS\@Dayz_Epoch1051 " You will notice in the Server and Client params that i am not referencing the Arma 2 directory OR the Expansion directory. The Addons (from Arma2) folder is copied into the Arma OA directory on both the Server and the Client.  The Server and Client are on 2 diff machines. This current configuration works perfectly with NO issues. Lets get that straight.  Now with this said, Ive had friends join with out issues using this same client method. What ive noticed is people trying to join thru out the day and getting kick almost immediately OR sitting in debug (used spectate to watch). Yes, verify sigs are enabled.  This got me wondering why? Had another friend try joining and they used DayzLauncher. He would log in, then get sent to debug right after the lobby.  if he switched back to my method, joins right in with no issues.  Ok, so i tried joining with DayzLauncher, same thing, i get stuck in debug.  Ok this got me thinking how DZL is loading, its referencing the Arma 2 directory and the Expansion folder such as: " "-mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion" " ok, so maybe thats my problem on my server. so I attempt to use this param on the server: " start arma2oaserver.exe -port=2302 "-config=instance_11_Chernarus\config.cfg" "-cfg=instance_11_Chernarus\basic.cfg" "-profiles=instance_11_Chernarus" -name=instance_11_Chernarus "-mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion;@DayzOverwatch;@DayZ_Epoch1051;@DayZ_Epoch_Server" " And this one on the Client thru steam: " -window -nosplash -mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 2;Expansion;C:\@ArmaMODS\@DayzOverwatch;C:\@ArmaMODS\@Dayz_Epoch1051 " no dice, Session Lost.  Ok, Lets try DZL, nope, same thing, Session Lost.  Ok, lets try DZL and connect to someone else's Overpoch server,  SAME THING. Ask my buddy to try, Same result.  Reinstall EVERYTHING fresh. SAME THING. only a hand full of servers are able to be joined with DZL, and I tried almost EVERY Overpoch server i could find in DZL. Now, back to my method, I am able to join EVERY overpoch server i can find in the Server browser with out issue.  So im asking all the server owners and gamers to fill me in on the secrete here? People say the whole copy the Addons folder no longer works, but it seems to be the ONLY method that works for me in any configuration. Clients shouldn't have to do anything special to connect to my server, so how are all the Servers on DZL getting people to connect with out issues? Any help would be appreciated, though ive probably tried it. If you comment, ill respond with results.
    • By Cosmoe
      I started a server with a buddy who has a lot more understanding of scripting then I do and he is doing most of the work... we were running epoch and he decided after we (he) messed something up in the .pbo file to try overpoch. Shortly into messing around with that he decided that we were better off sticking with just Epoch.
       
      So our problem is now that the Dayz Launcher is reading overwatch in our mods and if you try to connect to the server it makes you download overwatch... but if you do that it wont let you play because of extra keys. 
       
      The server is up and running fine if you launch just through arma multiplayer, but I want people to be able to join us via the dayz launcher.
       
      So my question is how to I get the launcher to read my server as just epoch again? I am sorry if this is a stupid question but I can't get it figured out and I have done a bunch of searching to no avail. I understand that the launcher reads a -mod string? but no idea how to locate said -mod string.
       
      I use vilayer as my host, if that helps you know where I should look/what I should alter as I know each hosting company has things set up slightly different.
       
      Thank you in advance for any help on getting this fixed and a HUGE thanks to all in the modding community who have made this game so awesome!
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...