Jump to content

Question

Good evening guys,

the last day 45+ players played on our Server. The frames are realy nice, still 50+ .. No desyncs etc.

But theres exactly one annoying thing, well better sayn two. My traders are extreme slow! (From the first minute after Restart on..)

A car takes nearly one min to spawn in at the trader.. To open cars u need also a lot of time. What can i do against it?

Heared sth. about config based trader ? What will that cause ? Think there's something wrong with the database. Does it need to restart

sometimes ? Or is it okay to let it run 24/7..

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Restarts should be done atleast every 3rd or 4th hour. Use CONFIG TRADERS, instead of normal traders, it is much smoother and reduces some lag. The rest is tweaking, changing database settings, server settings etc. It can take a long while before you find settings that are good for your server.

Share this post


Link to post
Share on other sites
  • 0

This frame rate is extremely high for a 45 players server. How do you measured it?

Did you used the #login password then #monitor 1 chat commands?

 

Xen E312 xx (Sandy Bridge)
32 GB Ram
 
No I dont use them. Fixed it by letting the DB restart every normal Server Restart... Yes thinking about using Config Traders..

Share this post


Link to post
Share on other sites
  • 0

Restarts should be done atleast every 3rd or 4th hour. Use CONFIG TRADERS, instead of normal traders, it is much smoother and reduces some lag. The rest is tweaking, changing database settings, server settings etc. It can take a long while before you find settings that are good for your server.

Any help on configuration trader ?

The wiki is not being updatede :/

http://epochmod.gamepedia.com/Init.sqf

Share this post


Link to post
Share on other sites
  • 0

I am also having the same issue. However things like Tow and salvage is slow too. It will finally come up after like 3 min trying to scroll and for it to finally show. I think its something to do with the menus not the scripts maybe menu lag?

Share this post


Link to post
Share on other sites
  • 0

same here, bevore update to 1051 and installing plot4life every thing was super fast, like opening doors/trading tow/lift with 50+players. Now after installing plot4life and 1051 every thing went bad, traders loading years in 90% tow isnt working cause no one stands there for like 2mins to get the option. Also a huge desync issue, sometimes the chains come with 35+ players sometimes with 50 players and sometimes with 3 players but they come like every 5min and then cars start to fly or driving in a circle...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Brian Soanes
      To unlock vehicles left in your traders over a server restart, open your epoch_server.pbo

      In epoch_server\compile\epoch_vehicle\EPOCH_load_vehicles.sqf
      Find
      if (_allowDamage) then { Just above that, add this
      A3E_SafeZonePosArray = [ [[18451.9,14278.1,0]], //Altis East trader [[13333.5,14494.3,0]], //Altis Central trader [[6192.46,16834,0]] //Altis West trader ]; { if (_vehicle distance (_x select 0) < 200) then { _vehicle lock false; diag_log format["Vehicle %1 left in trader unlocked @ %2", _class, mapGridPosition _vehicle]; }; } forEach A3E_SafeZonePosArray; Pack pbo and you're good to go
    • By Thug
      In the file server_spawnTraders.sqf
      private "_trader"; { _trader = createAgent [_x select 0,_x select 1,[],0,"CAN_COLLIDE"]; {_trader removeMagazine _x;} count magazines _trader; removeAllItems _trader; // removeAllWeapons _trader;//this is commented out so traders have weapons removeBackpack _trader; _trader switchMove ""; _trader setDir (_x select 2); _trader setVehicleInit "this disableAI 'ANIM'; this disableAI 'AUTOTARGET'; this disableAI 'FSM'; this disableAI 'MOVE'; this disableAI 'TARGET'; this setBehaviour 'CARELESS'; this forceSpeed 0; this allowDamage false;"; _trader setUnitAbility 0.6; _trader disableAI "ANIM"; _trader disableAI "AUTOTARGET"; _trader disableAI "FSM"; _trader disableAI "MOVE"; _trader disableAI "TARGET"; _trader setBehaviour "CARELESS"; _trader forceSpeed 0; _trader allowDamage false; _trader enableSimulation false; } count _this; processInitCommands; What would I have to do to get the Traders to move like they did in v1.0.5.1
      I have tried but can not get it to work.
    • By Thug
      I have an overpoch Sauerland server. The vehicle traders are not spawning when you buy. The SOB takes your money and gives you a key, but no vehicle.  The arrow comes up for about 12 seconds.  After the restart, they are there, all on top of each other.
      NO, I do not have infistar installed.  It brakes the server. No admin tools at all.
      Here are my server and client RPTs. Can someone please take a look for me?
      Client
      Server
      All other traders work.
       
    • By blueman
      I made some changes to the traders inventory.
      So they they have 15 drinks, and 15 food.
      However, when I restart server, and check, the inventory was just like it was before restart.
      I have a feeling I don't understand the loot system yet, and the traders.
      Looks like it's a running tally of what ever gets sold to them, and it carries over through restarts.
      Probably only resets after it reaches a certain point (amount of items).

      What I'd like to do, is have the traders have a minimum of 15 food and 15 drink at all times is that possible?
      Thanks,
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...