Jump to content
mudzereli

[release] 1.0.6 - Deploy Anything 2.8.2 - Now with Epoch building! | Customizable: DB saving | Plot | Vehicles/Buildings | Packing

Recommended Posts

 

 

 

i think the problem here is not that hard to solve, never messed around with deploy anything that much though, BUT:

 

Array

String

 

_inventory = (weapons _player) + (magazines _player) + (typeOf (unitBackpack _player));

 

so if i read that right this lines needs to be:

_inventory = (weapons _player) + (magazines _player) + [(typeOf (unitBackpack _player))];

 

 

Ok, so I found that code in wrapper.sqf. I will edit it and see what happens.

Share this post


Link to post
Share on other sites

player_deploy.sqf

 

from

_missing = "";
_hasrequireditem = true;
{
    _hastoolweapon = _x in weapons player;
    if(!_hastoolweapon) exitWith { _hasrequireditem = false; _missing = getText (configFile >> "cfgWeapons" >> _x >> "displayName"); };
} count _require; 

to

_missing = "";
_hasrequireditem = true;
{
    _hastoolweapon = _x in weapons player;
	_hasBackpack = _x == typeOf (unitBackpack player);
    if(!_hastoolweapon && !_hasBackpack) exitWith { _hasrequireditem = false; _missing = getText (configFile >> "cfgWeapons" >> _x >> "displayName"); };
} count _require;

not tested though, but you get the idea :)

Share this post


Link to post
Share on other sites

well right ^^

little bit tired here -.-

 

forget the last part:

 

try change this line:

_hastoolweapon = (_index call getDeployableKitClass) in ((weapons player) + (magazines player));

to

_hastoolweapon = (_index call getDeployableKitClass) in ((weapons player) + (magazines player) + [typeOf (unitBackpack player)]);

to this

Share this post


Link to post
Share on other sites

Thanks for all the help, Schwede. That final bit of code worked. The only problem now is that the gunbag isn't removed from the player when he deploys the gun and if you allow repacking, you get another gunbag on the ground, along with a tripod bag so now you have two gunbags and a tripod bag. Of course the solution to the last part is simply not to allow repacking, but it would be awesome if there's a way to remove the backpack from the player when the gun gets deployed.

Share this post


Link to post
Share on other sites

Thanks for all the help, Schwede. That final bit of code worked. The only problem now is that the gunbag isn't removed from the player when he deploys the gun and if you allow repacking, you get another gunbag on the ground, along with a tripod bag so now you have two gunbags and a tripod bag. Of course the solution to the last part is simply not to allow repacking, but it would be awesome if there's a way to remove the backpack from the player when the gun gets deployed.

 

Look for this in wrapper.sqf

_player removeMagazine _part;

Add this under

_player removeBackpack _part;

Share this post


Link to post
Share on other sites

 

Look for this in wrapper.sqf

_player removeMagazine _part;

Add this under

_player removeBackpack _part;

 

Adding that removes the Deploy Anything items. I can't right click on the gun pack and if I click on my toolbox, I only have the standard Epoch options, none of the stuff in the Deploy Anything config.

Share this post


Link to post
Share on other sites

this needs a bit more coding:

 

removeBackpack unit

 

but this will remove everytime the backpack of the player. Will write something in a couple of minutes

 

EDIT: 

 

try adding this instead:

		if (isClass(configFile >> "CfgVehicles" >> (typeOf _part))) then {
			removeBackpack _player;
		};

if this does not work try it just with:

		if (isClass(configFile >> "CfgVehicles" >> _part)) then {
			removeBackpack _player;
		};

Share this post


Link to post
Share on other sites

 

this needs a bit more coding:

 

removeBackpack unit

 

but this will remove everytime the backpack of the player. Will write something in a couple of minutes

 

EDIT: 

 

try adding this instead:

		if (isClass(configFile >> "CfgVehicles" >> (typeOf _part))) then {
			removeBackpack _player;
		};

if this does not work try it just with:

		if (isClass(configFile >> "CfgVehicles" >> _part)) then {
			removeBackpack _player;
		};

 

The second one worked! Thanks. The only issue now is that setting damage limit to -1 doesn't prevent it from being repacked and when you repack it, a tripod bag appears with the gun bag.

Share this post


Link to post
Share on other sites

Ok, so now there's a new problem. With this solved, the backpack is taken away, which is great, but when I enter the gun, my screen goes black. If I exit to the lobby and come back in, I can see again and I can enter the gun and use it just fine. If I disassemble it and redeploy it, the same black screen happens again.

Share this post


Link to post
Share on other sites

Ok, so now there's a new problem. With this solved, the backpack is taken away, which is great, but when I enter the gun, my screen goes black. If I exit to the lobby and come back in, I can see again and I can enter the gun and use it just fine. If I disassemble it and redeploy it, the same black screen happens again.

 

You may need to add it to dayz_allowedObjects 

Share this post


Link to post
Share on other sites

That did it! Now, how to stop the gun from being disassembled.... 

 

I enabled packing for the gun, but the pack option doesnt show up

 

This is the code :

["M2StaticMG_US_Bag_EP1",[0,2,0],1,0.9,true,false,false,true,true,true,false,["M2StaticMG_US_EP1"],[],["M2StaticMG_US_Bag_EP1"],"true"]

Share this post


Link to post
Share on other sites

I've tried setting damage to 0, 0.9, 1 and -1 and I still get the option to disassemble. 

 

On another note, I have set up a recipe for an M240 nest, but I'm getting that same black screen as I did at first with the M2. I added "Fort_Nest_M240" to DZE_safeVehicle and dayz_allowedObjects. Any idea if it needs to be added someplace else? As with the M2, I get the black screen and have to go to the lobby and come back before I can see again. 

 

*edit* It seems that the black screen is intermittent. I just deployed an M2 and I got the black screen again. I'm getting it with a DSHKM mounted gun too....

 

*edit 2* I apparently had the guns set to false for _simulation. Changed that to true and all seems ok now.

Share this post


Link to post
Share on other sites

I've tried setting damage to 0, 0.9, 1 and -1 and I still get the option to disassemble. 

 

The disassemble option is not from the script. its an arma feature on certain static guns. Cant get rid of it :(

Share this post


Link to post
Share on other sites
Guest

The disassemble option is not from the script. its an arma feature on certain static guns. Cant get rid of it :(

If you find the function Name you can use "terminate" to kill that function but don't ask me where to look ^^ probably maybe just do a commandingMenu instead of addaction. At least that will disallow the disassembling option to pop up.

Share this post


Link to post
Share on other sites

If you find the function Name you can use "terminate" to kill that function but don't ask me where to look ^^ probably maybe just do a commandingMenu instead of addaction. At least that will disallow the disassembling option to pop up.

 

There is an event handler called WeaponDisassembled

Share this post


Link to post
Share on other sites

I cannot seem to get this to work along side any towing and lifting script i have tried and would love to have a little help on this :(

ive tried running logistic tow and lift and also am now running r3y tow and lift after removing logistic tow and lift.

This script works fine until you add towing and lifting and then it breaks with no errors in rpt.

I installed this script to the T along with the overwrites part of it

Share this post


Link to post
Share on other sites
player removeAllEventHandlers 'WeaponDisassembled';

that doesnt seem to work. The scroll menu for disassemble still shows up. its a big problem beucase disassembling will get you the bag back and after the restart the wep will appear again

Share this post


Link to post
Share on other sites

Anyway to use this with DZGM? I cant get it working right. Ever since I downloaded this it overwrites the right click menu for the DZGM so it makes it unusable. 

 

in overwrites/clickactions : 

["Group Management","Group Management","execVM 'dzgm\loadGroupManagement.sqf';","true"],

Don't forget to take the ItemRadio class out of your extra_rc.hpp.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By FG_Trap
      Made this in my free time awhile ago thought id make it public.
      Right Alt is the key to open the menu.
      Install instructions are inside the download.
      https://github.com/NWDZ-Trapxxgods/traps-menu
       
       
      here is a picture of the server menu
       
    • By lordacus
      so i have been making a server between trying to get my provider to update their mods section. after getting this don i found the server with epoch and infistar were conflicting each other such as: when joining i can use infistar but when i press f9 or i to enter my inventory or f10 for the mobile pad it then conflicts (i think) infistar and i can no longer use it. any ideas on how to stop this
       
    • By vbawol
      Open world survival mod set just two years after the mass extinction of billions of people. Those that remain are left with remnants of a once technological society. Try to survive, build, or explore your way through the harsh dynamic environment.
      Features
      Powerful persistence framework for Arma 3 with native Windows and Linux dedicated server support. Fully configurable script based security checks. Base Building re-envisioned for Arma 3 PhysX. Persistent secure and insecure storage devices. Upgradeable locking doors. Barter based economy and trading systems backed a single currency ¤ called "Krypto". Hostile Environment with several different types of antagonists, Air and Water temperature extremes, and Earthquakes. Hunting, Fishing, Tame Dogs, Explore & Loot: Wrecked ships, Abandoned vehicles and buildings, Perform task based missions and more! Open source APL-SA Epoch Survival MP gamemode. Open source APL-SA Modders resource configs and Class List. Assets can be used as a mod dependency on Steam workshop.
    • By Achef
      Greetings!
      So I recently started up in a new host and haven't gotten to make the server run, found that a ca/modules bis_fnc issue is recurring but doesn't affect players when running coop missions like the default arma 2 oa ones, but when trying with Epoch hive won't connect/start despite being configured.
      Hive error
      Meanwhile at line 23...
       
      I'm still bad with Pastebin, sorry.
       
      This error has been chasing me for 2 days now
    • By WeepiestLem0n
      So I've been wanting to create a private ArmA 2 DayZ Epoch server for a bunch of my mates to play on, however I dont have a dedicated machine and want to run it on my PC. So I looked at the server download files on the GitHub page and followed the ReadMe, however I absolutely cannot figure out how to get the MySQL server and DB set up. I have downloaded MySQL Server on my PC and created the admin role, root passwords and ran it as a windows service. I now have no clue how to create the database and am wondering if anyone can help me set this up or let me know if I've done anything wrong. 

      I can add on Steam or Discord if need be for convenience.
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...