Jump to content
RimBlock

[Release] - A Plot for life v2.5. Keep your buildables on death. Take plot ownership

Recommended Posts

Nah, it's set in init.sqf to this:

DZE_PlotPole = [70,65];

And it's not all what is in range. The base we tried to claim yesterday had some half walls taken over which were "miles away" but not the cinderwalls directly next to the plotpole itself

 

Check for duplicate objectUIDs in your DB.

 

I posted sql code to do this here.

 

Check you are using the latest version of Take_Ownership.

 

I may move the Take Ownership server side to cut down on network traffic.

Share this post


Link to post
Share on other sites

Rimblock any idea why its doing my error? People cant unlock safes nor lockboxes and they cant take plot ownership

(yes I set it true in init.sqf)

 

fn_selfactions is where the option is set for the scroll wheel menu.  Check the entry is setup in that file for take_ownership correctly.

 

make sure you have setup the unlock sqf files for doors and safes in the compiles.sqf (eg. player_unlockVault.sqf).

 

If you are using other mods like Plot Management or Door Management then you will need to check what they need as well,

Share this post


Link to post
Share on other sites

fn_selfactions is where the option is set for the scroll wheel menu.  Check the entry is setup in that file for take_ownership correctly.

 

make sure you have setup the unlock sqf files for doors and safes in the compiles.sqf (eg. player_unlockVault.sqf).

 

If you are using other mods like Plot Management or Door Management then you will need to check what they need as well,

i do not use those mods, I however use ZSC 3.0

And okay, i will check...

 

 

EDIT: I do have take ownership in there...

if (s_player_plot_take_ownership < 0) then {
if (DZE_PlotOwnership) then {
_isowner = [player, _cursorTarget] call FNC_check_owner;
If (( _isowner select 0 )) then{
s_player_plot_take_ownership = player addAction ["Take plot items ownership", "Custom\A_Plot_for_Life\Action\plot_take_ownership.sqf", "", 1, false];
};
};
};

Edit 2: I do have custom player unlock vault in compiles:

 

player_unlockVault =			compile preprocessFileLineNumbers "custom\A_Plot_for_Life\Compile\player_unlockVault.sqf";

Share this post


Link to post
Share on other sites

Have just moved Take Ownership server side.

 

Will start testing that and the changes for Epoch 1.0.6 a bit later today.

 

If all looks good from initial testing then will push to my DayZ-Epoch fork in the next day or so.

 

I will not be incorporating any of these changes in to the standalone A Plot for Life mod int he short term but may later depending on how long it looks like Epoch 1.0.6 is going to task before it comes out.

Share this post


Link to post
Share on other sites

 

i do not use those mods, I however use ZSC 3.0

And okay, i will check...

 

 

EDIT: I do have take ownership in there...

if (s_player_plot_take_ownership < 0) then {
if (DZE_PlotOwnership) then {
_isowner = [player, _cursorTarget] call FNC_check_owner;
If (( _isowner select 0 )) then{
s_player_plot_take_ownership = player addAction ["Take plot items ownership", "Custom\A_Plot_for_Life\Action\plot_take_ownership.sqf", "", 1, false];
};
};
};

Edit 2: I do have custom player unlock vault in compiles:

 

player_unlockVault =			compile preprocessFileLineNumbers "custom\A_Plot_for_Life\Compile\player_unlockVault.sqf";

 

Are you the owner of the plot pole ?.  The Take Ownership option only appears if you are the plot poles owner (to take over another owners plot you have to remove their pole and put your own one down for the option to appear).

Share this post


Link to post
Share on other sites

Can I get some help on the exact locations for where I need to put each of these folders/files for a vilayer server. The vilayer server is setup a bit different when it comes to it's files and I think that might be causing my issue.

 

Vilayer has a folder called vilayercodecustom, inside that I have a dayz_overpoch folder that contains all the files that vilayer compiles into my server PBO. and a mission folder that vilayer compiles into my mission pbo.

 

With vilayer I am unable to download my actual pbo files (or I do not know how lol) and as such I may be placing these files in the wrong locations.

Share this post


Link to post
Share on other sites

You don't need the PBOs. Download dayz_overpoch and overpoch_YOURMAP from vilayercodecustom, do the necessary changes and re-upload them to vilayercodecustom. The folders are being compiled with server restart ;)

Share this post


Link to post
Share on other sites

You don't need the PBOs. Download dayz_overpoch and overpoch_YOURMAP from vilayercodecustom, do the necessary changes and re-upload them to vilayercodecustom. The folders are being compiled with server restart ;)

 

I understand that and I usually use an ftp client to just modify my files. My question is where these folders should go on a vilayer server.

Share this post


Link to post
Share on other sites

The plot4life files? Into your missionfile root unless you want to modify each path :P So basically open overpoch_MAP and put the Custom folder in there. 

 

Ok, I have a custom folder there with the the plot 4 life folder and snap pro folder inside it. Where do I put the contents of the server folder that is downloaded with this script?

Share this post


Link to post
Share on other sites

The paths equal the subfolders - thought that was obvious ;)

 

Nope, I have never done any scripting before and everything I have learned has been from this website and youtube....so I'm a complete beginer. Having said that, I still don't understand the location for the contents of the system folder.

 

Directions says:

 

Create a custom folder in the server root directory (the one you have the @mod files in) and copy the contents of the Server folder in to it (you can merge them in to the dayz_server.pbo but need to change the references).
 
I do not quite understand where this is asking me to do this.

Share this post


Link to post
Share on other sites

Okay if you're completely new and didn't add anything to your server so far simply add all three subfolders from the Server folder (system, compile and init) into your missionfile in the Custom folder to use the standard paths from the plot4life files.

Share this post


Link to post
Share on other sites

Okay if you're completely new and didn't add anything to your server so far simply add all three subfolders from the Server folder (system, compile and init) into your missionfile in the Custom folder to use the standard paths from the plot4life files.

 

Thanks a ton, sorry for being so bad at this, will give it a try :)

Share this post


Link to post
Share on other sites

Debugging A Plot for Life on Epoch v1.0.6 test and have moved the Take Ownership function to the server.  

 

One thing I have noticed though is that the list of items is not getting populated correctly on the server.  I have reverted to nearestObjects rather than nearEntities and it seems to be working fine.  nearEntities worked fine when the function was purely client side but if anyone is having problems with items being detected then they could try the following change.

 

Open Plot_Take_Ownership.sqf

 

Find 

_findNearestObjects = (position _plotpole) nearEntities _distance;

Change to

_findNearestObjects = nearestObjects [(position _plotpole), [], _distance];

The version running on the server should be much better for lag prevention.  People can always take a look on my Epoch v1.0.6 GitHub files and work out the differences if they wish to try it.  The names should be fairly obvious and check the puiblicEH.sqf for the PV event handlers. 

Share this post


Link to post
Share on other sites

I'll try that, maybe then it will finally work for me :D

 

Edit:
Just tested it and it looks like everything's working great now! I can remove basically everything from my base again. Thank you!

Share this post


Link to post
Share on other sites

Are you the owner of the plot pole ?.  The Take Ownership option only appears if you are the plot poles owner (to take over another owners plot you have to remove their pole and put your own one down for the option to appear).

Yes I am, I just had placed the pole, went away, next restart tried it...

Share this post


Link to post
Share on other sites

Yes I am, I just had placed the pole, went away, next restart tried it...

 

Then either the code in the fn_selfactions is not correct so the option is not showing up or the plot pole is not saving with the correct ownership details.

Share this post


Link to post
Share on other sites

I had some compatibility with 2.5 and plot management/door management. I decided to revert back to 2.35 and put the files is the same location I did before. 

I put the custom folder in my mission pbo. 

I put the files from the server folder inside the custom folder.

I made all the requested changes to the init.sqf and description.ext. 

Now when anyone tries to join my server they get stuck around the "waiting for server to start authentication".

Any ideas what is causing this?

Share this post


Link to post
Share on other sites

Hello i got the plot 4 life working but when placing a Vault i do not get the option to unlock it.

This is perfectly normal as your character is now tied to the safe. You can check if you want by asking someone else to interact with the safe. They will still get the code input dialogue.

Share this post


Link to post
Share on other sites

This is perfectly normal as your character is now tied to the safe. You can check if you want by asking someone else to interact with the safe. They will still get the code input dialogue.

But how can i access the gear myself then?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By vbawol
      Open world survival mod set just two years after the mass extinction of billions of people. Those that remain are left with remnants of a once technological society. Try to survive, build, or explore your way through the harsh dynamic environment.
      Features
      Powerful persistence framework for Arma 3 with native Windows and Linux dedicated server support. Fully configurable script based security checks. Base Building re-envisioned for Arma 3 PhysX. Persistent secure and insecure storage devices. Upgradeable locking doors. Barter based economy and trading systems backed a single currency ¤ called "Krypto". Hostile Environment with several different types of antagonists, Air and Water temperature extremes, and Earthquakes. Hunting, Fishing, Tame Dogs, Explore & Loot: Wrecked ships, Abandoned vehicles and buildings, Perform task based missions and more! Open source APL-SA Epoch Survival MP gamemode. Open source APL-SA Modders resource configs and Class List. Assets can be used as a mod dependency on Steam workshop.
    • By McLovin
      NOTICE: Duplicate of another question posted in the wrong section.
       
      So I've been playing this server that has a number of mods installed. I've been playing it for quite a while with the only errors I've been getting are regarding a 45 round RPK mag being missing, but other than that I've had no errors or any issues loading. Upon trying to place a plot pole, nothing happens; absolutely nothing, like no preview shows up, no prompt saying "starting construction" or anything like that, just blankness. When I try to do it again it says "building already in progress" and I can't do anything, not even lock my vehicle. Is there anything that can be done, or that can explain this phenomenon? To further the understanding of how this came to be, I bought a plot pole from the trader in Trader City Stary and tried placing it near Stary, but not too near it (near a thicket of bushes in the distance). Upon right clicking and hitting the build option, that's when I face my issue.
    • By xtrmsnpr
      Hello to all.

      So, the old company from {grof communty} is back,this time away from that clan.We are operating by ourselves and we have opened a new dayz mod epoch server!
      https://steamcommunity.com/groups/kirterpos

      And we want you to join us and have fun!
      It runs 24/7

      Server IP:
      144.76.99.158:2600

      Name:
      Kir Terpos Playground Epoch|DAY/NIGHT|Startkit|Custom events

      Map: Chernarus

      Slots:
      30

      Location:
      Germany


      --------

      In order to join the server, you need to download through DZlauncher these files:

      dayz Epoch 1.0.6.2

      and of course ARMA 2OA beta patch (obsolete) through STEAM.
      and arma2oa beta version from steam options!

      ---------------

      Server will restart every 6hours (no notification yet).
      Server will backup database every 8hours.

      Server has custom random events.
      Server has day/night circle (UTC+6)
      You start with custom gear,ready for PVP with a shiny m9SD and some surprises as well.

      @Sandbird is an extra feature to this server
      ---
      Discord for you:
      https://discord.gg/684KQH

      Welcome all,and we hope you like it.

      kir terpos aka kir menios aka xtrmsnpr
    • By victorks
      my first work in editin :) https://uploaddeimagens.com.br/imagens/20180307202515_1-jpg https://uploaddeimagens.com.br/imagens/20180307202245_1-jpg DOWNLOAD: https://www.dropbox.com/s/oq97j7x59362kqe/CASTLEai.sqf?dl=0 AI M2 NEED WAI: https://pastebin.com/GJMnPvZP ON THE MAP: https://pastebin.com/cyqH9rNV  
       
      https://www.dropbox.com/s/oq97j7x59362kqe/CASTLEai.sqf?dl=0
       
       
       
       
       
       
       
       
       
    • By UGRexie
      Dayz epoch server 
      Name: Dayz Epoch Tavi -missions-Hardcore-unitedgamers   Connection Info: 193.111.186.225:2302 Map  - Taviana
      List of mods in sever , 
      -Single Coin Currency
      Plot For Life
      Plot Management
      Group Management
      Lift & Tow
      Service points
      Custom start gear
      No weight limit
      Slow zombies
      1 Step build
      Andre Convoys
      Para Spawn
      DZAI 
      Wai Missions
      DZMS Missions
       
      -Our Server is Hardcore ,
      -if you has a idea for a mod ask a admin , 
       
       
      -Server Restart every 4 hours 
      -Admin Teamspeak support, 
        ts- ts3.unitedgamers.eu
      Server Admin - Ask in ts for them if needed,
       [UG]Chieff,[UG]Rexie
  • Advertisement
  • Supporters
  • Discord

×
×
  • Create New...