Jump to content

Search the Community

Showing results for tags 'sarge ai'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
  • DayZ
    • Discussion
    • Public Servers
    • DayZ SA Resources
    • Q&A Section
  • ArmA 3
    • Epoch Survival
    • Community Projects
    • Q&A Section
    • Terrain Discussion
    • Resources
  • Arma 3 Resources
  • ArmA 2
    • General Discussion.
    • Q&A Section
    • Resources
    • Legacy Resources
    • A2: Community Projects
    • A2 Community Servers
  • Space Engineers
    • General Discussion.
    • Public Servers
  • Other Games
    • Discussion
  • Off Topic
    • Off Topic

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 8 results

  1. Hi All, Even though this is probably a 2 second job for an experienced scripter, it took me far too long to sort it out. Now that it is working, I would like to share with others who might need it. If you're having the same issue with Sarge AI on an Epoch Admin Tools installed server (issue = when player gets into SargeAI spawned patrol vehicle & it blows up), here is the fix. Preliminary tests show, it works fine on my server. Packed PBO archive = @DayZ_Epoch_Server > addons > dayz_server.pbo File in archive = init > server_functions.sqf Modification Steps Unpack the PBO, open the abovementioned file with Notepad++, find the section below by seaching for this >> server_checkHackers. Delete the whole block that exists in your file (take a backup of the file first!) then copy & paste the whole block. Save the file & exit file editor. Repack the PBO. Restart the server & test. Hope this helps someone, I wish I had this post somewhere in the forums, 4 hours ago :) server_checkHackers = { if (DZE_DYN_AntiStuck2nd > 3) then { DZE_DYN_HackerCheck = nil; DZE_DYN_AntiStuck2nd = 0; }; if(!isNil "DZE_DYN_HackerCheck") exitWith { DZE_DYN_AntiStuck2nd = DZE_DYN_AntiStuck2nd + 1;}; DZE_DYN_HackerCheck = true; { // Epoch Admin Tools //epoch admin default line is the one below // if(vehicle _x != _x && !(vehicle _x in PVDZE_serverObjectMonitor) && (isPlayer _x) && !((typeOf vehicle _x) in DZE_safeVehicle) && (vehicle _x getVariable ["MalSar",0] !=1)) then { // This is working copied from http://opendayz.net/threads/killing-a-hacker.19355/#post-98883 // if(vehicle _x != _x && (vehicle _x getVariable ["Sarge",0] != 1) && !(vehicle _x in PVDZE_serverObjectMonitor) && (isPlayer _x) && !((typeOf vehicle _x) in DZE_safeVehicle)) then { // the above two combined if(vehicle _x != _x && !(vehicle _x in PVDZE_serverObjectMonitor) && (vehicle _x getVariable ["Sarge",0] != 1) && (isPlayer _x) && !((typeOf vehicle _x) in DZE_safeVehicle) && (vehicle _x getVariable ["MalSar",0] !=1)) then { diag_log ("CLEANUP: KILLING A HACKER " + (name _x) + " " + str(_x) + " IN " + (typeOf vehicle _x)); (vehicle _x) setDamage 1; _x setDamage 1; sleep 0.25; }; sleep 0.001; } forEach allUnits; DZE_DYN_HackerCheck = nil; };
  2. Hey all! New to the forum and somewhat new to installing mods to DayZ Epoch servers. I have experience installing mods on other games/servers but I am no professional, so I apologize in advance for my noobish questions! I just put together a fresh Epoch server lastnight. It is a private server for only a few friends of mine. We would like to install Sarge AI and Epoch Mission System to our server so there is almost always something to do. I have been using Google and YouTube religiously in order to properly setup our server. I was able to get our server up and running! I looked at the Epoch Mission System thread and noticed it said a requirement was Sarge AI 1.5.2. I have looked all over the place, and I am unable to find version 1.5.2! Where can I find it? Thank you again for your help! I know I will have a few more questions, but for the moment, I am stuck! --EDIT Has Sarge AI 1.5.0 been updated to 1.5.2 in the MASTER? (https://github.com/Swiss-Sarge/SAR_AI-1.5.0)
  3. I'm trying to spawn static ai on my epoch server, but they don't show up. The dynamic spawning is working fine and dandy. I'm hoping someone will point out a mistake I made, cause I can't figure it out. :) Here's part of the SAR_cfg_grps_tavi.sqf: // --------------------------------------------------------------- // Definition of area markers for static spawns // --------------------------------------------------------------- // add if needed, see examples in the chernarus file // Sabina, heli patrol area _this = createMarker ["SAR_patrol_sabina", [14894.9, 11081.3]]; _this setMarkerShape "RECTANGLE"; _this setMarkeralpha 0; _this setMarkerType "Flag"; _this setMarkerBrush "Solid"; _this setMarkerSize [1000, 4500]; SAR_marker_helipatrol_sabina = _this; // Lyepestok, heli patrol area _this = createMarker ["SAR_patrol_lyepestok", [11579.5, 15413.4]]; _this setMarkerShape "RECTANGLE"; _this setMarkeralpha 0; _this setMarkerType "Flag"; _this setMarkerBrush "Solid"; _this setMarkerSize [400, 400]; SAR_marker_helipatrol_lyepestok = _this; // NWAF, heli patrol area _this = createMarker ["SAR_patrol_nwaf", [10567, 18429.6]]; _this setMarkerShape "RECTANGLE"; _this setMarkeralpha 0; _this setMarkerType "Flag"; _this setMarkerBrush "Solid"; _this setMarkerSize [800, 1000]; SAR_marker_helipatrol_nwaf = _this; // Dubovo, heli patrol area _this = createMarker ["SAR_patrol_dubovo", [16540.9, 12674.3]]; _this setMarkerShape "RECTANGLE"; _this setMarkeralpha 0; _this setMarkerType "Flag"; _this setMarkerBrush "Solid"; _this setMarkerSize [500, 5000]; SAR_marker_helipatrol_dubovo = _this; // Krasnoznamensk, heli patrol area _this = createMarker ["SAR_patrol_kraz", [8482.28, 8101.42]]; _this setMarkerShape "RECTANGLE"; _this setMarkeralpha 0; _this setMarkerType "Flag"; _this setMarkerBrush "Solid"; _this setMarkerSize [500, 1700]; _this setMarkerDir 262.10; SAR_marker_helipatrol_kraz = _this; // Branibor, heli patrol area _this = createMarker ["SAR_patrol_branibor", [7206.91, 4933.56]]; _this setMarkerShape "RECTANGLE"; _this setMarkeralpha 0; _this setMarkerType "Flag"; _this setMarkerBrush "Solid"; _this setMarkerSize [400, 5000]; _this setMarkerDir 127.30; SAR_marker_helipatrol_branibor = _this; // Static AI Spawn Test _this = createMarker ["SAR_patrol1",[10913.4,17315.5,0.002]]; _this setMarkerShape "RECTANGLE"; _this setMarkeralpha 0; _this setMarkerType "Flag"; _this setMarkerBrush "Solid"; _this setMarkerSize [5, 5]; SAR_patrol1 = _this; // ---------------------------------------------------------------------------------------- // End of area marker definition section // ---------------------------------------------------------------------------------------- diag_log format["SAR_AI: Area & Trigger definition finalized"]; diag_log format["SAR_AI: Static Spawning for Helicopter patrols started"]; // // Static, predefined heli patrol areas with configurable units // // Parameters used: // Areaname // 1,2,3 = soldier, survivors, bandits // //Heli Patrol Sabina [sAR_marker_helipatrol_sabina,3] call SAR_AI_heli; //Heli Patrol Lyepestok [sAR_marker_helipatrol_lyepestok,3] call SAR_AI_heli; //Heli patrol NWAF [sAR_marker_helipatrol_nwaf,3] call SAR_AI_heli; //Heli patrol Dubovo [sAR_marker_helipatrol_dubovo,3] call SAR_AI_heli; //Heli patrol Krasnoznamensk [sAR_marker_helipatrol_kraz,3] call SAR_AI_heli; //Heli patrol Branibor [sAR_marker_helipatrol_branibor,3] call SAR_AI_heli; // add if needed, see examples in the chernarus file diag_log format["SAR_AI: Static Spawning for Helicopter patrols finished"]; //--------------------------------------------------------------------------------- // Static, predefined infantry patrols in defined areas with configurable units //--------------------------------------------------------------------------------- // Example: [sAR_area_DEBUG,1,0,1,""] call SAR_AI; // // SAR_area_DEBUG = areaname (must have been defined further up) // 1 = type of group (1 = soldiers, 2 = survivors, 3 = bandits) // 0 = amount of snipers in the group // 1 = amount of rifleman in the group // // // Example entries: // SARGE DEBUG - Debug group // military, 0 snipers, 1 riflemen, patrol //[sAR_area_DEBUG,1,0,1,""] call SAR_AI; // military, 2 snipers, 4 riflemen, patrol //[sAR_area_DEBUG,1,2,4,""] call SAR_AI; // survivors, 1 snipers, 3 riflemen, patrolling the NWAF //[sAR_marker_helipatrol_nwaf,2,1,3,""] call SAR_AI; // bandits, 5 snipers, 2 riflemen, patrolling the NWAF //[sAR_marker_helipatrol_nwaf,3,5,2,""] call SAR_AI; //--------------------------------------------------------------------------------- // add here if needed // Test AI [sAR_patrol1,1,0,3,"",true] call SAR_AI; // ---- end of configuration area ---- diag_log format["SAR_AI: Static Spawning for infantry patrols finished"];
  4. First of all, thank you to everyone who helped me with my server on this forum. I got so far and now the only thing that is left to do is Correct some minor issues. I have made a list of things that I need to do in order to have the server "perfectly" setup :D Green = Fixed Red = Not fixed 1. BattlEye Restriction Kicks Random Kicks from the game by BattlEye with various restrictions when Lifting/Towing/Shooting etc. 2. Side Chat names not displaying When someone uses Side Chat, I am unable to see their names so I cannot warn them in anyway. Is there a solution to this? 3. No "Red" missions with Sarge AI's I have 2 missions per server restart (every 3h) however all of the missions are "Green" and not a single one was "Red" Yet. Is there something missing from my Sarge AI's scripts? How can I enable the red missions? 4. Modify Sarge AI's Bot difficulty Players are able to walk and take loot in front of the AI's on the server. I want AI's to shoot players on sight. How can I change the difficulty on AI's to maximum? 5. Fix Tow/Lift Helis seem to lift everything they see even tho my code states that they should only be able to lift planes. Axe Cop is currently helping me with this however let me know if you came across this before. Axe Cop fixed my problem. Please reach out if you have similar problems with Tow/Lift script. I will help you out as much as I can. 6. Vehicles disappearing from Sarge AI missions The minute a player completes the AI mission, the vehicle that was spawned with the mission disappears immediately. The loot stays however only vehicles/helis are vanishing. How can that be fixed? I want players to have the spawned vehicles until next restart. If you have some ideas on the problems above please reply with the number corresponding to the issue and it's title. Once specific issue is solved I will mark it Green and will show How it was fixed for others that might have similar problem. Thank you in advance!!!
  5. Hey There! I'm relatively new to the community, and also new to the whole scripting thing, so please forgive any noobish mistakes from the get go. I'm running DayZ 1.8.0.2 with Epoch 1.0.2.4 with Arma 2 Beta Build 103718 on a Nitrado.net server hosting in Europe. I have a number of mods installed including: - self blood bag -auto refuel -house lights at night -DzAI -Sarge AI (I know, I know, it's probably overkill, but I wanted an AI war!) I've TRIED to install animated heli crash sites and side missions, but to no avail. As you probably know, not having side missions on a low population server can get pretty boring...so it's essential that I get the side missions up and running. I've also placed a bunch of custom buildings (which I've found here and in the great DayZ community), and was forced to place them on the mission PBO, because they weren't showing up on the Server PBO. I really wanted to have the AI be able to use them as static bases and cover, but of course, if the files are on the mission pbo, the AI won't see the buildings...... I've provided links to both the PBOs and I would be grateful for anyone to take a peak and let me know what I've done wrong. Mission PBO (/dayz/mpmissions) http://www.mediafire.com/?rasr18f47z44f1f Server PBO (/dayz/@DayZ_Epoch_Server/addons) http://www.mediafire.com/?b4hm5bmu3dqtgme Looking forward to your input. PsychoSyd
  6. Hello! I have just purchased a brand new Day-Z Epoch server, but I am currently having some issues finding out how I can install Sarge AI to my server. If you know how please get back to me in reply to this thread, or email me at [email protected] Thanks!
  7. Hello all, So I have a fresh Epoch 1.0.2.3 server setup, and have been working on getting Sarge AI installed. I have followed the directions listed, though I'm stuck on a restriction error from BattlEye. Steps taken in order, as follows - 1. Under MPMissions > DayZ_Epoch_11.Chernarus, I created a new 'addons' folder and moved SHK-POS, SARGE, and UPSMON into the folder. 2. Edit init.sqf under MPMissions > DayZ_Epoch_11.Chernarus, nd add the provided lines at the very end. 3. Edit description.ext and add the provided line at the very end. 4. Use PBOViewer, and unpackaged dayz_server.pbo that's located under @DayZ_Epoch_Server > addons directory. Then make the provided changes to server_cleanup.fsm. 5. Didn't touch SAR_config.sqf since those were set to false already. 6. Edited scripts.txt under instance_11_Chernarus > BattlEye, and the lines provided were not listed there so I added both to this file. Restarted the server, and everything goes smoothly until you get to Requesting Server Authentication, which now takes between 60-120 seconds to load which without these changes, it normally went through instantly. Once that finally loads through, I get a BattlEye Restriction #0 and am kicked. Below is from the log, edited out the GUID and IP with xxxx. - - - 21:00:04 BattlEye Server: Initialized (v1.177) 21:00:04 Host identity created. 21:00:42 Necro uses modified data file 21:00:42 BattlEye Server: Player #0 Necro (xxxx) connected 21:00:42 Player Necro connecting. 21:00:42 Mission DayZ Epoch Chernarus read from directory. 21:00:43 Player Necro connected (id=95305030). 21:00:43 BattlEye Server: Player #0 Necro - GUID: xxxx (unverified) 21:00:43 BattlEye Server: Verified GUID (xxxx) of player #0 Necro 21:00:46 Roles assigned. 21:00:46 Reading mission ... 21:00:54 Mission read. 21:01:39 Game started. 21:02:04 Player Necro kicked off by BattlEye: Script Restriction #0 21:02:04 Player Necro disconnected. Thank you in advance. I'm sure it's something simple I'm missing or may have done incorrect. Server works fine without Sarge AI. Only breaks when I make the edits.
  8. Asian Kid

    AI help

    I have this Ai problem I am not sure if its Epoch or something else. I have install Sarge AI and DZAI and all the gunshots from the AI are silent. I am running normal Cherno Epoch.
×
×
  • Create New...