Jump to content

Aristoi

Member
  • Content Count

    87
  • Joined

  • Last visited

About Aristoi

  • Rank
    Survivor

Profile Information

  • Gender
    Not Telling
  1. I know the opinions vary widely, but I found the loot to be much too rare. I'm not even talking high end items. Even food and water seems that way. It may be something to do with the odd way the "loot bubble" system works, but after having wandered for 2 hours without finding much at all (including through military areas), I found the experience to be rather underwhelming. Is this loot system and rarity something the devs are happy with? I get that there is some kind of "group search" bonus but that seems a bit biased to me. Is the intent that everyone has to group up or else?
  2. https://github.com/vbawol/DayZ-Epoch/commit/8dc7ce4250d883dd39624c11398bd7db9e504f61#diff-588a2586143abd41109d64f90c49f16b
  3. What is confusing me is that Vilayer seems to restart the MySQL instance as well (at least it goes down during the restart via the tools I use). How is it that a rogue hive connection could remain if the DB restarts as well?
  4. This is what I am hoping for, as well.
  5. The RPT errors are one thing, but what about the objects actually not appearing on the maps, plus the addition of vehicles past the limit? Why was that not occurring before?
  6. Thanks for the summary, Kroenen. We had to move away from EMS initially due to the very weak AI which was too easily defeated by players. WAI, though perhaps a bit less varied on the missions, has very challenging AI. If EMS is still using the default AI, I'd need to holdout until EMS gets WAI or DZAI included. That said, what's with Fuchs saying EMS 0.3 now incorporates WAI? "The code is better written and similar to WAI" Maybe this is just internal and not related to the AI?
  7. It sounds like from the Github issue tracker that the theory is this is a server restart issue. Is there any further research going into this angle, or are we waiting on something else? EDIT: Just saw your reply, vbawol. For those of us using Vilayer, what's the fix? Get them to change whatever their restart process is?
  8. Sorry if this has been covered (I have searched), but I'm a bit confused as to what is going on with the various mission systems. If I am following, EMS 0.3 (based on DZMS) is now similarly written to WAI (using it's AI?), but is not actually WAI, and is moving to use DZAI, (and both DZAI and WAI are being separately maintained). I also saw some comment that EMS is porting its missions to WAI, which is confusing. I'd like to use a mission system that included the nasty AI in WAI (which I am using currently), and WAI missions seems decent. What does EMS 0.3 bring to the table?
  9. When I have done it, I used queries like these: # This will give you a general idea of the types of vehicles # on the map that will be deleted select od.Classname , count(*) from object_data od where od.CharacterID = 0 and od.Inventory in ('[]', '[[[],[]],[[],[]],[[],[]]]') group by Classname order by count(*) desc; # If you have LastUpdated on your object_data table this one will show all # objects that have NOT been updated since they were spawned select * from object_data od where od.CharacterID = 0 and od.Inventory in ('[]', '[[[],[]],[[],[]],[[],[]]]') and od.Datestamp = od.LastUpdated; # This will delete all empty and unlocked vehicles, # add "and od.Datestamp = od.LastUpdated" if you want to # use the time comparison delete from object_data od where od.CharacterID = 0 and od.Inventory in ('[]', '[[[],[]],[[],[]],[[],[]]]'); Your mileage may vary, and you may want to back these up to another table in case you need to recover them.
  10. I'm not convinced this is the issue. The log shows the hive being initialized both times (or attempting). How could that be the previous server instance's hive connections?
  11. Sure, I did it myself. It goes in server_monitor.sqf.
  12. It happened again, though there were some new messages I had not see: 2014/02/14, 6:20:59 Ref to nonnetwork object 2e23d0c0# 1056792: kamaz.p3d 2014/02/14, 6:20:59 Ref to nonnetwork object 2e210800# 1056795: safe.p3d <...etc...> Some highlights: 2014/02/14, 6:19:12 "DayZ Epoch: PRELOAD Functions\init [[<No group>:0 (FunctionsManager)],any]" 2014/02/14, 6:19:12 "DayZ Epoch: MPframework inited" 2014/02/14, 6:20:20 "HIVE: Starting" 2014/02/14, 6:20:20 "server_monitor.sqf execution count = 1" 2014/02/14, 6:20:20 "HIVE: trying to get objects" 2014/02/14, 6:20:21 "HIVE: found 1571 objects" 2014/02/14, 6:20:21 "HIVE: Commence Object Streaming..." 2014/02/14, 6:20:21 "HIVE: got 521 Epoch Objects and 1050 Vehicles" 2014/02/14, 6:22:03 "HIVE: Vehicle Spawn limit reached!" 2014/02/14, 6:35:09 "HIVE: Starting" 2014/02/14, 6:35:09 "server_monitor.sqf execution count = 1" 2014/02/14, 6:35:09 "HIVE: trying to get objects" 2014/02/14, 6:35:09 "HIVE: connection problem... HiveExt response:["ERROR","Instance already initialized"]" 2014/02/14, 6:35:09 "HIVE: trying to get objects" 2014/02/14, 6:35:09 "HIVE: connection problem... HiveExt response:["ERROR","Instance already initialized"]" 2014/02/14, 6:35:09 "HIVE: trying to get objects" 2014/02/14, 6:35:09 "HIVE: connection problem... HiveExt response:["ERROR","Instance already initialized"]" 2014/02/14, 6:35:09 "HIVE: trying to get objects" 2014/02/14, 6:35:09 "HIVE: connection problem... HiveExt response:["ERROR","Instance already initialized"]" 2014/02/14, 6:35:09 "HIVE: trying to get objects" 2014/02/14, 6:35:09 "HIVE: connection problem... HiveExt response:["ERROR","Instance already initialized"]" 2014/02/14, 6:35:10 "HIVE: Spawning # of Vehicles: 300" Full file (Too big for pastebin): https://dl.dropboxusercontent.com/u/405582/ARMA2OASERVER.RPT
  13. I'm not sure if it is related, though I suspect it is at least possible, but one of the side effects seems to be tons of vehicles past the limit set. Ours is 300 and the most recent load: 2014/02/13, 10:04:01 "HIVE: got 494 Epoch Objects and 1054 Vehicles" 2014/02/13, 10:05:01 "HIVE: Vehicle Spawn limit reached!" A little more detail on this one. On one of the hive duplicate loads, it did this: 2014/02/12, 10:11:25 "HIVE: Starting" 2014/02/12, 10:11:25 "HIVE: trying to get objects" 2014/02/12, 10:11:26 "HIVE: found 1337 objects" 2014/02/12, 10:11:26 "HIVE: Commence Object Streaming..." 2014/02/12, 10:11:26 "HIVE: got 472 Epoch Objects and 865 Vehicles" 2014/02/12, 10:12:10 "HIVE: Starting" 2014/02/12, 10:12:10 "HIVE: trying to get objects" 2014/02/12, 10:12:10 "HIVE: connection problem... HiveExt response:["ERROR","Instance already initialized"]" 2014/02/12, 10:12:11 "HIVE: Spawning # of Vehicles: 300" 2014/02/12, 10:12:11 "HIVE: Spawning # of Debris: 200" 2014/02/12, 10:12:11 "HIVE: Spawning # of Ammo Boxes: 3" 2014/02/12, 10:12:11 "HIVE: Spawning # of Veins: 50" I think that extra 300 vehicles took us to that most recent log message with over 1,000.
  14. I've added this code, I'll let you know how it goes.
  15. Thanks vbawol! We have Infistar and some custom buildings running. Otherwise should be vanilla Epoch. I've attached our init.sqf for reference. init.sqf.txt
×
×
  • Create New...