Jump to content

SmokeyBR

Member
  • Content count

    188
  • Joined

  • Last visited

  • Days Won

    1

SmokeyBR last won the day on June 29 2016

SmokeyBR had the most liked content!

1 Follower

About SmokeyBR

  • Rank
    Hardened

Recent Profile Visitors

739 profile views
  1. SmokeyBR

    [RELEASE] WAI 2.2.5

    i have seen players abusing this... the only way i would know how to do it, its going back to the old way, which would require to edit every mission with vehicle being spawned like u showed. I thought a better way might be possible without having to make so many adjustments. If thats the only way possible and only doing it because i asked dont bother with it then, since it seems im the only one bothered by it. thank you i do love the changes you made.
  2. SmokeyBR

    [RELEASE] WAI 2.2.5

    i use KeyinCrate so keys will be put inside the crate, i do this so players will be able to unlock a vehicle only when finishing the mission howerver thats not how it works currently the key will be added to the crate right when vehicles are spawned, making possible for players to approach the crate and loot key before completing mission. Shouldn't the keys be added after mission completion together with loot? Is that how it was intended ? to me and older version of WAI it was how it worked, i am not sure how @JasonTM meant for it to work, if thats how u wanted, ok, however if not please take a look because i am not sure how to do it. https://github.com/worldwidesorrow/WICKED-AI/blob/master/WAI/compile/custom_publish_vehicle.sqf#L80 https://github.com/worldwidesorrow/WICKED-AI/blob/master/WAI/compile/functions.sqf#L225-L229
  3. SmokeyBR

    [RELEASE] WAI 2.2.5

    something that was reported on my server and i believe to be the only issue not taking into account with the latest rewrite of wai is how far bots and vehicles can get from their mission (air vehicles more so). The only reason i took out helicopters patrol from mission was because they stray way too far from their position and now they reported happening with a land vehicle ended up inside a safezone 1539m from the mission (how often it happens im unsure this is the first time someone said something) Is there no solution to this ? how are other server admins dealing with it ?
  4. SmokeyBR

    Server Shows up as Offline and 9999 ping in Dayz Launcher

    edit: just saw u already checked dzlauncher checker, so id say its only a matter of time... Theres only need to forward ports 2302-2305 really, theres some information about ports here https://community.bistudio.com/wiki/Arma_2:_Dedicated_Server, theres no reason at all to forward those other ports for a arma 2 server
  5. SmokeyBR

    [Release] Safe Zone Relocate

    OMG so stupid.... It was something wrong with the DZE_SafeZonePosArray like you said, only it was not broken i copied trader positions from mission.sqm for some reason that i cant recall, and in the process ended up with really high heights > 100, which is why it was not working. anyways thx.
  6. SmokeyBR

    [Release] Wicked AI 2.2.3 [1.0.6+]

    not sure if you are aware but the updated WAI comes with customsettings.sqf which overwrites the ones in config, specifically wai_avoid_missions becomes a really large number. https://github.com/f3cuk/WICKED-AI/blob/master/WAI/customsettings.sqf#L128-L134
  7. SmokeyBR

    [Release] Safe Zone Relocate

    so heres something weird that i do not understand. The first "Making Sure" shows up fine the second however does not i even thought of adding another line bellow the second "making sure" with _nearVehicles = _safeZonePos nearEntities [["Air","LandVehicle","Ship"],_safeZoneRadius]; diag_log format ["[SAFEZONE] Making Sure: %1",_x]; { diag_log format ["[SAFEZONE] Making Sure: %1",_x]; diag_log format ["[SAFEZONE] Double Sure"]; if (damage _x > _maxDamage) then { doubted it wanst displaying because there was no value to display, ideias ?
  8. SmokeyBR

    [Release] Safe Zone Relocate

    As far as anything broke goes i doubt it since i get no errors in server side or client side, also the DZE_SafeZonePosArray is referenced in other places which are working good. could you humor me and tell me if with the added diag_log format should be displayed regardless of variables true or false ? ive added two diag_log format ["[SAFEZONE] Making Sure: %1",_x]; it should display on server log as soon as server starts right ? /* Safe Zone Relocate by salival (https://github.com/oiad) */ private ["_customPosition","_customRadius","_maxDist","_maxDamage","_nearVehicles","_objDist","_position","_safeZonePos","_safeZoneRadius","_useCustomPosition","_unlock"]; _useCustomPosition = false; // Enable a custom position to move vehicles to (i.e a junk yard) _customPosition = [6942.64,15121.6,0]; // Position for vehicles to be moved to if _useCustomPosition = true; _customRadius = 5; // Minimum distance from the custom position to move vehicles to _maxDist = 1000; // Maximum distance from the safe zone position to find a safe position or custom position for relocation, setting this too low can make vehicles spawn very close to other vehicles. _objDist = 15; // Minimum distance from the safe position for relocation to the center of the nearest object. Specifying quite a large distance here will slow the function and might often fail to find a suitable position. _unlock = false; // Unlock vehicle when moved from the safe zone? _maxDamage = 0.75; // Vehicles above this amount of damage will be deleted { _safeZonePos = _x select 0; _safeZoneRadius = _x select 1; _nearVehicles = _safeZonePos nearEntities [["Air","LandVehicle","Ship"],_safeZoneRadius]; diag_log format ["[SAFEZONE] Making Sure: %1",_x]; { diag_log format ["[SAFEZONE] Making Sure: %1",_x]; if (damage _x > _maxDamage) then { deleteVehicle _x; [_x getVariable["ObjectID","0"],_x getVariable["ObjectUID","0"],"safeZoneRelocate"] call server_deleteObjDirect; diag_log format ["[SAFEZONE] %1 was deleted from the server for being too damaged before relocate: @%2 %3",typeOf _x,mapGridPosition _x,getPosATL _x]; } else { if (_useCustomPosition) then { _position = [_customPosition,_customRadius,_maxDist,_objDist,1,0,0,[]] call BIS_fnc_findSafePos; } else { _position = [_safeZonePos,_safeZoneRadius + 50,_maxDist,_objDist,if (_x isKindOf "Ship") then {2} else {0},0,0,[],[_safeZonePos,_safeZonePos]] call BIS_fnc_findSafePos; }; _x setPos _position; [_x,"position"] call server_updateObject; if (_unlock && {locked _x}) then {_x setVehicleLock "UNLOCKED"}; diag_log format ["[SAFEZONE] %1 was moved out of a safe zone to: @%2 %3",typeOf _x,mapGridPosition _position,_position]; }; } forEach _nearVehicles; } forEach DZE_safeZonePosArray;
  9. SmokeyBR

    [Release] Safe Zone Relocate

    doesnt seem to be working for me anymore if anyone else could confirm....
  10. SmokeyBR

    Daylight Becomes Night Too Fast!

    since u didnt exaclty say what your settings in hiveext.ini are, check [Time] ;Possible values: Local, Custom, Static ;You cannot use Static on OFFICIAL Hive, it will just revert to Local Type = Static ;If using Custom type, offset from UTC in hours (can be negative as well) ;Offset = -8 ;If using Static type (Hour value always the same on every server start), the value (0-24) to set the Hour to Hour = 13
  11. SmokeyBR

    Time Acceleration for 1061

    anyone tried this one ?
  12. SmokeyBR

    Duplicate Primary Key Mysql

    @ebayShopper thanks for the help even thou i tried changing ObjectID number still couldnt not delete the data. i had seached before for solutions to the error on more specified forums for mysql and i did come across a guy saying that backing up database, dropping it and recreate the database could solve it, i tried and did work did not even need to delete the vehicles causing the error. Something broken in database ? anyways its fixed... hopefully hehe for reference http://www.rathishkumar.in/2016/01/how-to-solve-mysql-error-code-1062.html
  13. SmokeyBR

    Duplicate Primary Key Mysql

    im searching through phpmyadmin i did also search with Mysql workbench (without limiting rows) both showed only one result. i have not tried changing ObjectID will do once i get a chance, thou if anyone knows why this is happening be nice to know why. thanks
  14. SmokeyBR

    Duplicate Primary Key Mysql

    heres the thing when i search for ObjectID = 70447 only one result shows theres no duplicates or at least not showing duplicates, and when i try to delete it gives the same error and doesnt delete.
  15. SmokeyBR

    Duplicate Primary Key Mysql

    a few days back i saw this on hive log Database: [Error] Error 1062 (Duplicate entry '69457' for key 'PRIMARY') in MySQLStmtExecute SQL: 'DELETE FROM `Object_DATA` WHERE `ObjectID` = ? AND `Instance` = ? VALUES(69457, 11)' tried to deleate manually but could not then i kinda forgot about it.... Today when i was updating and testing garage another one showed up. I have no ideia how to resolve this or what is the actual issue, from what i can tell its trying to delete the object but not deleating due to the primary key error, can anyone help out with this ?
×